Ir para conteúdo

Publicidade

 Estatísticas do Fórum

  • 0 Usuários ativos

    0 membros, 0 visitantes, 0 membros anônimos

Foto
- - - - -

sorteio

  • Por favor, faça o login para responder
2 respostas neste tópico

#1 Zer0

Zer0
  • Members
  • 40 posts

Postado 10 abril 2007 - 15:58

Seguinte galera, estou fazendo um trabalho no VisuAlg e preciso da ajuda de vocês... eu preciso fazer o sorteio de 17 números, mas esses não podem ser repetidos... alguém aí me dá uma forcinha???valeuu
  • 0

Publicidade

#2 Vergil

Vergil

    Hammer smashed face

  • Members
  • 787 posts

Postado 10 abril 2007 - 17:33

Fiz um algoritmo utilizando RAND para gerar números aleatórios. O problema é que ele gera números decimais(real). Caso você precise de números inteiros, pesquise o comando "aleatorio" do VisualG. Segue o código:
algoritmo "Gerador_de_Numeros_Aleatorios"// Função : Gerar 17 números aleatórios// Autor : Vergil// Data : 10/04/2007// Seção de Declarações var   contar, contar2 : inteiro   Numeros : vetor[1..17] de real   num : realinicio	  contar <- 1	  // Gerar os 17 números aleatoriamente	  enquanto contar <= 17 faca		   num <- rand * 20 // recebe um número aleatório entre 0 e 20 (decimal)		   para contar2 de 1 ate contar faca // percorre todos os valores já sorteados				se num <> Numeros[contar] entao // se for um número inédito, atribui ao vetor				   Numeros[contar] <- num				   contar <- contar + 1				   interrompa				senao				   interrompa // se for repetido, mandar sortear outro número				fimse		   fimpara	  fimenquanto	  // Exibir os valores na tela	  para contar de 1 ate 17 faca		   escreval(Numeros[contar]:2:1)	  fimparafimalgoritmo
http://forum.imaster...tyle_emoticons/default/joia.gif
  • 0

#3 Arcanjo®

Arcanjo®
  • Members
  • 2 posts

Postado 02 maio 2007 - 10:30

Olá, estou usando o comando ALEATORIO no VisualG, só que o mesmo está me gerando números em sequência de 1 a 15. Gostaria de saber o que está errado no meu código. Desde já agradeço.algoritmo "semnome"// Função :// Autor :// Data : 2/5/2007// Seção de Declarações varx, contador, contador2 : inteiroinicio// Seção de Comandos aleatorio onaleatorio 1, 25contador <- 0para contador de 1 ate 15 faca para contador2 de 1 ate contador faca se contador2 <> contador entao contador <- contador + 1 interrompa senao interrompa fimse fimparafimparaaleatorio offpara contador de 1 ate 15 faca escreval("O nº escolhido entre 1 e 25 é: >>> ", contador)fimparafimalgoritmo
  • 0




Publicidade

/ins>