Ir para o conteúdo

Publicidade

 Estatísticas do Fórum

  • 0 Usuários ativos

    0 membro(s), 0 visitante(s) e 0 membros anônimo(s)

Foto:

Vetores

  • Por favor, faça o login para responder
9 respostas neste tópico

#1 aphaaa

aphaaa
  • Membros
  • 52 posts

Postado 16 abril 2009 - 11:56

entrei nessa area a poucos dias, e ainda to em fase de aprendizagem, porem preciso fazer um exercicio aqui e nao tem ninguem aqui na empresa rpa me auxiliar.

tem como alguem me ajuda?

Escreva um algoritmo que lê um vetor A(10) e escreva a posição de cada elemento igual a 10 deste
vetor.


preciso fazer esse exercicio.

tendo esse como base eu consigo fazer os outros e creio que esse é bestinha ate.

grato
  • 0

#2 quitZAUMMM

quitZAUMMM

    YES, WE CAN

  • Moderadores
  • 3.923 posts

Postado 16 abril 2009 - 12:39

---
Titulo Editado:

Ajudeem-me :seta: Vetores

---

É concordo com você é "bestinha" o exerc. msm.
tente fazer, e poste oq conseguir, ai eu te oriento.

[]s
  • 0

#3 aphaaa

aphaaa
  • Membros
  • 52 posts

Postado 16 abril 2009 - 12:42

ok

tentarei sim.

mas eu to meio perdido aqui.

ainda nao encontrei por onde começar!!

hahahaha

mas valew por ao menos reponder o topico e oferecer ajuda!
  • 0

#4 aphaaa

aphaaa
  • Membros
  • 52 posts

Postado 16 abril 2009 - 12:59

eu tentei segui o exemplo da apostila

algoritmo "semnome"
// Função :
// Autor :
// Data : 16/4/2009
// Seção de Declarações 
var
 a:vetor [a1..a10] de real
 i:real
inicio
   // Seção de Comandos

   //Escreva um algoritmo que lê um vetor A(10) e escreva a posição de cada elemento igual a 10 deste vetor

   a<-0


   para i de 1 ate 10 faca
	 leia (a)
	 se A[i]> a1 entao
	   a<- a+1
	 fimse
   fimpara
  
   para i de 1 ate 10 faca
	 se (a=10) entao
	 escreval ("posição", a)
	 fimse
   fimpara



fimalgoritmo


faz só uma semana que eu to mechendo com isso ainda soumuito lesado e nao entendo muito, mas em breve eu entenderei!
  • 0

#5 quitZAUMMM

quitZAUMMM

    YES, WE CAN

  • Moderadores
  • 3.923 posts

Postado 16 abril 2009 - 13:21

+ td bem a declaração do vetor você jah ta craque..
falta rever um pouco + na leitura para encher o vetor.
agora vo mostrar como q é, o resto:

para i de 0 até 9 faça
	se (a[i] == 10) então 
		Escreva("Posicao " + i);
	fim_se
fim_para

Entaum naum sei como é no visualg pq nunca mechi nessa ferramenta, + essa é a lógica.

[]s
  • 0

#6 aphaaa

aphaaa
  • Membros
  • 52 posts

Postado 16 abril 2009 - 13:54

valew mesmo.

vou tentar aquii!

e jaja eu falo se deu certo ou nem!

=]
  • 0

#7 aphaaa

aphaaa
  • Membros
  • 52 posts

Postado 16 abril 2009 - 14:05

ficou assim.


porem nao esta escrevendo a posição.

o programa executou sem erros, os erros que deu eu consegui arrumar o unico problema é que não declarou a posição.


e ficou asism:

algoritmo "semnome"
// Função :
// Autor :
// Data : 16/4/2009
// Seção de Declarações
var
a:vetor [1..10] de real
i:inteiro
inicio
// Seção de Comandos

//Escreva um algoritmo que lê um vetor A(10) e escreva a posição de cada elemento igual a 10 deste vetor

para i de 1 ate 9 faca
se (a[i] = 10) entao
Escreva("Posicao ", i)
fimse
fimpara



fimalgoritmo
  • 0

#8 quitZAUMMM

quitZAUMMM

    YES, WE CAN

  • Moderadores
  • 3.923 posts

Postado 16 abril 2009 - 14:27

com ctz neh..
como disse você terá q encher o vetor agora, faça algo assim:
para i de 0 ate 9 faca
	leia a[i];
fimpara

  • 0

#9 M. Wanderley

M. Wanderley
  • Membros
  • 5 posts

Postado 22 abril 2009 - 12:35

ficou assim.


porem nao esta escrevendo a posição.

o programa executou sem erros, os erros que deu eu consegui arrumar o unico problema é que não declarou a posição.


e ficou asism:

algoritmo "semnome"
// Função :
// Autor :
// Data : 16/4/2009
// Seção de Declarações
var
a:vetor [1..10] de real
i:inteiro
inicio
// Seção de Comandos

//Escreva um algoritmo que lê um vetor A(10) e escreva a posição de cada elemento igual a 10 deste vetor

para i de 1 ate 9 faca
se (a[i] = 10) entao
Escreva("Posicao ", i)
fimse
fimpara



fimalgoritmo



uma pequena correção:
no se você deverá colocar (a[i]=a[10]), e essa condicional deve ser colocado num outro "para", como você havia feito inicialmente:

para i de 1 ate 10 faca
se a[i] = a[10] entao
escreva "posicao", i
fimse
fimpara
  • 0

#10 quitZAUMMM

quitZAUMMM

    YES, WE CAN

  • Moderadores
  • 3.923 posts

Postado 22 abril 2009 - 14:52

se o vetor é de 10 posições Wanderley essa posição: a[10]; naum existe, pois o indice começa do 0

[]s
  • 0




Publicidade

/ins>