Ir para o conteúdo

Publicidade

 Estatísticas do Fórum

  • 0 Usuários ativos

    0 membro(s), 0 visitante(s) e 0 membros anônimo(s)

Cursos Online iMasters
Foto:

Curso Intensivo - [Aula 01]

  • Por favor, faça o login para responder
29 respostas neste tópico

#1 Warcraft ~

Warcraft ~
  • Membros
  • 16 posts

Postado 25 junho 2009 - 17:52

Tópicos da Aula:
Aula 01 - Algoritmo
• Introdução à Lógica de Programação
• Itens Fundamentais do Algoritmo
• Variáveis
• Exercícios Propostos

[INICIOAULA]

• Introdução à Lógica de Programação:
Para um computador executar operações é necessário que ele seja programado, e esta programação é feita através de uma linguagem que "ele" entenda. Os computadores só executam instruções expressas em linguagem de máquina (forma numérica) e isto gera vários incovenientes para o ser humano. Diante de tais problemas, surgiram as linguagens simbólicas de fácil compreensão para o homem, que são traduzidas para a linguagem de máquina por um programa chamado compilador.

A primeira destas linguagens foi o Fortran, com característica técnicas e científicas. Com o passar dos tempos, muitas outras linguagens surgiram, especificamente voltadas para problemas de natureza comercial e administrativa.

Para elaborar um programa é necessário ter toda a sequência de passos e operações estabelecidas de modo formal para a resolução do problema. Para isso, encontraremos, neste curso, uma técnica muito útil e ficiente que é o algoritmo.

• Algoritmo:
Um algoritmo é uma estratégia para resolver um desejado problema. Ele está associado ao desenvolvimento de uma técnica capaz de encontrar uma solução para este problema.

Os dados do problema são a entrada do algoritmo e a solução corresponde à saída deste algoritmo. Considera-se a entrada como uma variável independente básica, a partir da qual são produzidas as saídas do algoritmo.

Os algoritmos são escritos quase que livremente em língua portuguesa, apresentando a estratégia desejada, contendo algumas sentenças especiais com formato predefinido.

A apresentação de um algoritmo é formada por uma sequência de instruções ordenadas em linhas de maneira a dar em seu decurso a solução do problema.

Exemplo de um algoritmo:

algoritmo "semnome"
var
nome: caractere
---o: caractere
idade: inteiro
altura: inteiro
peso: inteiro
totalm: inteiro
totalf: inteiro
idm: inteiro
idf: inteiro
maiorpeso: inteiro
menorpeso: inteiro
menoralt: inteiro
medm: real
medf: real
i: inteiro
inicio
menorpeso <- 1000
menoralt <- 1000

para i de 1 ate 2 faca
escreval ("Nome: ")
leia (nome)
escreval ("---o: ")
leia (---o)
escreval ("Idade: ")
leia (idade)
escreval ("Altura: ")
leia (altura)
escreval ("Peso: ")
leia (peso)

se ---o="M" entao
totalm <- totalm + 1
idm <- idm + idade
fimse
se ---o="F" entao
totalf <- totalf + 1
idf <- idf + idade
fimse
se (---o="M") e (peso > maiorpeso) entao
maiorpeso <- peso
fimse
se (---o="M") e (peso < menorpeso) entao
menorpeso <- peso
fimse
se (---o="F") e (altura < menoralt) entao
menoralt <- altura
fimse
fimpara
medm <- idm/totalm
medf <- idf/totalf
escreva (medm, medf, maiorpeso, menorpeso, menoralt)
// Seção de Comandos 
fimalgoritmo

Se você ainda é iniciante, não tente entender este algoritmo, você entenderá ele apenas daqui a algumas aulas.

• Variáveis:
Uma variável corresponde a uma posição de memória cujo conteúdo poderá variar durante a execução de um programa. Em uma equação matemática A + B = 7, A e B representam posições de memória que conterão as parcelas da equação, e os valores da mesma são infinitos.

As variáveis são identificadas por um nome que é composto de um ou mais caracteres, o primeiro caractere deve ser uma letra e não poderá conter caracteres especiais (?/']^&%$#@) e nem ser uma palavra reservada da linguagem utilizada.

Os nomes das variáveis deverão ser claros e objetivos, até mesmo para outros poderem entender o mesmo. Se em um algoritmo for necessário armazenar o total de vários números, um bom nome para esta variável seria soma ou total.

As variáveis só armazenam valores de um mesmo tipo, isto é, precisaremos declarar no algoritmo, qual o tipo de dedado que a variável irá trabalhar, e não poderemos atribuir a esta variável valores diferentes do tipo declarado.

• Exercícios Propostos:

1) O que você entende por algoritmo?


2) O que você entende por variável?


3) O que você entende por lógica de programação?


4) O que é um compilador?


5) Cite algumas linguagens de programação baseadas no algoritmo:


[FIMAULA]


Vocês devem ter percebido que não comecei a construção de algoritmos como prometido na 1ª aula. Fiz isto pois acho que primeiramente vocês devem aprender a teoria. Respondam as questões discursivamente e me mande por e-mail, responderei corrigido.

Abraços,
  • 0

#2 quitZAUMMM

quitZAUMMM

    YES, WE CAN

  • Moderadores
  • 3.923 posts

Postado 29 junho 2009 - 14:46

O ponta pé foi dado (rs.)
vamos ver se o pessoal do fórum mostra interesse.
Pois esse é o principio para quem qr se tornar um programador ;D

[]s
  • 0

#3 Milton Quirino

Milton Quirino
  • Membros
  • 72 posts

Postado 30 junho 2009 - 16:22

Muito boa a iniciativa !!

eu mesmo estou acompanhando o curso...
  • 0

#4 Fall

Fall
  • Membros
  • 127 posts

Postado 03 julho 2009 - 09:47

Show de bola parabens pela ideia
  • 0

#5 thiagodiniz

thiagodiniz
  • Membros
  • 1 posts

Postado 08 julho 2009 - 13:48

estou iniciando e vou acompanhar o curso.
grato.
  • 0

#6 force

force
  • Membros
  • 5 posts

Postado 14 julho 2009 - 10:29

muito bom comecei a acompanhar tambem obrigado e parabens pela iniciativa!
  • 0

#7 butterball

butterball
  • Membros
  • 1 posts

Postado 27 julho 2009 - 20:22

Amigo estou chegando agora! Posso começar este curso apartir de amanhã? E as respostas posso mandar amanhã com as duas aulas? Por favor espero orientação!
Obrigado!
  • 0

#8 Matheus Brito

Matheus Brito

    Estudando...

  • Membros
  • 3.503 posts

Postado 27 julho 2009 - 23:42

Parabéns pela iniciativa.
Abs e sucesso ai no curso
  • 0

#9 quintelab

quintelab

    Nunca é simples.

  • Moderadores
  • 8.487 posts

Postado 28 julho 2009 - 13:37

Amigo estou chegando agora! Posso começar este curso apartir de amanhã? E as respostas posso mandar amanhã com as duas aulas? Por favor espero orientação!
Obrigado!


butterball, seja bem vindo ao Fórum, conheça nossas regras: Regras do Fórum

Você pode começar a qualquer momento, e qualquer dúvida só postar no fórum principal de Lógica de Programação e Algoritmos.

Abraços...
  • 0

#10 EdnaAparecida

EdnaAparecida
  • Membros
  • 10 posts

Postado 30 julho 2009 - 16:30

Fazendo uma pesquisa na net vi este curso achei a iniciativa ótima porém não acho importante que quem não conseguir seja tirado do curso, pois muitas pessoas tem dificuldade, eu mesma estou no ultimo ano de sistemas e tenho muita dificuldade. A minha maior dificuldade é ser auto didata, por este motivo estava mesmo procurando um curso presencial, na minha busca encontrei este online eu vou me esforçar a fazer porém se eu não passar em alguns testes não me tire assim do forum eu vou me esforçar, talvez estes primeiros tópicos não sejam tão dificeis mais pra mim, porém é sempre bom testar. Estou grata a Deus e a vocês por esta iniciativa. Hoje mesmo já vou começar. Este forum me ajudou muito nas aulas de asp, e creio que vai me ajudar agora em logica também.

Edna
  • 0

#11 Gs3llmann

Gs3llmann

    NEVER GIVE UP!

  • Membros
  • 179 posts

Postado 30 julho 2009 - 17:13

Warcraft,

Gostei muito da iniciativa, espero que tenha o meio e fim também!

já havia feito um curso de algoritmo, mas como faz tempo e não pratiquei já esqueci tudo, vou me esforçar pra acompanhar.

Mandei as respostas no seu e-mail, abraços.

  • 0

#12 gildolima

gildolima
  • Membros
  • 1 posts

Postado 18 agosto 2009 - 20:51

gostaria de saber se há tempo para entrar neste curso ainda ou não não tenho experiência,
em programação e gostaria de aprender logica e este curso parece ser muito bom gostaria
de saber se a tempo para aprender e se poço aprender ainda.
grato pela colaboração aguardo resposta.
  • 0

#13 quitZAUMMM

quitZAUMMM

    YES, WE CAN

  • Moderadores
  • 3.923 posts

Postado 20 agosto 2009 - 15:09

Bom não vi + postagens do curso galera.
O jeito é baixar umas apostilas e ir postando as dúvidas, claro para isso poste no fórum principal de Lógica de Programação e Algoritmos;

[]s
  • 0

#14 dementtor

dementtor
  • Membros
  • 30 posts

Postado 25 setembro 2009 - 16:42

OOOOOOOOOOOOOOOOOOOOOOuuuuu!!!

Show de bola...vlw...mesmo eu estava procurando o Inicio hehehehehe...post d+ vlw...

abraços a todos!!!

  • 0

#15 dementtor

dementtor
  • Membros
  • 30 posts

Postado 25 setembro 2009 - 17:16

Eu fiz um Algoritmo bem mais simples que o amigo la em cima...mais tbm funciona e detalhei cada ação para ninguem ter duvida...beleza...espero ki ajude a alguem pq o PARA sempre e um problema...no meu caso...hehehehe....abraços...a todos...




var //variavel

num: inteiro //idendentidade de variavel

inicio //inicio do algoritmo

para num <- 0 ate 50 faca //ação do algoritmo OBS: "num" recebe algum valor nesse caso ZERO ponto de partida e o 50 e meu limite desejado.

   escreval(num) //ação para ecrever o Algoritmo na tela "escreval - escreve um em baixo do outro" e o "escreva - normal insere uma informação do lado da outra".

fimpara // assim que começamos a ação identificamos o "para" e se esse PARA tem um inicio ele TBM tem um FIM...no caso FIMPARA.

fimalgoritmo //fim ABSOLUTO


---------
  • 0

#16 Vitor Augusto

Vitor Augusto
  • Membros
  • 16 posts

Postado 29 setembro 2009 - 09:22

Muito Bom mesmo
obrigado por compartilhar
  • 0

#17 Lost Dark

Lost Dark
  • Membros
  • 178 posts

Postado 18 novembro 2009 - 08:07

Opa Muito boa essa 1º aula ja estou respondendo as questões vlw mesmo flw
  • 0

#18 Mrs8.o

Mrs8.o
  • Membros
  • 15 posts

Postado 25 dezembro 2009 - 12:57

Iniciativa muito boa kra.


Pode contar com a minha participação.
ja to resolvendo os exercicios.
  • 0

#19 open_sorce

open_sorce
  • Membros
  • 3 posts

Postado 02 fevereiro 2010 - 17:00

1) O que você entende por algoritmo?
algoritmo pode ser considerado uma seqüência de procedimentos
Finito que, se forem executados em determinado período de tempo
Chegar ao seu objetivo.



2) O que você entende por variável?
Variável e um jeito de marcar todos os dados que são inseridos em um determinado
Problema .



3) O que você entende por lógica de programação?
Lógica de programação nada mais é do que uma forma de se escrever um programa de computador com uma linguagem de fácil entendimento para nós seres humanos

4) O que é um compilador?
Compiladores são responsáveis por traduzir e interpretar os programas que estão nas diferentes linguagens de programação para a linguagem que a maquina entende.

5) Cite algumas linguagens de programação baseadas no algoritmo:

Cobol, Fortran ,Basic, Pascal ,[/font]
  • 0

#20 adierbal

adierbal
  • Membros
  • 39 posts

Postado 08 fevereiro 2010 - 00:16

Galera, sou um retardatário, pois sou novato nesse forum. Espero que ainda de para participar desse curso.

E pela iniciativa do curso ... :clap:

abraços :joia:
  • 0




Publicidade

/ins>