Ir para o conteúdo

Publicidade

 Estatísticas do Fórum

  • 0 Usuários ativos

    0 membro(s), 0 visitante(s) e 0 membros anônimo(s)

Foto:

Exercicio de Algoritmo para ser resolvido com o visualg

  • Por favor, faça o login para responder
1 resposta neste tópico

#1 Valdir Junior

Valdir Junior
  • Membros
  • 1 posts

Postado 21 junho 2010 - 12:49

Estou com dificuldade em resolver alguns exercicios de algoritmo, pois estava doente no dia em que o professor aplicou esses exercicios para turma, e não pude ir na aula.
Desde já agradeço se puderem me ajudarem... (de preferencia ser resolvido no programa visualg)

1-Fazer um programa para calcular e mostrar a tabuada de um número qualquer digitado pelo usuário.

2-As maçãs custam R$0,30 cada se forem compradas menos do que uma dúzia, e R$0,25 se forem compradas pelo menos doze. Escreva algoritmo programa que leia o número de maçãs compradas, calcule e escreva o valor total da compra.

3-Faça um algoritmo que calcule o fatorial de N(N!), sendo que o valor inteiro de N deve ser escolhido pelo usuário.
N!=1*2*3*...*(N-1)*N
0!=1
Ex:5! = 5*4*3*2*1=120

4-Faça um algoritmo para determinar e escrever a soma dos números pares de 100 a 200, inclusive.

5-Ler o nome de 2 times e o número de gols marcados na partida (p/ cada time). Escrever o nome do vencedor. Caso não haja vencedor deverá ser impressa a palavra EMPATE.

6-Escreva um algoritmo que leia o número de litros vendidos e o tipo de combustível (codificado da seguinte forma: A-álcool, G-gasolina), calcule e imprima o valor a ser pago pelo cliente sabendo-se que o preço do litro de gasolina é R$2,70 e o preço do litro do álcool é R$1,60.

Agradeço se puderem me ajudar...Abraços a todos
  • 0

#2 JhOnE RoSsInI

JhOnE RoSsInI
  • Membros
  • 72 posts

Postado 04 julho 2010 - 22:37

exercicio numero 1
algoritmo "tabuada"
// Função :tabuada
// Autor :jhone
// Data : 6/6/2010
// Seção de Declarações 
var
tab:vetor[1..10] de inteiro
num,cont:inteiro
inicio
cont <- 1
//pergunta o numero
escreval("Informe um numero inteiro")
leia(num)
//faz a conta
enquanto (cont > 0) e (cont <= 10) faca
tab[num] <- num * cont
//exibe a tabuada
escreval(num," x", cont, " =",tab[num])
cont <- cont + 1
fimenquanto
fimalgoritmo

exercicio numero 4
algoritmo "soma dos pares"
// Função :
// Autor :JhOnE RoSsInI
// Data : 4/7/2010
// Seção de Declarações 
var
cont,par:inteiro
inicio
// Seção de Comandos]
para cont de 100 ate 200 faca
     se(cont mod 2 = 0) entao
        par <- cont + par
     fimse
fimpara
escreva("A soma dos pares é: ",par)
fimalgoritmo

Editado por Mário Monteiro, 07 julho 2010 - 15:14 .
Inclusão da tag [code]

  • 0




Publicidade

/ins>