Ir para o conteúdo

Publicidade

 Estatísticas do Fórum

  • 1 Usuários ativos

    0 membro(s), 1 visitante(s) e 0 membros anônimo(s)

Cursos Online iMasters
Foto:

[Resolvido] Numero Par ou Impar

  • Por favor, faça o login para responder
3 respostas neste tópico

#1 Wagner sz

Wagner sz

    Wagner

  • Membros
  • 37 posts

Postado 15 março 2012 - 14:54

Oi, sou iniciante em algoritmos e estou tendo dificuldade para entender algoritmos de decisão. Enfim queria saber onde eu errei? Eu uso o visualg. xD

-->Escreva um programa que leia um número inteiro. Mostrar se o número é “par” ou “ímpar”.

algoritmo "Par_impar"
// Função :
// Autor :
// Data : 15/3/2012
// Seção de Declarações
var
n: inteiro
inicio
// Seção de Comandos
leia (n)
se n /2 = 0 entao
escreva ("O valor é par:")
fimse
se n /2 = 1 entao
escreva ("O valor é impar:")
fimse


fimalgoritmo

Editado por Mário Monteiro, 20 março 2012 - 14:00 .
Retirada a palavra "HELP" do Titulo ou Descrição

  • 0

#2 ulfreitas

ulfreitas

    Ulysses Freitas

  • Membros
  • 178 posts

Postado 15 março 2012 - 16:35

Boa tarde Wagner
Neste exercício você deve dividir a variável por 2 e se o resto da divisão for igual a zero o numero é par senao o numero é impar.
Você pode utilizar o operador mod para verificar o resto da divisão.

A diferença entre mod e / é:
n<-7 // n possui o valor 7
n/2 = 3 // valor da divisão
n mod 2 = 1 // resto da divisão

Outra coisa você só tem duas possibilidades ou é par ou é impar, você não precisa checar o resultado duas vezes ou seja duas condições, uma basta
se (n mod 2 = 0) par
senao impar

algoritmo "Par_impar"
var
n: inteiro
inicio
// Seção de Comandos
leia (n)
se n mod 2 = 0 entao
  escreva ("O valor é par:")
senao
  escreva ("O valor é impar:")
fimse
fimalgoritmo

Aproveitando leia este tópico para te ajudar a postar suas dúvidas no forum:
http://forum.imaster...ntes-de-postar/

Editado por ulfreitas, 15 março 2012 - 16:35 .

  • 0

#3 Wagner sz

Wagner sz

    Wagner

  • Membros
  • 37 posts

Postado 16 março 2012 - 10:09

Ah ok, entendi agora, valeu !
  • 0

#4 Kairo Gabriel

Kairo Gabriel
  • Membros
  • 9 posts

Postado 16 março 2012 - 17:08

Oi, sou iniciante em algoritmos e estou tendo dificuldade para entender algoritmos de decisão. Enfim queria saber onde eu errei? Eu uso o visualg. xD

-->Escreva um programa que leia um número inteiro. Mostrar se o número é “par” ou “ímpar”.

algoritmo "Par_impar"
// Função :
// Autor :
// Data : 15/3/2012
// Seção de Declarações
var
n: inteiro
inicio
// Seção de Comandos
leia (n)
se n /2 = 0 entao
escreva ("O valor é par:")
fimse
se n /2 = 1 entao
escreva ("O valor é impar:")
fimse


fimalgoritmo


no
se n /2 = 0 entao
entao você coloca no / você usa mod que e igual %
so substituir o / por %
  • 0




Publicidade

/ins>