Jump to content

JhOnE RoSsInI

Members
  • Content count

    72
  • Joined

  • Last visited

Community Reputation

0 Comum

4 Followers

About JhOnE RoSsInI

  • Birthday 08/16/1991

Informações Pessoais

  • Sexo
    Masculino
  • Interesses
    Programação JAVA, CSharp. Para web HTML, CSS, JavaScript e por ai vai o meu interesse...

Contato

  • Site Pessoal
    http://infocodigopc.blogspot.com
  1. esse é para somar o peso do caminhão mas com vetor ele fica bem menor algoritmo "Somar peso" // Função : // Autor : JhOnE RoSsInI // Data : 05/07/2010 // Seção de Declarações var Q_caixa:vetor[1..25] de real cont:inteiro total,peso:real inicio // Seção de Comandos para cont de 1 ate 25 passo 1 faca escreva("Informe o peso da caixa nº ",cont," : ") leia (Q_caixa[cont]) total <- total + Q_caixa[cont] fimpara escreval ("Peso Total : ",total) fimalgoritmo
  2. JhOnE RoSsInI

    Exercício Visualg

    Ta ai gustavo granato ta meio certo e só volta quando coloca número diferente da uma estudada nele ai e você quitzaummm da uma olhada ai tambem e ve oque você acha o pessoal que visita tambem deixa comentarios ai é um exercicio dificiu até eu demorei quase três horas para conseguir isso ai dão ajuda ai para ele repetir quando colocar letras frases é para a ajuda do nosso amigo ai beleza valew algoritmo "Calcular fatorial e fibonacci" // Função : Calcular fatorial e fibonacci" // Autor : Gustavo Granato Silva // Data : 16/4/2010 // Seção de Declarações var num,fat,contador:inteiro //variáveis do fatorial fibA,fibB,fibC:real //variaveis do fibonacci numero,op,comeco:inteiro //variaveis dos comandos inicio // Seção de Comandos procedimento lercomeco inicio enquanto(op <> 3 faca Escreval ("Digite 1 para fatorar") Escreval ("Digite 2 para calcular o fibonacci de um número") Escreval ("Digite 3 para sair") Leia (op) se(op <> 1)e(op <> 2)e(op <> 3)entao //ve se for outro numero volta no inicio lercomeco fimse fimprocedimento lercomeco //calcular fatorial fat:=1 Se (op = 1) entao Escreval ("Digite um número a ser fatorado: ") Leia (num) para contador de 1 ate num faca fat:=fat*contador fimpara Escreval(fat) Senao //calcular fibonacci Se (op = 2) entao Escreval ("Digite o número para calcular o fibonacci") Leia (numero) fibA:=1 fibB:=1 fibC:=0 para cont de 1 ate numero faca Escreval ("O número", numero, " em fibonatti é: ", fibA) Escreval fibA:=fibB+fibC; fibC:=fibB fibB:=fibA fimpara senao //sair do programa se (op = 3) entao Escreval (" ") Escreval (" ") Escreval (" ") Escreval (" Você está saindo do programa!") Escreval (" ") Escreval (" ") Escreval (" ") fimse fimse fimse fimenquanto fimalgoritmo
  3. JhOnE RoSsInI

    Exercício Visualg

    para andersonbassanalista não sei se ta certo mas funcionou beleza ta ai algoritmo "semnome" // Função : // Autor : // Data : 6/6/2010 // Seção de Declarações var ir,inss,salario_bruto,salario_liquido,hora_extra,valor_hora_extra:real nome:caracter inicio // pedir informação escreval("Informe seu nome") leia(nome) escreval("Informe a quantidade de horas extras trabalhadas") leia(hora_extra) //calculos valor_hora_extra <- hora_extra * 10 //calcila o valor da hora extra salario_bruto <- (3 * 350) + valor_hora_extra //define o salario bruto se(salario_bruto > 1.500) entao //ver se salario é maior que 1.500 para fazer desconto inss <- salario_bruto * 0.12 //desconto do inss ir <- salario_bruto * 0.20 //desconto do inposto de renda salario_liquido <- salario_bruto - (inss + ir) //definindo o salario liquido fimse //exibindo escreval("Salário bruto é:R$", salario_bruto) //exibindo salario bruto escreval("Salário liquido é:R$", salario_liquido) //exibindo salario liquido escreval("Hora trabalhada:",hora_extra) //exibindo hora extra escreval("INSS:R$", inss) //exibindo desconto do inss escreval("IR:R$", ir) //exibindo desconto do IR fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.