Jump to content

MichaelCommando

Members
  • Content count

    3
  • Joined

  • Last visited

Community Reputation

0 Comum

About MichaelCommando

  1. MichaelCommando

    [Resolvido] Algoritimo visualg

    Aê galera. Consegui responder em sala, meus problemas eram o mod junto com a repeiçao. Era so colocar um contador pra contar quantas vezes o mod era igual a 0, ai entra um "se" para falar se é primo ou nao. o algoritimo ficou assim: para i de x ate y faca para j de x ate i faca se i mod j = 0 entao c<- c+1 fimse fimpara se c = 2 entao escreval("numeros primos sao", i) Pode fechar o topico.Vlw pela ajuda!
  2. MichaelCommando

    [Resolvido] Algoritimo visualg

    obrigado pela ajuda, más ainda não consegui responder. O algoritmo lê os dois numeros que digito e fala se eles são primos ou não, porem o que eu quero é mostrar se os números entre eles são primos ou não. Por exeemplo: eu informo dois numeros, 1 e 5, o algoritmo deve falar se 1, 2, 3, 4, e 5 são primos ou não. o alg ficou assim: algoritmo "Questao 2" // Função : Determinar se um numero é primo ou nao // Autor : Michael Jordan - Turma 722 // Data : 20/08/2010 // Seção de Declarações var N, x, nn, c, n2, d, y: inteiro inicio escreval("numeros primos") escreval("Informe um numero") leia(n) se N > 0 entao nn<- 1 para c de 2 ate (n-1) faca se n mod c = 0 entao x<- x+1 fimse fimpara escrevaL("informe outro numero") leia(n2) para d de 2 ate (n2-1) faca se n2 mod d = 0 entao y<- x+1 fimse fimpara se x <> 0 entao escreval(N, " nao faz parte dos numeros primos") senao se x= 0 entao escrevaL(n, " faz parte dos numeros primos") fimse se y <> 0 entao escreval(n2, "nao faz parte dos numeros primos ") senao se y= 0 entao escreval(n2, " faz parte dos numeros primos") fimse fimse fimse fimse // Seção de Comandos fimalgoritmo desde já agradeço.
  3. olá galera!, Sou novo no forum e estou iniciando em algoritmos com o visualg, e estou sentindo dificuldades nas estruturas de repetiçao. O exercicio é o seguinte: Faça um algortmo que receba dois numeros naturais X e Y e escrever todos os numeros primos entre eles. eu apenas consegui fazer o algoritimo mostrar se o numero é primo ou nao: algoritmo "Questao 5" // Função : Escrever os números primos entre X e Y // Autor : Michael Jordan - Turma 722 // Data : 20/08/2010 // Seção de Declarações var N, x, nn, c: inteiro inicio escreval("numeros primos") escreval escreval("Informe um numero") leia(n) se N > 0 entao nn<- 1 para c de 2 ate (n-1) faca se n mod c = 0 entao x<- x+1 fimse fimpara se x <> 0 entao escreval(N, " nao faz parte dos numeros primos") senao se x= 0 entao escrevaL(n, " faz parte dos numeros primos") fimse fimse fimse // Seção de Comandos fimalgoritmo Essa questão faz parte de uma lista com 12 questoes para ser entregue nesta segunda. Se puderem me ajudar, desde já agradeço.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.