Jump to content

luroberto

Members
  • Content count

    26
  • Joined

  • Last visited

Community Reputation

0 Comum

About luroberto

Informações Pessoais

  • Sexo
    Masculino
  1. luroberto

    Aspas duplas passadas como texto em C#

    Olá itlpps, Está acontecendo a mesma coisa. A variável a, recebe a contra barra, além das aspas.
  2. luroberto

    Aspas duplas passadas como texto em C#

    Prezados, Estou utilizando uma aplicação windows forms C# que abre uma planilha do MS. Excel e formata esta planilha com várias informações. Uma delas é a função PROCV dentro da função SEERRO que em caso de erro a função deverá atribuir a célula da planilha o valor vazio (Representado por duas aspas duplas ""), porém quando utilizo \"" dentro da string ou @""""" ele retorna sempre com o texto a contra-barra \" provocando uma exceção no excel, pois o mesmo não consegue interpretar essa (contra barra) \. Utilizando qualquer uma das formas a baixo, no tempo de execução a aplicação insere a contra-barra antes das aspas: // utiliando este código string a = @""""""; //ou este // string a = " \"" "; string Linhas = Convert.ToString(lin); String procv = "=SEERRO(PROCV(E" + Linhas + ";SALESFORCE!$A$2:$B$7000;2;FALSO);" + a + ")";
  3. luroberto

    Erro ao criar Controller MVC4 WebAPI

    Já resolvi o problema. Efetuei a desinstalação do Entity Framework (estava instalado a versão 6, que não é suportado) pelo console do nuget do Visual studio. Depois instalei a versão 5.0.0
  4. luroberto

    Erro ao criar Controller MVC4 WebAPI

    Prezados, Estou criando um novo projeto bem simples ASP.NET MVC4 Web API utilizando a linguagem C#, MS Visual Studio 2013. Configurei a conection string no Web.Config <add name="conexaoSQL" connectionString="Data Source=PC01000\SQLEXPRESS; Initial Catalog=BANCODB; User Id=sa; Password=MinhaSenha;" providerName="System.Data.SqlClient" /> Criei as classes (Model) de conexão com o banco: using System; using System.Collections.Generic; using System.Linq; using System.Web; using System.Data.Entity; namespace projeto.Models { public class conexaoSQL : DbContext { public conexaoSQL() : base("name=conexaoSQL") { } } } Critei também a classe(Model) com as propriedades da tabela criada: using System; using System.Collections.Generic; using System.Linq; using System.Web; using System.ComponentModel.DataAnnotations; using System.Data.Entity; namespace projeto.Models { public class Usuario { [Key] public Int32 Id { get; set; } public string Nome { get; set; } public string Telefone { get; set; } public string Celular { get; set; } public string Email { get; set; } public string Endereco { get; set; } } } Porém no momento em que clico com o botão direito do mouse na pasta Controllers, clico em Add/Controller, configuro conforme as informações abaixo Controller name: UsuarioController Scaffolding options Template: API controller with read/write actions, using Entity Framework Model class: Usuario(projeto.Models) Data context class: Usuario(projeto.Models) e clico em Adicionar, é apresentada uma tela de erro com a seguinte mensagem: "Unsuported Context type". Alguém sabe me informar o pq desse erro e como faço para solucioná-lo?
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.