Jump to content

flavionorvel

Members
  • Content count

    23
  • Joined

  • Last visited

Community Reputation

0 Comum

1 Follower

About flavionorvel

Recent Profile Visitors

591 profile views
  1. flavionorvel

    Converter linguagem C para visualg

    #include <stdio.h> #include <stdlib.h> // Limites de tamanhos #define MINIMO 2 #define MAXIMO 50 // Variáveis globais int opcao = 0; int linhas = MAXIMO; int colunas = MAXIMO; int matrizA[MAXIMO][MAXIMO]; int matrizB[MAXIMO][MAXIMO]; void limpar_tela(); // Retorna resposta do usuario se quer rodar novamente int rodar_novamente() { int opcao = 0; printf("\n\nDeseja rodar novamente? Digite 1 para SIM e 0 para Não: "); scanf("%d",&opcao); if (opcao == 1 || opcao == 0) { return opcao; } printf("\nOpcao invalida. Escolha novamente."); return rodar_novamente(); } // Recebe valor inteiro do usuario int receber_numero() { int numero = 0; scanf("%d",&numero); if (numero >0) { return numero; } printf("\nNúmero inválido. digite um número positivo.: "); return receber_numero(); } // Valida tamanhos de linhas e colunas int validar_tamanhos(int linhas, int colunas) { if ((linhas >= MINIMO && linhas <= MAXIMO) && (colunas >= MINIMO && colunas <= MAXIMO) && (linhas ! = colunas)) { return 1; } printf("\nLinhas e Colunas devem ser diferentes e ter valores entre %d e %d. Tente novamente.",MINIMO,MAXIMO); return 0; } // Preencher matriz void preencher_matriz(int matriz[MAXIMO][MAXIMO], int linhas, int colunas) { int i,j; for (i = 0 ; i < linhas ; i ++) { for (j = 0 ; j < colunas ; j ++) { printf("\nDigite um valor inteiro para a posicao %d-%d da matriz A: ",i,j); matriz[j] = receber_numero(); } } } // Imprimir matrizes void imprimir_matrizes(int matrizA[MAXIMO][MAXIMO], int matrizB[MAXIMO][MAXIMO], int linhas, int colunas) { int i,j; limpar_tela(); printf("\n\nMATRIZ A\n"); for (i = 0 ; i < linhas ; i++) { for (j = 0 ; j < colunas ; j ++) { printf("\nMATRIZ A POSICAO %d-%d: %d",i,j,matrizA[j]); } } printf("\n\nMATRIZ B (TRANSPOSTA DE A)\n"); for (i = 0 ; i < colunas ; i++) { for (j = 0 ; j < linhas ; j ++) { printf("\nMATRIZ B POSICAO %d-%d: %d",i,j,matrizB[j]); } } } void limpar_tela() { system("@cls||clear"); } // Laço principal int main() { int i,j; do { //Inicializar variáveis opcao = 0; linhas = 0; colunas = 0; i = 0; j = 0; do { printf("\nEntre com o tamanho para linhas: "); linhas = receber_numero(); printf("\nEntre com o tamanho para colunas: "); colunas = receber_numero(); } while (!validar_tamanhos(linhas,colunas)); // entrar com valores para a matriz A preencher_matriz(matrizA, linhas, colunas); // criar matriz transposta de A for(i = 0 ; i < linhas ; i ++) { for(j = 0 ; j < colunas ;j ++) { matrizB[j] = matrizA[j]; } } // Imprimir matrizes imprimir_matrizes(matrizA,matrizB,linhas, colunas); // Pergunta ao usuário se quer continuar opcao = rodar_novamente(); } while (opcao == 1); }me
  2. flavionorvel

    Linguagem C help

    Elabore um algoritmoem Linguagem C,quereceba via teclado um vetor de 100 posições de números inteiros e positivos. O algoritmo deve validar corretivamente durante a entrada do vetor do para que não tenha número repetido. Após a entrada, processar e mostrar: a) O vetor em sua forma de entrada com a validação; b) Qual o maior número e qual posição (índice do vetor) ele aparece (original de entrada); c) Esse mesmo vetor ordenado crescente (do menor número para o maior); d) O valor da média aritmética destes elementos; e) Qual percentual de número pares em relação ao total geral de números informados. Observação1: 1) Usar a diretiva “define” para possibilitar escolhermos a dimensão do vetor, facilitando os testes (as simulações); 2) Importante lembrar que Para verificar se um número é “PAR” utilizamos a função MOD, e para esta função funcionar, o número deve ser do “TIPO INTEIRO”.
  3. flavionorvel

    Bubble sort

    Assim, vamos receber um vetor de 100 posições de números inteiros, processar a classificação deste vetor em ordem crescente. Fazer de forma que o usuário (cliente) possa voltar e executar a classificação com outros números. CONCEITOS: 1) Mostrar o vetor em sua forma de entrada (sem ordenar); 2) Mostrar o vetor ordenado crescente. 3) Criar as seguintes funções: uma função para validar corretivamente para termos somente números positivos. Uma função para validar corretivamente a resposta para << s >> ou << n >>.
  4. Elabore um algoritmo que solicite inicialmente a quantidade de crianças nascidas no período (validar corretivamente para ser maior ou igual a zero, dentro do código principal) e em seguida crie um laço de entrada para solicitar o sexo da criança morta (1-Feminino, 2-Masculino e/ou 9-Finalizar) e o número de meses de vida da criança (deve ser inteiro e entre 0 a 144
  5. flavionorvel

    linguagem pascal

    Um matemático italiano da idade média conseguiu modelar o ritmo de crescimento da população de coelhos através de uma sequência de números naturais que passou a ser conhecida como sequência de Fibonacci. O n-ésimo número da sequência de Fibonacci Fn é dado pela seguinte fórmula de recorrência: Var // Seção de Declarações das variáveis n, F1, F2, Funcao, Conta: inteiro; Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreva ("Digite um numero n:"); ler (n); Conta: = 1; F1: = 1; F2: = 1; Funcao: = 0; enquanto (Conta <= n) faça início F1: = F2; F2: = Funcao; Funcao: = F1 + F2; Conta: = Conta + 1 fim; writeln ('F de', n, '=', Funcao) fimse Fimalgoritmo qual foi meu erro
  6. flavionorvel

    erro em codigo

    Um banco concederá um crédito especial aos seus clientes, variável com o saldo médio no último ano. Faça um algoritmo que leia o saldo médio de um cliente e calcule o valor do crédito de acordo com a tabela abaixo. Mostre uma mensagem informando o saldo médio e o valor do crédito. (use o comando switch e não faça repetições) Algoritmo "credito" Var Saldo, valor: Real Inicio Escreva ("Bem vindo ao banco"); leia Escreva ("Digite o saldo desejado"); Leia (saldo); Se (saldo > = 0) e (saldo < = 200); Então Escreva ("Você não tem crédito para a operação"); Fim se Se (saldo > = 201) e (saldo < = 400); Então valor ? (saldo*0,2); Escreva ("O seu limite de crédito é:"valor); Fim se Se (saldo > = 401) e (saldo < = 600); Então valor ? (saldo*0,3); Escreva ("O seu limite de crédito é:"valor); Se (saldo > = 601); Então Escreva ("O seu limite de crédito é:"valor); Fim se fimAlgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.