Jump to content

GMVieira

Members
  • Content count

    1
  • Joined

  • Last visited

Community Reputation

0 Comum

About GMVieira

  1. GMVieira

    Matriz Visualg

    EXERCÍCIO: Faça uma subrotina que receba uma matriz 10x10, o número de uma linha, o número de uma coluna e retorne uma matriz 9x9, resultante da remoção da coluna e da linha informados. Comecei a fazer no visualg até onde eu consegui, mas meu algoritmo esta errado porque ele não consegue pular a linha e coluna eliminadas, tirando só o valor e fazendo como se ainda existisse 10 linhas e 10 colunas. Alguém poderia me ajudar? algoritmo "Matriz" var matriz10: vetor [1..10,1..10] de inteiro matriz9: vetor [1..9,1..9] de inteiro linha,coluna,l,c: inteiro inicio para linha de 1 ate 10 faca para coluna de 1 ate 10 faca matriz10[linha,coluna] <- 10 fimpara fimpara escreval ("Informe a linha (1 a 10) ") leia (l) escreval ("Informe a coluna (1 a 10) ") leia © para linha de 1 ate 10 faca para coluna de 1 ate 10 faca se ( (linha <> l) e (coluna <> c) ) entao matriz9[linha,coluna]<- matriz10[linha,coluna] fimse fimpara fimpara fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.