Jump to content

carlozz

Members
  • Content count

    1
  • Joined

  • Last visited

Community Reputation

0 Comum

About carlozz

  1. Estou no começo de um curso de Ti e meu professor passou um exercício em visualg estou com dificuldades apenas para fazer o item b ) da lista de coisas que o programa deve fazer. O Exercicio foi o seguinte: Meu programa está funcionando rendondinho só não consegui pensar em nada para o item b ) por isso decidi pedir ajuda a vocês que tem muito mais experiência no assunto. algoritmo "Exercicio 1" var S, med_anterior, media, maiorS, Perc : real cont : inteiro inicio maiorS:=0 med_anterior:=0 media:=0 repita escreva ("Digite o valor do salário:") leia (S) se s<>0 entao cont:=cont+1 med_anterior:=med_anterior+S fimse se (S<=1.000) entao S:=S+(S*2/10) fimse se (S>1.000) e (S<=2.000) entao S:=S+(S/10) fimse se (S>2.000) entao S:=S+(S/20) fimse se S>maiorS entao maiorS:=S fimse media:=media+S ate S=0 perc:=media/med_anterior-1.0 escreval ("A folha sálarial da empresa antes do reajuste era igual a R$ ", med_anterior) escreval ("A folha sálarial da empresa após os reajustes é igual a R$ ", media) escreval ("O percentual de aumento sobre a folha salarial foi de :", perc*100:2:2,"%") escreval ("O maior salário é R$ ", maiorS) escreval ("A média sálarial antes dos reajuste era igual a R$ ", med_anterior/cont) escreval ("A média sálarial após o reajusta é igual a R$ ", media/cont) fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.