Jump to content

BinnNNNNNN

Members
  • Content count

    1
  • Joined

  • Last visited

Community Reputation

0 Comum

About BinnNNNNNN

  1. Boa tarde, pessoal tenho a seguinte dúvida, necessito criar uma função que retorne o valor da soma da diagonal principal, dos elementos que somente sejam pares, a seguir vai um trecho do código, podem me dar uma luz ? Desde já fico muito grato! algoritmo "MatrizOrdemCinco" var i, j: Inteiro m: vetor[1..5, 1..5] de Real sMatriz: Real inicio Para i <- 1 ate 5 faca Para j <- 1 ate 5 faca Escreva("Matriz: ") Leia(m[i,j]) FimPara FimPara LimpaTela Para i <- 1 ate 5 faca Para j <- 1 ate 5 faca Escreva(m[i,j]:10) FimPara Escreval() FimPara Para i <- 1 ate 5 faca Para j <- 1 ate 5 faca Se (m[i,j] % 2=0) entao <- Acontece um erro aqui de declaração de inteiro. sMatriz <- (m[1,1] + m[2,2] + m[3,3] + m[4,4] + m[5,5]) FimSe FimPara FimPara Escreva("A soma é : ", sMatriz) fimalgoritmo (OBS: Não está em função estou ciente, fiz no corpo principal por enquanto.)
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.