Jump to content

marialuiza

Members
  • Content count

    9
  • Joined

  • Last visited

Community Reputation

0 Comum

1 Follower

About marialuiza

  1. marialuiza

    Função em c

    Média e maior salário sempre retorna 0, como faço pra corrigir? A prefeitura de uma cidade fez uma pesquisa entre os seus habitantes, coletando dados sobre o salárioe número de filhos. Faça uma função que leia esses dados para um número não determinado de pessoas e retorne a média de salário da população, a média do número de filhos, o maior salário e o percentual de pessoas com salário até R$350,00. #include <stdio.h> #include <locale.h> float mediasalario(float *salario, int n) { int i; float ms=0; for(i=0;i<n;i++) { ms += salario; } return ms/n; } float mediafilhos (int *filhos, int m) { int i; float mf=0; for(i=0;i<m;i++) { mf +=filhos; } return mf/m; } float maiorsalario(float *salario, int o) { int i; float maior = 0; for(i=0; i < o; i++) { if (salario > maior) { maior = salario; } } return maior; } float percentual(float *salario, int p) { int i, sal = 0; float percent; for(i=0;i<p;i++) { if (salario <= 350) { sal += salario; percent = (sal * 100) / p; } } return percent; } main(void) { setlocale(LC_ALL, "Portuguese"); int i,x; float salario[x]; int filhos[x]; printf("Digite o número de habitantes para cadastro: \n"); scanf("%d", &x); for(i=0;i<x;i++) { printf("\nHabitante %d - Digite seu salário: ", i+1); scanf("%f", &salario); printf("Quantidade de filhos: "); scanf("%d", &filhos); } printf("\nMÉDIA SALARIAL: %f", mediasalario(salario,x)); printf("\nMÉDIA DO NÚMERO DE FILHOS: %f", mediafilhos(filhos, x)); printf("\nO MAIOR SALÁRIO É: %f", maiorsalario(salario,x)); printf("\n PERCENTUAL DE PESSOAS QUE RECEBEM 350 REAIS: %f", percentual(salario,x)); }
  2. marialuiza

    Vetor em função C

    Faça uma função que receba por parâmetro um vetor A de 25 números inteiros e substitua os números negativos por 0. Como retornar o vetor para a função principal? #include<stdio.h> #include <stdlib.h> int valoresnegativos(int n, float *A); int main(void) { int i; int A[25]; for (i = 0; i < 25; i++) { printf("Digite o valor %d: ", i+1); scanf("%d", &A); } } int valoresnegativos(int n, float *A) { int i; for (i = 0; i < 25; i++) { if(A<0) { A=0; } else { A=A; } } for(i=0;i<25;i++) printf("%d\n",A); }
  3. marialuiza

    Matriz em c

    Matriz 10x10 não tá funcionando, alguém ajuda? int main() { int m[10][10]; int i,j; for(i=0;i<10;i++) { for(j=0;j<10;j++) { printf("Digite o valor: "); scanf("%d", &m[j]); } } for(i=0;i<10;i++) { for(j=0;j<10;j++) { printf("%d", &m[j]); } printf("\n"); } system("pause"); }
  4. A prefeitura de uma cidade fez uma pesquisa entre os seus habitantes, coletando dados sobre o salário e número de filhos. Faça uma função que leia esses dados para um número não determinado de pessoas e retorne a média do salário da população, a média do número de filhos, o maior salário e o percentual de pessoas com salário até 350 reais. O final do algoritmo tá dando erro, como faço para mudá-lo? Var // Seção de Declarações das variáveis f: inteiro oi,s: real x, opcao: caracter funcao prefeitura (var a,b: real): real var ms, mf, maiors, ps, contfilhos, contsalario, somasalario, contsalario350: real inicio contfilhos <- 0 contsalario <- 0 somasalario <-0 contsalario350 <- 0 maiors <- 0 enquanto s>=0 faca se s>maiors entao maiors <- s fimse somasalario <- somasalario + s contsalario <- contsalario + 1 se s <= 350 entao contsalario350 <- contsalario350 + 1 fimse contfilhos <- contfilhos + f fimenquanto mf <- contfilhos/contsalario ms <- somasalario/contsalario ps <- (contsalario350/contsalario)*100 retorne maiors retorne mf retorne ms retorne ps fimfuncao Inicio // Seção de Comandos, procedimento, funções, operadores, etc... x <- "s" enquanto x="s" faca escreva ("Digite seu salário: ") leia (s) escreva ("Quantos filhos você tem? ") leia (f) escreva ("Digite SIM para ccadastrar e NÃO para sair") leia(opcao) se (opcao="não") entao interrompa senao se (opcao="sim") entao oi <- prefeitura(s,f) fimse fimse fimenquanto oi <- prefeitura(s,f) oi Fimalgoritmo
  5. Faça uma função que receba um vetor x de 30 elementos inteiros, por parâmetro, e retorne dois vetores A (com os elementos pares) e B (com os elementos ímpares). Como faço para retornar um vetor?
  6. Faça uma função que receba por parâmetro, um valor inteiro e positivo N e retorne o valor de S, onde a 1ª parcela da soma tem N=1, a 2ª parcela tem N=2,..., até N ser igual ao valor digitado. S = 1 + 1/2 + 1/3 + 1/4 + 1/5 + 1/N Fiz assim, porém o resultado não fecha, como arrumo o algoritmo? Var // Seção de Declarações das variáveis n: inteiro m: real funcao somaparcela (s:real): real var i: inteiro inicio s <- 1 para i de 1 ate n faca s <- s + 1/n fimpara retorne s fimfuncao Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreva ("Digite um número inteiro positivo: ") leia (n) m <- somaparcela(n) escreva (n) Fimalgoritmo
  7. Queria saber como fica o diagrama de blocos com um subalgoritmo, por ex.: Faça uma função que receba um número inteiro e positivo N como parâmetro e retorne a soma dos N números inteiro existentes entre o número 1 e esse número.
  8. marialuiza

    Ajuda com matrizes visualg

    A: vetor [1..6,1..6] de inteiro l,c, x: inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... para l de 1 ate 6 faca para c de 1 ate 6 faca escreval ("Informe o valor da posicao: ",l,"-",c,": ") leia (A[l,c]) fimpara para l de 1 ate 6 faca para c de 1 ate 6 faca se (A[l,c]) > 10 entao empaquei na parte de contar quantos valores maiores que 10 ela possui
  9. 1. Leia uma matriz 6 x 6, conte e escreva quantos valores maiores que 10 ela possui. 2. Declare uma matriz 5 x 5. Preencha com 1 a diagonal principal e com 0 os demais elementos. Escreva ao final a matriz obtida
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.