Jump to content

Rickson Jordan

Members
  • Content count

    1
  • Joined

  • Last visited

Community Reputation

0 Comum

About Rickson Jordan

  1. Olá companheiros, preciso da ajuda de vocês para resolver a SAÍDA/entrada deste código de Reservamento de Cadeiras em uma Sala, onde terá que registrar o quando escolher ENTRADA (E) de entrada na opção de -"se...entao" > cadeiras(assentos) disponíveis (Matriz 10x5) > logo em seguida>nome>matrícula a reservar somente UMA em seu "nome ou matrícula". -Caso a pessoa declare no inicio entre as opções de ENTRADA (S) de saída deverá aparecer novamente a Matriz (10X5) de Assentos e a Fileira e Posição que deseja tirar a pessoa, logo em seguido caso digite certo, aparecerá o NOME da pessoa naquela POSIÇÃO (i,j=a,b) informado desde o inicio), e confirmar pedindo a matricula da pessoa para fazer verificação(isso impedira que qualquer um faça alteração do sistema, sem a matricula da pessoa) que SAIU no meio do evento e apagar da (Matriz 10x5) que aparece no início e disponibilizar na próxima reserva que o Usuário cadastrar denovo Obs. No Final , quando o usuário não querer mais cadastrar ninguém, deverá aparecer uma Listagem das Pessoas(NOMES) que estavam Presente, com sua (MATRÍCULA.) e as Pessoas(NOMES) que desistiram , "saíram do evento" Esta dando erro justo na Parte de Desistir da Lugar, no finalzinho.. Na hora que faz a equivalência logica: "Se mat[a,b] = matricula[i,j] entao" <<<<<= Faz COMPARANDO uma matriz com a outra em termos de numero de linhas e colunas, mas eu não quero isso, quero que compare o VALOR que contém em cada VARIÁVEL COMPOSTA desta matriz, ex: mat[1,1]="nome" matricula[1,1]="nome" Equivalência Lógica de valores: (mat[1,1]="nome" = matricula[1,1]="nome") CONDIÇÃO VERDADEIRA <<<quero atingir essa Condição , caso seja igual os valor de cada matriz, levando em consideração a sua posição [a,b]=[i,j] Segue o código: algoritmo "Controle de Evento Acadêmico" var sala: vetor [1..10, 1..5] de Caractere // 1,1 1,2 1,3 1,4 1,5 // 2,1 2,2 2,3 2,4 2,5 // 3,1 3,2 3,3 3,4 3,5 // 4,1 4,2 4,3 4,4 4,5 // 5,1 5,2 5,3 5,4 5,5 // 6,1 6,2 6,3 6,4 6,5 // 7,1 7,2 7,3 7,4 7,5 // 8,1 8,2 8,3 8,4 8,5 // 9,1 9,2 9,3 9,4 9,5 // 10,1 10,2 10,3 10,4 10,5 i,j,f,p,totalpres: inteiro desistente: vetor[1..10,1..5] de caractere a,b:inteiro nome: vetor [1..10, 1..5] de caractere matricula: vetor [1..10, 1..5] de caractere r,pj, resp, resp2,confirma: caractere Procedimento cabecalho inicio Escreval("*****************************************************************************") Escreval("--------------------------- SYSTEM CONTROL ----------------------------") Escreval("*****************************************************************************") Fimprocedimento Procedimento end() inicio Se resp2="s" entao LimpaTela() Se (sala[f,p]=nome[i,j]) entao Escreval ("========================>Evento Encerrado!<======================= ") Escreval ("------------------- Lista de Alunos Presentes -------------------") totalpres <-0 Escreval ("Nome: ",nome[i,j],"--- Matricula: ", matricula[i,j]) Escreval ("Assento: ", f,",",p) totalpres <- totalpres + 1 Escreva("------------------------------------------------------------------") Escreval ("------------------ ",totalpres," aluno(s) presente(s) -------------------") FimSe FimSe Se resp2="c" entao LimpaTela() senao Escreval("Erro! Opção Inválida.") Fimse FimProcedimento Procedimento MostraSala() var f,p:inteiro inicio EscrevaL("------------------------------------------------------------------------") EscrevaL("=================RESERVAMENTO DE CADEIRA================================") EscrevaL("------------------------------------------------------------------------") Para f <- 1 ate 10 passo 1 faca Para p <-1 ate 5 passo 1 faca Se (sala[f,p] = "") entao Escreva ("[ ", f,",",p, " ] ") senao Escreva ("[ ------ ]") FimSe Fimpara Escreval() FimPara EscrevaL() EscrevaL("------------------------------------------------------------------------") FimProcedimento inicio para i <- 1 ate 10 faca para j <- 1 ate 5 faca Limpatela () cabecalho Escreval Escreva("Deseja registrar entrada ou saída(e{entrada}/s{saida}): ") Leia (resp) Limpatela () Se resp="e" entao cabecalho Escreval Escreval(" REGISTRO DE ENTRADA") Escreva("Nome do aluno: ") Leia (nome[i,j]) Escreva("Matricula: ") Leia (matricula[i,j]) LimpaTela MostraSala() Escreva("Reservar a cadeira: ") Leia(f,p) Se (sala[f,p]="") entao sala[f,p] <- nome[i,j] EscrevaL("Cadeira", f,",",p, " RESERVADA!") Senao EscrevaL("ERRO: Lugar Ocupado!") FimSe Escreva() LimpaTela() cabecalho Escreva ("Deseja encerrar o evento ou continuar (S/C): ") Leia (resp2) end() FimSe Se resp="s" entao cabecalho repita Escreval Escreval(" REGISTRO DE SAÍDA") EscrevaL("Nome do desistente: ") Leia (desistente[a,b]) Se nome[i,j]= desistente[a,b] entao Escreval("Tem certeza que deseja excluir esta reserva? SIM=1 | NAO=0: ") leia(confirma) Se confirma=1 entao sala[f,p]<-"" nome[i,j]<-"" escreval("Reserva Excluída com Sucesso!") senao escreval("Reserva Não Alterada!") fimse senao escreval("Este Lugar já está Desocupado!") Fimse EscrevaL("Deseja Continuar a Registar?") EscrevaL("(S)- Para Continuar/ (qualquer tecla)- para SAIR)") Leia(pj) ate (pj="s") senao Escreval Escreval ("Erro! Só sera aceito (e) para e entrada e (s) para saida.") Limpatela() FimSe FimPara FimPara fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.