Ir para conteúdo

EmersonReinecke

Members
  • Total de itens

    8
  • Registro em

  • Última visita

Reputação

1 Comum

Sobre EmersonReinecke

Últimos Visitantes

O bloco dos últimos visitantes está desativado e não está sendo visualizado por outros usuários.

  1. Boa Tarde Pessoal Estou fazendo esse programa q pede 10 numeros e troca os 5 primeiros pelos 5 ultimos e vice versa,so que toda vez mudo os 5 numeros das ultimas posições para frente as primeiras posições não entram nas ultimas posições do array,por isso gostaria de saber o que estou fazendo de errado. /* necessita de uma solução que a partir da alimentação de um vetor com 10 valores reais, após, desenvolva uma rotina de programa que troque os 5 primeiros valores pelos 5 últimos e vice-e-versa. Ao final deste processo, imprima o vetor obtido, ou seja todos valores contidos no vetor após a troca. */ package Vetores; import javax.swing.JOptionPane; public class Exercicio3 { public static void main(String[] args) { int valores[]=new int [10]; int valoresA[]=new int [10]; int valoresB[]=new int [10]; int p=0; for (int i=0; i<5; i++) { p++; valoresA=Integer.parseInt(JOptionPane.showInputDialog("Informe um numero para a posição "+p)); } for (int i=0; i<5; i++) { p++; valoresB=Integer.parseInt(JOptionPane.showInputDialog("Informe um numero para a posição "+p)); } for(int i=0; i<5; i++){ valores=valoresB; } for(int i=5; i<10; i++){ valores=valoresA; } for (int i=0; i<10; i++) { System.out.print(valores); } } }
  2. Ola A estrutura se deste algoritimo esta dando erro,agradeço se alguem puder me ajudar. // Função :6) Faça um algoritmo que o usuário informe dois números inteiros, que o segundo //número divida o primeiro e que se o resto for par, o quociente for ímpar e o resultado //for maior que 3, informe que ele venceu o desafio do algoritmo, e independente de //vencer ou não mostre os resultados das operações. // Autor :Emerson Reinecke // Data : 03/08/2017 // Seção de Declarações var n1,n2:inteiro resultado,quoc,resto:real inicio escreval("Digite um numero:") leia(n1) escreval("Digite um numero:") leia(n2) resultado<-(n1/n2) resto<-(n1 mod n2) quoc<-(n1 div n2) se (resto=0) e (resultado>3) e (quoc mod 2 = 0 ) entao escreval("Voce Venceu o Desafio do Algoritmo!") escreval("O Resultado da operação foi ",resultado,"") escreval("O Quociente da operação foi ",quoc,"") escreval("O Resto da operação foi ",resto,"") senao escreval("O Resultado da operação foi ",resultado,"") escreval("O Quociente da operação foi ",quoc,"") escreval("O Resto da operação foi ",resto,"") fimse fimalgoritmo
  3. EmersonReinecke

    Duvida para validar campos em JavaScript

    Show de bola Muito obrigado aos 2 ,ja me ajudou bastante.
  4. EmersonReinecke

    Duvida para validar campos em JavaScript

    Bom dia Estou aprendendo javascript e preciso validar campos de um formulario em javascript. Alguem poderia me mostrar como criar id e explicar como funciona,se puder me mostrar um exemplo no meu campo. <!DOCTYPE html> <html> <head> <link rel="stylesheet" type="text/css" href="estilo.css" /> <meta charset="UTF-8"/> <title>Pratica sobre Html Parte-3</title> <body class=body > <div class=form align="center"><h1>Formulário</h1></div> <div class=nome align="center"><p><b>Nome:</b><br></div> <div align="center"><input type=text name="nome" size="45"></p><br></div> <div class=email align="center"><p><b>Email:</b><br></div> <div align="center"><input type=text name="email" size="45"></p><br></div> <div class=assunto align="center"><p><b>Assunto:</b><br></div> <div align="center"><input type=text name="assunto" size="45"></p><br></div> <div class=mensagem align="center"><p><b>Mensagem:</b><br></div> <div align="center"><textarea name="Mensagem" rows="10" cols="50" wrap="virtual"></textarea></p><br></div> <div align="center"><p><input type="submit" value="Enviar Email"> <input type="reset" value="Limpar Formulário"></p></div> </body> </html>
  5. EmersonReinecke

    Visualg Função

    Obrigado Ismael!
  6. EmersonReinecke

    Visualg Função

    Boa noite Amigos Estou com dificuldade neste algoritimo,preciso que apos cadastrar itens ele tenha a opção de voltar para o menu principal. var codigo: vetor [1..5] de inteiro valor: vetor [1..5] de real descricao: vetor [1..5] de caracter fim,iniciar,opcao2: caracter opcao: inteiro ordem: inteiro inicio ordem <- 1 escreval("OPCOES") escreval("") escreval("Escolha a Opcao que Deseja Executar:") escreval("") escreval("1. Cadastro de Novo Produto:") escreval("2. Listagem de Produtos Cadastrados:") escreval("3. Listar Produto e a Quantidade em Estoque:") escreval("4. Gerar Cupom de Produtos Vendidos:") escreval("5. Calcular o Valor total de Cupons:") leia (opcao) limpatela escolha opcao //cadastro dos produtos caso 1 opcao2 <- "i" enquanto opcao2 = "i" faca escreval("Cadastrando um novo Produto na Loja:") escreval("") escreval("Digite o Código do PRODUTO:") leia(codigo[ordem]) escreval("Digite a Descricao do PRODUTO:") leia(descricao[ordem]) escreval("Digite o Valor do PRODUTO:") leia(valor[ordem]) escreval("Para cadastrar mais um produto Tecle 'I'. Para finalizar tecle 'F'") leia(opcao2) fimenquanto limpatela escreval("Produto cadastrado com sucesso!!") escreval("--------------------------------") escreval("Para cadastrar mais um produto Tecle 'I'. Para voltar ao menu tecle 'F'") leia(opcao2) fimescolha escolha opcao2 caso "f" escreval("Sistema Encerrado.") caso "i" enquanto opcao2 = "i" faca escreval("Cadastrando um novo Produto na Loja:") escreval("") escreval("Digite o Código do PRODUTO:") leia(codigo[ordem]) escreval("Digite a Descricao do PRODUTO:") leia(descricao[ordem]) escreval("Digite o Valor do PRODUTO:") leia(valor[ordem]) escreval("Para cadastrar mais um produto Tecle 'I'. Para finalizar tecle 'F'") leia(opcao2) fimenquanto fimescolha escolha opcao //listagem dos produtos caso 2 escreval("2. Listagem de Produtos Cadastrados:") escreval("Digite o codigo do produto:") leia(codigo[ordem]) escreval("O Produto Cadastrado é", [descricao], ".") fimescolha fimalgoritmo
  7. EmersonReinecke

    Visualg

    Alguem conheçe algum site com um manual de visualg pra indicar,que tenha comandos,funções.
  8. EmersonReinecke

    Visualg Exercicio

    Tenho esse exercício pra resolver,alguém poderia me ajudar? 3 - A prefeitura de “Xico City” deseja fazer uma pesquisa entre seus habitantes. Desenvolva uma solução para coletar dados sobre o salário e número de filhos de cada habitante e após as leituras, escrever: a) Média de salário da população b) Média do número de filhos c) Maior salário dos habitantes d) Percentual de pessoas com salário menor que R$ 150,00
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.