Jump to content

CRIS20

Members
  • Content count

    8
  • Joined

  • Last visited

Community Reputation

-5 Fraco

About CRIS20

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Escrever um algoritmo que lê: - a percentagem do IPI a ser acrescido no valor das peças - o código da peça 1, valor unitário da peça 1, quantidade de peças 1 - o código da peça 2, valor unitário da peça 2, quantidade de peças 2 O algoritmo deve calcular o valor total a ser pago e apresentar o resultado. Fórmula : (valor1*quant1 + valor2*quant2)*(IPI/100 + 1)
  2. Elaborar um algoritmo que lê 3 valores a,b,c e verifica se eles formam ou não um triângulo. Supor que os valores lidos são inteiros e positivos. Caso os valores formem um triângulo, calcular e escrever a área deste triângulo. Se não formam triângulo escrever os valores lidos. ( se a > b + c não formam triângulo algum, se a é o maior).
  3. ID,peso_boi,boigordo,boimagro: inteiro matricula,media,totalpeso: real raca_boi,dono,fazenda: caracter inicio // Seção de Comandos escreval(" BEM-VINDO AS FAZENDINHAS!! ") escreval escreval para ID de 1 ate 5 faca escreva("Raça do Boi: ") leia(raca_boi) escreva("Nome do Dono do Boi: ") leia(dono) escreva("Nome da fazendo que o Boi pertence: ") leia(fazenda) escreva("Peso do Boi: ") leia(peso_boi) matricula<- escreval("ID | Matricula | Peso do Boi | Raça do Boi | Dono do Boi | Fazendo do Boi |") escreval(ID," ",matricula," ",peso_boi," ",raca_boi," ",dono," ",fazenda) escreval("---------------------------------------------------------------------------") fimpara media<- ()/5 escreval("Média dos pesos: ",media) escreval("Boi mais gordo: ",boigordo) escreval("Boi mais magro: ",boimagro) fimalgoritmo
  4. Criar um algoritmo que cadastre 5 bois com as informações seguintes: ID MATRICULA NO SISTEMA REGRA: ANO VIGENTE+valoraleatorio (exemplo: 2017208) PESO DO BOI RAÇA DO BOI NOME DO DONO/FAZENDA Após o cadastro faça o algoritmo analisar e informar O BOI MAIS GORDO O BOI MAIS MAGRO *se houver dois no mesmo peso mostrar os dois* MÉDIA DOS PESOS DO BOIS CADASTRADOS Alguém pode me ajudar como se faz????
  5. var nome_cliente: caracter valor_produto,valor_total,codigos: inteiro inicio // Seção de Comandos escreval("Digite o nome do cliente: ") leia(nome_cliente) escreva("Digite o valor do produto: ") leia(valor_produto) escreval("---------------------------------------------------------------------------------") escreval("1 - Pagamento à vista em dinheiro, ganha 10% de desconto") escreval("2 - Pagamento à vista no cartão de crédito, 10% de juros no valor do produto") escreval("3 - Pagamento parcelado em 2x, 15% de juros no valor do produto") escreval("4 - Pagamento em 3x ou mais parcelas, 5,5% de juros em cada parcela") escreval("---------------------------------------------------------------------------------") escreval("Digite a forma de pagamento que você deseja: ") leia(codigos) //caso 1 fimalgoritmo
  6. Boa Tarde, alguém pode me ajudar? Faça um algoritmo que pergunte ao usuário o valor do produto e quando o usuário pergunta ao cliente a forma de pagamento, esta seja descriminada da seguinte forma: no caso 1: pagamento à vista no dinheiro, ganha 10% de desconto no caso 2: pagamento à vista no cartão de crédito sofre 10% de juros no valor do produto no caso 3: pagamento parcelado em até 2x, sofre 15% de juros no valor do produto no caso 4: pagamento no minimo em 3x parcelas ou mais sofre 5,5% EM CADA parcela Usar outrocaso também Caso apareça a mensagem de Opção invalida o programa volte ao menu para o usuário escolher um opção valida desafioaula4.alg
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.