Jump to content

LFormaggine

Members
  • Content count

    1
  • Joined

  • Last visited

Community Reputation

0 Comum

About LFormaggine

  1. Pessoal, estou tentando fazer um jogo da velha um pouco diferente do padrão. É uma versão bem simples. Só que um dos comandos está dando problema e eu não faço ideia o porquê disso. Vejam: algoritmo "Jogo da Velha" var jogo: vetor[1..3, 1..3] de inteiro i, j: inteiro cont: inteiro pos1: inteiro pos2: inteiro num: vetor[1..9] de inteiro Procedimento Topo() inicio EscrevaL ("---------------") EscrevaL (" JOGO DA VELHA ") EscrevaL ("---------------") cont <- 1 Para i <- 1 ate 3 faca Para j <- 1 ate 3 faca jogo [i,j] <- cont Se jogo[i,j] = num[pos1] entao Escreva ("| X|") senao Se jogo[i,j] = num[pos2] entao Escreva ("| O|") senao Escreva ("| ", cont, "| ") FimSe FimSe cont <- cont + 1 FimPara EscrevaL () FimPara EscrevaL ("---------------") FimProcedimento Procedimento JogadaJ1 () inicio Repita EscrevaL ("Digite a posição para o jogador (X)") Leia (pos1) Se num[pos1] = jogo[i,j] entao Escreva ("JOGADA INVÁLIDA. Digite outra posição") FimSe Ate num[pos1] <> jogo[i,j] num[pos1] <- pos1 Topo () JogadaJ2 () FimProcedimento Procedimento JogadaJ2 () inicio Repita EscrevaL ("Digite a posição para o jogador (O)") Leia (pos2) Se num[pos2] = jogo[i,j] entao Escreva ("JOGADA INVÁLIDA. Digite outra posição") FimSe Ate num[pos2] <> jogo[i,j] num[pos2] <- pos2 Topo () JogadaJ1 () FimProcedimento inicio LimpaTela EscrevaL ("---------------") EscrevaL (" JOGO DA VELHA ") EscrevaL ("---------------") cont <- 1 Para i <- 1 ate 3 faca Para j <- 1 ate 3 faca jogo [i,j] <- cont Escreva ("| ", cont, "| ") cont <- cont + 1 FimPara EscrevaL () FimPara JogadaJ1 () fimalgoritmo Ainda não terminou, mas há um erro de sintaxe na linha do "Se jogo[i,j] = num[pos1] entao" e "Se jogo[i,j] = num[pos2] entao". Alguém pode me dizer por quê ?
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.