Ir para conteúdo

Cash999

Members
  • Total de itens

    2
  • Registro em

  • Última visita

Reputação

0 Comum

Sobre Cash999

  1. Meu código esta assim: programa { //variavel global inteiro matriz[3][3] funcao logico repetiu(inteiro n, inteiro lin, inteiro col){ para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(nao(l == lin e c == col)){ se(matriz[l][c] == n){ retorne verdadeiro } } } } retorne falso } funcao inicio(){ //receber a matriz para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ leia(matriz[l][c]) } } para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(repetiu(matriz[l][c], l, c)) escreva(matriz[l][c], " - ") } } } }
  2. O QUE CONSEGUIR FAZER ATÉ O MOMENTO FOI ISSO programa { //variavel global inteiro matriz[3][3] funcao logico repetiu(inteiro n, inteiro lin, inteiro col){ para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(nao(l == lin e c == col)){ se(matriz[l][c] == n){ retorne verdadeiro } } } } retorne falso } funcao inicio(){ //receber a matriz para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ leia(matriz[l][c]) } } para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(repetiu(matriz[l][c], l, c)) escreva(matriz[l][c], " - ") } } } }
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.