Jump to content

Arhon Berdichevsky

Members
  • Content count

    2
  • Joined

  • Last visited

Community Reputation

0 Comum

About Arhon Berdichevsky

  1. Arhon Berdichevsky

    Código acessa banco no EasyPHP (localhost) mas não no Wamp (acesso remoto).

    Para resolver o problema no sisteminha do estoque de manutenção fui no Wamp e desabilitei a opção ONLY_FULL_GROUP_BY em MySQL >>MySQL setting >> sql-mode.
  2. Oi, pessoal. Usando o seguinte código consigo acessar o banco de dados sem problemas no EasyPHP (localhost). $sql = "SELECT id, nome, sum(entrada) AS soma_entrada, datahist from historico WHERE id='$id' AND datahist BETWEEN '$datainicial' AND '$datafinal' GROUP by datahist"; $resultado = mysqli_query($strcon,$sql) or die ("Erro...1"); Já no Wamp instalado num servidor usando acesso remoto, não consigo acessar o BD e visualizo Erro...1. O erro acontece somente nesse código; com outros arquivos do mesmo projeto consigo o acesso normalmente ao banco de dados. Será que tem alguma coisa nesse código que o Wamp não aceita e o EasyPHP sim??? Para testar se a tabela estava com algum problema no Wamp, usei o seguinte código e consegui visualizar direitinho a variavel $entri, mas depois aparece o Erro...1 do die. $sql = "SELECT entrada from historico WHERE id_hist='8'"; $resultado = mysqli_query($strcon,$sql) or die ("Erro...0"); while ($registro = mysqli_fetch_array($resultado)){ $entri = $registro['entrada']; } echo $entri; echo "<br/>"; $sql = "SELECT id, nome, sum(entrada) AS soma_entrada, datahist from historico WHERE id='$id' AND datahist BETWEEN '$datainicial' AND '$datafinal' GROUP by datahist"; $resultado = mysqli_query($strcon,$sql) or die ("Erro...1"); Fico no aguardo das resposta. Obrigado desde já.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.