Jump to content

dev_thiagosilva

Members
  • Content count

    16
  • Joined

  • Last visited

Everything posted by dev_thiagosilva

  1. Opa marlon, consegui resolver o problema... estou fazendo isso para pegar o nome e tudo que eu quiser.. $sql = "SELECT id,Nome,Sobrenome,data_nascimento,cpf, email, senha FROM users WHERE Nome='$Nome'"; foreach($pdo->query($sql)as $row) { } Eu tava pensando e acabei lembrando de uns projetos antigos e resolvi da uma olhada na documentação do php e consegui chegar aí.
  2. pessoal, estou com dificuldade em pegar os dados do usuario em uma sessão. na verdade eu consigo pegar apenas o nome dele, mas eu quero pegar as informações apartir do id do usuario logado e depois vincular todas as ações desse usuario com o que ele fizer. alguém poderia me dar um caminho pra seguir??? agradeço desde já.
  3. dev_thiagosilva

    ERRO de UPDATE MARIADB (PHP)

    VALEU amigo. ja tinha resolvido, mas era isso mesmo.. obrigado
  4. dev_thiagosilva

    ERRO de UPDATE MARIADB (PHP)

    Pessoal estou com erro na hora de atualizar um registro.... podem me ajudar???? Esse é o arquivo: update.php $pdo = Banco::conectar(); $pdo->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION); $sql = "UPDATE create_cardapio set sabor = ?, tamanho = ?, igrediente = ?, valor = ?, where id = ?"; $q = $pdo->prepare($sql); $q->execute(array($sabor, $tamanho, $igrediente, $valor, $id)); Banco::desconectar(); header("Location: index.php"); Esse é o erro. Fatal error: Uncaught PDOException: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'where id = '6'' at line 1 in /opt/lampp/htdocs/PadariaSystem/pages/adm/update.php:66 Stack trace: #0 /opt/lampp/htdocs/PadariaSystem/pages/adm/update.php(66): PDOStatement->execute(Array) #1 {main} thrown in /opt/lampp/htdocs/PadariaSystem/pages/adm/update.php on line 66 Por favor, se algume der uma ajuda agradeço....
  5. Bom, eu quero pegas os dados dele e exibir em uma página de perfil, assim ele pode fazer o CRUD também.
  6. Pessoal não estou conseguindo colocar meu arquivo na pasta HTDOCS no linux, quando eu copio a pasta ele rejeita. Tem como mudar essa situação???? estou usando o XAMPP no Linux.
  7. dev_thiagosilva

    Otimização de query para busca

    você ta mostrando o que exatamente ele tem que mostrar???? Pode ser que ele esteja correndo onde nao seja preciso ir... se possivel tem como colocar o código? vamos resolver isso
  8. dev_thiagosilva

    CONECTANDO BANCO DE DADOS COM MYSQLI

    Olá pessoal sou novo aqui no IMASTER, porém tenho um pouco de conhecimento em php. Bom vamos ao que realmente interessa, se você chegou aqui é porque ainda esta se enrolando com a conexão com o banco de dados com MYSQLI. vamos lá então... <?php $servidor = ''localhost'; $usuario = ''root'; $senha = '' '; // eu deixo vazia porque é o padrão do xampp(o meu server local) $bd = ''teste' $mysqli = new mysqli($servidor, $usuario, $senha, $db); if (mysqli_connect_errno())trigger_error(mysqli_connect_error()); // esse é uma condicional pra caso de erro.. bom é isso aí pessoal. Simples não? Qualquer dúvida deixa nos comentários.
  9. dev_thiagosilva

    Problema com select

    me mostra o banco de dados pode???? os dados estão sendo enviados para o seu banco de dados???? todos!!?
  10. dev_thiagosilva

    Formulário dinamico

    pode usar uma condicional para o numero de dependentes, cria um formulário e de acordo com o numero de dependentes a condicional vai mostrar no cadastro.
  11. dev_thiagosilva

    "Página não encontrada" - Não consigo acessar página via servlet

    servidor esta ligado/???
  12. dev_thiagosilva

    Problema com posicionamento de DIV's

    explica aqui como você resolveu e dar a sessão como resolvida
  13. dev_thiagosilva

    Algoritmo - Estrutura Enquanto

    algoritmo "THIAGOSILVA.DVL" // Função : IMPRIMIR NUMEROS E MOSTRAR O MAIOR // Autor : // Data : 4/6/2018 // Seção de Declarações var VALOR1, VALOR2, VALOR3: INTEIRO inicio // Seção de Comandos ESCREVAL("ESCREVA O PRIMEIRO NUMERO") LEIA(VALOR1) ESCREVAL("ESCREVA O SEGUNDO NUMERO") LEIA(VALOR2) ESCREVAL("ESCREVA O TERCEIRO NUMERO") LEIA(VALOR3) SE VALOR1 > VALOR2 ENTAO ESCREVAL(VALOR1, "MAIOR NUMERO") FIMSE SE VALOR1 > VALOR3 ENTAO ESCREVAL(VALOR1, "MAIOR NUMERO") FIMSE SENAO SE VALOR2 > VALOR1 ENTAO ESCREVAL(VALOR2, "MAIOR NUMERO") FIMSE SENAO VALOR2 > VALOR3 ENTAO ESCREVAL(VALOR2, "MAIOR NUMERO") FIMSE SENAO VALOR3 > VALOR1 ENTAO ESCREVAL(VALOR3, "MAIOR NUMERO") FIMSE SENAO VALOR3 > VALOR2 ENTAO ESCREVAL(VALOR3, "MAIOR NUMERO") FIMSE fimalgoritmo SEGUE MAIS OU MENOS ESSA LÓGICA.
  14. dev_thiagosilva

    Algoritmo - Estrutura Enquanto

    SEGUINTE. DEU PRA PERCEBER QUE VOCÊ ESTA ATRIBUINDO VALOR ZERO A SUA VARIALVEL S, ENTAO QUANDO você PEDE PRA IMPRIMIR ELE APARECE ZERO. TEM QUE ORGANIZAR MAIS O CÓDIGO E VER O QUE REALMENTE VOCÊ ESTA PRECISANDO, TEM VARIAVES QUE NAO ESTAÕA SENDO UTILIZADAS.
  15. dev_thiagosilva

    Algoritmo - Estrutura Enquanto

    OLÁ, AINDA PRECISA DE AJUDA???
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.