Ir para conteúdo

Niê

Members
  • Total de itens

    2
  • Registro em

  • Última visita

Reputação

0 Comum

Sobre Niê

Contato

  • Twitter
    demianrice
  1. Niê

    Erro no código VisualG

    Por favor, deixe o código aqui para que possamos conferir e editar o mesmo. Ter um print do código é cansativo e nos faz ter que digitar o código novamente...
  2. o Estoque Cadastro de item no estoque Descrição / Quantidade / Preço de custo / Preço de venda Cadastro de combo promocional Descrição / Quantidade / Preço de custo / Preço de venda Retirar item do estoque Retira quantidade do item selecionado Relatório de itens no estoque. Todos os itens Olá! Estou desenvolvendo o código relacionado a estas funções: algoritmo "ESTOQUE" // Estoque // Cadastro de item no estoque // Descrição / Quantidade / Preço de custo / Preço de venda // Cadastro de combo promocional // Descrição / Quantidade / Preço de custo / Preço de venda // Retirar item do estoque // Retira quantidade do item selecionado // Relatório de itens no estoque. // Todos os itens tipo //dados do produto Produto = registro desc :caractere //descricao qtd :inteiro //quantidade pCusto:real //preco de custo pVenda:real //preco de venda fimRegistro var produtos :vetor [1..1] de Produto i,j :inteiro codItem :inteiro opc :caractere fim_cad :inteiro procedimento cadastro_item inicio codItem <- codItem+1 escreval("** Cadastro de produto **") escreva ("Descrição :") leia(produtos[codItem].desc) escreva ("Quantidade :") leia(produtos[codItem].qtd) escreva ("Preço de CUSTO :") leia (produtos[codItem].pCusto) escreva ("Preço de VENDA :") leia (produtos[codItem].pVenda) //Abaixo irá mostrar o último produto cadastrado // escreval ("Produto :",produtos[coditem].desc) //escreval ("Quantidade :",produtos[coditem].qtd) // escreval ("Preço R$:",produtos[coditem].Pvenda ,",00") // leia() i:= 0 fimProcedimento procedimento imprimir_produtos()//Prodedimento para imprimir os produtos cadastrados escreval ("Em breve.") fimProcedimento procedimento menu() inicio repita limpaTela escreval("--------- ESTOQUE - PDV--------") escreval() escreval(" 1-Cadastro de Item ") escreval(" 3-EM CONSTRUÇÃO ") escreval(" 4-EM CONSTRUÇÃO ") escreval(" 5-Sair ") escreval() escreval(" 0-*Imprimir produtos ") escreval("-------------------------------") leia(opc) escolha (opc) caso "1" limpaTela cadastro_item() //qdn esse método é invocado, ao finalizar, o programa vai continuar daqui... caso "3" limpaTela escreval("EM CONTRUÇÃO") caso "0' limpaTela imprimir_produtos() fimEscolha ate opc="5" fimProcedimento inicio codItem <- 0 menu() fimAlgoritmo A partir daqui minha mente travou, não vou para frente nem para trás. Alguém me da um start pls? Estou para desenvolver a parte de imprimir itens cadastrados, porém quero antes de tudo armazenar para poder imprimi-los.
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.