Jump to content

ludlima

Members
  • Content count

    3
  • Joined

  • Last visited

Everything posted by ludlima

  1. Boa noite,estou tentando executar um algoritmo no visualg que leia 100 números,descubra se existe números primos,se sim mostrar em que posição se encontra. Entretanto,o programa só está executando até onde mostra o vetor. Gostaria de ajuda de como terminar e realizar a verificação do número primo. Var num, cont, divisor: inteiro VET: vetor[0..99] de inteiro Inicio escreval ("Olá!Você quer saber se existe número primo? ") Para num <- 0 ate 99 faca Escreva("Digite o ", num, "o. valor: ") Leia(VET[num]) FimPara LimpaTela escreva ("Vetor: ") para num <- 0 ate 99 faca escreva (VET[num]) fimpara escreval ("") cont <- 0 divisor <- 1 Para num <- 0 ate 99 faca cont <- cont + 1 divisor <- divisor + 1 se (divisor <= num)e(num mod divisor = 0)e (cont = 2) entao EscrevaL("Valor", VET[num], " na posicao [",num, "] é Primo!") fimse fimpara Fimalgoritmo
  2. ludlima

    Dúvida algoritmo ordenação.

    Muito Obrigado,tentarei realizar
  3. Boa noite,estou tentando fazer um algoritmo que leia 50 números e mostre em ordem crescente e decrescente ao usuário,preciso utilizar vetor. Até agora só conseguir fazer a parte crescente. Alguém tem alguma dica de como fazer a parte decrescente? Var CONTADORA, CONTADORB: inteiro NUM, AUX: inteiro VET: vetor[0..49] de inteiro Inicio para CONTADORA de 0 ate 49 faca escreval ("Digite um número") leia (NUM) VET[CONTADORA] <- NUM fimpara para CONTADORA de 0 ate 48 faca para CONTADORB de CONTADORA + 1 ate 49 faca se VET[CONTADORA] > VET[CONTADORB] entao AUX <-VET[CONTADORB] VET[CONTADORB] <- VET[CONTADORA] VET[CONTADORA] <- AUX fimse fimpara fimpara escreval("A ordem crescente dos números é: ") para CONTADORA de 0 ate 49 faca escreva(VET[CONTADORA]) fimpara Fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.