Jump to content

tuamae

Members
  • Content count

    1
  • Joined

  • Last visited

Community Reputation

0 Comum

About tuamae

  1. aqui esta a versão corrigida do programa Algoritmo "Valores e Média" Var media, valores, valorant, cont, resultado, valoressomados: real valor: INTEIRO Inicio valoressomados <- 0 cont <- 1 valores <- 0 valor <- 0 valorAnt <-0 escreval ("Algoritmo para receber um numero x de valores e calcular média") escreval ("Para para calcular a média digite -1 a qualquer momento") escreval ("Digite os valores:") leia (valores) valorant <- valores enquanto valor <> -1 faca escreval ("Digite os valores:") leia (valores) cont <- cont+1 escreval ("Digite qualquer valor para continuar, ou digite -1 para finalizar a inserção de dados") leia(valor) valorant <- valores + valorant fimenquanto escreval ("Valores digitados:", cont) resultado <- valorant/cont escreval ("A média dos valores é:", resultado) Fimalgoritmo gambiarra a gente aceita, o que a gente não aceita é a derrota. e outra coisa que a gente nao aceita é "programar" nesse pascal mascarado.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.