Jump to content

Search the Community

Showing results for tags 'Visualg'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 123 results

  1. Preciso desenvolver um algoritmo no Visualg, da função y=3x+8, onde, a partir da informação de um valor para a variável independente x, o sistema automaticamente informe o valor da variável dependente y. porém quando vou executar da erro no código: var x, y: real inicio escreval("Digite o valor do coeficiente x") leia(x) Escreval ("O valor da conta é igual a:" + y) Leia (y) y=(3.x)+8 fimdoalgoritmo
  2. Quando eu excuto o algoritmo, a primeira condição comporta-se bem, mas apartir da segunda aparece o erro: Esperava-se encontrar ENTAO na linha "se((med=<8.9) e (med>=8))entao" Esperava-se encontrar ENTAO na linha "escreval("Seu rendimento foi muito bom" Algoritmo "semnome" Var med: real Inicio escreval("-------------------") escreval(" RENDIMENTO ESCOLAR") escreval("--------------------") escreval("Qual é a sua média: ") leia(med) se ((med=10) ou (med>=9))entao escreval ("Seu rendimento foi excelente") senao se ((med=<8.9) e (med>=8))entao escreval("Seu rendimento foi muito bom") senao se ((med= 7.9) e (med>=7))entao escreval("Seu rendimento foi bom") senao se ((med=6.9) e (med>=6))entao escreval("Seu rendimento foi regular") senao se ((med=5.9) e (med>=5))entao escreval("Seu rendimento foi insuficiente") senao escreval("Seu rendimento foi ruim") fimse fimse fimse fimse fimse Fimalgoritmo
  3. vanessalopes

    Exercícios Em Algoritmo

    Olá Gente me ajudam a resolver esses exercícios? Vamos lá ( TODOS ESSES PROGRAMAS A ESTRUTURA DE REPETIÇÃO E ENQUANTO E SE TAMBÉM OBRIGADA) 1 - Imprima Os Números Primos Compreendidos entre 1 e 100 e faça um algoritmo para resolver esse problema. Eu Montei o Algoritmo dessa forma, ele roda mais o resultado não tá exato no Visual G, se puder me ajudar com essa questão var p,n:inteiro inicio leia (n) p<- 1 enquanto p<=100 faca se p mod = 0 entao escreva (" Esse Numero é Primo",p) senao escreva (" Esse numero não é Primo") fimse fimenquanto fimalgoritmo 2 - faça um algoritmo para que seja digitado a idade e diga se a pessoa e maior de idade ou não faça isso até que alguém digite 100 anos. estrutura de repetição enquanto faca/se entao 3 -faça um algoritmo que imprima de 1 a 100 de forma decrescente estrutura de repetição enquanto acrescentei o exemplo d<-d-1 mesmo assim não rodou 4- construa um algoritmo que diga os divisores de 100 compreendidos de 1 a 20 bom, esse também eu fiz mais não conseguir roda 5 - DIVISOES DO TRIANGULO E DIZER SE O MESMO E ISOCELE, ESCALENO OU EQUILATERIO LEIA (L1) LEIA (L2) LEIA (L3) .... (SE)
  4. Bom dia Galera, não sei se este é a div certa para a postagem (div sacou?) Mas vamos lá, A uns 2meses to estudando linguagens de programação, comecei pela Logica de Programação com o professor Guanabara,Agora estou em Python e HTML5 CSS e Java. Python estou no que o professor chama de Mundo 2, aprendendo if, elif, else, já sei operadores aritméticos etc. HTML5 está mais no inicio, to aprendendo a trabalha com o css para dar estilo na pagina.(Também sei Banco de Dados no MySQL) Mas vamos ao assunto, to procurando colegas que estejam na parecida situação como eu, para realmente estudarmos juntos. Certa vez o professor falou que isso ajudaria e muito, e concordo, alguém para ajudar, e alguem para você ajudar, é um crescimento e tanto, então convido-os quem tiver interesse duas cabeças pensam mais que 1. (ou não se a outra cabeça for de um gênio!Jobs,BIl,Einsten,Hawking esses cara kk) Geralmente, estudos das 4h manhã ate as 6hrs da manhã, depois a noite das 19 até a hora que os olhos sangrarem! Pode mandar msg aqui no meu perfil, estou online! Obrigado!
  5. Sou estudante do 1º Ano do curso técnico em Informática do IFSP, e preciso de ajuda para fazer esse Algoritmo usando o visuAlg. 01) Levando em consideração o início dos sistemas de informatização as informações eram armazenadas em arquivo do tipo texto. Analisando internamente estes arquivos pode-se notar que nada mais são do que matrizes, pois cada coluna representava um campo e cada linha uma tupla. Partindo desta informação construa uma matriz para armazenar o RA, CPF e um código para 40 alunos (no CPF digitar somente os números) e uma matriz que guardará 4 notas de 40 alunos e seus respectivos códigos, criando assim um tipo de relacionamento entre as duas matrizes. O primeiro CPF da matriz 1 representa o aluno que possui as 4 notas da primeira posição da segunda matriz. Após o preenchimento de todos os dados das 2 matrizes você deverá perguntar qual o tipo de consulta deverá ser realizada (1-RA, 2-CPF e 3-Código) se for escolhido a opção 1 deve ser solicitado o RA e pesquisar o mesmo na matriz e mostrar o RA, as 4 notas e a média das 4 notas do aluno, se a opção for 2 você deverá solicitar o CPF e também mostrar o CPF, as 4 notas e a média das 4 notas do aluno e se a opção for 3 você deverá solicitar o CÓDIGO e também mostrar o Código, as 4 notas e a média das 4 notas do aluno. Em ambas as consultas deve ser mostrado a situação do aluno (Aprovado quando a média for no mínimo 6; Recuperação quando a média for no mínimo 4 e não chegar a 6; e Reprovado se a média for inferior a 4). Ao mostrar cada resultado o sistema deve pedir se o usuário deseja fazer uma nova pesquisa. Caso deseje deve digitar S(SIM) para continuar ou N(NÃO) para finalizar.
  6. Louislayne

    Algoritmo

    Crie um algoritmo, usando repetição PARA-ATE-FACA que leia o nome, sexo e salário de 50 candidatos e, ao final da leitura, imprima: a. Maior salário entre os homens b. Maior salário entre as mulheres c. Média dos salários dos homens d. Média dos salários das mulheres
  7. Estou fazendo um algoritmo que solicita a posição (latitude e longitude) do usuário 1 e a posição do usuário 2. Considerando a distância segura para o seu deslocamento, por exemplo, em 20 metros. Caso a distância segura seja ultrapassada, dispare uma mensagem de alerta para o usuário. Algoritmo "Calculo da Distancia" Var x1,x2,y1,y2, d: real Inicio escreval ("Digite no ponto A o valor de X1") leia (x1) escreval ("Digite no ponto A o valor de Y2") leia (y1) escreval ("Digite no ponto B o valor de X2") leia (x2) escreval ("Diite no ponto B o valor de Y2") leia (y2) d<- raizq(((x2-x1)^2)+((y2-y1)^2)) escreval("A distancia entre o ponto A e B no plano cartesiano é: ",d) Fimalgoritmo
  8. yasuo_mono_dedo

    Visualg (INICIANTE)

    VisualG Minha professora de lógica de programação passou alguns exercícios e preciso da ajuda de vocês O exercício que me acarretou dúvida extrema foi esse: Escreva um programa que leia um número qualquer e apresente-o somente se ele for menor que 100 ou entre 500 e 700 O que me causou dúvida foi que eu ainda não aprendi a fazer isso :/ Quem puder ajudar eu agradeceria <3
  9. algoritmo "ESCOLHA DE NUMEROS PARES OU IMPARES UNSANDO A ESTRUTURA DE CONDICIONAMENTO ESCOLHA COM A ESTRUTURA DE REPETIÇÃO PARA" var V,MUN,VALORES:INTEIRO inicio ESCREVA("DIGITE O NUMERO DESEJADO :") LEIA(V) escreval("----------------------------") escreval(" [1] PARA PAR ") escreval(" [2} para IMPAR ") ESCREVAL("----------------------------") ESCREVAL("ESCOLHA UM DOS VALORES") LEIA(VALORES) ESCOLHA(VALORES) caso 1 PARA MUN <- 0 ATE V FACA SE (MUN MOD 2 =0) ENTAO escreval(MUN) FIMSE MUN <- MUN +1 FIMPARA caso 2 PARA MUN <- 0 ATE V FACA SE (MUN MOD 2 =1) ENTAO escreval(MUN) FIMSE MUN <- MUN +1 FIMPARA FIMESCOLHA fimalgoritmo
  10. escreval("CPF COMPLETO: ",vet[1],vet[2],vet[3]," .",vet[4],vet[5],vet[6]," .",vet[7],vet[8],vet[9]," -",digitoum,digitodois) Gostaria de deixar os números um do lado do outro, porém sem esse espaçamento. Os números sempre ficam todos meio separados, desta maneira: 3 2 1 . 1 4 3 . 1 2 2 - 5 9 Não conheço nenhum comando que consiga fazer isso, ou nem sei se existe algum jeito.
  11. luizrufino

    Dificuldade com questão

    Boa tarde pessoal, estou com dificuldade para desenvolver as linhas de códigos de um problema. Escreva um algoritmo em potrugol que leia o NOME do responsável e o número de filhos matriculados em uma escolinha de futebol. com mensalidade de $120,00, imprimir o valor que o responsável vai pagar, baseando-se na seguinte tabele de descontos filhos matriculados Desconto 1 10% 2 a 3 15% acima de 3 20 Se alguém puder me ajudar, pode ser somente a estrutura básica.
  12. Olá aos mestres do algoritmo com VisuAlg, tenho o seguinte algoritmo: algoritmo "Estrutura Indexadas - Vetor(Array)" // Seção de Declarações var indice, qtd_Veiculos, tot_Veiculos : inteiro nome_veiculo: vetor [1..40] de caractere inicio // Seção de Comandos escreval("Digite a Quantidade de Veículos para Cadastrar ou -1 Para Sair: ") leia(qtd_Veiculos) enquanto qtd_Veiculos <> -1 faca para indice de 1 ate qtd_Veiculos faca escreva("Digite o Nome do Veículo: ") leia(nome_veiculo[indice]) fimpara tot_Veiculos <- 0 tot_Veiculos <- (tot_Veiculos + (indice + 1)) escreval("Digite a Quantidade de Veículos para Cadastrar ou -1 Para Sair: ") leia(qtd_Veiculos) fimenquanto para indice de 1 ate tot_Veiculos faca escreval("O Veículo ", nome_veiculo[indice], " tem o índice ", indice) fimpara fimalgoritmo Estou usando vetor, o que acontece é o seguinte, por exemplo, digite dois veículos, quando ele retorna perguntando se quero encerrar, eu digo que quero incluir mais dois veículos, ao digitar -1 para sair, ele imprime somente os dois últimos veículos cadastrados e não 4 veículos, que deveria ser o correto, conforme figura anexa. Onde estou errando? Fico no aguardo de ajuda, muito grato.
  13. algoritmo "Bhaskara" var a, b, c, delta, raiz_delta, x1, x, x_delta, x2: Real inicio Escreva("Informe um numero inteiro diferente de 0: ") Leia(a) Escreva("Informe outro numero inteiro diferente de 0: ") Leia(b) Escreva("Novamente, informe outro numero inteiro diferente de 0: ") Leia(c) delta <- (b^2-4*a*c) Se (delta<0) entao delta <- Abs(delta) raiz_delta <- (RaizQ(delta)) x <- (b-b*2)/(2*a) x_delta <- raiz_delta/(2*a) x1 <- (x, "+", x_delta, "i") x2 <- (x, "-", x_delta, "i") Escreval("Utilizando ", a, " como 'a', ", b, " como 'b', ", c, " como 'c' em Delta e aplicando a ") Escreval("Formula de Bhaskara, chegamos ao resultado:) Escreva("x1 = ", x1, " e x2 ", x2) FimSe fimalgoritmo Parece ser algo bem idiota, mas não estou conseguindo resolver... Ajuda?
  14. algoritmo "semnome" // Função : // Autor : // Data : 17/06/2019 // Seção de Declarações var i,j,aux:inteiro Matriz_A: vetor [1..3,1..3] de inteiro Matriz_B: vetor [1..3,1..3] de inteiro matriz_C: vetor [1..3,1..3] de inteiro inicio // Seção de Comandos // VETOR A para i de 1 ate 3 faca para j de 1 ate 3 faca escreval ("matriz A: coluna:",i,"linha:",j) escreval ("informe o valor da posicao: [",i,"]: [",j,"]:") leia(matriz_A[i,j]) fimpara fimpara limpatela //VETOR B para i de 1 ate 3 faca para j de 1 ate 3 faca escreval ("matriz B: coluna:",i,"linha:",j) escreval ("informe o valor da posicao: [",i,"]: [",j,"]:") leia(matriz_B[i,j]) fimpara fimpara limpatela //VETOR C Para i de 1 ate 3 faca Para j de 1 ate 3 faca matriz_C [i,j] <- ( matriz_A[i,1] * matriz_B[1,j] ) + (matriz_A[i,2] * matriz_B[2,j] ) + (matriz_A[i,3] * matriz_B[3,j] ) Escreval("matriz_C ",i , " x ",j , " : ", matriz_C [i,j]) Fimpara Fimpara
  15. Bom dia galera! Então, eu fiz esse algoritimo para resolver um exercicio (Faça um Programa que leia três números e mostre-os em ordem decrescente). Ele esta funcional, tudo certinho(eu acho). O que eu realmente queria saber é se existe uma forma de eu simplificar ele utilizando apenas as estruturas condicionais ou se dessa forma que eu fiz já é o mais simples possivel ? Valeu pela atenção pessoal!!! Segue o codigo criado no visualg //Faça um Programa que leia três números e mostre-os em ordem decrescente algoritmo "ex009" var n1, n2, n3: inteiro inicio escreva("Primeiro numero: ") leia(n1) escreva("Segundo numero: ") leia(n2) escreva("Terceiro numero: ") leia(n3) se (n1<n2) e (n2<n3) entao escreva(n3,n2,n1) senao se (n1<n3) e (n3<n2) entao escreva(n2,n3,n1) senao se (n2<n1) e (n1<n3) entao escreva(n3,n1,n2) senao se (n2<n3) e (n3<n1) entao escreva(n1,n3,n2) senao se (n3<n1) e (n1<n2) entao escreva(n2,n1,n3) senao se (n3<n2) e (n2<n1) entao escreva(n1,n2,n3) fimse fimse fimse fimse fimse fimse fimalgoritmo
  16. O exercício propunha fazer duas funções uma para multiplicação e outra para criar uma fatorial, porém devem ser feitas usando apenas operações de soma e subtração bom fiz uma função para multiplicar e esta funcionando porém estou tentando utiliza-la para fazer a fatorial e o resultado sempre da zero ;-; podem me ajudar algoritmo "semnome" var a,b:inteiro funcao multi(a:inteiro;b:inteiro):real var aux:real inicio se a=0 entao retorne 0 senao aux <- 0 enquanto b>0 faca aux <- aux+a b <- b-1 fimenquanto retorne aux fimse fimfuncao funcao fatorial(a:inteiro):real var fat,res:real inicio enquanto fat > 0 faca fat<-a fat <- fat - 1 res <- multi(fat,a) fimenquanto retorne res fimfuncao inicio leia(a) escreval(fatorial(a)) fimalgoritmo
  17. Bom pessoal, estou desenvolvendo um programa em VisualG para uma atividade da Faculdade, que apresente um menu de opções e que permita ao usuário escolher a opção desejada, receba os dados necessários para executar a operação e mostre o resultado. Verificar a possibilidade de opção inválida e não se preocupar com as restrições, como salário inválido. Porém ao executar o mesmo apresenta o erro de "Esperava encontrar entao" e "fimse". algoritmo "semnome" var op: caracter sal, nsal,: real meses: inteiro inicio // Seção de Comandos escreva ("Informe o salário R$: ") leia (sal) limpatela escreval(" MENU ") escreval("1. Novo salário") escreval("2. Férias ") escreval("3. Décimo Terceiro") escreval("4. Sair ") escreval(" ") escreva ("Informe a operação: ") leia (op) limpatela escolha op enquanto op <> 4 faca caso "1" escreva ("O salário do funcionário é R$:", sal, "reais.") se sal <= 350 entao escreva ("O novo salário será R$: ", sal*0.15, "reais") fimse se sal = 350 e <= 600 entao escreva ("O novo salário será R$: ", sal*0.10, "reais") fimse se sal > 600 entao escreva ("O novo salário será R$: ", sal*0.05, "reais") fimse caso "2" escreva ("O salário acrescido de férias será R$ :" (sal+(sal*0.3))) caso "3" escreva ("Informe os meses trabalhados") leia (meses) escreva ("O seu décimo terceiro será RS: " (sal+(sal*meses)/12)) caso "4" escreva ("Encerrar execução") outrocaso ("Opção inexistente") fimescolha fimenquanto fimalgoritmo
  18. Ao sair de um procedimento e entrar em outro, ta apresentando erro quando tento finalizar o programa. Var // Seção de Declarações das variáveis nome: vetor [1..3] de caractere telef: vetor [1..3] de caractere ema: vetor [1..3] de caractere codigo,codigo_contato,codigo_contato_cheio, menu_apagar,opc, opc1: inteiro cont, menu_mostrar,op: inteiro procedimento principal() Inicio // Seção de Comandos, procedimento, funções, operadores, etc... repita escreval ("") escreval ("=== AGENDA TELEFÔNICA ===") escreval ("") escreval ("1. Inserir novo contato") escreval ("2. Apagar contato") escreval ("3. Mostrar todos os contatos") escreval ("4. Sair") escreva ("Digite opcao: ") leia (codigo) limpatela ate (codigo=1) ou (codigo=2) ou (codigo=3) ou (codigo=4) escolha (codigo) caso 1 contato() caso 2 apagar() caso 3 mostrar() caso 4 interrompa fimescolha fimprocedimento //---------------------- NOVO CONTATO ---------------------- procedimento contato() inicio para cont de 1 ate 3 faca limpatela escreval("== INSERIR NOVO CONTATO ==") escreva ("Nome: ") leia (nome[cont]) escreva ("Telefone: ") leia (telef[cont]) escreva ("E-mail: ") leia (ema[cont]) escreval("") escreval("Usuario cadrastrado com sucesso") repita escreval("") escreval("1.Insira novo contato") escreval("2.Voltar ao menu") escreval("") escreva("Digite opção: ") leia(codigo_contato) escolha (codigo_contato) caso 1 escreva("") caso 2 interrompa limpatela principal() outrocaso escreval("") escreval("Opção invalida") escreval("") escreval("Pressione ENTER para voltar") leia(op) limpatela fimescolha ate codigo_contato = 1 fimpara limpatela escreval("") escreval("Lista de contato cheia") repita escreval("") escreval("1.Voltar ao menu") escreval("2.Sair") escreval("") escreval("Digite opção") leia(codigo_contato_cheio) escolha (codigo_contato_cheio) caso 1 limpatela principal() caso 2 interrompa outrocaso escreval("") escreval("Opção invalida") escreval("") escreval("Pressione ENTER para voltar") leia(op) limpatela fimescolha ate codigo_contato_cheio = 1 fimprocedimento //------------------------ Apagar contato------------------------------------ procedimento apagar() inicio limpatela escreval("== APAGAR CONTATO ==") Escreval("") escreva ("Qual contato você quer apagar? ") Escreval("") para cont de 1 ate 3 faca Escreval(cont,". ",nome[cont]) fimpara Escreval("") Escreva("Digite opção:") Leia(opc) se opc >0 entao se opc <4 entao nome[opc]<-"" telef[opc]<-"" ema[opc]<-"" Escreval("") Escreval("Contato Apagado com sucesso") repita escreval("") escreval("1.Apagar outro contato") escreval("2.Voltar ao menu") escreval("3.Sair") escreva("Digite opção:") leia(menu_apagar) Escolha(menu_apagar) caso 1 limpatela apagar() caso 2 limpatela principal() caso3 interrompa outrocaso escreval("") escreval("Opção invalida") escreval("") escreval("Pressione ENTER para voltar") leia(op) senao apagar() fimse fimse fimse fimescolha ate menu_apagar = 3 fimprocedimento //-------------------------- Mostrar todos os contatos --------------------- procedimento mostrar() inicio limpatela escreval("== LISTA DE CONTATOS ==") Escreval("") para cont de 1 ate 3 faca Escreval(cont,". ",nome[cont]) fimpara Escreval("") Escreva("Digite opção:") Leia(opc1) se opc1 >0 entao se opc1 <4 entao limpatela Escreval("Nome: ",nome[opc1]) Escreval("Telefone: ",telef[opc1]) Escreval("E-mail: ",ema[opc1]) repita escreval("") escreval("1.Mostrar outro contato") escreval("2.Voltar ao menu") escreval("") escreva("Digite opção:") Leia(menu_mostrar) Escolha(menu_mostrar) caso 1 limpatela mostrar() caso 2 limpatela principal() outrocaso escreval("") escreval("Opção invalida") escreval("") escreval("Pressione ENTER para voltar") leia(op) senao mostrar() fimse fimse fimescolha limpatela ate menu_mostrar = 1 fimprocedimento inicio // Seção de Comandos principal() Fimalgoritmo
  19. Boa noite,estou tentando executar um algoritmo no visualg que leia 100 números,descubra se existe números primos,se sim mostrar em que posição se encontra. Entretanto,o programa só está executando até onde mostra o vetor. Gostaria de ajuda de como terminar e realizar a verificação do número primo. Var num, cont, divisor: inteiro VET: vetor[0..99] de inteiro Inicio escreval ("Olá!Você quer saber se existe número primo? ") Para num <- 0 ate 99 faca Escreva("Digite o ", num, "o. valor: ") Leia(VET[num]) FimPara LimpaTela escreva ("Vetor: ") para num <- 0 ate 99 faca escreva (VET[num]) fimpara escreval ("") cont <- 0 divisor <- 1 Para num <- 0 ate 99 faca cont <- cont + 1 divisor <- divisor + 1 se (divisor <= num)e(num mod divisor = 0)e (cont = 2) entao EscrevaL("Valor", VET[num], " na posicao [",num, "] é Primo!") fimse fimpara Fimalgoritmo
  20. Boa noite,estou tentando fazer um algoritmo que leia 50 números e mostre em ordem crescente e decrescente ao usuário,preciso utilizar vetor. Até agora só conseguir fazer a parte crescente. Alguém tem alguma dica de como fazer a parte decrescente? Var CONTADORA, CONTADORB: inteiro NUM, AUX: inteiro VET: vetor[0..49] de inteiro Inicio para CONTADORA de 0 ate 49 faca escreval ("Digite um número") leia (NUM) VET[CONTADORA] <- NUM fimpara para CONTADORA de 0 ate 48 faca para CONTADORB de CONTADORA + 1 ate 49 faca se VET[CONTADORA] > VET[CONTADORB] entao AUX <-VET[CONTADORB] VET[CONTADORB] <- VET[CONTADORA] VET[CONTADORA] <- AUX fimse fimpara fimpara escreval("A ordem crescente dos números é: ") para CONTADORA de 0 ate 49 faca escreva(VET[CONTADORA]) fimpara Fimalgoritmo
  21. flavionorvel

    Converter linguagem C para visualg

    #include <stdio.h> #include <stdlib.h> // Limites de tamanhos #define MINIMO 2 #define MAXIMO 50 // Variáveis globais int opcao = 0; int linhas = MAXIMO; int colunas = MAXIMO; int matrizA[MAXIMO][MAXIMO]; int matrizB[MAXIMO][MAXIMO]; void limpar_tela(); // Retorna resposta do usuario se quer rodar novamente int rodar_novamente() { int opcao = 0; printf("\n\nDeseja rodar novamente? Digite 1 para SIM e 0 para Não: "); scanf("%d",&opcao); if (opcao == 1 || opcao == 0) { return opcao; } printf("\nOpcao invalida. Escolha novamente."); return rodar_novamente(); } // Recebe valor inteiro do usuario int receber_numero() { int numero = 0; scanf("%d",&numero); if (numero >0) { return numero; } printf("\nNúmero inválido. digite um número positivo.: "); return receber_numero(); } // Valida tamanhos de linhas e colunas int validar_tamanhos(int linhas, int colunas) { if ((linhas >= MINIMO && linhas <= MAXIMO) && (colunas >= MINIMO && colunas <= MAXIMO) && (linhas ! = colunas)) { return 1; } printf("\nLinhas e Colunas devem ser diferentes e ter valores entre %d e %d. Tente novamente.",MINIMO,MAXIMO); return 0; } // Preencher matriz void preencher_matriz(int matriz[MAXIMO][MAXIMO], int linhas, int colunas) { int i,j; for (i = 0 ; i < linhas ; i ++) { for (j = 0 ; j < colunas ; j ++) { printf("\nDigite um valor inteiro para a posicao %d-%d da matriz A: ",i,j); matriz[j] = receber_numero(); } } } // Imprimir matrizes void imprimir_matrizes(int matrizA[MAXIMO][MAXIMO], int matrizB[MAXIMO][MAXIMO], int linhas, int colunas) { int i,j; limpar_tela(); printf("\n\nMATRIZ A\n"); for (i = 0 ; i < linhas ; i++) { for (j = 0 ; j < colunas ; j ++) { printf("\nMATRIZ A POSICAO %d-%d: %d",i,j,matrizA[j]); } } printf("\n\nMATRIZ B (TRANSPOSTA DE A)\n"); for (i = 0 ; i < colunas ; i++) { for (j = 0 ; j < linhas ; j ++) { printf("\nMATRIZ B POSICAO %d-%d: %d",i,j,matrizB[j]); } } } void limpar_tela() { system("@cls||clear"); } // Laço principal int main() { int i,j; do { //Inicializar variáveis opcao = 0; linhas = 0; colunas = 0; i = 0; j = 0; do { printf("\nEntre com o tamanho para linhas: "); linhas = receber_numero(); printf("\nEntre com o tamanho para colunas: "); colunas = receber_numero(); } while (!validar_tamanhos(linhas,colunas)); // entrar com valores para a matriz A preencher_matriz(matrizA, linhas, colunas); // criar matriz transposta de A for(i = 0 ; i < linhas ; i ++) { for(j = 0 ; j < colunas ;j ++) { matrizB[j] = matrizA[j]; } } // Imprimir matrizes imprimir_matrizes(matrizA,matrizB,linhas, colunas); // Pergunta ao usuário se quer continuar opcao = rodar_novamente(); } while (opcao == 1); }me
  22. Fernando Cavaccini

    Dividir área em partes iguais

    Boa noite pessoal, estou criando um algoritmo no Visualg, que é para um usuário que está construindo uma casa, porém em uma parte, é necessário dividir a área interna da casa em partes iguais, mas não sei como posso fazer isso, se alguém pudesse dar uma dica. Obrigado desde já.
  23. Olá, sou nova na programação e ainda estou trabalhando só com o visualg. Então relevem qualquer coisa, por favor. Bom... Meu professor pediu para fazermos um programa no visualg que escrevesse de 0 até 100 por extenso. Tem algumas restrições só podemos usar: Se; fimse; Escreva; leia; <- •Não pode usar vetores e isso complicou muito. •Não pode ser (todo) assim: se (numero=45) enato escreva("Quarenta e cinco"), porque isso ia gastar muitas linhas. Ele deu uma dica de como fazer: Var: Unidaden: inteiro Unidadec: caractere Dezena: caractere Numero: inteiro Inicio: escreva ("Digite um número e tecle enter: ) leia (numero) Se (numero>20) e (numero<30) entao escreva ("Vinte e ", ???)
  24. Olá, gostaria que vocês pudessem me ajudar a desenvolver e com resolução esses exercícios aqui, estou quebrando a cabeça e não consigo chegar em nadaaa, obrigado!!! Primeiro exercício 1-Leia um valor inteiro entre 1000 e 9999 e verifique se o número formado apenas pelos algarismos que estão nas casas das unidades de milhar e das centenas é ou não múltiplo de 4. Segundo " " 2- Numa loja de eletrodomésticos, o vendedor encarregado da seção de televisores recebe, mensalmente, um salário fixo mais comissão. Esta comissão é calculada em relação ao tipo e a quantidade de televisores vendidos por mês, obedecendo a seguinte tabela: Sobre o seu salário fixo há um desconto de 10% referente ao INSS. Caso o seu salário bruto exceda a R$ 1500,00 haverá desconto de imposto de renda, conforme a segunda a tabela ao lado, aplicada sobre o valor excedente a R$ 1500,00. Calcule: a comissão do funcionário, o salário bruto, os valores de cada desconto, o total dos descontos e o salário líquido. Terceiro " " Escreva um algoritmo que leia o valor de 3 ângulos de um triângulo e escreva se o triângulo é retângulo, obtusângulo ou acutângulo. A saber, o triângulo retângulo possui um ângulo reto, o triângulo obtusângulo possui um ângulo obtuso, e o triângulo acutângulo possui 3 ângulos agudos. Quarto No Campeonato Mundial de Cross Fit o atleta deve pesar entre 65 Kg (inclusive) e 100 Kg (inclusive) e medir de 1,70 m (inclusive) a 1,95 m (inclusive). Escrever um algoritmo para ler a altura e o peso de um jogador e determinar se o jogador está apto a participar do campeonato, escrevendo a mensagem correta, conforme a situação: • ACEITO (se a altura e o peso do jogador estiverem dentro da faixa especificada) • TOTALMENTE RECUSADO (se a altura e o peso do jogador forem inválidos) • RECUSADO POR ALTURA (se somente a altura do jogador for inválida) • RECUSADO POR PESO (se somente o peso do jogador for inválido)
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.