Jump to content

Search the Community

Showing results for tags 'Visualg'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 123 results

  1. Galera estou precisando de ajuda para saber se essa questão está certa. Faça um algoritmo que leia um número N e mostre todos os números múltiplos de 5, no intervalo de 1 a N. var cont, n, soma:inteiro inicio n <- 1 soma <- 0 enquanto ( n <> 0 ) faca escreval("Valor ") leia(n) se (n % 5 = 0) entao soma <- soma + n escreval (n, " é multiplo de 5") senao escreval (n, " não é multiplo de 5") fimse fimenquanto Não sei se é exatamente isso que a questão pede. Outras questões que estou em dúvida são essas 6- Faça um algoritmo que leia um número inteiro N (maior que 11) e mostre os números entre 11 e N que quando divididos por 11 produzam resto igual a 5. (utilizar estrutura SE...ENTAO dentro da estrutura (REPITA... ATE). 10- Escreva um algoritmo para ler 2 valores e se o segundo valor informado for ZERO, deve ser lido um novo valor, ou seja, para o segundo valor não pode ser aceito o valor zero. Depois mostrar o resultado da divisão do primeiro valor lido pelo segundo valor lido. (utilizar a estrutura REPITA... ATE) 5- Faça um algoritmo que leia um número N e mostre todos os números múltiplos de 5, no intervalo de 1 a N.
  2. Ola A estrutura se deste algoritimo esta dando erro,agradeço se alguem puder me ajudar. // Função :6) Faça um algoritmo que o usuário informe dois números inteiros, que o segundo //número divida o primeiro e que se o resto for par, o quociente for ímpar e o resultado //for maior que 3, informe que ele venceu o desafio do algoritmo, e independente de //vencer ou não mostre os resultados das operações. // Autor :Emerson Reinecke // Data : 03/08/2017 // Seção de Declarações var n1,n2:inteiro resultado,quoc,resto:real inicio escreval("Digite um numero:") leia(n1) escreval("Digite um numero:") leia(n2) resultado<-(n1/n2) resto<-(n1 mod n2) quoc<-(n1 div n2) se (resto=0) e (resultado>3) e (quoc mod 2 = 0 ) entao escreval("Voce Venceu o Desafio do Algoritmo!") escreval("O Resultado da operação foi ",resultado,"") escreval("O Quociente da operação foi ",quoc,"") escreval("O Resto da operação foi ",resto,"") senao escreval("O Resultado da operação foi ",resultado,"") escreval("O Quociente da operação foi ",quoc,"") escreval("O Resto da operação foi ",resto,"") fimse fimalgoritmo
  3. Receber um número inteiro e imprimir a soma de todos os números inteiros entre este número e seu segundo múltiplo. Imprima também o primeiro e o segundo múltiplos deste número:
  4. sabem fazer algumas dessas questões? 1- Fazer um algoritmo que armazene em um vetor os 10 primeiros valores primos. 2. Escreva um algoritmo que peça um número n ao usuário, e que gere um novo n de acordo com a seguinte regra: • se n é par, n = n / 2 • se n é impar, n = 3 * n + 1 • imprime n • O programa deve parar quando x tiver o valor igual a 1. Por exemplo, para n = 13, a saída será: 40 -> 20 -> 10 -> 5 -> 16 -> 8 -> 4 -> 2 -> 1 3. Crie um algoritmo que peça um número inteiro ao usuário, e imprima a seguinte tabela: Informe um valor: 4 1 2 4 3 6 9 4 8 12 16 4. Fazer um algoritmo que leia um número que servira para controlar os primeiros números ímpares. Deverá ser impressa a soma desses números. Suponha que o número informado será maior que zero, caso não seja, informar o erro. Exemplo: Informe um número: 5 1 3 5 7 9 A soma dos 5 valores impares é: 25 5. Fazer um algoritmo que armazene em um vetor os 10 primeiros valores primos. 6. Fazer um algoritmo que leia um vetor N de 20 posições. Troque a seguir, o 1° elemento com o ultimo, o 2° elemento com o penúltimo, etc., até trocar o 10° com o 11°. Mostrar o vetor modificado. 7. Fazer um algoritmo que que leia um vetor K de 30 posições. Troque a seguir todos os elementos de ordem ímpar do vetor com os de ordem par imediatamente posterior. Mostrar o vetor modificado.
  5. Faça o programa que apresenta a seguinte saída, perguntando ao usuário o número máximo. Este número deve ser sempre ímpar. Exemplo: Entrada: 9 Saída: 1 2 3 4 5 6 7 8 9 2 3 4 5 6 7 8 3 4 5 6 7 4 5 6 5
  6. Faça um programa que apresente a seguinte saída, perguntando ao usuário o número máximo. Este número deve ter ímpar. Exemplo: Entrada: 9 Saída: 1 2 3 4 5 6 7 8 9 2 3 4 5 6 7 8 3 4 5 6 7 4 5 6 5 Obs.: tem que ser em PORTUGOL
  7. Crie um algoritmo que calcule os N primeiros termos de uma PA (progressão aritmética). O algoritmo deve receber o primeiro termo, a razão e a quantidade de termos que devem ser apresentados. Ao final mostre os dez termos da sequencia. O cálculo de cada termo obedece a seguinte fórmula an<- a1+(n-1)*r, onde: an - n-ésimo termos n- número do termo r - razão algoritmo "PA" var razao, n, a1, an: inteiro //Inicio escreva ("Entre com a razão:") leia (razao) escreva ("Entre com o primeiro termo:") leia (a1) escreva ("Entre com o elemento N:") leia (n) an<-a1+(n-1)*razao escreva ("O elemento" ,n, "é:" ,an) fimalgoritmo Eu consegui fazer esse algoritmo só não sei como mostrar os dez termos da sequencia, me ajudem, por favor!!!
  8. ficarei muito grato se alguém puder me ajudar com esse exercício 1) A partir da intercalação de dados de dois vetores de 5 números inteiros cada, com dados ordenados crescentemente, montar um terceiro vetor de 10 elementos, de tal forma que este tenha os dados dos dois vetores anteriores e também esteja ordenado.
  9. Boa tarde pessoal, Estou tendo dificuldades com o seguinte exercício sobre vetores: algoritmo "satanás" var v : vetor[1..30] de inteiro i, j, menor, maior, tmp : inteiro inicio para i de 1 ate 5 faca leia(v) se(i = 1) entao maior := v[1] fimse se ((i = 2) e (v > maior)) entao menor := v[1] maior := v[2] senao se ((i = 2) e (v < maior)) entao menor := v[2] fimse fimse se ((i <> 1) e (i <> 2) e (v > maior)) entao maior := v senao se ((i <> 1) e (i <> 2) e (v < menor)) entao menor := v fimse fimse fimpara tmp := v[1] v[1] := menor menor := tmp v[5] := tmp maior := tmp para i de 1 ate 5 faca escreva(v) fimpara fimalgoritmo Eu consegui fazer a troca do 1º número pela posição do menor e do último pela posição do maior, mas o menor não vai para a primeira posição e do maior pelo último. Por exemplo: o usuário informa 5 números: 5, 2, 3, 1, 4 A troca acontece: 1, 2, 3, 1, 5 Observe que foi o 1 foi pra posição do 5, mas o 5 não foi para a posição do 1, do mesmo jeito que o 5 foi para a última posição, mas o número da última posição não foi para o lugar do 5. :( Obrigado desde já.
  10. dillan

    Visualg

    Peguei este algoritmo em um livro mas quando faço no visualg sempre dar erro onde está o problema: Algoritmo "semnome" // // // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : Nome do(a) aluno(a) // Data atual : 09/05/2017 Var mes:inteiro Inicio leia (mes) caso mes seja 1 faca escreva("Janeiro") seja 2 faca escreva("Fevereiro") seja 3 faca escreva("Março") seja 4 faca escreva("Abril") seja 5 faca escreva("Maio") seja 6 faca escreva("Junho") seja 7 faca escreva("Julho") seja 8 faca escreva("Agosto") seja 9 faca escreva("Setembro") seja 10 faca escreva("Outubro") seja 11 faca escreva("Novembro") seja 12 faca escreva("Dezembro") senao escreva("Valor Invalido") fim_caso Fimalgoritmo
  11. rafatrinity

    Merge Sort

    como fazer merge sort de forma não recursiva e/ou sem passar vetor como parametro
  12. Boa Noite, sou novo no fórum e estou com uma dúvida e queria que me ajudassem, vou colocar o enunciado de um código e o código até onde eu fiz, estou fazendo utilizando o visualg 3.0 Faça um programa para armazenar o RG de 100 usuários. O programa terá a opção de adicionar, buscar, ordenar ou remover os dados. O programa deverá ter as seguintes condições: Adicionar: Efetuar uma pesquisa para saber se o RG existe ou não no vetorSe existir, informar que o número já se encontra presente no vetor e não adicione Caso não exista, verifique se o vetor está ou não lotado antes de inserir Pesquisar: O usuário poderá escolher entre a pesquisa sequencial ou bináriaSe a pesquisa binária for selecionada, informe que o vetor deve estar ordenado e deixe o usuário escolher a ordenação antes de efetuar a pesquisa Ordenar:O usuário poderá escolher qual o método de ordenação desejado: Bubblesort, Seleção Direta, Heapsort, Inserção direta, Merge sort e Quicksort Se o vetor já estiver ordenado, informe para o usuário e não faça a ordenação Escolha 4 (quatro) dos 6 (seis) algoritmos de ordenação para colocar no programa Remover:O usuário poderá escolher entre remover todos os elementos do vetor ou somente um No caso de somente um elemento, o usuário deverá informar qual o elemento a ser removido (reordene o vetor) _______________________________________________________________________________________ Tela Inicial do programa: COPACABANA– PROGRAMA RG [1] Adicionar [2] Pesquisar [3] Ordenar [4] Remover [0] Sair Opção: _______________________________________________________________________________________ Tela do menu adicionar: COPACABANA – PROGRAMA RG ADICIONAR ELEMENTO RG [POSIÇÃO ATUAL DO VETOR]: _______________________________________________________________________________________ Tela do menu Pesquisar: COPACABANA – PROGRAMA RG PESQUISAR ELEMENTO [1] Pesquisa Sequencial [2] Pesquisar Binária [0] Voltar Opção: ______________________________________________________________________________________ Tela do menu Ordenar: COPACABANA– PROGRAMA RG ORDENAR VETOR [1] Método Bubblesort, [2] Método Quicksort [3] Método Heapsort [4] Método Merge sort [5] Método Seleção Direta [6] Método Inserção direta [0] Voltar Opção: -------------------------------------------------------------------------------------------------------------------------------------------- algoritmo "COPACABANA-PROGRAMA RG" var opcao,i,rg:inteiro vetorRg:vetor[1..10]de inteiro funcao menu():inteiro var opcao:inteiro inicio escreval(" COPACABANA - PROGRAMA RG ") escreval() escreval("1-Adcionar") escreval("2-Pesquisar") escreval("3-Ordenar") escreval("4-Remover") escreval("0-Sair") escreval() escreval("Escolha a opcao") leia(opcao) retorne opcao fimfuncao funcao cadastraRG(var i:inteiro):inteiro var rg:inteiro inicio fimfuncao inicio se i=10 entao escreval("Número máximo de cadastros alcançado. Favor exclua um registro para continuar.") senao i<-i+1 repita escolha(menu()) caso 1 limpatela escreval("ADICIONAR ELEMENTO") escreva("RG:") leia(rg) limpatela caso 2 escreval("PESQUISAR ELEMENTO") escreval("1-Pesquisa Sequencal") escreval("2-Pesquisa Binaria") escreval("0-Voltar") leia(opcao) se opcao=1 então escreva("Altere o Nome:") senao se opcao=2 então escreva("Altere o RG") fimse fimse caso 3 escreval("*****ORDENAR VETOR*****") escreval("1-METODO BUBLESORT") escreval("2-METODO QUICKSORT") escreval("3-SELEÇÃO DIRETA") escreval("4-INSERÇÃO DIRETA") escreval("0-VOLTAR") leia(opcao) se opcao=1 então escreva("METODO BUBLESORT:") senao se opcao=2 então escreva("METODO QUICKSORT:") senao se opcao=3 então escreva("SELEÇÃO DIRETA:") senao se opcao=4 então escreva("INSERÇÃO DIRETA:") senao se opcao=0 então escreva("VOLTAR:") fimse fimse fimse fimse fimse caso 4 escreval("*****Excluir dados:*****") escreval("Excluir RG - 1") leia(opcao) se opcao=1 então escreva("Exclua o Nome:") senao fimse caso 0 escreva("Programa encerrado!") outrocaso escreval("opção Invalida") fimescolha ate menu()=0 fimalgoritmo
  13. EmersonReinecke

    Visualg Função

    Boa noite Amigos Estou com dificuldade neste algoritimo,preciso que apos cadastrar itens ele tenha a opção de voltar para o menu principal. var codigo: vetor [1..5] de inteiro valor: vetor [1..5] de real descricao: vetor [1..5] de caracter fim,iniciar,opcao2: caracter opcao: inteiro ordem: inteiro inicio ordem <- 1 escreval("OPCOES") escreval("") escreval("Escolha a Opcao que Deseja Executar:") escreval("") escreval("1. Cadastro de Novo Produto:") escreval("2. Listagem de Produtos Cadastrados:") escreval("3. Listar Produto e a Quantidade em Estoque:") escreval("4. Gerar Cupom de Produtos Vendidos:") escreval("5. Calcular o Valor total de Cupons:") leia (opcao) limpatela escolha opcao //cadastro dos produtos caso 1 opcao2 <- "i" enquanto opcao2 = "i" faca escreval("Cadastrando um novo Produto na Loja:") escreval("") escreval("Digite o Código do PRODUTO:") leia(codigo[ordem]) escreval("Digite a Descricao do PRODUTO:") leia(descricao[ordem]) escreval("Digite o Valor do PRODUTO:") leia(valor[ordem]) escreval("Para cadastrar mais um produto Tecle 'I'. Para finalizar tecle 'F'") leia(opcao2) fimenquanto limpatela escreval("Produto cadastrado com sucesso!!") escreval("--------------------------------") escreval("Para cadastrar mais um produto Tecle 'I'. Para voltar ao menu tecle 'F'") leia(opcao2) fimescolha escolha opcao2 caso "f" escreval("Sistema Encerrado.") caso "i" enquanto opcao2 = "i" faca escreval("Cadastrando um novo Produto na Loja:") escreval("") escreval("Digite o Código do PRODUTO:") leia(codigo[ordem]) escreval("Digite a Descricao do PRODUTO:") leia(descricao[ordem]) escreval("Digite o Valor do PRODUTO:") leia(valor[ordem]) escreval("Para cadastrar mais um produto Tecle 'I'. Para finalizar tecle 'F'") leia(opcao2) fimenquanto fimescolha escolha opcao //listagem dos produtos caso 2 escreval("2. Listagem de Produtos Cadastrados:") escreval("Digite o codigo do produto:") leia(codigo[ordem]) escreval("O Produto Cadastrado é", [descricao], ".") fimescolha fimalgoritmo
  14. Pessoal, esou aprendendo algoritmos e gostaria de saber se vocês tem alguma lista de exercícios pra me passar :D Até agora aprendi: se.. entao escolha enquanto... faca para... faca repita... ate De preferência uma lista que conte com o que eu aprendi acima. Obrigado desde já!
  15. Alguém poderia me explicar pq acontece esse erro no visualg: quando declaro a variável graos do tipo inteiro: Algoritmo "rainha" // Uma rainha requisitou os serviços de um monge, o qual exigiu o // pagamento em grãos de trigo da seguinte maneira: os grãos de // trigo seriam dispostos em um tabuleiro de xadrez, de tal forma // que a primeira casa do tabuleiro tivesse um grão, e as casas // seguintes o dobro da anterior. Construa um algoritmo que calcule // quantos grãos de trigo a Rainha deverá pagar ao monge. Var casa: inteiro graos: inteiro Inicio graos := 1 escreval("casa -- graos") Para casa de 1 ate 64 faca graos := graos * 2 escreval(casa," -- ",graos) casa := casa + 1 FimPara escreval() escreva("A rainha deverá pagar ", graos," grãos para o monge.") Fimalgoritmo Início da execução casa -- graos 1 -- 2 2 -- 4 3 -- 8 4 -- 16 5 -- 32 6 -- 64 7 -- 128 8 -- 256 9 -- 512 10 -- 1024 11 -- 2048 12 -- 4096 13 -- 8192 14 -- 16384 15 -- 32768 16 -- 65536 17 -- 131072 18 -- 262144 19 -- 524288 20 -- 1048576 21 -- 2097152 22 -- 4194304 23 -- 8388608 24 -- 16777216 25 -- 33554432 26 -- 67108864 27 -- 134217728 28 -- 268435456 29 -- 536870912 30 -- 1073741824 31 -- -2147483648 32 -- 0 33 -- 0 34 -- 0 35 -- 0 36 -- 0 37 -- 0 38 -- 0 39 -- 0 40 -- 0 41 -- 0 42 -- 0 43 -- 0 44 -- 0 45 -- 0 46 -- 0 47 -- 0 48 -- 0 49 -- 0 50 -- 0 51 -- 0 52 -- 0 53 -- 0 54 -- 0 55 -- 0 56 -- 0 57 -- 0 58 -- 0 59 -- 0 60 -- 0 61 -- 0 62 -- 0 63 -- 0 64 -- 0 A rainha deverá pagar 0 grãos para o monge. Fim da execução. quando declaro a variável graos do tipo real: Algoritmo "rainha" // Uma rainha requisitou os serviços de um monge, o qual exigiu o // pagamento em grãos de trigo da seguinte maneira: os grãos de // trigo seriam dispostos em um tabuleiro de xadrez, de tal forma // que a primeira casa do tabuleiro tivesse um grão, e as casas // seguintes o dobro da anterior. Construa um algoritmo que calcule // quantos grãos de trigo a Rainha deverá pagar ao monge. Var casa: inteiro graos: real Inicio graos := 1 escreval("casa -- graos") Para casa de 1 ate 64 faca graos := graos * 2 escreval(casa," -- ",graos) casa := casa + 1 FimPara escreval() escreva("A rainha deverá pagar ", graos," grãos para o monge.") Fimalgoritmo Início da execução casa -- graos 1 -- 2 2 -- 4 3 -- 8 4 -- 16 5 -- 32 6 -- 64 7 -- 128 8 -- 256 9 -- 512 10 -- 1024 11 -- 2048 12 -- 4096 13 -- 8192 14 -- 16384 15 -- 32768 16 -- 65536 17 -- 131072 18 -- 262144 19 -- 524288 20 -- 1048576 21 -- 2097152 22 -- 4194304 23 -- 8388608 24 -- 16777216 25 -- 33554432 26 -- 67108864 27 -- 134217728 28 -- 268435456 29 -- 536870912 30 -- 1073741824 31 -- 2147483648 32 -- 4294967296 33 -- 8589934592 34 -- 17179869184 35 -- 34359738368 36 -- 68719476736 37 -- 137438953472 38 -- 274877906944 39 -- 549755813888 40 -- 1099511627776 41 -- 2199023255552 42 -- 4398046511104 43 -- 8796093022208 44 -- 17592186044416 45 -- 35184372088832 46 -- 70368744177664 47 -- 140737488355328 48 -- 281474976710656 49 -- 562949953421312 50 -- 1.12589990684262E15 51 -- 2.25179981368525E15 52 -- 4.5035996273705E15 53 -- 9.00719925474099E15 54 -- 1.8014398509482E16 55 -- 3.6028797018964E16 56 -- 7.20575940379279E16 57 -- 1.44115188075856E17 58 -- 2.88230376151712E17 59 -- 5.76460752303423E17 60 -- 1.15292150460685E18 61 -- 2.30584300921369E18 62 -- 4.61168601842739E18 63 -- 9.22337203685478E18 64 -- 1.84467440737096E19 A rainha deverá pagar 1.84467440737096E19 grãos para o monge. Fim da execução. Como faço para exibir o número inteiro normal?
  16. Escrever um algoritmo que lê: - a percentagem do IPI a ser acrescido no valor das peças - o código da peça 1, valor unitário da peça 1, quantidade de peças 1 - o código da peça 2, valor unitário da peça 2, quantidade de peças 2 O algoritmo deve calcular o valor total a ser pago e apresentar o resultado. Fórmula : (valor1*quant1 + valor2*quant2)*(IPI/100 + 1)
  17. Elaborar um algoritmo que lê 3 valores a,b,c e verifica se eles formam ou não um triângulo. Supor que os valores lidos são inteiros e positivos. Caso os valores formem um triângulo, calcular e escrever a área deste triângulo. Se não formam triângulo escrever os valores lidos. ( se a > b + c não formam triângulo algum, se a é o maior).
  18. Dentro do conceito da Industria 4.0 de utilizaçao de tecnologia para aumentar produtividade. Qual linguagem de Progamaçao para um iniciante, desenvolver um software para utilizar em um raspberry . Para trabalhar em conjunto com um CLP (Controladores Lógicos Programáveis ) e ajudar no monitoramento de uma partida indireta de um motor que utiliza 3 contatores para seu acionamento Pretendo fazer um TCC no final do curso de Eletrotecnica final do ano 2017.
  19. Oi gente, to com o seguinte problema: " Crie um algoritmo que peça o nome, a altura e o peso de duas pessoas e apresente o nome e peso da mais pesada e o nome e altura da mais alta. " Eu consegui fazer o programa receber a maior altura e o maior peso. No entanto, quando ele vai ler o nome do mais pesado ou mais alto, só faz a leitura do último nome digitado pelo usuário. Alguma dica? tks :) algoritmo "Pesadao" var c: inteiro nome: caractere h, p, mh, mp: real inicio enquanto (c < 2) faca c <- c + 1 escreva("NOME: ") leia(nome) escreva("PESO: ") leia(p) escreva("ALTURA: ") leia(h) limpatela Se(h > mh) entao mh <- h Se(p > mp) entao mp <- p fimse fimse fimenquanto escreval("O maior peso é de ", nome, " pesando: ", mp, "Kg") escreval("A maior altura é de ", nome, "medindo: ", mh, "m") fimalgoritmo
  20. Criar um algoritmo que cadastre 5 bois com as informações seguintes: ID MATRICULA NO SISTEMA REGRA: ANO VIGENTE+valoraleatorio (exemplo: 2017208) PESO DO BOI RAÇA DO BOI NOME DO DONO/FAZENDA Após o cadastro faça o algoritmo analisar e informar O BOI MAIS GORDO O BOI MAIS MAGRO *se houver dois no mesmo peso mostrar os dois* MÉDIA DOS PESOS DO BOIS CADASTRADOS Alguém pode me ajudar como se faz????
  21. Boa tarde amigos. O professor passou uma atividade que não estou conseguindo fazer, de jeito maneira. Já li e reli todo o material já apresentado, pesquisei na internet, assisti vídeos, e não consigo desenvolver a atividade. Não sei mais o que fazer. Acho que esse é um daqueles problemas para espantar os alunos já no início da faculdade. Já tentei no Portugol Studio e no Visualg. Por favor, vocês podem me ajudar a entender o que se pede, e como fazer? Desenvolver um algoritmo que tenha como dado de entrada a data de nascimento de uma pessoa qualquer no formato dia, mês e ano. A partir dessa data, calcular a idade da pessoa em: a) anos, meses e dias. Ex: a resposta seria a pessoa tem 38 anos 3 meses e 5 dias de vida b) meses e dias. EX: a pessoa tem 459 meses e 5 dias C) somente em dias. Ex: a pessoa tem 30.995 dias de vida OBS: considerar o ano com 365 dias e o mês com 30dias. Segue meu código: algoritmo "idades" var diaAtual, mesAtual, anoAtual, diaNas, mesNas, anoNas, anos, meses, dias : INTEIRO inicio escreval ("Digite dia, mês, e ano atuais") escreval ("Formato DD/MM/AAAA, separados com a tecla Enter: ") leia (diaAtual, mesAtual, anoAtual) escreval ("Digite dia, mês, e ano do nascimento") escreval ("Formato DD/MM/AAAA, separados com a tecla Enter: ") leia (diaNas, mesNas, anoNas) // ANO SE ((mesAtual = mesNas) E (diaAtual >= diaNas)) então //JÁ FEZ ANIVERSARIO anos <- anoAtual - anoNas FIMSE SE ((mesAtual = mesNas) E (diaAtual < diaNas)) então //AINDA NÃO FEZ ANIVERSARIO anos <- anoAtual - anoNas - 1 FIMSE SE (mesAtual < mesNas) então //AINDA NÃO FEZ ANIVERSARIO anos <- anoAtual - anoNas - 1 FIMSE //MÊS SE ((mesAtual < mesNas) E (diaAtual >= diaNas)) então //Se não fez aniversário mas completou mês corrente meses <- 12 - (mesNas - mesAtual) FIMSE SE ((mesAtual < mesNas) E (diaAtual < diaNas)) então //Se não fez aniversário e nem completou mês corrente meses <- 12 (mesNas - mesAtual) - 1 FIMSE SE ((mesAtual > mesNas) E (diaAtual < diaNas)) então meses <- (mesAtual - mesNas) - 1 FIMSE //DIA SE (diaAtual < diaNas) então dias <- 30 - diaNas + diaAtual FIMSE SE (diaAtual >= diaNas) então dias <- diaAtual - diaNas FIMSE fimalgoritmo Desde já agradeço.
  22. Boa Tarde, alguém pode me ajudar? Faça um algoritmo que pergunte ao usuário o valor do produto e quando o usuário pergunta ao cliente a forma de pagamento, esta seja descriminada da seguinte forma: no caso 1: pagamento à vista no dinheiro, ganha 10% de desconto no caso 2: pagamento à vista no cartão de crédito sofre 10% de juros no valor do produto no caso 3: pagamento parcelado em até 2x, sofre 15% de juros no valor do produto no caso 4: pagamento no minimo em 3x parcelas ou mais sofre 5,5% EM CADA parcela Usar outrocaso também Caso apareça a mensagem de Opção invalida o programa volte ao menu para o usuário escolher um opção valida desafioaula4.alg
  23. EmersonReinecke

    Visualg

    Alguem conheçe algum site com um manual de visualg pra indicar,que tenha comandos,funções.
  24. Ta dando erro de sintaxe nesse algoritmo, mas nao consigo achar :/ Alguem sabe onde tá? Obg desde ja
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.