Jump to content

Search the Community

Showing results for tags 'Visualg'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 113 results

  1. rafatrinity

    Merge Sort

    como fazer merge sort de forma não recursiva e/ou sem passar vetor como parametro
  2. Boa Noite, sou novo no fórum e estou com uma dúvida e queria que me ajudassem, vou colocar o enunciado de um código e o código até onde eu fiz, estou fazendo utilizando o visualg 3.0 Faça um programa para armazenar o RG de 100 usuários. O programa terá a opção de adicionar, buscar, ordenar ou remover os dados. O programa deverá ter as seguintes condições: Adicionar: Efetuar uma pesquisa para saber se o RG existe ou não no vetorSe existir, informar que o número já se encontra presente no vetor e não adicione Caso não exista, verifique se o vetor está ou não lotado antes de inserir Pesquisar: O usuário poderá escolher entre a pesquisa sequencial ou bináriaSe a pesquisa binária for selecionada, informe que o vetor deve estar ordenado e deixe o usuário escolher a ordenação antes de efetuar a pesquisa Ordenar:O usuário poderá escolher qual o método de ordenação desejado: Bubblesort, Seleção Direta, Heapsort, Inserção direta, Merge sort e Quicksort Se o vetor já estiver ordenado, informe para o usuário e não faça a ordenação Escolha 4 (quatro) dos 6 (seis) algoritmos de ordenação para colocar no programa Remover:O usuário poderá escolher entre remover todos os elementos do vetor ou somente um No caso de somente um elemento, o usuário deverá informar qual o elemento a ser removido (reordene o vetor) _______________________________________________________________________________________ Tela Inicial do programa: COPACABANA– PROGRAMA RG [1] Adicionar [2] Pesquisar [3] Ordenar [4] Remover [0] Sair Opção: _______________________________________________________________________________________ Tela do menu adicionar: COPACABANA – PROGRAMA RG ADICIONAR ELEMENTO RG [POSIÇÃO ATUAL DO VETOR]: _______________________________________________________________________________________ Tela do menu Pesquisar: COPACABANA – PROGRAMA RG PESQUISAR ELEMENTO [1] Pesquisa Sequencial [2] Pesquisar Binária [0] Voltar Opção: ______________________________________________________________________________________ Tela do menu Ordenar: COPACABANA– PROGRAMA RG ORDENAR VETOR [1] Método Bubblesort, [2] Método Quicksort [3] Método Heapsort [4] Método Merge sort [5] Método Seleção Direta [6] Método Inserção direta [0] Voltar Opção: -------------------------------------------------------------------------------------------------------------------------------------------- algoritmo "COPACABANA-PROGRAMA RG" var opcao,i,rg:inteiro vetorRg:vetor[1..10]de inteiro funcao menu():inteiro var opcao:inteiro inicio escreval(" COPACABANA - PROGRAMA RG ") escreval() escreval("1-Adcionar") escreval("2-Pesquisar") escreval("3-Ordenar") escreval("4-Remover") escreval("0-Sair") escreval() escreval("Escolha a opcao") leia(opcao) retorne opcao fimfuncao funcao cadastraRG(var i:inteiro):inteiro var rg:inteiro inicio fimfuncao inicio se i=10 entao escreval("Número máximo de cadastros alcançado. Favor exclua um registro para continuar.") senao i<-i+1 repita escolha(menu()) caso 1 limpatela escreval("ADICIONAR ELEMENTO") escreva("RG:") leia(rg) limpatela caso 2 escreval("PESQUISAR ELEMENTO") escreval("1-Pesquisa Sequencal") escreval("2-Pesquisa Binaria") escreval("0-Voltar") leia(opcao) se opcao=1 então escreva("Altere o Nome:") senao se opcao=2 então escreva("Altere o RG") fimse fimse caso 3 escreval("*****ORDENAR VETOR*****") escreval("1-METODO BUBLESORT") escreval("2-METODO QUICKSORT") escreval("3-SELEÇÃO DIRETA") escreval("4-INSERÇÃO DIRETA") escreval("0-VOLTAR") leia(opcao) se opcao=1 então escreva("METODO BUBLESORT:") senao se opcao=2 então escreva("METODO QUICKSORT:") senao se opcao=3 então escreva("SELEÇÃO DIRETA:") senao se opcao=4 então escreva("INSERÇÃO DIRETA:") senao se opcao=0 então escreva("VOLTAR:") fimse fimse fimse fimse fimse caso 4 escreval("*****Excluir dados:*****") escreval("Excluir RG - 1") leia(opcao) se opcao=1 então escreva("Exclua o Nome:") senao fimse caso 0 escreva("Programa encerrado!") outrocaso escreval("opção Invalida") fimescolha ate menu()=0 fimalgoritmo
  3. EmersonReinecke

    Visualg Função

    Boa noite Amigos Estou com dificuldade neste algoritimo,preciso que apos cadastrar itens ele tenha a opção de voltar para o menu principal. var codigo: vetor [1..5] de inteiro valor: vetor [1..5] de real descricao: vetor [1..5] de caracter fim,iniciar,opcao2: caracter opcao: inteiro ordem: inteiro inicio ordem <- 1 escreval("OPCOES") escreval("") escreval("Escolha a Opcao que Deseja Executar:") escreval("") escreval("1. Cadastro de Novo Produto:") escreval("2. Listagem de Produtos Cadastrados:") escreval("3. Listar Produto e a Quantidade em Estoque:") escreval("4. Gerar Cupom de Produtos Vendidos:") escreval("5. Calcular o Valor total de Cupons:") leia (opcao) limpatela escolha opcao //cadastro dos produtos caso 1 opcao2 <- "i" enquanto opcao2 = "i" faca escreval("Cadastrando um novo Produto na Loja:") escreval("") escreval("Digite o Código do PRODUTO:") leia(codigo[ordem]) escreval("Digite a Descricao do PRODUTO:") leia(descricao[ordem]) escreval("Digite o Valor do PRODUTO:") leia(valor[ordem]) escreval("Para cadastrar mais um produto Tecle 'I'. Para finalizar tecle 'F'") leia(opcao2) fimenquanto limpatela escreval("Produto cadastrado com sucesso!!") escreval("--------------------------------") escreval("Para cadastrar mais um produto Tecle 'I'. Para voltar ao menu tecle 'F'") leia(opcao2) fimescolha escolha opcao2 caso "f" escreval("Sistema Encerrado.") caso "i" enquanto opcao2 = "i" faca escreval("Cadastrando um novo Produto na Loja:") escreval("") escreval("Digite o Código do PRODUTO:") leia(codigo[ordem]) escreval("Digite a Descricao do PRODUTO:") leia(descricao[ordem]) escreval("Digite o Valor do PRODUTO:") leia(valor[ordem]) escreval("Para cadastrar mais um produto Tecle 'I'. Para finalizar tecle 'F'") leia(opcao2) fimenquanto fimescolha escolha opcao //listagem dos produtos caso 2 escreval("2. Listagem de Produtos Cadastrados:") escreval("Digite o codigo do produto:") leia(codigo[ordem]) escreval("O Produto Cadastrado é", [descricao], ".") fimescolha fimalgoritmo
  4. Pessoal, esou aprendendo algoritmos e gostaria de saber se vocês tem alguma lista de exercícios pra me passar :D Até agora aprendi: se.. entao escolha enquanto... faca para... faca repita... ate De preferência uma lista que conte com o que eu aprendi acima. Obrigado desde já!
  5. Alguém poderia me explicar pq acontece esse erro no visualg: quando declaro a variável graos do tipo inteiro: Algoritmo "rainha" // Uma rainha requisitou os serviços de um monge, o qual exigiu o // pagamento em grãos de trigo da seguinte maneira: os grãos de // trigo seriam dispostos em um tabuleiro de xadrez, de tal forma // que a primeira casa do tabuleiro tivesse um grão, e as casas // seguintes o dobro da anterior. Construa um algoritmo que calcule // quantos grãos de trigo a Rainha deverá pagar ao monge. Var casa: inteiro graos: inteiro Inicio graos := 1 escreval("casa -- graos") Para casa de 1 ate 64 faca graos := graos * 2 escreval(casa," -- ",graos) casa := casa + 1 FimPara escreval() escreva("A rainha deverá pagar ", graos," grãos para o monge.") Fimalgoritmo Início da execução casa -- graos 1 -- 2 2 -- 4 3 -- 8 4 -- 16 5 -- 32 6 -- 64 7 -- 128 8 -- 256 9 -- 512 10 -- 1024 11 -- 2048 12 -- 4096 13 -- 8192 14 -- 16384 15 -- 32768 16 -- 65536 17 -- 131072 18 -- 262144 19 -- 524288 20 -- 1048576 21 -- 2097152 22 -- 4194304 23 -- 8388608 24 -- 16777216 25 -- 33554432 26 -- 67108864 27 -- 134217728 28 -- 268435456 29 -- 536870912 30 -- 1073741824 31 -- -2147483648 32 -- 0 33 -- 0 34 -- 0 35 -- 0 36 -- 0 37 -- 0 38 -- 0 39 -- 0 40 -- 0 41 -- 0 42 -- 0 43 -- 0 44 -- 0 45 -- 0 46 -- 0 47 -- 0 48 -- 0 49 -- 0 50 -- 0 51 -- 0 52 -- 0 53 -- 0 54 -- 0 55 -- 0 56 -- 0 57 -- 0 58 -- 0 59 -- 0 60 -- 0 61 -- 0 62 -- 0 63 -- 0 64 -- 0 A rainha deverá pagar 0 grãos para o monge. Fim da execução. quando declaro a variável graos do tipo real: Algoritmo "rainha" // Uma rainha requisitou os serviços de um monge, o qual exigiu o // pagamento em grãos de trigo da seguinte maneira: os grãos de // trigo seriam dispostos em um tabuleiro de xadrez, de tal forma // que a primeira casa do tabuleiro tivesse um grão, e as casas // seguintes o dobro da anterior. Construa um algoritmo que calcule // quantos grãos de trigo a Rainha deverá pagar ao monge. Var casa: inteiro graos: real Inicio graos := 1 escreval("casa -- graos") Para casa de 1 ate 64 faca graos := graos * 2 escreval(casa," -- ",graos) casa := casa + 1 FimPara escreval() escreva("A rainha deverá pagar ", graos," grãos para o monge.") Fimalgoritmo Início da execução casa -- graos 1 -- 2 2 -- 4 3 -- 8 4 -- 16 5 -- 32 6 -- 64 7 -- 128 8 -- 256 9 -- 512 10 -- 1024 11 -- 2048 12 -- 4096 13 -- 8192 14 -- 16384 15 -- 32768 16 -- 65536 17 -- 131072 18 -- 262144 19 -- 524288 20 -- 1048576 21 -- 2097152 22 -- 4194304 23 -- 8388608 24 -- 16777216 25 -- 33554432 26 -- 67108864 27 -- 134217728 28 -- 268435456 29 -- 536870912 30 -- 1073741824 31 -- 2147483648 32 -- 4294967296 33 -- 8589934592 34 -- 17179869184 35 -- 34359738368 36 -- 68719476736 37 -- 137438953472 38 -- 274877906944 39 -- 549755813888 40 -- 1099511627776 41 -- 2199023255552 42 -- 4398046511104 43 -- 8796093022208 44 -- 17592186044416 45 -- 35184372088832 46 -- 70368744177664 47 -- 140737488355328 48 -- 281474976710656 49 -- 562949953421312 50 -- 1.12589990684262E15 51 -- 2.25179981368525E15 52 -- 4.5035996273705E15 53 -- 9.00719925474099E15 54 -- 1.8014398509482E16 55 -- 3.6028797018964E16 56 -- 7.20575940379279E16 57 -- 1.44115188075856E17 58 -- 2.88230376151712E17 59 -- 5.76460752303423E17 60 -- 1.15292150460685E18 61 -- 2.30584300921369E18 62 -- 4.61168601842739E18 63 -- 9.22337203685478E18 64 -- 1.84467440737096E19 A rainha deverá pagar 1.84467440737096E19 grãos para o monge. Fim da execução. Como faço para exibir o número inteiro normal?
  6. Escrever um algoritmo que lê: - a percentagem do IPI a ser acrescido no valor das peças - o código da peça 1, valor unitário da peça 1, quantidade de peças 1 - o código da peça 2, valor unitário da peça 2, quantidade de peças 2 O algoritmo deve calcular o valor total a ser pago e apresentar o resultado. Fórmula : (valor1*quant1 + valor2*quant2)*(IPI/100 + 1)
  7. Elaborar um algoritmo que lê 3 valores a,b,c e verifica se eles formam ou não um triângulo. Supor que os valores lidos são inteiros e positivos. Caso os valores formem um triângulo, calcular e escrever a área deste triângulo. Se não formam triângulo escrever os valores lidos. ( se a > b + c não formam triângulo algum, se a é o maior).
  8. Dentro do conceito da Industria 4.0 de utilizaçao de tecnologia para aumentar produtividade. Qual linguagem de Progamaçao para um iniciante, desenvolver um software para utilizar em um raspberry . Para trabalhar em conjunto com um CLP (Controladores Lógicos Programáveis ) e ajudar no monitoramento de uma partida indireta de um motor que utiliza 3 contatores para seu acionamento Pretendo fazer um TCC no final do curso de Eletrotecnica final do ano 2017.
  9. Oi gente, to com o seguinte problema: " Crie um algoritmo que peça o nome, a altura e o peso de duas pessoas e apresente o nome e peso da mais pesada e o nome e altura da mais alta. " Eu consegui fazer o programa receber a maior altura e o maior peso. No entanto, quando ele vai ler o nome do mais pesado ou mais alto, só faz a leitura do último nome digitado pelo usuário. Alguma dica? tks :) algoritmo "Pesadao" var c: inteiro nome: caractere h, p, mh, mp: real inicio enquanto (c < 2) faca c <- c + 1 escreva("NOME: ") leia(nome) escreva("PESO: ") leia(p) escreva("ALTURA: ") leia(h) limpatela Se(h > mh) entao mh <- h Se(p > mp) entao mp <- p fimse fimse fimenquanto escreval("O maior peso é de ", nome, " pesando: ", mp, "Kg") escreval("A maior altura é de ", nome, "medindo: ", mh, "m") fimalgoritmo
  10. Criar um algoritmo que cadastre 5 bois com as informações seguintes: ID MATRICULA NO SISTEMA REGRA: ANO VIGENTE+valoraleatorio (exemplo: 2017208) PESO DO BOI RAÇA DO BOI NOME DO DONO/FAZENDA Após o cadastro faça o algoritmo analisar e informar O BOI MAIS GORDO O BOI MAIS MAGRO *se houver dois no mesmo peso mostrar os dois* MÉDIA DOS PESOS DO BOIS CADASTRADOS Alguém pode me ajudar como se faz????
  11. Boa tarde amigos. O professor passou uma atividade que não estou conseguindo fazer, de jeito maneira. Já li e reli todo o material já apresentado, pesquisei na internet, assisti vídeos, e não consigo desenvolver a atividade. Não sei mais o que fazer. Acho que esse é um daqueles problemas para espantar os alunos já no início da faculdade. Já tentei no Portugol Studio e no Visualg. Por favor, vocês podem me ajudar a entender o que se pede, e como fazer? Desenvolver um algoritmo que tenha como dado de entrada a data de nascimento de uma pessoa qualquer no formato dia, mês e ano. A partir dessa data, calcular a idade da pessoa em: a) anos, meses e dias. Ex: a resposta seria a pessoa tem 38 anos 3 meses e 5 dias de vida b) meses e dias. EX: a pessoa tem 459 meses e 5 dias C) somente em dias. Ex: a pessoa tem 30.995 dias de vida OBS: considerar o ano com 365 dias e o mês com 30dias. Segue meu código: algoritmo "idades" var diaAtual, mesAtual, anoAtual, diaNas, mesNas, anoNas, anos, meses, dias : INTEIRO inicio escreval ("Digite dia, mês, e ano atuais") escreval ("Formato DD/MM/AAAA, separados com a tecla Enter: ") leia (diaAtual, mesAtual, anoAtual) escreval ("Digite dia, mês, e ano do nascimento") escreval ("Formato DD/MM/AAAA, separados com a tecla Enter: ") leia (diaNas, mesNas, anoNas) // ANO SE ((mesAtual = mesNas) E (diaAtual >= diaNas)) então //JÁ FEZ ANIVERSARIO anos <- anoAtual - anoNas FIMSE SE ((mesAtual = mesNas) E (diaAtual < diaNas)) então //AINDA NÃO FEZ ANIVERSARIO anos <- anoAtual - anoNas - 1 FIMSE SE (mesAtual < mesNas) então //AINDA NÃO FEZ ANIVERSARIO anos <- anoAtual - anoNas - 1 FIMSE //MÊS SE ((mesAtual < mesNas) E (diaAtual >= diaNas)) então //Se não fez aniversário mas completou mês corrente meses <- 12 - (mesNas - mesAtual) FIMSE SE ((mesAtual < mesNas) E (diaAtual < diaNas)) então //Se não fez aniversário e nem completou mês corrente meses <- 12 (mesNas - mesAtual) - 1 FIMSE SE ((mesAtual > mesNas) E (diaAtual < diaNas)) então meses <- (mesAtual - mesNas) - 1 FIMSE //DIA SE (diaAtual < diaNas) então dias <- 30 - diaNas + diaAtual FIMSE SE (diaAtual >= diaNas) então dias <- diaAtual - diaNas FIMSE fimalgoritmo Desde já agradeço.
  12. Boa Tarde, alguém pode me ajudar? Faça um algoritmo que pergunte ao usuário o valor do produto e quando o usuário pergunta ao cliente a forma de pagamento, esta seja descriminada da seguinte forma: no caso 1: pagamento à vista no dinheiro, ganha 10% de desconto no caso 2: pagamento à vista no cartão de crédito sofre 10% de juros no valor do produto no caso 3: pagamento parcelado em até 2x, sofre 15% de juros no valor do produto no caso 4: pagamento no minimo em 3x parcelas ou mais sofre 5,5% EM CADA parcela Usar outrocaso também Caso apareça a mensagem de Opção invalida o programa volte ao menu para o usuário escolher um opção valida desafioaula4.alg
  13. EmersonReinecke

    Visualg

    Alguem conheçe algum site com um manual de visualg pra indicar,que tenha comandos,funções.
  14. Ta dando erro de sintaxe nesse algoritmo, mas nao consigo achar :/ Alguem sabe onde tá? Obg desde ja
  15. EmersonReinecke

    Visualg Exercicio

    Tenho esse exercício pra resolver,alguém poderia me ajudar? 3 - A prefeitura de “Xico City” deseja fazer uma pesquisa entre seus habitantes. Desenvolva uma solução para coletar dados sobre o salário e número de filhos de cada habitante e após as leituras, escrever: a) Média de salário da população b) Média do número de filhos c) Maior salário dos habitantes d) Percentual de pessoas com salário menor que R$ 150,00
  16. olá estou precisando de uma ajuda com esses exercícios, pois não estou conseguindo fazer... "VisuAlg" 1) O MDC (máximo divisor comum) de 2 números inteiros A e B pode ser calculado pelo seguinte procedimento: Enquanto B for diferente de zero R recebe o valor do resto da divisão de A por B A recebe o valor de B B recebe o valor de R Fim Enquanto Escreva um algoritmo capaz de calcular e mostrar o MDC de 2 números inteiros digitados pelo operador. _______________________________________________________________________________________________________________ 2) Construa uma algoritmo capaz de calcular o valor de S, sabendo-se que S é claculado por: s=(1/ 1)+(3/ 2)+(5/ 3)+(7/ 4)+(9/ 5)+(11/ 6)+⋯+(99/50) __________________________________________________________________________________________________________________ 3) Construa um algoritmo capaz de receber as coordenadas x e y de dois pontos em um plano cartesiano e calcule a mostre a distância entre eles.
  17. E aí pessoal, blz? Sou novo aqui e no mundo da programação. Bem, estava tentando fazer esse pequeno exercício de verificação do triângulo e só consegui pq vi umas dicas na net. Na aula o prof não dá muitas dicas, então tentei fazer sozinho mas não consegui. Eis aqui o algoritmo: Var LadoA, LadoB, LadoC:inteiro Tri, Equi, Isos, Escal: logico Inicio Escreval("Digite Lado A") Leia(LadoA) Escreval("Digite Lado B") Leia(LadoB) Escreval("Digite Lado C") Leia(LadoC) Tri <- (LadoA<LadoB+LadoC) e (LadoB<LadoA+LadoC) e (LadoC<LadoA+LadoB) Equi <- (LadoA=LadoB) e (LadoB=LadoC) Isos <- (LadoA=LadoB) ou (LadoB=LadoC) Escal <- (LadoA<>LadoB) e (LadoB<>LadoC) Se Tri entao Escreval("Os lados informados formam um triangulo") Se Equi entao Escreval("Este triangulo é equilátero") Senao Se Isos entao Escreval("Este triangulo é isósceles") Senao Se Escal entao Escreval("Este triangulo é escaleno") Fimse Fimse Fimse Senao Escreval("Os lados não formam um triangulo") Fimse Fimalgoritmo Minha dúvida de iniciante é: 1) Pq aqui (LadoA<LadoB+LadoC) quando inverto pra (LadoB+LadoC>LadoA) não dá certo? 2) Pq aqui (LadoA=LadoB) e (LadoB=LadoC) não pode ser (LadoA=LadoB) e (LadoA=LadoC), já que A=B, sendo assim não é igual a B=A? 3) Pq esse último "Senao", depois do Fimse, quando coloco logo depois do "Escreval("Os lados não formam um triangulo")" ele não me retorna a resposta? Muito obg pela atenção!
  18. var n1,n2,n3,n4,n5,n6,m1,m2,m3,m4: real inicio escreva("Digite a nota do A1+3 pontos: ") leia(n1) escreva("Digite a nota do A2: ") leia(n2) m1<-(n1+n2)/2 escreval("Sua média é", m1) se m1>=7.5 entao escreval("Passou no 1° trimestre") <--------- Ele da erro de sintaxe nessa linha senao escreva("Nota necessaria na recuperação é: ", 15-m1) fimse Alguém poderia me ajudar?
  19. Olá pessoal! preciso fazer o seguinte quadrado no visualg: 1 2 3 4 5 2 4 3 3 4 2 5 4 3 2 1 para isso, eu estou usando dois contadores, só que não to conseguindo fazer o lado vertical decrescente nem o lado horizontal decrescente. não entendo por que raios o visualg imprime o primeiro valor de " j " na linha horizontal e não to conseguindo pensar como inserir os outros lados decrescentes. podem me dar uma ajudinha nessa? escreva("Escolha um número: ") leia (base) i <- 0 j <- 0 enquanto (i < base) faca i <- i + 1 escreva(i) fimenquanto enquanto (j < base) faca j <- j + 1 escreval(j) fimenquanto rime o primeiro algarismo da primeira linha vertical, na horizontal.
  20. Eae galera, beleza? Hoje eu estava um pouco curioso e resolvi testar uma hipótese. Será que se dividirmos um número inteiro sempre por dois chegaremos a um número indivisível? Como isto daria muito trabalho resolvi escrever um algoritmo no Visualg. O meu código é o seguinte: algoritmo "Teste da razão 2" // Função : Encontrar um número indivisível // Autor : XikuGuarana // Data : 08/03/2017 // Seção de Declarações var n1: inteiro resultado: real inicio // Seção de Comandos EscrevaL("Digite um número inteiro qualquer:") Leia(n1) resultado <- n1 LimpaTela Se(n1 > 0) entao repita resultado <- (resultado / 2) EscrevaL(resultado) ate resultado = 0 FimSe EscrevaL("========== Resultado ==========") EscrevaL("O menor número encontrado foi " , resultado) fimalgoritmo Pois bem. A ideia era que a repetição só acabasse quando fosse encontrado o número zero. E para minha surpresa, após alguns segundos o programa foi encerrado e o menor número encontrado foi 4.94065645841247E-324. Alguém tem ideia do que este número significa? Por que as divisões não continuaram ocorrendo? Desde já agradeço toda a atenção e ajuda prestadas. Um forte abraço.
  21. Elabore um algoritmo que mostre todos os números de 100 ate 150, e ao final a soma de todos os números nesse intervalo. Var n: inteiro soma, cont: inteiro Inicio n <- 100 enquanto (cont < 50) faca n <- n + 1 escreval(n) soma <- soma + n cont <- cont + 1 fimenquanto escreval("Resultado da soma: ", soma) Ta contando até 150 o problema é que eu não sei se a soma ta certa.
  22. Olá! Tenho a seguinte questão para resolver: Escreva um programa que lê um valor inteiro (maior do que 1 e menor ou igual a 10) e exibe a tabuada (até 10) de multiplicação do número lido. Você deverá escrever as seguintes funções e procedimentos: funcao leNumero(): inteiro Lê um número inteiro no intervalo especificado (entre 1 e 10) e o retorna. Cada vez que for digitado um número inválido (fora do intervalo especificado) a função deve exibir a mensagem "Número inválido. Digite novamente!" procedimento tabuada(n: inteiro) Recebe como parâmetro um número inteiro e exibe na tela a tabuada de multiplicação até 10 do número lido. Não entendi se tenho de ler o número dentro da função e se sim, como vou mandá-lo da função para o procedimento?
  23. Olá mundo, tudo certo? Espero que alguém possa me ajudar, vamos lá. Estou com um problema para resolver a respeito de um trabalho na faculdade. Preciso desenvolver um código em PORTUGOL que execute um MENU para agendar consultas com diversos médicos, mostrando data, hora, especialização do médico, enfim. Precisa ser completo. Programa solicita nome do paciente Programa solicita especialidade médica desejada Programa solicita que o paciente escolha o médico Programa mostra datas e horas disponíveis para agendar a consulta com aquele médico (OBS.: O horário não pode bater com o horário de outra consulta) (OBS.: Cada consulta tem um intervalo de 45 minutos ou 1 hora se facilitar) (OBS.: A clínica funciona de 8h as 18h de segunda a sexta) Paciente seleciona a data e hora Programa mostra confirmação contendo nome do paciente, nome e especialização do médico, data e hora da consulta. Programa retorna para o menu inicial. Estou estagnado na parte de datas e horas. Não consigo pensar uma maneira de fazê-lo. Exemplo: Como vou determinar os meses com 28, 29(ano bissexto), 30 ou 31 dias? E como mostrar apenas os dias e horários disponíveis para o paciente escolher sua consulta? Os horários escolhidos previamente por outros pacientes não podem aparecer para não causar conflito. Se alguém puder me dar uma luz, será muito bem-vindo. Segue parte do código que fiz. Está muito incompleto ainda, porém não sei mais como prosseguir a partir do "caso 1" no código abaixo.. algoritmo "Menu Clínico" // Função : Efetuar o agendamento de consultas com o médico específico // Autor : GRUPO 6! // Data : 11/14/2016 // Seção de Declarações var opcao1, cardio, opcao_cardio, neuro, opcao_neuro, nutri, opcao_nutri, geri, opcao_geri: inteiro paciente: caractere inicio // Seção de Comandos escreval ("==========================================================") escreval ("|| OLÁ, SEJA BEM VINDO AO PERSONAL CONSULTA AGENDATOR ||") escreval ("==========================================================") escreval ("Por favor, informe seu nome: ") leia (paciente) procedimento menu_inicial inicio escreval ("==========================================================") escreval ("|| ESPECIALIZAÇÕES MÉDICAS! ||") escreval ("==========================================================") escreval ("||1. Cardiologista ||") escreval ("||2. Neurologista ||") escreval ("||3. Nutricionista ||") escreval ("||4. Geriatra ||") escreval ("||5. SAIR ||") escreval ("==========================================================") fimprocedimento procedimento menu_cardio inicio escreval ("==========================================================") escreval ("|| CARDIOLOGISTAS ||") escreval ("||======================================================||") escreval ("||1. Dra. Cristiane Guedes Pita ||") escreval ("||2. Dr. George Paulo Cobe Fonseca ||") escreval ("||3. Voltar ||") escreval ("==========================================================") fimprocedimento procedimento menu_neuro inicio escreval ("==========================================================") escreval ("|| NEUROLOGISTAS ||") escreval ("||======================================================||") escreval ("||1. Dr. Carlos Trigueiro de Souza ||") escreval ("||2. Dr. Antônio Tomás Turbano ||") escreval ("||3. Voltar ||") escreval ("==========================================================") fimprocedimento procedimento menu_nutri inicio escreval ("==========================================================") escreval ("|| NUTRICIONISTAS ||") escreval ("||======================================================||") escreval ("||1. Mônica Cristina Salgado Galvão ||") escreval ("||2. Fernanda Tarcélia de Oliveira Pinto ||") escreval ("||3. Voltar ||") escreval ("==========================================================") fimprocedimento procedimento menu_geri inicio escreval ("==========================================================") escreval ("|| GERIATRAS ||") escreval ("||======================================================||") escreval ("||1. Dr. Carlos Antonio Batista de Medeiros ||") escreval ("||2. Dr. Anceio Botelho Pinto ||") escreval ("||3. Voltar ||") escreval ("==========================================================") fimprocedimento repita menu_inicial escreval ("Olá ", paciente,", por favor, escolha uma opção:") leia (opcao1) limpatela se opcao1>=6 então escreval ("**********************************************************") escreval ("*************OPÇÃO INVÁLIDA, TENTE NOVAMENTE**************") escreval ("**********************************************************") fimse ate (opcao1=1) ou (opcao1=2) ou (opcao1=3) ou (opcao1=4) ou (opcao1=5) escolha (opcao1) caso 1 repita menu_cardio escreval ("Digite o número referente ao seu médico de preferência: ") leia (opcao_cardio) limpatela ate opcao_cardio=3 caso 2 menu_neuro caso 3 menu_nutri caso 4 menu_geri caso 5 escreval ("==========================================================") escreval ("|| Obrigado por utilizar o PERSONAL CONSULTA AGENDATOR! ||") escreval ("==========================================================") fimescolha fimalgoritmo Gratidao e boas vibrações! <3
  24. Sou novo na área de TI! E preciso de uma ajuda do pessoal mais experiente. Quero fazer um Caixa Eletrônico que saque somente notas de 50 e 20. Vale ressaltar que ele dá preferencia às notas de 50. Eu não consigo fazer de jeito nenhum. O codigo abaixo foi até onde consegui. Se alguem poder me mandar algum codigo novo eu aceito. Ou até msm um otimizar esse abaixo, tmb aceito. Lembrando, ele só pode sacar notas de 50 e 20. Dar prioridade as notas de 50. Minha dificuldade é com certos valores, por exemplo, R$160,00. Não consigo fazer com que retire 2 notas de 50 e 3 notas de 20. Por favor me ajudem. Algoritmo "semnome" var saqueUsuario,nota50,nota20:inteiro sacarValor50,sacarValor20:inteiro Funcao sacarValor50 : inteiro var N50:inteiro inicio N50 <- 5 enquanto ((saqueUsuario >= 50) e (N50 > 0)) faca saqueUsuario <- saqueUsuario - 50 N50 <- N50 - 1 fimenquanto retorne N50 fimFuncao Funcao sacarValor20 : inteiro var N20:inteiro inicio N20 <- 10 enquanto ((saqueUsuario >= 20) e (N20 > 0)) faca saqueUsuario <- saqueUsuario - 20 N20 <- N20 - 1 fimenquanto retorne N20 fimFuncao inicio leia (saqueUsuario) nota50 <- sacarValor50() nota20 <- sacarValor20() fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.