Jump to content

Search the Community

Showing results for tags 'Visualg'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Web Development
    • HTML e CSS
    • Javascript
    • PHP
    • Ruby
    • Python
    • Java
    • .NET
    • Docker, Kubernets and other environments
    • WordPress
    • Mobile
    • Agile
    • Desenvolvimento de Games
    • Banco de Dados
    • Design and UX
    • Algoritmos & Outras Tecnologias
  • Entretenimento e uso pessoal
    • Segurança & Malwares
    • Geral
    • iMasters's pub

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 117 results

  1. Criar um algoritmo que cadastre 5 bois com as informações seguintes: ID MATRICULA NO SISTEMA REGRA: ANO VIGENTE+valoraleatorio (exemplo: 2017208) PESO DO BOI RAÇA DO BOI NOME DO DONO/FAZENDA Após o cadastro faça o algoritmo analisar e informar O BOI MAIS GORDO O BOI MAIS MAGRO *se houver dois no mesmo peso mostrar os dois* MÉDIA DOS PESOS DO BOIS CADASTRADOS Alguém pode me ajudar como se faz????
  2. Boa tarde amigos. O professor passou uma atividade que não estou conseguindo fazer, de jeito maneira. Já li e reli todo o material já apresentado, pesquisei na internet, assisti vídeos, e não consigo desenvolver a atividade. Não sei mais o que fazer. Acho que esse é um daqueles problemas para espantar os alunos já no início da faculdade. Já tentei no Portugol Studio e no Visualg. Por favor, vocês podem me ajudar a entender o que se pede, e como fazer? Desenvolver um algoritmo que tenha como dado de entrada a data de nascimento de uma pessoa qualquer no formato dia, mês e ano. A partir dessa data, calcular a idade da pessoa em: a) anos, meses e dias. Ex: a resposta seria a pessoa tem 38 anos 3 meses e 5 dias de vida b) meses e dias. EX: a pessoa tem 459 meses e 5 dias C) somente em dias. Ex: a pessoa tem 30.995 dias de vida OBS: considerar o ano com 365 dias e o mês com 30dias. Segue meu código: algoritmo "idades" var diaAtual, mesAtual, anoAtual, diaNas, mesNas, anoNas, anos, meses, dias : INTEIRO inicio escreval ("Digite dia, mês, e ano atuais") escreval ("Formato DD/MM/AAAA, separados com a tecla Enter: ") leia (diaAtual, mesAtual, anoAtual) escreval ("Digite dia, mês, e ano do nascimento") escreval ("Formato DD/MM/AAAA, separados com a tecla Enter: ") leia (diaNas, mesNas, anoNas) // ANO SE ((mesAtual = mesNas) E (diaAtual >= diaNas)) então //JÁ FEZ ANIVERSARIO anos <- anoAtual - anoNas FIMSE SE ((mesAtual = mesNas) E (diaAtual < diaNas)) então //AINDA NÃO FEZ ANIVERSARIO anos <- anoAtual - anoNas - 1 FIMSE SE (mesAtual < mesNas) então //AINDA NÃO FEZ ANIVERSARIO anos <- anoAtual - anoNas - 1 FIMSE //MÊS SE ((mesAtual < mesNas) E (diaAtual >= diaNas)) então //Se não fez aniversário mas completou mês corrente meses <- 12 - (mesNas - mesAtual) FIMSE SE ((mesAtual < mesNas) E (diaAtual < diaNas)) então //Se não fez aniversário e nem completou mês corrente meses <- 12 (mesNas - mesAtual) - 1 FIMSE SE ((mesAtual > mesNas) E (diaAtual < diaNas)) então meses <- (mesAtual - mesNas) - 1 FIMSE //DIA SE (diaAtual < diaNas) então dias <- 30 - diaNas + diaAtual FIMSE SE (diaAtual >= diaNas) então dias <- diaAtual - diaNas FIMSE fimalgoritmo Desde já agradeço.
  3. Boa Tarde, alguém pode me ajudar? Faça um algoritmo que pergunte ao usuário o valor do produto e quando o usuário pergunta ao cliente a forma de pagamento, esta seja descriminada da seguinte forma: no caso 1: pagamento à vista no dinheiro, ganha 10% de desconto no caso 2: pagamento à vista no cartão de crédito sofre 10% de juros no valor do produto no caso 3: pagamento parcelado em até 2x, sofre 15% de juros no valor do produto no caso 4: pagamento no minimo em 3x parcelas ou mais sofre 5,5% EM CADA parcela Usar outrocaso também Caso apareça a mensagem de Opção invalida o programa volte ao menu para o usuário escolher um opção valida desafioaula4.alg
  4. EmersonReinecke

    Visualg

    Alguem conheçe algum site com um manual de visualg pra indicar,que tenha comandos,funções.
  5. Ta dando erro de sintaxe nesse algoritmo, mas nao consigo achar :/ Alguem sabe onde tá? Obg desde ja
  6. EmersonReinecke

    Visualg Exercicio

    Tenho esse exercício pra resolver,alguém poderia me ajudar? 3 - A prefeitura de “Xico City” deseja fazer uma pesquisa entre seus habitantes. Desenvolva uma solução para coletar dados sobre o salário e número de filhos de cada habitante e após as leituras, escrever: a) Média de salário da população b) Média do número de filhos c) Maior salário dos habitantes d) Percentual de pessoas com salário menor que R$ 150,00
  7. olá estou precisando de uma ajuda com esses exercícios, pois não estou conseguindo fazer... "VisuAlg" 1) O MDC (máximo divisor comum) de 2 números inteiros A e B pode ser calculado pelo seguinte procedimento: Enquanto B for diferente de zero R recebe o valor do resto da divisão de A por B A recebe o valor de B B recebe o valor de R Fim Enquanto Escreva um algoritmo capaz de calcular e mostrar o MDC de 2 números inteiros digitados pelo operador. _______________________________________________________________________________________________________________ 2) Construa uma algoritmo capaz de calcular o valor de S, sabendo-se que S é claculado por: s=(1/ 1)+(3/ 2)+(5/ 3)+(7/ 4)+(9/ 5)+(11/ 6)+⋯+(99/50) __________________________________________________________________________________________________________________ 3) Construa um algoritmo capaz de receber as coordenadas x e y de dois pontos em um plano cartesiano e calcule a mostre a distância entre eles.
  8. E aí pessoal, blz? Sou novo aqui e no mundo da programação. Bem, estava tentando fazer esse pequeno exercício de verificação do triângulo e só consegui pq vi umas dicas na net. Na aula o prof não dá muitas dicas, então tentei fazer sozinho mas não consegui. Eis aqui o algoritmo: Var LadoA, LadoB, LadoC:inteiro Tri, Equi, Isos, Escal: logico Inicio Escreval("Digite Lado A") Leia(LadoA) Escreval("Digite Lado B") Leia(LadoB) Escreval("Digite Lado C") Leia(LadoC) Tri <- (LadoA<LadoB+LadoC) e (LadoB<LadoA+LadoC) e (LadoC<LadoA+LadoB) Equi <- (LadoA=LadoB) e (LadoB=LadoC) Isos <- (LadoA=LadoB) ou (LadoB=LadoC) Escal <- (LadoA<>LadoB) e (LadoB<>LadoC) Se Tri entao Escreval("Os lados informados formam um triangulo") Se Equi entao Escreval("Este triangulo é equilátero") Senao Se Isos entao Escreval("Este triangulo é isósceles") Senao Se Escal entao Escreval("Este triangulo é escaleno") Fimse Fimse Fimse Senao Escreval("Os lados não formam um triangulo") Fimse Fimalgoritmo Minha dúvida de iniciante é: 1) Pq aqui (LadoA<LadoB+LadoC) quando inverto pra (LadoB+LadoC>LadoA) não dá certo? 2) Pq aqui (LadoA=LadoB) e (LadoB=LadoC) não pode ser (LadoA=LadoB) e (LadoA=LadoC), já que A=B, sendo assim não é igual a B=A? 3) Pq esse último "Senao", depois do Fimse, quando coloco logo depois do "Escreval("Os lados não formam um triangulo")" ele não me retorna a resposta? Muito obg pela atenção!
  9. var n1,n2,n3,n4,n5,n6,m1,m2,m3,m4: real inicio escreva("Digite a nota do A1+3 pontos: ") leia(n1) escreva("Digite a nota do A2: ") leia(n2) m1<-(n1+n2)/2 escreval("Sua média é", m1) se m1>=7.5 entao escreval("Passou no 1° trimestre") <--------- Ele da erro de sintaxe nessa linha senao escreva("Nota necessaria na recuperação é: ", 15-m1) fimse Alguém poderia me ajudar?
  10. Olá pessoal! preciso fazer o seguinte quadrado no visualg: 1 2 3 4 5 2 4 3 3 4 2 5 4 3 2 1 para isso, eu estou usando dois contadores, só que não to conseguindo fazer o lado vertical decrescente nem o lado horizontal decrescente. não entendo por que raios o visualg imprime o primeiro valor de " j " na linha horizontal e não to conseguindo pensar como inserir os outros lados decrescentes. podem me dar uma ajudinha nessa? escreva("Escolha um número: ") leia (base) i <- 0 j <- 0 enquanto (i < base) faca i <- i + 1 escreva(i) fimenquanto enquanto (j < base) faca j <- j + 1 escreval(j) fimenquanto rime o primeiro algarismo da primeira linha vertical, na horizontal.
  11. Eae galera, beleza? Hoje eu estava um pouco curioso e resolvi testar uma hipótese. Será que se dividirmos um número inteiro sempre por dois chegaremos a um número indivisível? Como isto daria muito trabalho resolvi escrever um algoritmo no Visualg. O meu código é o seguinte: algoritmo "Teste da razão 2" // Função : Encontrar um número indivisível // Autor : XikuGuarana // Data : 08/03/2017 // Seção de Declarações var n1: inteiro resultado: real inicio // Seção de Comandos EscrevaL("Digite um número inteiro qualquer:") Leia(n1) resultado <- n1 LimpaTela Se(n1 > 0) entao repita resultado <- (resultado / 2) EscrevaL(resultado) ate resultado = 0 FimSe EscrevaL("========== Resultado ==========") EscrevaL("O menor número encontrado foi " , resultado) fimalgoritmo Pois bem. A ideia era que a repetição só acabasse quando fosse encontrado o número zero. E para minha surpresa, após alguns segundos o programa foi encerrado e o menor número encontrado foi 4.94065645841247E-324. Alguém tem ideia do que este número significa? Por que as divisões não continuaram ocorrendo? Desde já agradeço toda a atenção e ajuda prestadas. Um forte abraço.
  12. Elabore um algoritmo que mostre todos os números de 100 ate 150, e ao final a soma de todos os números nesse intervalo. Var n: inteiro soma, cont: inteiro Inicio n <- 100 enquanto (cont < 50) faca n <- n + 1 escreval(n) soma <- soma + n cont <- cont + 1 fimenquanto escreval("Resultado da soma: ", soma) Ta contando até 150 o problema é que eu não sei se a soma ta certa.
  13. Olá! Tenho a seguinte questão para resolver: Escreva um programa que lê um valor inteiro (maior do que 1 e menor ou igual a 10) e exibe a tabuada (até 10) de multiplicação do número lido. Você deverá escrever as seguintes funções e procedimentos: funcao leNumero(): inteiro Lê um número inteiro no intervalo especificado (entre 1 e 10) e o retorna. Cada vez que for digitado um número inválido (fora do intervalo especificado) a função deve exibir a mensagem "Número inválido. Digite novamente!" procedimento tabuada(n: inteiro) Recebe como parâmetro um número inteiro e exibe na tela a tabuada de multiplicação até 10 do número lido. Não entendi se tenho de ler o número dentro da função e se sim, como vou mandá-lo da função para o procedimento?
  14. Olá mundo, tudo certo? Espero que alguém possa me ajudar, vamos lá. Estou com um problema para resolver a respeito de um trabalho na faculdade. Preciso desenvolver um código em PORTUGOL que execute um MENU para agendar consultas com diversos médicos, mostrando data, hora, especialização do médico, enfim. Precisa ser completo. Programa solicita nome do paciente Programa solicita especialidade médica desejada Programa solicita que o paciente escolha o médico Programa mostra datas e horas disponíveis para agendar a consulta com aquele médico (OBS.: O horário não pode bater com o horário de outra consulta) (OBS.: Cada consulta tem um intervalo de 45 minutos ou 1 hora se facilitar) (OBS.: A clínica funciona de 8h as 18h de segunda a sexta) Paciente seleciona a data e hora Programa mostra confirmação contendo nome do paciente, nome e especialização do médico, data e hora da consulta. Programa retorna para o menu inicial. Estou estagnado na parte de datas e horas. Não consigo pensar uma maneira de fazê-lo. Exemplo: Como vou determinar os meses com 28, 29(ano bissexto), 30 ou 31 dias? E como mostrar apenas os dias e horários disponíveis para o paciente escolher sua consulta? Os horários escolhidos previamente por outros pacientes não podem aparecer para não causar conflito. Se alguém puder me dar uma luz, será muito bem-vindo. Segue parte do código que fiz. Está muito incompleto ainda, porém não sei mais como prosseguir a partir do "caso 1" no código abaixo.. algoritmo "Menu Clínico" // Função : Efetuar o agendamento de consultas com o médico específico // Autor : GRUPO 6! // Data : 11/14/2016 // Seção de Declarações var opcao1, cardio, opcao_cardio, neuro, opcao_neuro, nutri, opcao_nutri, geri, opcao_geri: inteiro paciente: caractere inicio // Seção de Comandos escreval ("==========================================================") escreval ("|| OLÁ, SEJA BEM VINDO AO PERSONAL CONSULTA AGENDATOR ||") escreval ("==========================================================") escreval ("Por favor, informe seu nome: ") leia (paciente) procedimento menu_inicial inicio escreval ("==========================================================") escreval ("|| ESPECIALIZAÇÕES MÉDICAS! ||") escreval ("==========================================================") escreval ("||1. Cardiologista ||") escreval ("||2. Neurologista ||") escreval ("||3. Nutricionista ||") escreval ("||4. Geriatra ||") escreval ("||5. SAIR ||") escreval ("==========================================================") fimprocedimento procedimento menu_cardio inicio escreval ("==========================================================") escreval ("|| CARDIOLOGISTAS ||") escreval ("||======================================================||") escreval ("||1. Dra. Cristiane Guedes Pita ||") escreval ("||2. Dr. George Paulo Cobe Fonseca ||") escreval ("||3. Voltar ||") escreval ("==========================================================") fimprocedimento procedimento menu_neuro inicio escreval ("==========================================================") escreval ("|| NEUROLOGISTAS ||") escreval ("||======================================================||") escreval ("||1. Dr. Carlos Trigueiro de Souza ||") escreval ("||2. Dr. Antônio Tomás Turbano ||") escreval ("||3. Voltar ||") escreval ("==========================================================") fimprocedimento procedimento menu_nutri inicio escreval ("==========================================================") escreval ("|| NUTRICIONISTAS ||") escreval ("||======================================================||") escreval ("||1. Mônica Cristina Salgado Galvão ||") escreval ("||2. Fernanda Tarcélia de Oliveira Pinto ||") escreval ("||3. Voltar ||") escreval ("==========================================================") fimprocedimento procedimento menu_geri inicio escreval ("==========================================================") escreval ("|| GERIATRAS ||") escreval ("||======================================================||") escreval ("||1. Dr. Carlos Antonio Batista de Medeiros ||") escreval ("||2. Dr. Anceio Botelho Pinto ||") escreval ("||3. Voltar ||") escreval ("==========================================================") fimprocedimento repita menu_inicial escreval ("Olá ", paciente,", por favor, escolha uma opção:") leia (opcao1) limpatela se opcao1>=6 então escreval ("**********************************************************") escreval ("*************OPÇÃO INVÁLIDA, TENTE NOVAMENTE**************") escreval ("**********************************************************") fimse ate (opcao1=1) ou (opcao1=2) ou (opcao1=3) ou (opcao1=4) ou (opcao1=5) escolha (opcao1) caso 1 repita menu_cardio escreval ("Digite o número referente ao seu médico de preferência: ") leia (opcao_cardio) limpatela ate opcao_cardio=3 caso 2 menu_neuro caso 3 menu_nutri caso 4 menu_geri caso 5 escreval ("==========================================================") escreval ("|| Obrigado por utilizar o PERSONAL CONSULTA AGENDATOR! ||") escreval ("==========================================================") fimescolha fimalgoritmo Gratidao e boas vibrações! <3
  15. Sou novo na área de TI! E preciso de uma ajuda do pessoal mais experiente. Quero fazer um Caixa Eletrônico que saque somente notas de 50 e 20. Vale ressaltar que ele dá preferencia às notas de 50. Eu não consigo fazer de jeito nenhum. O codigo abaixo foi até onde consegui. Se alguem poder me mandar algum codigo novo eu aceito. Ou até msm um otimizar esse abaixo, tmb aceito. Lembrando, ele só pode sacar notas de 50 e 20. Dar prioridade as notas de 50. Minha dificuldade é com certos valores, por exemplo, R$160,00. Não consigo fazer com que retire 2 notas de 50 e 3 notas de 20. Por favor me ajudem. Algoritmo "semnome" var saqueUsuario,nota50,nota20:inteiro sacarValor50,sacarValor20:inteiro Funcao sacarValor50 : inteiro var N50:inteiro inicio N50 <- 5 enquanto ((saqueUsuario >= 50) e (N50 > 0)) faca saqueUsuario <- saqueUsuario - 50 N50 <- N50 - 1 fimenquanto retorne N50 fimFuncao Funcao sacarValor20 : inteiro var N20:inteiro inicio N20 <- 10 enquanto ((saqueUsuario >= 20) e (N20 > 0)) faca saqueUsuario <- saqueUsuario - 20 N20 <- N20 - 1 fimenquanto retorne N20 fimFuncao inicio leia (saqueUsuario) nota50 <- sacarValor50() nota20 <- sacarValor20() fimalgoritmo
  16. Boa tarde! Como posso distribuir números aleatórios de 1 a 8 com uma repetição de cada número em uma matriz 4x4 ? "Sem limites de repetição" var matriz : vetor [1..4,1..4] de inteiro Linha, Coluna : inteiro inicio para Linha de 1 ate 4 faca para Coluna de 1 ate 4 faca matriz[Linha,Coluna] <- randi(8) fimpara fimpara para Linha de 1 ate 4 faca para Coluna de 1 ate 4 faca escreva (matriz[Linha,Coluna]:8) fimpara escreval fimpara
  17. Olá, bom dia, estou fazendo um algoritmo que leia os números em ordem crescente, mas está dando um erro de aparecer tudo 0. E eu não consigo achar o erro. Olhem o código: algoritmo "semnome" // Função : // Autor : // Data : 28/09/2016 // Seção de Declarações var x,i,aux:inteiro nome:caracter sobrenome:caracter A: vetor[1..3,1..2] de inteiro inicio escreva("Informe seis números ") PARA x de 1 ATE 3 FACA PARA i de 1 ATE 2 FACA LEIA(A[x,i]) fimpara fimpara PARA x de 1 ATE 3 FACA PARA i de 1 ATE 2 FACA PARA x de 1 ate 3 faca se A[x] < A entao aux <- A[x] se A[x] < A entao A <- aux fimse fimse fimpara fimpara para i de 1 ate 3 faca escreval(A) fimpara fimpara fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.