Jump to content

Search the Community

Showing results for tags 'Visualg'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 123 results

  1. EmersonReinecke

    Visualg Exercicio

    Tenho esse exercício pra resolver,alguém poderia me ajudar? 3 - A prefeitura de “Xico City” deseja fazer uma pesquisa entre seus habitantes. Desenvolva uma solução para coletar dados sobre o salário e número de filhos de cada habitante e após as leituras, escrever: a) Média de salário da população b) Média do número de filhos c) Maior salário dos habitantes d) Percentual de pessoas com salário menor que R$ 150,00
  2. olá estou precisando de uma ajuda com esses exercícios, pois não estou conseguindo fazer... "VisuAlg" 1) O MDC (máximo divisor comum) de 2 números inteiros A e B pode ser calculado pelo seguinte procedimento: Enquanto B for diferente de zero R recebe o valor do resto da divisão de A por B A recebe o valor de B B recebe o valor de R Fim Enquanto Escreva um algoritmo capaz de calcular e mostrar o MDC de 2 números inteiros digitados pelo operador. _______________________________________________________________________________________________________________ 2) Construa uma algoritmo capaz de calcular o valor de S, sabendo-se que S é claculado por: s=(1/ 1)+(3/ 2)+(5/ 3)+(7/ 4)+(9/ 5)+(11/ 6)+⋯+(99/50) __________________________________________________________________________________________________________________ 3) Construa um algoritmo capaz de receber as coordenadas x e y de dois pontos em um plano cartesiano e calcule a mostre a distância entre eles.
  3. E aí pessoal, blz? Sou novo aqui e no mundo da programação. Bem, estava tentando fazer esse pequeno exercício de verificação do triângulo e só consegui pq vi umas dicas na net. Na aula o prof não dá muitas dicas, então tentei fazer sozinho mas não consegui. Eis aqui o algoritmo: Var LadoA, LadoB, LadoC:inteiro Tri, Equi, Isos, Escal: logico Inicio Escreval("Digite Lado A") Leia(LadoA) Escreval("Digite Lado B") Leia(LadoB) Escreval("Digite Lado C") Leia(LadoC) Tri <- (LadoA<LadoB+LadoC) e (LadoB<LadoA+LadoC) e (LadoC<LadoA+LadoB) Equi <- (LadoA=LadoB) e (LadoB=LadoC) Isos <- (LadoA=LadoB) ou (LadoB=LadoC) Escal <- (LadoA<>LadoB) e (LadoB<>LadoC) Se Tri entao Escreval("Os lados informados formam um triangulo") Se Equi entao Escreval("Este triangulo é equilátero") Senao Se Isos entao Escreval("Este triangulo é isósceles") Senao Se Escal entao Escreval("Este triangulo é escaleno") Fimse Fimse Fimse Senao Escreval("Os lados não formam um triangulo") Fimse Fimalgoritmo Minha dúvida de iniciante é: 1) Pq aqui (LadoA<LadoB+LadoC) quando inverto pra (LadoB+LadoC>LadoA) não dá certo? 2) Pq aqui (LadoA=LadoB) e (LadoB=LadoC) não pode ser (LadoA=LadoB) e (LadoA=LadoC), já que A=B, sendo assim não é igual a B=A? 3) Pq esse último "Senao", depois do Fimse, quando coloco logo depois do "Escreval("Os lados não formam um triangulo")" ele não me retorna a resposta? Muito obg pela atenção!
  4. var n1,n2,n3,n4,n5,n6,m1,m2,m3,m4: real inicio escreva("Digite a nota do A1+3 pontos: ") leia(n1) escreva("Digite a nota do A2: ") leia(n2) m1<-(n1+n2)/2 escreval("Sua média é", m1) se m1>=7.5 entao escreval("Passou no 1° trimestre") <--------- Ele da erro de sintaxe nessa linha senao escreva("Nota necessaria na recuperação é: ", 15-m1) fimse Alguém poderia me ajudar?
  5. Olá pessoal! preciso fazer o seguinte quadrado no visualg: 1 2 3 4 5 2 4 3 3 4 2 5 4 3 2 1 para isso, eu estou usando dois contadores, só que não to conseguindo fazer o lado vertical decrescente nem o lado horizontal decrescente. não entendo por que raios o visualg imprime o primeiro valor de " j " na linha horizontal e não to conseguindo pensar como inserir os outros lados decrescentes. podem me dar uma ajudinha nessa? escreva("Escolha um número: ") leia (base) i <- 0 j <- 0 enquanto (i < base) faca i <- i + 1 escreva(i) fimenquanto enquanto (j < base) faca j <- j + 1 escreval(j) fimenquanto rime o primeiro algarismo da primeira linha vertical, na horizontal.
  6. Eae galera, beleza? Hoje eu estava um pouco curioso e resolvi testar uma hipótese. Será que se dividirmos um número inteiro sempre por dois chegaremos a um número indivisível? Como isto daria muito trabalho resolvi escrever um algoritmo no Visualg. O meu código é o seguinte: algoritmo "Teste da razão 2" // Função : Encontrar um número indivisível // Autor : XikuGuarana // Data : 08/03/2017 // Seção de Declarações var n1: inteiro resultado: real inicio // Seção de Comandos EscrevaL("Digite um número inteiro qualquer:") Leia(n1) resultado <- n1 LimpaTela Se(n1 > 0) entao repita resultado <- (resultado / 2) EscrevaL(resultado) ate resultado = 0 FimSe EscrevaL("========== Resultado ==========") EscrevaL("O menor número encontrado foi " , resultado) fimalgoritmo Pois bem. A ideia era que a repetição só acabasse quando fosse encontrado o número zero. E para minha surpresa, após alguns segundos o programa foi encerrado e o menor número encontrado foi 4.94065645841247E-324. Alguém tem ideia do que este número significa? Por que as divisões não continuaram ocorrendo? Desde já agradeço toda a atenção e ajuda prestadas. Um forte abraço.
  7. Elabore um algoritmo que mostre todos os números de 100 ate 150, e ao final a soma de todos os números nesse intervalo. Var n: inteiro soma, cont: inteiro Inicio n <- 100 enquanto (cont < 50) faca n <- n + 1 escreval(n) soma <- soma + n cont <- cont + 1 fimenquanto escreval("Resultado da soma: ", soma) Ta contando até 150 o problema é que eu não sei se a soma ta certa.
  8. Olá! Tenho a seguinte questão para resolver: Escreva um programa que lê um valor inteiro (maior do que 1 e menor ou igual a 10) e exibe a tabuada (até 10) de multiplicação do número lido. Você deverá escrever as seguintes funções e procedimentos: funcao leNumero(): inteiro Lê um número inteiro no intervalo especificado (entre 1 e 10) e o retorna. Cada vez que for digitado um número inválido (fora do intervalo especificado) a função deve exibir a mensagem "Número inválido. Digite novamente!" procedimento tabuada(n: inteiro) Recebe como parâmetro um número inteiro e exibe na tela a tabuada de multiplicação até 10 do número lido. Não entendi se tenho de ler o número dentro da função e se sim, como vou mandá-lo da função para o procedimento?
  9. Olá mundo, tudo certo? Espero que alguém possa me ajudar, vamos lá. Estou com um problema para resolver a respeito de um trabalho na faculdade. Preciso desenvolver um código em PORTUGOL que execute um MENU para agendar consultas com diversos médicos, mostrando data, hora, especialização do médico, enfim. Precisa ser completo. Programa solicita nome do paciente Programa solicita especialidade médica desejada Programa solicita que o paciente escolha o médico Programa mostra datas e horas disponíveis para agendar a consulta com aquele médico (OBS.: O horário não pode bater com o horário de outra consulta) (OBS.: Cada consulta tem um intervalo de 45 minutos ou 1 hora se facilitar) (OBS.: A clínica funciona de 8h as 18h de segunda a sexta) Paciente seleciona a data e hora Programa mostra confirmação contendo nome do paciente, nome e especialização do médico, data e hora da consulta. Programa retorna para o menu inicial. Estou estagnado na parte de datas e horas. Não consigo pensar uma maneira de fazê-lo. Exemplo: Como vou determinar os meses com 28, 29(ano bissexto), 30 ou 31 dias? E como mostrar apenas os dias e horários disponíveis para o paciente escolher sua consulta? Os horários escolhidos previamente por outros pacientes não podem aparecer para não causar conflito. Se alguém puder me dar uma luz, será muito bem-vindo. Segue parte do código que fiz. Está muito incompleto ainda, porém não sei mais como prosseguir a partir do "caso 1" no código abaixo.. algoritmo "Menu Clínico" // Função : Efetuar o agendamento de consultas com o médico específico // Autor : GRUPO 6! // Data : 11/14/2016 // Seção de Declarações var opcao1, cardio, opcao_cardio, neuro, opcao_neuro, nutri, opcao_nutri, geri, opcao_geri: inteiro paciente: caractere inicio // Seção de Comandos escreval ("==========================================================") escreval ("|| OLÁ, SEJA BEM VINDO AO PERSONAL CONSULTA AGENDATOR ||") escreval ("==========================================================") escreval ("Por favor, informe seu nome: ") leia (paciente) procedimento menu_inicial inicio escreval ("==========================================================") escreval ("|| ESPECIALIZAÇÕES MÉDICAS! ||") escreval ("==========================================================") escreval ("||1. Cardiologista ||") escreval ("||2. Neurologista ||") escreval ("||3. Nutricionista ||") escreval ("||4. Geriatra ||") escreval ("||5. SAIR ||") escreval ("==========================================================") fimprocedimento procedimento menu_cardio inicio escreval ("==========================================================") escreval ("|| CARDIOLOGISTAS ||") escreval ("||======================================================||") escreval ("||1. Dra. Cristiane Guedes Pita ||") escreval ("||2. Dr. George Paulo Cobe Fonseca ||") escreval ("||3. Voltar ||") escreval ("==========================================================") fimprocedimento procedimento menu_neuro inicio escreval ("==========================================================") escreval ("|| NEUROLOGISTAS ||") escreval ("||======================================================||") escreval ("||1. Dr. Carlos Trigueiro de Souza ||") escreval ("||2. Dr. Antônio Tomás Turbano ||") escreval ("||3. Voltar ||") escreval ("==========================================================") fimprocedimento procedimento menu_nutri inicio escreval ("==========================================================") escreval ("|| NUTRICIONISTAS ||") escreval ("||======================================================||") escreval ("||1. Mônica Cristina Salgado Galvão ||") escreval ("||2. Fernanda Tarcélia de Oliveira Pinto ||") escreval ("||3. Voltar ||") escreval ("==========================================================") fimprocedimento procedimento menu_geri inicio escreval ("==========================================================") escreval ("|| GERIATRAS ||") escreval ("||======================================================||") escreval ("||1. Dr. Carlos Antonio Batista de Medeiros ||") escreval ("||2. Dr. Anceio Botelho Pinto ||") escreval ("||3. Voltar ||") escreval ("==========================================================") fimprocedimento repita menu_inicial escreval ("Olá ", paciente,", por favor, escolha uma opção:") leia (opcao1) limpatela se opcao1>=6 então escreval ("**********************************************************") escreval ("*************OPÇÃO INVÁLIDA, TENTE NOVAMENTE**************") escreval ("**********************************************************") fimse ate (opcao1=1) ou (opcao1=2) ou (opcao1=3) ou (opcao1=4) ou (opcao1=5) escolha (opcao1) caso 1 repita menu_cardio escreval ("Digite o número referente ao seu médico de preferência: ") leia (opcao_cardio) limpatela ate opcao_cardio=3 caso 2 menu_neuro caso 3 menu_nutri caso 4 menu_geri caso 5 escreval ("==========================================================") escreval ("|| Obrigado por utilizar o PERSONAL CONSULTA AGENDATOR! ||") escreval ("==========================================================") fimescolha fimalgoritmo Gratidao e boas vibrações! <3
  10. Sou novo na área de TI! E preciso de uma ajuda do pessoal mais experiente. Quero fazer um Caixa Eletrônico que saque somente notas de 50 e 20. Vale ressaltar que ele dá preferencia às notas de 50. Eu não consigo fazer de jeito nenhum. O codigo abaixo foi até onde consegui. Se alguem poder me mandar algum codigo novo eu aceito. Ou até msm um otimizar esse abaixo, tmb aceito. Lembrando, ele só pode sacar notas de 50 e 20. Dar prioridade as notas de 50. Minha dificuldade é com certos valores, por exemplo, R$160,00. Não consigo fazer com que retire 2 notas de 50 e 3 notas de 20. Por favor me ajudem. Algoritmo "semnome" var saqueUsuario,nota50,nota20:inteiro sacarValor50,sacarValor20:inteiro Funcao sacarValor50 : inteiro var N50:inteiro inicio N50 <- 5 enquanto ((saqueUsuario >= 50) e (N50 > 0)) faca saqueUsuario <- saqueUsuario - 50 N50 <- N50 - 1 fimenquanto retorne N50 fimFuncao Funcao sacarValor20 : inteiro var N20:inteiro inicio N20 <- 10 enquanto ((saqueUsuario >= 20) e (N20 > 0)) faca saqueUsuario <- saqueUsuario - 20 N20 <- N20 - 1 fimenquanto retorne N20 fimFuncao inicio leia (saqueUsuario) nota50 <- sacarValor50() nota20 <- sacarValor20() fimalgoritmo
  11. Boa tarde! Como posso distribuir números aleatórios de 1 a 8 com uma repetição de cada número em uma matriz 4x4 ? "Sem limites de repetição" var matriz : vetor [1..4,1..4] de inteiro Linha, Coluna : inteiro inicio para Linha de 1 ate 4 faca para Coluna de 1 ate 4 faca matriz[Linha,Coluna] <- randi(8) fimpara fimpara para Linha de 1 ate 4 faca para Coluna de 1 ate 4 faca escreva (matriz[Linha,Coluna]:8) fimpara escreval fimpara
  12. Olá, bom dia, estou fazendo um algoritmo que leia os números em ordem crescente, mas está dando um erro de aparecer tudo 0. E eu não consigo achar o erro. Olhem o código: algoritmo "semnome" // Função : // Autor : // Data : 28/09/2016 // Seção de Declarações var x,i,aux:inteiro nome:caracter sobrenome:caracter A: vetor[1..3,1..2] de inteiro inicio escreva("Informe seis números ") PARA x de 1 ATE 3 FACA PARA i de 1 ATE 2 FACA LEIA(A[x,i]) fimpara fimpara PARA x de 1 ATE 3 FACA PARA i de 1 ATE 2 FACA PARA x de 1 ate 3 faca se A[x] < A entao aux <- A[x] se A[x] < A entao A <- aux fimse fimse fimpara fimpara para i de 1 ate 3 faca escreval(A) fimpara fimpara fimalgoritmo
  13. PRISCILA CORREIA SILVA

    Algoritmo vetor - visualg

    Boa Noite, galera precisando de uma ajuda, travei no código..... A questão é: Faça um vetor com 50 posições e preencha com valores aleatórios de 0 a 100. a) O programa deverá pedir um número entre 0 a 100 e o programa deverá informar qual a célula que apresenta o valor mais próximo (ou igual) ao digitado. b) Deve ser informado a posição no vetor e o valor desta posição (indicando se é aproximado ou exato). *** CONSEGUI FAZER A OPÇÃO A, PORÉM A OPÇÃO B NÃO TENHO A MINIMA IDEIA DE COMO FAZER!!!! Segue meu código: var numeros: vetor[1..50] de inteiro i, num: inteiro inicio para i de 1 ate 50 faca numeros <- randi(100) fimpara //EXIBINDO VETOR para i de 1 ate 50 faca escreval("Vetor ", i, " numero: ", numeros) fimpara //PRIMEIRA PERGUNTA escreval("Digite um numero de 0 a 100") leia(num) se(((num) < 0) ou ((num) > 100)) entao escreval("Numero invalido! Digite novamente:") leia(num) senao para i de 1 ate 49 faca se numeros = num entao fimse fimpara escreval("Na posicao: ",i, " / numero: ",numeros, " Exato!") fimse fimalgoritmo
  14. 1. Leia uma matriz 6 x 6, conte e escreva quantos valores maiores que 10 ela possui. 2. Declare uma matriz 5 x 5. Preencha com 1 a diagonal principal e com 0 os demais elementos. Escreva ao final a matriz obtida
  15. Boa tarde pessoal, estou com problemas em certos procedimentos no meu algoritmo, bom o enunciado pede: 1. Desenvolver um algoritmo estilo caixa eletrônico, nele poderá ser feito: a. Autenticação do usuário; b. Saque; c. Depósito; d. Saldo; e. Extrato; f. Sair a. Deixe pré-cadastrada uma matriz com três nomes, cpfs e senhas. Enquanto o usuário não informar o CPF e SENHA corretos deverá ser perguntado o CPF e SENHA. Após informados corretamente serão dadas as opções: saque, depósito, extrato, saldo ou sair. b. Poderá ser sacado desde que o valor não seja maior que o dinheiro que esteja em conta. Caso você tenha R$200,00 em conta não poderá ser realizados saques superiores a esse valor. c. Depósitos poderão ser feitos desde que sejam superiores a R$0,00. Valide caso o usuário informe zero ou algum número negativo. d. Saldo que dispõe a conta; e. Extrato de todos os saques e depósitos efetuados. f. Sair do sistema quando a pessoa informar uma palavra ou número específico sairá do sistema. segue abaixo o codigo, caso alguem esteja disposto a ajudar :) algoritmo "ex 1 - funções procedimentos" var vtrSaque:vetor[0..15] de real vtrDeposito:vetor[0..15] de real totalDp:real saldo:real cadastro:vetor [0..2, 0..2] de caracter linha,coluna:inteiro opcao:inteiro cpf, senha:caracter nome:caracter valorSaque:real valorDp:real validarSaque:logico validarDeposito:logico validarDados:logico //procedimento perguntas procedimento laco() var inicio enquanto validarDados <- falso faca limpatela //faaer as perguntas entrar() fimenquanto fimprocedimento //procedimento entrar procedimento entrar() var inicio escreval("Informe seu CPF(APENAS NUMEROS):") leia(cpf) escreval("Informe sua senha") leia(senha) para linha de 0 ate 2 faca se (senha = cadastro[linha,2]) e (cpf = cadastro[linha,1]) entao validarDados <- verdadeiro senao validarDados <- falso fimse fimpara fimprocedimento procedimento menu() var opcao:inteiro inicio enquanto opcao <> 5 faca escreval("1 - SAQUE;") escreval("2 - DEPOSITAR;") escreval("3 - SALDO;") escreval("4 - EXTRATO;") escreval("5 - SAIR.") leia(opcao) limpatela //chamar o procedimento para escolha de opcao escolherOpcao(opcao:inteiro) fimenquanto fimprocedimento //procedimento escolherOpcao procedimento escolherOpcao(opcao:inteiro) var inicio escolha opcao caso 1 sacar() caso 2 depositar() caso 3 saldo() caso 4 extrato caso 5 escreval("**********************************************") escreval("* SISTEMA FINALIZADO *") escreval("**********************************************") outrocaso escreval("Opção inválida") fimescolha fimprocedimento //procedimento CADASTRAR procedimento cadastrar() var inicio //cadastro 1 cadastro[0,0] <- "matheus" cadastro[0,1] <- "07369926931" cadastro[0,2] <- "java" //cadastro 2 cadastro[1,0] <- "fulano" cadastro[1,1] <- "12345678923" cadastro[1,2] <- "123" //cadastro 3 cadastro[2,0] <- "ciclano" cadastro[2,1] <- "44283970972" cadastro[2,2] <- "321" fimprocedimento //FUNÇÔES SACAR, DEPOSITAR, SALDO, EXTRATO. //FUNÇÃO SACAR procedimento sacar():caracter var valorsaque:real totalDp:real totalSaque:real inicio escreval("Informe o valor do saque") leia(valorsaque) para linha de 0 ate 15 faca se (vtrSaque[linha] = 0) entao vtrSaque[linha] <- valorSaque interrompa se totalDp >= saldo entao retorne "Saque efetuado com sucesso" senao escreval("Saldo Insuficiente") fimse fimse fimprocedimento //procedimento DEPOSITO procedimento depositar() var valorDp:real inicio escreval("Informe o valor do deposito") leia(valorDp) para linha de 0 ate 15 faca se (vtrDeposito[linha] = 0) entao vtrDeposito[linha]<- valorDp totalDp <-totalDp + vtrDeposito[linha] interrompa fimse fimpara fimprocedimento //funcao SALDO procedimento saldo (saldo:real):real var inicio saldo <- totalDp - vtrsaque[linha] retorne saldo fimprocedimento //programa inicio //Cadastrar os valores na matriz cadastrar() //Efetuar o login entrar() //Menu menu() fimalgoritmo
  16. Leia a velocidade máxima permitida em uma avenida e a velocidade com que o motorista estava dirigindo nela e calcule a multa que uma pessoa vai receber, sabendo os seguintes dados: a ) 50 reais se o motorista estiver ultrapassando em até 10 km/h a velocidade permitida (abaixo de 56 km/h não deverá ocorrer multa). b )100 reais se o motorista ultrapassar de 11 a 30 km/h a velocidade permitida c ) 200 reais se estiver acima de 31km/h da velocidade permitida. Meu algoritmo (com erro): algoritmo "Exercício 14" var v, vmax, m : real inicio escreva ("Velocidade máxima permitida :") leia (vmax) escreva ("Velocidade do Motorista :") leia (v) se ( v <= vmax + 10 e v >= vmax + 6) entao m <- 50 senao se (v <= vmax+ 30 e v >= vmax + 11) entao m <- 100 senao se (v >= vmax + 31) entao m <- 200 senao m <- 0 fimse fimse fimse escreva (m) fimalgoritmo Quando vou compilar, a linha se ( v <= vmax + 10 e v >= vmax + 6) entao acusa erro. O que poderia ser? Eu não posso por um cálculo di tipo "v <= vmax + 10" ? Vou agradecer mt pela ajuda, pois faz parte de uma lista que preciso entregar como trabalho.
  17. Segundo minha cognição, o exercício pede para ler dois vetores distintos, então somar cada elemento correspondente e, apresentá-los num terceiro vetor. O problema é que o exemplo do enunciado não faz jus, ao que acabei de falar. Confiram: "Faça uma subrotina que receba dois vetores V1(100) e V2(100) em que cada posição contem um dígito e retorne V3(101) com a soma dos números nos vetores. Ex: V1 = 0 0 0 3 2 1 V2 = 0 0 4 7 3 2 ----------------------- V3 = 0 0 5 0 5 3" Vocês podem reparar que o exemplo não mostra as somas (V3) corretamente, então pode ser algo diferente do que eu compreendi! Será que li certo, ou é pra fazer outra coisa?
  18. Estou desenvolvendo um algoritmo no visualg, para um trabalho da faculdade, e gostaria que alguém me dissesse se posso melhorar meu algoritmo. Sou iniciante e o trabalho é muito complexo. Consiste em criar um sistema de cadastro para alunos de terminado curso e armazenar o resultado em vetores. Alguém pode me dizer se posso melhorar o algoritmo em algo. Ele parece que tem um problema quando escolho o opção 4. Ainda nao terminei, mas gostaria que alguém opinasse se estou certo fazer dessa forma. algoritmo "semnome" var cadastro: vetor [1..1,1..9] de caractere alunos,opcao, confirmdel,php,java,delphi,arduino,pulanum,i,sexom,sexof: inteiro cont: inteiro nomepesq, nomedel, snomedel: caractere encontrado, inserir: logico procedimento principal() inicio repita escreval ("Menu Principal") escreval ("1 - Cadastrar Aluno") escreval ("2 - Calcular a quantidade de alunos do sexo Feminino e Masculino") escreval ("3 - Exibir o aluno mais velho e o aluno mais novo") escreval ("4 - Exibir a quantidade de alunos por curso") escreval ("5 - Sair") escreva ("Digite uma Opcao: ") leia (opcao) limpatela ate (opcao=1) ou (opcao=2) ou (opcao=3) ou (opcao=4) ou (opcao=5) escolha (opcao) caso 1 cadastroaluno() caso 2 quantidadealunosporsexo() caso 3 consulta_nome() caso 4 alunosporcurso() caso 5 cont<-0 interrompa fimescolha fimprocedimento //---------------------- CADASTRO ---------------------- procedimento cadastroaluno inicio para i de 1 ate 1 faca escreval("==== CADASTRO DE ALUNOS ====") escreva("Digite a matricula ") leia(cadastro[i,1]) escreva("") escreval ("Digite o nome do aluno") leia (cadastro[i,2]) escreval ("sexo") escreval ("M - masculino") escreval ("F - feminino") leia (cadastro[i,3]) escreval ("Idade") leia (cadastro[i,4]) escreval("telefone") leia(cadastro[i,5]) escreval("Email:") leia(cadastro[i,6]) escreval ("turno") escreval ("1 - manhã") escreval ("2 - noite") leia(cadastro[i,7]) escreval ("curso") escreval ("1 - PHP") escreval ("2 - Java") escreval ("3 - Delphi") escreval ("4-Arduino") leia (cadastro[i,8]) escreval("Tipo ( 1-Novo/ 2-Ex Aluno/ 3-Convênio)") leia(cadastro[i,9]) fimpara principal () fimprocedimento //-------------------------- CONSULTA PELO sexo --------------------- procedimento quantidadealunosporsexo() inicio escreval("---- quantidade de alunos de cada sexo ") para i de 1 ate 1 faca se cadastro[i,3] = "m" entao sexom<- sexom + 1 fimse se cadastro[i,3] = "f" entao sexof<- sexof + 1 fimse fimpara Escreval("Total de Homens: ", sexom) Escreval("Total de Mulheres: ", sexof) principal() fimprocedimento procedimento alunosporcurso() inicio para i de 1 ate 1 faca se cadastro[i,8] = "1" entao php<- php + 1 fimse se cadastro[i,8] = "2" entao java<- java + 1 fimse se cadastro[i,8] = "3" entao delphi<- delphi + 1 fimse se cadastro[i,8] = "4" entao arduino<-arduino + 1 fimse fimpara escreval("o total de alunos do curso de php é ",php) escreval("o total de alunos do curso de java é ",java) escreval("o total de alunos do curso de delphi é ",delphi) escreval("o total de alunos do curso de arduino é ",arduino) principal() fimprocedimento inicio principal() fimalgoritmo
  19. Estou Programando um sistema de vendas para cinema, ja está tudo quase pronto, a unica coisa que falta é recusar a venda de um bilhete caso a cadeira já esteja ocupada... me ajudem por favor? var sala_cinema: vetor[1..10, 1..30] de caracter opcao_desejada: inteiro fileira, cadeira: inteiro x,y, bilheteria_inteira, bilheteria_meia: inteiro tipo_entrada:caracter inicio repita escreval(" ") escreval("1 - Iniciar nova Sessão: ") escreval("2 - Exibir o mapa de ocupação do cinema ") escreval("3 - Vender um bilhete ") escreval("4 -Totalizar a bilheteria ") escreval("5 -Fechar o sistema ") leia(opcao_desejada) escolha (opcao_desejada) caso 1 escreval("Iniciar nova sessão!") caso 2 escreval("Exibe Mapa!") escreval("") para fileira de 1 ate 10 passo 1 faca escreval("") para cadeira de 1 ate 30 passo 1 faca se (sala_cinema[fileira,cadeira] = "") entao escreva(" O") senao escreva(" ", sala_cinema[fileira,cadeira]) fimse fimpara fimpara escreval("") caso 3 escreval("Vender Bilhete!") escreval("Informe a fileira: ") leia(fileira) escreval("Informe a cadeira: ") leia(cadeira) sala_cinema[fileira,cadeira] <- "X" escreval("Escreva M para meia e I para inteira: ") leia(tipo_entrada) para x de 1 ate 10 passo 1 faca escreval("") para y de 1 ate 30 passo 1 faca se (sala_cinema[x,y] = "") entao escreva(" O") senao se (sala_cinema[x,y] = "X") entao se (tipo_entrada = "I") entao escreva(" X") bilheteria_inteira <- bilheteria_inteira + 1 senao escreva(" M") bilheteria_meia <- bilheteria_meia + 1 fimse fimse fimse fimpara fimpara caso 4 escreval("Totalizar Bilheteria") escreval("") escreval("O total da bilheteria INTEIRA entrada foi: ", bilheteria_inteira*30) escreval("") escreval("O total da bilheteria MEIA entrada foi: ", bilheteria_meia*15) para x de 1 ate 10 passo 1 faca para y de 1 ate 30 passo 1 faca sala_cinema[x,y] <- "" fimpara fimpara caso 5 escreval("Finalizando Sistema!") outrocaso escreval("Não exite esta opção!") fimescolha ate (opcao_desejada = 5) fimalgoritmo
  20. Bom sou novo em programação e exercicio que me foi passado é para calcular o valor do salario liquido q será pago em cima do salario bruto descontando o IRPF e o INSS... só que a professora declarou de varios números, então ta meio f*** pq eu fiz o primeiro, só que ta exibindo na tela o valor dos outros e ainda por cima ta subtraindo eles! segue abaixo o ultimo codigo q escrevi, o outro eu perdi, o fato dela ter pedido de um numero até outro é tantos % está me complicando DESCULPA AQUI EMBAIXO NÃO ESTÁ COMO AS OUTRAS PERGUNTAS, NÃO SEI FAZER, SE ALGUEM PODER ME ENSINAR AGRADEÇO inicio // Seção de Comandos escreval("Digite o valor bruto") leia(salbruto) //IRPF porcentagemIRPF1<-7.50/100 porcentagemIRPF2<-15/100 porcentagemIRPF3<-22.50/100 porcentagemIRPF4<-27.50/100 //INSS porcentagemINSS1<-8/100 porcentagemINSS2<-9/100 porcentagemINSS3<-11/100 //Processamento de dados se (salbruto <=1247.70) entao desconto1<- salbruto*porcentagemINSS1 salfinal<- salbruto-desconto1 fimse se (salbruto >=1247.71) ou (salbruto <=2079.50) entao desconto1<- salbruto*porcentagemINSS2 salfinal<- salbruto-desconto1 se (salbruto >=1499.16) ou (salbruto <=2246.75) entao desconto1<-salbruto*porcentagemINSS2 desconto2<-salbruto*porcentagemIRPF1 somadesconto<-desconto1+desconto2 salfinal<-salbruto-somadesconto fimse fimse escreval("O SALARIO FINAL É: ", salfinal) fimalgoritmo
  21. Estou no começo de um curso de Ti e meu professor passou um exercício em visualg estou com dificuldades apenas para fazer o item b ) da lista de coisas que o programa deve fazer. O Exercicio foi o seguinte: Meu programa está funcionando rendondinho só não consegui pensar em nada para o item b ) por isso decidi pedir ajuda a vocês que tem muito mais experiência no assunto. algoritmo "Exercicio 1" var S, med_anterior, media, maiorS, Perc : real cont : inteiro inicio maiorS:=0 med_anterior:=0 media:=0 repita escreva ("Digite o valor do salário:") leia (S) se s<>0 entao cont:=cont+1 med_anterior:=med_anterior+S fimse se (S<=1.000) entao S:=S+(S*2/10) fimse se (S>1.000) e (S<=2.000) entao S:=S+(S/10) fimse se (S>2.000) entao S:=S+(S/20) fimse se S>maiorS entao maiorS:=S fimse media:=media+S ate S=0 perc:=media/med_anterior-1.0 escreval ("A folha sálarial da empresa antes do reajuste era igual a R$ ", med_anterior) escreval ("A folha sálarial da empresa após os reajustes é igual a R$ ", media) escreval ("O percentual de aumento sobre a folha salarial foi de :", perc*100:2:2,"%") escreval ("O maior salário é R$ ", maiorS) escreval ("A média sálarial antes dos reajuste era igual a R$ ", med_anterior/cont) escreval ("A média sálarial após o reajusta é igual a R$ ", media/cont) fimalgoritmo
  22. Algoritmo "Obter notas e apresentar em ordem crescente" Var aNotas: VETOR[1..50] DE INTEIRO I, J, Y, L, K, nNumero: INTEIRO Inicio Escreva("Digite o número de notas que você deseja ordenar: ") Leia(nNumero) Para I De 1 Ate nNumero Passo 1 Faca Escreva("Digite a", I,"° nota: ") Leia(aNotas[I]) Fimpara Para K De 1 Ate I-1 Faca Para J De 1 Ate nNumero Faca Se aNotas[J] > aNotas[J+1] Entao Y <- aNotas[J] aNotas[J] <- aNotas[J+1] aNotas[J+1] <- Y Fimse Fimpara Fimpara Para L De 1 Ate J Faca Escreval(aNotas[L]) Fimpara Fimalgoritmo Olá pessoal, Eu preciso fazer um algoritmo no VisualG que leia um determinado número de notas e as organize-as de forma crescente, eu consegui elaborar o algoritmo, mais, no resultado ele aparece um 0, sendo que eu não digitei nenhum 0. Exemplo: Digitei: 9 10 2 No resultado aparece: 0 2 9 10 O algoritmo está acima, obrigado.
  23. GMVieira

    Matriz Visualg

    EXERCÍCIO: Faça uma subrotina que receba uma matriz 10x10, o número de uma linha, o número de uma coluna e retorne uma matriz 9x9, resultante da remoção da coluna e da linha informados. Comecei a fazer no visualg até onde eu consegui, mas meu algoritmo esta errado porque ele não consegue pular a linha e coluna eliminadas, tirando só o valor e fazendo como se ainda existisse 10 linhas e 10 colunas. Alguém poderia me ajudar? algoritmo "Matriz" var matriz10: vetor [1..10,1..10] de inteiro matriz9: vetor [1..9,1..9] de inteiro linha,coluna,l,c: inteiro inicio para linha de 1 ate 10 faca para coluna de 1 ate 10 faca matriz10[linha,coluna] <- 10 fimpara fimpara escreval ("Informe a linha (1 a 10) ") leia (l) escreval ("Informe a coluna (1 a 10) ") leia © para linha de 1 ate 10 faca para coluna de 1 ate 10 faca se ( (linha <> l) e (coluna <> c) ) entao matriz9[linha,coluna]<- matriz10[linha,coluna] fimse fimpara fimpara fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.