Jump to content

Search the Community

Showing results for tags 'erro'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 290 results

  1. XCobra Commandx

    Sistema de Login

    Ola ! Sou iniciante em php e fui tentar criar um sistema de login usando um código pronto (página do tutorial com o sistema para download) , porem encontrei dificuldades em aplicar o código. O problema é que quando eu aperto o botão "sing up" ele não muda a tabela e fica travado apenas na plataforma de login além de não incorporar a fonte desejada. Aqui esta o meu : site de testes. Estou usando o 000webhost para testar os códigos e praticar , porque além de gratuito ele oferece um banco de dados e a habilidade de editar os códigos em qualquer língua (php 7.1).
  2. DinhoPHP

    Conteúdo Sob Demanda (Erro)

    Olá! Preciso desesperadamente finalizar um carregamento sob demanda, porém esse já é o segundo que adapto ao site do cliente e dá erro no Chrome. Por favor me ajudem! pagina.php <div style="display:none;height:36px;" class="tips"><?=__FILE__?></div> <?php $limite = empty($INI['system']['limite_vitrine']) ? 20 : (int) $INI['system']['limite_vitrine']; $ordem = 'rand()'; $sql = "select * from team where ehdestaque = 'Y' and (status is null or status = 1) and (pago = 'sim' or anunciogratis = 's') and begin_time < '".time()."' and end_time > '".time()."' order by " . $ordem . " limit " . $limite; $rs = mysql_query($sql); if(mysql_num_rows($rs)){ ?> <div class="destaquesMobile"> <?php while($l = mysql_fetch_assoc($rs)){ $l['title'] = utf8_decode($l['title']); $link = $ROOTPATH . "/?idoferta=" . $l['id']; if($l['imgdestaque'] !=""){ $imagemoferta = $INI['system']['wwwprefix']."/media/".$l['image']; //ESTA LINHA ESTAVA NO ELSE } else{ $imagemoferta = getImagemDestaque($l['imgdestaque']); //ESTA LINHA ESTAVA NO IF } if(!(empty($l["maximo_hospede"]))) { $hospedes = "Total de h&oacute;spedes: " . $l["maximo_hospede"]; } if(!(empty($l["team_price"]))) { $valordiaria = "Valor: R$ " . number_format($l["team_price"],2,",","."); } if(!(empty($l["imob_tipo"]))) { $sqlT = "select nome from tipoimoveis where id = '" . $l["imob_tipo"] . "'"; $rsT = mysql_query($sqlT); $tipo = mysql_fetch_assoc($rsT); } else { $bairro = utf8_decode("Bairro não informado."); } $l['title'] = $l['title']; ?> <div class="itemMobile post"> <div id="caption_mobile" class="caption_mobile" style="background-color: #f9f6f7;"><?=$l['title']?></div> <figure class="boxFigureMobile"> <p class="boxContentText"> <?=displaySubStringWithStrip($l['title'], 30)?> </p> <a href="<?=$link?>"> <img src="<?=$imagemoferta?>" alt="<?=$l['title']?>" title="<?=$l['title']?>"> </a> </figure> <div class="boxContentMobile"> <p class="boxContentNormal"><?php echo "Imóvel: " . utf8_decode($tipo["nome"]); ?></p> <p class="boxContentNormal"><?php echo $valordiaria; ?></p> <p class="boxContentNormal"><?php echo $hospedes; ?></p> <div id="box_redes_sociais"> <img id="share_redes_sociais" class="boxContentNormal" src="http://www.balcaodeservico.com.br/skin/padrao/images/icon_facebook.png"/> <img id="share_redes_sociais" class="boxContentNormal" src="http://www.balcaodeservico.com.br/skin/padrao/images/icon_instagram.png"/> <img id="share_redes_sociais" class="boxContentNormal" src="http://www.balcaodeservico.com.br/skin/padrao/images/icon_twitter.png"/> <img id="share_redes_sociais" class="boxContentNormal" src="http://www.balcaodeservico.com.br/skin/padrao/images/icon_whatsapp.png"/> </div> </div> </div> <?php } ?> <a href="#" id="loadmore">Carregar mais...</a> <a href="#" id="totop">Ir para o topo</a> </div> <?php } ?> carregamento_sob_demanda.js (O Chrome sempre acusa erro na linha 6 ou 7. /** * Created by Equipe Nova Info on 05/10/2017. */ //Carrega um conteúdo inicial ao carregar a página //AS DUAS LINHAS SEGUINTES SÃO AS QUE O CHROME ENCONTRA O ERRO $(function () { num_posts_show = 3; speed_to_top = 1000; // in ms $(".post").slice(0, num_posts_show).show(); $("#loadmore").on('click', function (e) { e.preventDefault(); $("div:hidden").slice(0, num_posts_show).slideDown(); if ($("div:hidden").length == 0) { $("#load").fadeOut('slow'); } $('html,body').animate({ scrollTop: $(this).offset().top }, 1500); }); }); $('#totop').click(function () { $('body,html').animate({ scrollTop: 0 }, speed_to_top); return false; }); $(window).scroll(function () { if ($(this).scrollTop() > 50) { $('#totop').fadeIn(); } else { $('#totop').fadeOut(); } }); responsive.css .post { display:none; padding: 10px; border-width: 0 1px 1px 0; border-style: solid; border-color: #efefef; box-shadow: 0 1px 1px #cdcdcd; margin-bottom: 5px; background-color: #f1f1f1; } .totop { position: fixed; bottom: 10px; right: 20px; } .totop a { display: none; } a, a:visited { color: #33739E; text-decoration: none; display: block; margin: 10px 0; } a:hover { text-decoration: none; } #loadmore { padding: 10px; text-align: center; background-color: #33739E; color: #fff; border-width: 0 1px 1px 0; border-style: solid; border-color: #fff; box-shadow: 0 1px 1px #ccc; transition: all 600ms ease-in-out; -webkit-transition: all 600ms ease-in-out; -moz-transition: all 600ms ease-in-out; -o-transition: all 600ms ease-in-out; } #loadmore:hover { background-color: #fff; color: #33739E; }
  3. Tenho a seguinte consulta select * from ( select proc_distribuicao.idusuario, count(proc_distribuicao.idusuario) as qtd from proc_distribuicao group by idusuario ) as consulta where consulta.qtd > 1 é exatamente o que passei horas procurando ela me retorna : id qtd | 2 | 2 | | 7 | 2 | | 8 | 2 | | 9 | 2 | | 10 | 2 | | 12 | 2 | | 13 | 3 | | 14 | 2 | | 20 | 4 | Só que preciso que ela me retorne somente os registro que não fazem parte dessa lista select * from usuario where idusuario NOT IN (select * from ( select proc_distribuicao.idusuario, count(proc_distribuicao.idusuario) as qtd from proc_distribuicao group by idusuario ) as consulta where consulta.qtd > 1) É ai que dá esse erro Como resolver ?
  4. rogirn2

    Syntax Error, Unexpected T_variable

    Olá pessoal, estou com um problema chato que aparentemente é simples, mas não tô conseguindo achar o erro de jeito nenhum... Vi que já haviam aberto um tópico sobre esse mesmo erro, mas era muito antigo (de 2008) e o cara só resolveu postando o código dele aqui, por isso resolvi postar o meu para que mais olhos possam procurar, pq os meus cansaram de tanto procurar e não achar nada. ps.: no tópico em questão este erro tinha sido causado devido a falta de um ";" ou do excesso de aspas no código, mas o meu não tem nada disso (ao menos não aos meus olhos, espero estar errado). <?php if(!isset($_GET['token']) || $_GET['token'] != "meuToken") { echo "Token não confere!"; exit(); } require_once('scripts/banco.php'); require_once('PHPMailer/class.phpmailer.php'); require_once('PHPMailer/class.smtp.php'); if($clientes = $banco->query("SELECT * FROM clientes WHERE token != ''")){ while($cliente = $clientes->fetch_assoc()){ $corpo = ' <html> <head> <title>Titulo</title> <meta http-equiv="content-type" content="text/html; charset=utf-8"> </head> <body bgcolor="#FFFFFF" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0"> <!-- Save for Web Slices (1.png) --> <center> <table id="Tabela_01" width="650" height="1455" border="0" cellpadding="0" cellspacing="0"> <tr> <td colspan="3"> <img src="https://gallery.mailchimp.com/eaea0012d51d0c982ab77172b/images/be84f1f0-743e-44bc-87b1-1389292c88ec.jpg" width="650" height="702" alt="" style="display:block;"> </td> </tr> <tr> <td colspan="3"> <img src="https://gallery.mailchimp.com/eaea0012d51d0c982ab77172b/images/78060dda-bbd8-424e-bb60-bba99909bf45.jpg" width="650" height="212" alt="" style="display:block;"> </td> </tr> <tr> <td rowspan="2"> <img src="https://gallery.mailchimp.com/eaea0012d51d0c982ab77172b/images/daf32221-1e04-4d9a-8c54-50f431a8bfea.jpg" width="45" height="541" alt="" style="display:block;"> </td> <td> <a href="http://www.superfacilatacado.com.br/finalizar_cadastro.php?token='.$cliente['token'].'"> <img src="https://gallery.mailchimp.com/eaea0012d51d0c982ab77172b/images/10544e6c-c550-4f83-883e-196a9cb031d0.png" width="156" height="26" border="0" alt="" style="display:block;"> </a> </td> <td rowspan="2"> <img src="https://gallery.mailchimp.com/eaea0012d51d0c982ab77172b/images/8936e151-0c50-4ec7-a285-0f467f96cfd7.jpg" width="449" height="541" alt="" style="display:block;"> </td> </tr> <tr> <td> <img src="https://gallery.mailchimp.com/eaea0012d51d0c982ab77172b/images/9d39104c-1e50-447e-a614-13172eaec86a.jpg" width="156" height="515" alt="" style="display:block;"> </td> </tr> </table> </center> <!-- End Save for Web Slices --> </body> </html>'; $mailer = new PHPMailer(); $mailer->SMTPDebug = 1; $mailer->Port = 587; //Indica a porta de conexão para a saída de e-mails. Utilize obrigatoriamente a porta 587. $mailer->Host = 'smtp.servidorsmtp.com.br'; //Onde em 'servidor_de_saida' deve ser alterado por um dos hosts abaixo: //Para cPanel: 'mail.dominio.com.br'; //Para Plesk 11 / 11.5: 'smtp.dominio.com.br'; //Descomente a linha abaixo caso revenda seja 'Plesk 11.5 Linux' //$mailer->SMTPSecure = 'ssl'; $mailer->SMTPAuth = true; //Define se haverá ou não autenticação no SMTP $mailer->CharSet = "UTF-8"; $mailer->Username = 'meuemail@meuemail.com.br'; //Informe o e-mai o completo $mailer->Password = 'minhasenha'; //Senha da caixa postal $mailer->FromName = 'Igor Brito'; //Nome que será exibido para o destinatário $mailer->From = 'meuemail@meuemail.com.br'; //Obrigatório ser a mesma caixa postal indicada em "username" $mailer->AddAddress($cliente['email']); //Destinatários $mailer->Subject = "Assunto do Email"; $mailer->Body = $corpo; $mailer->IsHTML(true); if($mailer->Send()){ echo "E-mail enviado com sucesso para: ".$cliente['email']."<br>"; }else{ echo "Falha ao enviar e-mail para: ".$cliente['email']."<br>"; } } }else{ echo $banco->error; }
  5. Renato Keüller

    Ajuda com Erro PHP

    Olá. Tenho um script PHP que funciona normalmente. Mas quando vou fazer upload de arquivos ele dá o seguinte erro: (SyntaxError: Unexpected token h in JSON at position 0) Por favor, me ajudem.
  6. Gusttavo Mello

    syntax error unexpected

    pessoal tou aprendendo php e tou com o seguinte erro no codigo codigo: <?php session_start(); $usuariot = $_POST ['usuario']; $senhat = $_POST ['senha']; include_once("conexao.php") $result = mysql_query("SELECT * FROM usuarios WHERE login='usuariot' AND senha='senhat' LIMIT 1") $resultado = mysql_fetch_assoc($result); $resultado['nome']; ?> erro: Parse error: syntax error, unexpected '$result' (T_VARIABLE)
  7. Olá. O meu problema é o seguinte: Tenho um texto salvo no meu banco de dados com um caracter acentuado e quando faço a busca desse texto no banco e o exibo na tela no lugar do caracter é exibido um símbolo. Só que quando faço o SELECT direto no sgbd ele mostra o caracter normalmente, já alterei o charset do php.ini para utf8 mas continua o problema. Não sei se tem há ver mas uso o PDO.
  8. Olá. Eu uso vários arquivos JavaScript em meu site e quando uso uma função de um arquivo em um outro diferente é exibido um erro: NOME DA FUNÇÃO is not defined Então gostaria de saber como consertar esse erro
  9. Boa tarde. Estou com um erro e não consigo solucionar. Tenho um programa feito em Delphi XE 8 com MySQL utilizando Firedac. Consigo ativar normalmente minha query em tempo de desenvolvimento, mas em run time apresenta o seguinte erro: --------------------------- Debugger Exception Notification --------------------------- Project GestorEstoque.exe raised exception class EDatabaseError with message 'qProduto: Type mismatch for field 'cdproduto', expecting: LongWord actual: AutoInc'. --------------------------- Break Continue Help --------------------------- Este erro ocorre quando tento pesquisar o produto pelo campo cdproduto. Pesquisei bastante na internet, falaram para remover os campos e adicionar novamente, fiz isso e não adiantou. O que resolveu temporariamente foi eu alterar o campo no MySQL, alterei o campo cdproduto de INT para INT(6), mas depois de um tempo ele voltar o problema. O que não entendo é porque no Field Editor da minha query produto, o campo cdproduto esta como TLongWordField Tenho outras tabelas com o mesmo tipo de campo INT com AutoIncremento e no Field Editor da query ele reconhece o campo como tipo TFDAutoIncField. Sou novo com MySQL, até então eu utilizava Firebird, pode ser algo simples mas não estou conseguindo resolver. Alguém ja teve o mesmo problema ou alguém que possa me dar um norte para eu identificar o problema? Agradeço a atenção Dario
  10. Veja o exemplo: create table time( id int not null primary key auto_increment, nome varchar(50) unique )engine=innodb; delimiter $$ CREATE PROCEDURE insertteam (nometime varchar(50)) begin declare continue handler for 1062 select 'você ja inseriu esse nome anteriormente'; insert into time (id, nome) values(null, nometime); end$$ delimiter ; call insertteam ('BRASIL'); select * from time; se eu "chamar" e inserir brasil novamente ele trava corretamente, até ai tudo ok. Mas quando vou inserir um time que ainda não existe ele insere corretamente, mas pula os ids nas respectivas vezes que tentei inserir brasil novamente e deu errado. Por exemplo: se eu tentar inserir brasil 5 vezes ele insere a primeira e da erro nas outras. Mas depois quando eu for inserir "mexico" ele insere corretamente mas no id = 6.
  11. Para que serve exatamente a função handler e como posso utiliza-la para tratar um erro no mysql?
  12. Claudinéia Costa

    erro no arquivo php no wordpress

    Olá amigos estou com um erro depois de uma atualização no wordpress. seguinte mensagem. Fatal error: Class 'Walker' not found in /home/u514182106/public_html/wp-includes/class-walker-page.php on line 17 porém o arquivo esta normal comparando com outros sites. link do site: http://vidacoachingfinanceiro.com.br/
  13. MMMartins

    tratamento de erro mysql

    gostaria de saber como funciona e como inserir a função @@ERROR no script abaixo: DELIMITER $ DROP PROCEDURE CRIAR_CONSULTA$ CREATE PROCEDURE CRIAR_CONSULTA(IDPAC INT, IDMED INT, IDHOS INT) BEGIN start transaction; if (IDPAC > 0 AND IDMED > 0 AND IDHOS > 0) THEN INSERT INTO CONSULTA (IDCONSULTA, ID_PACIENTE, ID_MEDICO, ID_HOSPITAL, DATA) VALUES(NULL, IDPAC, IDMED, IDHOS, CURTIME()); SELECT(' DADOS INSERIDOS COM SUCESSO ') AS 'MENSAGEM'; commit; ELSE SELECT ('INSIRA OS DADOS CORRETAMENTE') AS 'MENSAGEM DE ERRO'; ROLLBACK; END IF; END$ DELIMITER
  14. romuloS

    3 erro no perfil.php

    sao 3 erros que aparece aqui Warning: mysqli_query(): Couldn't fetch mysqli in C:\wamp64\www\redesocial\perfil.php on line 20 ( ! ) Warning: mysqli_num_rows() expects parameter 1 to be mysqli_result, null given in C:\wamp64\www\redesocial\perfil.php on line 22 ( ! ) Warning: mysqli_close(): Couldn't fetch mysqli in C:\wamp64\www\redesocial\perfil.php on line 44 <?php $page_title = 'perfil'; require_once('inicia_sessao.php'); require_once('proteger_pagina.php'); // Insert the page header require_once('cabecalho.php'); require_once('conectar.php'); // Menu de navegação require_once('navmenu.php'); // Pegar os dados do perfil do banco de dados if (!empty($_SESSION['user_id'])) { $query = "SELECT nome_de_usuario, join_date, nome_completo, email FROM usuarios WHERE user_id = '" . $_SESSION['user_id'] . "'"; } else { $query = "SELECT nome_de_usuario, join_date, nome_completo, email FROM usuarios WHERE user_id = '" . $_COOKIE['user_id'] . "'"; } $data = mysqli_query($dbc, $query); if (mysqli_num_rows($data) == 1) { // Se o usuário for encontrado, exibir as informações $row = mysqli_fetch_array($data); echo '<table>'; if (!empty($row['nome_de_usuario'])) { echo '<tr><td class="label">Nome de usuário:</td><td>' . $row['nome_de_usuario'] . '</td></tr>'; } if (!empty($row['nome_completo'])) { echo '<tr><td class="label">Nome completo:</td><td>' . $row['nome_completo'] . '</td></tr>'; } if (!empty($row['email'])) { echo '<tr><td class="label">E-mail:</td><td>' . $row['email'] . '</td></tr>'; } if (!empty($row['join_date'])) { list($data, $hora) = explode(' ', $row['join_date']); list($ano, $mes, $dia) = explode('-', $data); echo '<tr><td class="label">Registrado:</td><td>' . $dia . '-' . $mes . '-' . $ano . ' / ' . $hora . '</td></tr>'; } } echo '</td></tr>'; echo '</table>'; mysqli_close($dbc); // Rodapé require_once('rodape.php'); ?>
  15. RedHot66

    Erro hospedagem Zend Framework 2

    Estou hospedando um sistema criado em Zend 2 em um servidor dedicado com Windows Server 2008, Apache 2.4, PHP 7.1.5. O usuário que está rodando o apache já está com permissão total nos arquivos, mas estou recebendo o seguinte erro: Fatal error: require_once(): Failed opening required '/vendor/doctrine/orm/lib/Doctrine/ORM/Mapping/Driver/DoctrineAnnotations.php' (include_path='.;C:\php\pear') in C:\Apache24\htdocs\urldosite.com.br\vendor\doctrine\annotations\lib\Doctrine\Common\Annotations\AnnotationRegistry.php on line 64 Alguém sabe como posso resolver?
  16. jardelcosta

    Mensagem do Envio do email PHP

    Boa tarde, galera! Estou utilizando PHPMailler para enviar e-mails e está quase tudo certinho. Tá enviando normal, porém após enviar, está aparecendo umas mensagem de configuração na tela. Alguém sabe como remover? Já setei o error_reporting para 0. Mensagem aparecendo tipo essa: SMTP->FROM SERVER:220 proxy.email-ssl.com.br ESMTP postfix (Debian/GNU)
  17. Olá. Comprei um novo notebook potente para modelar e renderizar meus projetos 3D, mas recentemente ao colocar qualquer textura disponível da biblioteca nos objetos o arquivo do 3ds Max fecha após a mensagem de erro. Já apaguei a pasta Enu e o problema persiste. Estou preocupada pois o notebook realmente tem ótimas configurações e uma ótima placa de vídeo. Em Render Setup já habilitei o mentalray e estou tentando usar as texturas do arch & design. Alguém consegue me ajudar? Obrigada desde já pela atenção!
  18. LucasVellez

    Erro "Function eregi() is deprecated".

    Olá, estou recebendo um erro: "Deprecated: Function eregi() is deprecated in" na linha "88" TODO O CÓDIGO: O Erro está na linha 88: if(!eregi('^image\/(pjpeg|jpeg|png|gif|bmp)$', $foto['type'])){ <?php elseif($tipo == 'avatar'): $foto = $_FILES['imagem']; $username = $_SESSION['usuario']; if($_FILES){ $largura = 1000000; $altura = 1000000; $tamanho = 1000000; if(!eregi('^image\/(pjpeg|jpeg|png|gif|bmp)$', $foto['type'])){ $error[1] = 'Isso não é uma imagem'; } if(empty($foto['name'])){ $error[2] = 'Selecione seu avatar'; } if(count($error) == 0){ preg_match('/\.(gif|bmp|png|jpg|jpeg){1}$/i', $foto['name'], $ext); $nome_imagem = md5(uniqid(time())) . "." . $ext[1]; $caminho_imagem = "media/uplouds/avatar/" . $nome_imagem; move_uploaded_file($foto['tmp_name'], $caminho_imagem); db::Query("UPDATE usuarios SET avatar='$nome_imagem' WHERE usuario='$username'"); echo('<div id="content_aviso_verde_esq"><div id="insert_content_aviso_verde_esq" class="text_content_aviso_verde_esq">Avatar alterado com sucesso</div></div>'); }else{ foreach($error as $erro){ echo('<div id="content_aviso_vermelho_esq"><div id="insert_content_aviso_vermelho_esq" class="text_content_aviso_vermelho_esq">'.$erro.'</div></div>'); } } } ?>
  19. DarkNuub

    Gerar XML com php (erro)

    Olá pessoal, olhando alguns tópicos aki no forum mesmo eu fiz esse código porem n ta rodando direito, n sei se o problema esta no meu código ou se est no meu banco de dados <?php $conn = mysqli_connect('localhost','root','') or die ('Erro ao conectar'); $db = mysqli_select_db($conn,'teste') or die ('Erro ao conectar com o banco de dados'); $query = mysqli_query($conn,"SELECT * FROM sopraelas ORDER BY id"); while( $row = mysqli_fetch_object( $query ) ) $Write [ ] = $row ; $Writer = new XMLWriter(); $Writer->openMemory(); $Writer->startDocument( '1.0' , 'utf-8' ) ; $Writer->setIndent(true); $Writer->startElement( 'Rss' ) ; forEach ( $Write as $Nodes ) { $Writer->startElement( 'Feed' ) ; if ( is_array ( $Nodes ) ) forEach ( $Nodes as $nodeName => $nodeValue ) $Writer->writeElement ( $nodeName , $nodeValue ) ; $Writer->endElement(); } $Writer->endElement(); $Output = $Writer->outputMemory ( true ) ; $fHandle = fopen ( 'backup.xml' , 'w+' ) ; fwrite ( $fHandle , $Output ) ; fclose ( $fHandle ) ; header ( 'Content-Type: text/xml;charset=utf-8' ) ; echo $Output; ?> a questão e q esta dando o seguinte erro: no meu banco de dados a estrutura é a seguinte: n sei se errei na estrutura,no código ou nos dois.
  20. Boa noite, Estou desenvolvendo um tema para wordpress e todas as imagens que coloco não carregam e/ou não são reconhecidas. Esta é a tag q estou usando: <img src="img/logo.png"/> Porem quando chamo imagens pelo arquivo style.css, com a o código background: url(img/logo.svg) center center/235px no-repeat; , elas carregam normalmente. Já testei com outros tipos de arquivos de imagens (jpeg, jpg, svg e gif) e continuam com o mesmo problema. Para testar o tema estou usando um servidor online gratuito
  21. Boa noite, Estou desenvolvendo um tema para wordpress e todas as imagens que coloco não carregam e/ou não são reconhecidas. Esta é a tag q estou usando: <img src="img/logo.png"/> Porem quando chamo imagens pelo arquivo style.css, com a o código background: url(img/logo.svg) center center/235px no-repeat; , elas carregam normalmente. Já testei com outros tipos de arquivos de imagens (jpeg, jpg, svg e gif) e continuam com o mesmo problema. Para testar o tema estou usando um servidor online gratuito
  22. Boa noite, Estou desenvolvendo um tema para wordpress e todas as imagens que coloco não carregam e/ou não são reconhecidas. Esta é a tag q estou usando: <img src="img/logo.png"/> Porem quando chamo imagens pelo arquivo style.css, com a o código background: url(img/logo.svg) center center/235px no-repeat; , elas carregam normalmente. Já testei com outros tipos de arquivos de imagens (jpeg, jpg, svg e gif) e continuam com o mesmo problema. Para testar o tema estou usando um servidor online gratuito
  23. #include <stdio.h> #include <string.h> #include <stdlib.h> #include <ctype.h> #define SIZE 200 #include<locale.h> #include<conio.h> #include <time.h> char nome [50]; char email [50]; int cpf ; int op; char ap; void cadastro(); void pesquisa(); void lista(); int main (void){ setlocale(LC_ALL, "Portuguese"); do{ system("cls"); printf(" MENU \n\n"); printf("\t I - incluir uma nova pessoa\n"); printf("\t B - buscar uma pessoa pelo nome\n"); printf("\t L - listar todas as pessoas\n"); printf("\tESC - para sair do cadastro\n"); ap = getche(); switch(ap) { case 'I': cadastro(); break; case 'B': pesquisa(); break; case 'L': lista(); break; case 27: printf("tchau"); break; default: printf("opção inválida"); break; } }while(ap!=27); } void lista(){ int i; for(i=0;i<SIZE;i++){ if(cpf>0){ printf("\nome: %s\nEmail: %s\nCPF: %d", nome, email, cpf); }else{ break; } } } void cadastro(){ static int linha; do{ printf("\ndigite o nome: "); scanf("%s", &nome[linha]); printf("\ndigite o email: "); scanf("%s", &email[linha]); printf("\ndigite o cpf: "); scanf("%d", &cpf[linha]); printf("\nDigite 1 para continuar ou outro valor para sair"); scanf ("%d", &op); linha++; }while (op==1); } void pesquisa(){ char nomepesquisa; int i; do{ printf("\nDigite o nome:"); scanf("%s", &nomepesquisa); for(i=0;i>SIZE;i++){ if(nome==nomepesquisa){ printf("\nNome: %s\nEmail: %s\nCPF: %d", nome, email, cpf); } } printf("\nDigite 1 para continuar pesquisando"); scanf("%d", &op); }while(op==1); } Estou com um problema neste código. estou começando agora na parte de programação e não entendo muito. #include <stdio.h> #include <string.h> #include <stdlib.h> #include <ctype.h> #define SIZE 200 #include<locale.h> #include<conio.h> #include <time.h> char nome [50]; char email [50]; int cpf ; int op; char ap; void cadastro(); void pesquisa(); void lista(); int main (void){ setlocale(LC_ALL, "Portuguese"); do{ system("cls"); printf(" MENU \n\n"); printf("\t I - incluir uma nova pessoa\n"); printf("\t B - buscar uma pessoa pelo nome\n"); printf("\t L - listar todas as pessoas\n"); printf("\tESC - para sair do cadastro\n"); ap = getche(); switch(ap) { case 'I': cadastro(); break; case 'B': pesquisa(); break; case 'L': lista(); break; case 27: printf("tchau"); break; default: printf("opção inválida"); break; } }while(ap!=27); } void lista(){ int i; for(i=0;i<SIZE;i++){ if(cpf>0){ printf("\nome: %s\nEmail: %s\nCPF: %d", nome, email, cpf); }else{ break; } } } void cadastro(){ static int linha; do{ printf("\ndigite o nome: "); scanf("%s", &nome[linha]); printf("\ndigite o email: "); scanf("%s", &email[linha]); printf("\ndigite o cpf: "); scanf("%d", &cpf[linha]); printf("\nDigite 1 para continuar ou outro valor para sair"); scanf ("%d", &op); linha++; }while (op==1); } void pesquisa(){ char nomepesquisa; int i; do{ printf("\nDigite o nome:"); scanf("%s", &nomepesquisa); for(i=0;i>SIZE;i++){ if(nome==nomepesquisa){ printf("\nNome: %s\nEmail: %s\nCPF: %d", nome, email, cpf); } } printf("\nDigite 1 para continuar pesquisando"); scanf("%d", &op); }while(op==1); }
  24. cleimarlemes

    [Resolvido] Gerar xls via php dando erro...

    Warning: mysqli_query() expects at least 2 parameters, 1 given in /home/u870495724/public_html/testexls.php on line 38 Warning: mysqli_query(): Empty query in /home/u870495724/public_html/testexls.php on line 40 Warning: mysqli_fetch_array() expects parameter 1 to be mysqli_result, boolean given in /home/u870495724/public_html/testexls.php on line 44 acima esta o erro que aparece pra mim.. e abaixo segue meu código completo.. <?php // Inclui a conexão //include_once("conexao2.php"); $servidor = "mysql.hostinger.com.br"; $usuario = "u8polo"; $senha = "po3"; $dbname = "u8polo"; //Criar a conexão $conn = mysqli_connect($servidor, $usuario, $senha, $dbname); if(!$conn){ die("Falha na conexao: " . mysqli_connect_error()); }else{ //echo "Conexao realizada com sucesso"; } // Nome do Arquivo do Excel que será gerado $arquivo = 'relatorio_entsai.xls'; // Criamos uma tabela HTML com o formato da planilha para excel $tabela = '<table border="1">'; $tabela .= '<tr>'; $tabela .= '<td colspan="2">RELATORIO DE ENTRADA E SAIDA</tr>'; $tabela .= '</tr>'; $tabela .= '<tr>'; $tabela .= '<td><b>Matricula</b></td>'; $tabela .= '<td><b>Nome</b></td>'; $tabela .= '<td><b>Tipo</b></td>'; $tabela .= '<td><b>Placa</b></td>'; $tabela .= '<td><b>Veiculo</b></td>'; $tabela .= '<td><b>Cidade</b></td>'; $tabela .= '<td><b>Uf</b></td>'; $tabela .= '<td><b>Empresa</b></td>'; $tabela .= '<td><b>Data Entrada</b></td>'; $tabela .= '<td><b>Hora Entrada</b></td>'; $tabela .= '<td><b>Hora Saida</b></td>'; $tabela .= '</tr>'; // Puxando dados do Banco de dados $banco_select = mysqli_query("SELECT * FROM tb_entrada"); $resultado_usuario = mysqli_query($conn, $banco_select); echo $resultado; while($dados = mysqli_fetch_array($resultado_usuario)) { $tabela .= '<tr>'; $tabela .= '<td>'.$dados['matricula'].'</td>'; $tabela .= '<td>'.$dados['nome'].'</td>'; $tabela .= '<td>'.$dados['tipo'].'</td>'; $tabela .= '<td>'.$dados['placa'].'</td>'; $tabela .= '<td>'.$dados['veiculo'].'</td>'; $tabela .= '<td>'.$dados['cidade'].'</td>'; $tabela .= '<td>'.$dados['uf'].'</td>'; $tabela .= '<td>'.$dados['empresa'].'</td>'; $tabela .= '<td>'.$dados['dataentrada'].'</td>'; $tabela .= '<td>'.$dados['horaentrada'].'</td>'; $tabela .= '<td>'.$dados['horasaida'].'</td>'; $tabela .= '</tr>'; } $tabela .= '</table>'; // Força o Download do Arquivo Gerado header ('Cache-Control: no-cache, must-revalidate'); header ('Pragma: no-cache'); header('Content-Type: application/x-msexcel'); header ("Content-Disposition: attachment; filename=\"{$arquivo}\""); echo $tabela; ?>
  25. Olá pessoal. Estou tentando importar uma tabela MySQL, o UpLoad é feito, e após uns 3 minutos de processamento vem o erro. Notice in .\libraries\sql-parser\src\UtfString.php#134 Uninitialized string offset: 48990Backtrace .\libraries\sql-parser\src\Lexer.php#418: SqlParser\UtfString->offsetGet(integer 43948) .\libraries\sql-parser\src\Lexer.php#258: SqlParser\Lexer->parseKeyword() .\libraries\sql-parser\src\Lexer.php#210: SqlParser\Lexer->lex() .\libraries\Util.class.php#634: SqlParser\Lexer->__construct(string ) .\import.php#750: PMA_Util::mysqlDie( string '#1054 - Unknown column \'url_amigavel\' in \'field list\'', string , boolean false, string 'db_import.php?db=banco_loja&amp;token=9dc9ea0f544fef6045ea063426trgty4', boolean true, ) O Erro acima é listado várias vezes. Essa Coluna ( url_amigavel ) funciona perfeitamente onde está o Banco de Origem, porém essa coluna foi inserida neste banco não faz muito tempo, cerca de 1 ano. Por que motivo será que está dando esse erro? Obrigado!
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.