Jump to content

Search the Community

Showing results for tags 'portugol'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 25 results

  1. O exercício propunha fazer duas funções uma para multiplicação e outra para criar uma fatorial, porém devem ser feitas usando apenas operações de soma e subtração bom fiz uma função para multiplicar e esta funcionando porém estou tentando utiliza-la para fazer a fatorial e o resultado sempre da zero ;-; podem me ajudar algoritmo "semnome" var a,b:inteiro funcao multi(a:inteiro;b:inteiro):real var aux:real inicio se a=0 entao retorne 0 senao aux <- 0 enquanto b>0 faca aux <- aux+a b <- b-1 fimenquanto retorne aux fimse fimfuncao funcao fatorial(a:inteiro):real var fat,res:real inicio enquanto fat > 0 faca fat<-a fat <- fat - 1 res <- multi(fat,a) fimenquanto retorne res fimfuncao inicio leia(a) escreval(fatorial(a)) fimalgoritmo
  2. Olá galera tudo beleza? Eu estou tentando resolver um problema no visualg, usando Portugol porém eu não sei aplicar algumas coisas que são pedidas no mesmo. Problema: Dado um número, informar se é par ou ímpar. Se for par somar 5 no número informado e se for ímpar multiplicar por 3 o número informado. Eu fiz a parte em que ele fala se o número e par ou ímpar, mas não sei fazer a parte da soma e a multiplicação alguém pode me ajudar? ALGORITMO: Var n:inteiro inicio escreval("Insira um número inteiro") leia (n) se (n mod2=0) entao escreval ("O número é par") senao escreval("O número é impar") fimse Fimalgoritmo
  3. Fala galera tudo beleza? Então meu professor passou um "problema" e falou para criar um programa no Visualg usando Portugol, só que eu estou com alguns problemas principalmente na fórmula, alguém pode me ajudar? Pergunta: Dado o preço do ingresso e a idade o programa devera informar o preço do ingresso com os seguintes descontos de acordo com a idade: IDADE 0-5-15% 6-20-5% 21-40- 2% acima de 40 - 30% Se puderem me ajudar agradeço.
  4. guiilhermej

    Ajuda Portugol

    Galera, to com um impasse em umas questões passadas na faculdade, eu realmente gosto de resolver meus exercícios, pois só assim sei que irei aprender, mas acontece que to meio perdido nessas questões, alguem me da um help por favor. 6. Escreva um algoritmo que peça um número n ao usuário, e que gere um novo n de acordo com a seguinte regra: • se n é par, n = n / 2 • se n é impar, n = 3 * n + 1 • imprime n • O programa deve parar quando x tiver o valor igual a 1. Por exemplo, para n = 13, a saída será: 40 -> 20 -> 10 -> 5 -> 16 -> 8 -> 4 -> 2 -> 1 7. Fazer um algoritmo que leia um número que servira para controlar os primeiros números ímpares. Deverá ser impressa a soma desses números. Suponha que o número informado será maior que zero, caso não seja, informar o erro. Informe um número: 5 1 3 5 7 9 A soma dos 5 valores impares é: 25 8. Fazer um algoritmo que leia os limites inferior e superior de um intervalo e o número cujos múltiplos se deseja que sejam impressos no intervalo aberto. Suponha que os dados digitados são para um intervalo crescente. Exemplo: Valor inicial: 5 Valor final: 15 Divisor: 3 6 9 12 15 9. Fazer um algoritmo que leia a quantidade de números que se deseja digitar para que possa ser impresso o maior e o menor número digitado. Não suponha que todos os números lidos serão positivos. Exemplo: Quantos números deseja digitar? 5 Informe um numero:3 Informe um numero:-2 Informe um numero:5 Informe um numero:6 Informe um numero:19 O maior numero informado foi: 19 O menor numero informado foi: -2
  5. Boa tarde galera, sei que não é muito comum problemas com essa linguagem porem estou no começo e preciso muito da ajuda de vocês, preciso desenvolver um programa que estou desde ontem tentando desenvolver e não consigo achar uma solução,a linguagem é portugol estou começando no mundo de programação mais estou com muita dificuldade em solucionar esse algorítimo: Solicite para o usuário nome e sexo de pessoas, ao final da entrada desses dados pergunte para o usuário se o mesmo deseja digitar mais pessoas, se sim solicite novamente os dados, se não, encerre o programa e exiba a quantidade de pessoas que foram digitadas, o total de pessoas do sexo masculino, o total do sexo feminino, o total de sexo inválido e a porcentagem de cada um. Alguém poderia me ajudar por favor
  6. Olá, pessoas. Criei um programa com fins de estudo no visualg, cuja finalidade é preencher uma matriz com valores aleatórios e, em seguida, conferir e armazenar numa segunda atriz se o valores gerados são pares ou ímpares. Todavia o programa fica dando um erro ("Access violation at address xxxx in module" visualg30.exe). Não sei se eu que estou errando na lógica, se meu pc está quebrado ou se é um bug do visualg. Abaixo deixo meu código para quem puder me ajudar. Obrigado :) Var // Seção de Declarações das variáveis matriz1: vetor [0..2, 0..2] de inteiro matriz2: vetor [0..2, 0..2] de caractere // Procedimento que gera valores inteiros aleatorios para preencher a matriz1. procedimento preencheMatriz var // Variaveis contadoras i1, i2: inteiro inicio para i1 de 0 ate 1 passo 1 faca para i2 de 0 ate 2 passo 1 faca aleatorio on leia (matriz1[i1,i2]) limpatela aleatorio off fimpara fimpara // Imprimindo a matriz na tela para i1 de 0 ate 1 passo 1 faca para i2 de 0 ate 2 passo 1 faca escreva (matriz1[i1,i2]) fimpara escreval ("") fimpara fimprocedimento // Procedimento que verifica se os valores das posições da matriz1 são pares // ou ímpares. procedimento verificaParImpar var i1, i2: inteiro inicio para i1 de 0 ate 1 passo 1 faca para i2 de 0 ate 2 passo 1 faca se (matriz1[i1, i2] MOD 2=0) entao matriz2[i1,i2] <- "par" escreva(matriz2[i1,i2], " ") senao matriz2[i1,i2] <- "ímpar" escreva(matriz2[i1,i2], " ") fimse fimpara escreval(" ") fimpara fimprocedimento Inicio // Seção de Comandos, procedimento, funções, operadores, etc... preencheMatriz verificaParImpar Fimalgoritmo
  7. Alguém sabe como resolver resolver esse exercício? Sou novo nessa área da programação e estou quebrando a minha cabeça para fazer. Se vocês pelo menos me der um base irei agradecer. Miguel é responsável pelas contas de uma grande empresa da área de mineração em Minas Gerais. Ele deseja pagar a seus funcionários um bom salário, mas se preocupa com as épocas de crise. Dessa forma, ele paga um salário fixo, condizente com a função do funcionário e paga a eles um valor adicional a título de participação de lucros. Ele deseja que você crie um programa que calcule quanto um funcionário específico receberá em um mês, tendo em vista a sua função e o quanto a empresa lucrou percentualmente em relação à expectativa. Os salários seguem a tabela: Nível Salário Ausente R$1600,00 Técnico R$2800,00 Analista R$3500,00 Especialista R$4000,00 ENUNCIADO Ainda, o salário é acrescido do percentual que excedeu as expectativas de lucro da empresa. Lembrando que se o percentual for inferior a 100% o empregado não pode receber menos do que o salário. Enunciado Agora, que Miguel já consegue saber o quanto um funcionário recebe em um mês, ele deseja saber o quanto ele deverá pagar para todos os seus funcionários. Agora, para cada funcionário ele pagará uma bonificação (percentual) sobre seu salário relacionada a seu desempenho individual, além da participação dos lucros. Ele então deseja que você crie um programa que, recebendo as informações suficientes para o cálculo do pagamento de cada funcionário, informe o valor de pagamento total. Questões 1. Identifique a entrada, saída e processamento para este problema. 2. Descreva textualmente os passos do algoritmo. 3. Identifique quais serão as variáveis e constantes utilizadas no algoritmo, com seus tipos respectivos. 4. Descreva as funções matemáticas que geram as saídas do algoritmo. 5. Para o algoritmo desenvolvido por você (não programado ainda!), identifique os laços e desvios de fluxo. 6. Escreva um código em Portugol que represente o algoritmo que resolve o problema de Miguel.
  8. Uma escola deseja saber algumas informações estatísticas referente a uma sala de aula com 20 alunos. Para isso, fora elaborado um questionário contendo as seguintes perguntas: - Nome do aluno - Data de nascimento (DD/MM/AAAA) - Sexo (F/M/O) - Signo - Altura Apresentar no final as seguintes informações: a) Percentual de alunos do sexo F b) média de idade dos alunos c) nome e peso da pessoa mais pesada do sexo M d) quantidade de pessoas do signo de aries abaixo de 1,80m de altura e) nome e altura da pessoa mais baixa f) média aritmética de peso de todos os alunos entrevistados g) percentual de pessoas que nasceram em ano BISSEXTO h) quantidade de pessoas que nasceram em dias PRIMO J) quantidade de alunos por signo Alguém me ajuda a explicar sobre parte que esta grifado Segue a imagem abaixo da onde eu parei código var NA,DDMMAAAA,S,Sig:CARACTERE inicio Escreval("Digite o nome aluno") leia(NA) Escreval("Digite data de nascimento") leia(DDMMAAAA) Repita Escreval("Digite o seu sexo") leia(S) SE (S<>"F") e (S<>"M") e (S<>"O") entao Escreval("sexo invalido") fimse ATE (S="F") ou (S="M") ou (S="0") Repita Escreval("Digite o seu signo") leia(Sig) SE (Sig<>"aries") e (Sig<>"touro") e (Sig<>"Gemeos") e (Sig<>"Cancer") e (Sig<>"Leao") e (Sig<>"Virgem") e (Sig<>"Libra") e (Sig<>"Escorpiao") e (Sig<>"Sagitario") e (Sig<>"Capricornio") e (Sig<>"Aquario") e (Sig<>"Peixes") entao Escreval("signo invalido") fimse ATE (Sig="aries") ou (Sig="touro") ou (Sig="Gemeos") ou (Sig="Cancer") ou (Sig="Leao") ou (Sig="Virgem") ou (Sig="Libra") ou (Sig="Escorpiao") ou (Sig="Sagitario") ou (Sig="Capricornio") ou (Sig="Aquario") ou (Sig="Peixes") Escreval("Digite a sua altura") leia(alt) Escreval("Digite o seu peso") leia(p) fimalgoritmo
  9. Carol Cavalcanti

    saque bancário

    Programa que recebe do usuário um valor de saque e as cédulas disponíveis no caixa eletrônico, retornando se o saque é possível com as cédulas disponíveis e quantas cédulas serão necessárias no total e especifica quantas cédulas de cada valor. o que fiz até agora: //Função inicial funcao inicio() { //Declaração de variáveis logico notaDeDois, notaDeCinco, notaDeDez, notaDeVinte, notaDeCinquenta, notaDeCem //Variáveis que guardam a informação //de verdadeiro ou falso para a //existência cada cédula no caixa //eletrônico inteiro quantidadeNotaDeDois, quantidadeNotaDeCinco, quantidadeNotaDeDez, quantidadeNotaDeVinte //Variáveis que guardam as inteiro quantidadeNotaDeCinquenta, quantidadeNotaDeCem //quantidades mínimas necessárias de cada uma das cédulas para o //saque do valor informado pelo usuário inteiro quantidadeCedulas = 0 //Variável para uso do programa para a soma da quantidade mínima de cédulas pro saque inteiro valorDeSaque //Valor a ser sacado, informado pelo usuário inteiro controleDeResposta //Variável que guardao valor (1 ou 2) da resposta do usuário para a existência da cédula no //caixa eletrônico para posterior conversão em uma variável lógica //Apresentação do programa escreva ("-- Caixa eletrônico --") escreva ("\nPrograma que informa as cédulas mínimas necessárias para um saque.\n") //Solicitações ao usuário escreva ("\n- Informe o valor do saque: ") leia (valorDeSaque) escreva ("- No caixa, há cédulas de R$ 2? (1- sim ou 2- não)\n") leia (controleDeResposta) se (controleDeResposta == 1){ //Conversão do controle de resposta (1 ou 2) em valor logico notaDeDois = verdadeiro } senao { notaDeDois = falso } escreva ("- No caixa, há cédulas de R$ 5? (1- sim ou 2- não)\n") leia (controleDeResposta) se (controleDeResposta == 1){ //Conversão do controle de resposta (1 ou 2) em valor logico notaDeCinco = verdadeiro } senao { notaDeCinco = falso } escreva ("- No caixa, há cédulas de R$ 10? (1- sim ou 2- não)\n") leia (controleDeResposta) se (controleDeResposta == 1){ //Conversão do controle de resposta (1 ou 2) em valor logico notaDeDez = verdadeiro } senao { notaDeDez = falso } escreva ("- No caixa, há cédulas de R$ 20? (1- sim ou 2- não)\n") leia (controleDeResposta) se (controleDeResposta == 1){ //Conversão do controle de resposta (1 ou 2) em valor logico notaDeVinte = verdadeiro } senao { notaDeVinte = falso } escreva ("- No caixa, há cédulas de R$ 50? (1- sim ou 2- não)\n") leia (controleDeResposta) se (controleDeResposta == 1){ //Conversão do controle de resposta (1 ou 2) em valor logico notaDeCinquenta = verdadeiro } senao { notaDeCinquenta = falso } escreva ("- No caixa, há cédulas de R$ 100? (1- sim ou 2- não)\n") leia (controleDeResposta) se (controleDeResposta == 1){ //Conversão do controle de resposta (1 ou 2) em valor logico notaDeCem = verdadeiro } senao { notaDeCem = falso } //Realização das aferições //Cédulas de R$100 se (notaDeCem == verdadeiro){ //Verifica se há cédulas de R$100 no caixa se (valorDeSaque/100>=1){ //Verifica se o valor de saque é superior a R$100 quantidadeNotaDeCem = valorDeSaque/100 //Cálculo da quantidade de cédulas de R$100 quantidadeCedulas = quantidadeCedulas + quantidadeNotaDeCem //Soma a quantidade de cédulas de R$100 a quantidade //mínima necessária de de cédulas para o saque valorDeSaque = valorDeSaque - (quantidadeNotaDeCem*100) //Subtrai o valor que já será sacado só em notas de //R$100 do valor total de saque } senao { //Caso haja cédulas de R$100 e o valor do saque seja inferior a R$100 quantidadeNotaDeCem = 0 } } senao { //Caso não haja cédulas de R$100 quantidadeNotaDeCem = 0 } //Cédulas de R$50 se (notaDeCinquenta == verdadeiro){ //Verifica se há cédulas de R$50 no caixa se (valorDeSaque/50>=1){ //Verifica se o valor de saque é superior a R$50 quantidadeNotaDeCinquenta = valorDeSaque/50 //Cálculo da quantidade de cédulas de R$50 quantidadeCedulas = quantidadeCedulas + quantidadeNotaDeCinquenta //Soma a quantidade de cédulas de R$50 a //quantidade mínima necessária de de cédula //para o saque valorDeSaque = valorDeSaque - (quantidadeNotaDeCinquenta*50) //Subtrai o valor que já será sacado só em notas de //R$50 do valor total de saque } senao { quantidadeNotaDeCinquenta = 0 //Caso haja cédulas de R$50 e o valor do saque seja inferior a R$50 } } senao { quantidadeNotaDeCinquenta = 0 //Caso não haja cédulas de R$100 } //Cédulas de R$20 se (notaDeVinte == verdadeiro){ //Verifica se há cédulas de R$20 no caixa se (valorDeSaque/20>=1){ //Verifica se o valor de saque é superior a R$20 quantidadeNotaDeVinte = valorDeSaque/20 //Cálculo da quantidade de cédulas de R$20 quantidadeCedulas = quantidadeCedulas + quantidadeNotaDeVinte //Soma a quantidade de cédulas de R$20 a //quantidade mínima necessária de de cédula para //o saque valorDeSaque = valorDeSaque - (quantidadeNotaDeVinte*20) //Subtrai o valor que já será sacado só em notas de R$20 //do valor total de saque } senao { quantidadeNotaDeVinte = 0 //Caso haja cédulas de R$20 e o valor do saque seja inferior a R$20 } } senao { quantidadeNotaDeVinte = 0 //Caso não haja cédulas de R$20 } //Cédulas de R$10 se (notaDeDez == verdadeiro){ //Verifica se há cédulas de R$10 no caixa se (valorDeSaque/10>=1){ //Verifica se o valor de saque é superior a R$10 quantidadeNotaDeDez = valorDeSaque/10 //Cálculo da quantidade de cédulas de R$10 quantidadeCedulas = quantidadeCedulas + quantidadeNotaDeDez //Soma a quantidade de cédulas de R$10 a quantidade //mínima necessária de de cédula para o saque valorDeSaque = valorDeSaque - (quantidadeNotaDeDez*10) //Subtrai o valor que já será sacado só em notas de R$10 //do valor total de saque } senao { quantidadeNotaDeDez = 0 //Caso haja cédulas de R$10 e o valor do saque seja inferior a R$10 } } senao { quantidadeNotaDeDez = 0 //Caso não haja cédulas de R$10 } //Cédulas de R$5 se (notaDeCinco == verdadeiro){ //Verifica se há cédulas de R$5 no caixa se (valorDeSaque/5>=1){ //Verifica se o valor de saque é superior a R$5 quantidadeNotaDeCinco = valorDeSaque/5 //Cálculo da quantidade de cédulas de R$5 quantidadeCedulas = quantidadeCedulas + quantidadeNotaDeCinco //Soma a quantidade de cédulas de R$5 a quantidade //mínima necessária de de cédula para o saque valorDeSaque = valorDeSaque - (quantidadeNotaDeCinco*5) //Subtrai o valor que já será sacado só em notas de R$5 //do valor total de saque } senao { quantidadeNotaDeCinco = 0 //Caso haja cédulas de R$5 e o valor do saque seja inferior a R$5 } } senao { quantidadeNotaDeCinco = 0 //Caso não haja cédulas de R$5 } //Cédulas de R$2 se (notaDeDois == verdadeiro){ //Verifica se há cédulas de R$2 no caixa se (valorDeSaque/2>=1){ //Verifica se o valor de saque é superior a R$2 quantidadeNotaDeDois = valorDeSaque/2 //Cálculo da quantidade de cédulas de R$2 quantidadeCedulas = quantidadeCedulas + quantidadeNotaDeDois //Soma a quantidade de cédulas de R$2 a quantidade //mínima necessária de de cédula para o saque valorDeSaque = valorDeSaque - (quantidadeNotaDeDois*2) //Subtrai o valor que já será sacado só em notas de R$2 //do valor total de saque } senao { quantidadeNotaDeDois = 0 //Caso haja cédulas de R$2 e o valor do saque seja inferior a R$2 } } senao { quantidadeNotaDeDois = 0 //Caso não haja cédulas de R$2 } //Exposição dos resultados se (valorDeSaque == 0){ //Verifica se todo o valor de saque pôde ser disposto nas cédulas disponíveis //Expõe a quantidade mínima de cédulas para a realização do saque escreva ("\n> A quantidade mínima de cédulas para a realização desse saque é ", quantidadeCedulas, ". Sendo elas:\n") //Exposição da quantidade mínima de cédulas de cada valor necessárias para a realização de saque se (quantidadeNotaDeCem > 0){ //Verifica se é necessária alguma cédula de R$100 escreva (quantidadeNotaDeCem, " notas de R$100\n") //Expõe a quantidade de cédula de R$100, caso haja } se (quantidadeNotaDeCinquenta > 0){ //Verifica se é necessária alguma cédula de R$50 escreva (quantidadeNotaDeCinquenta, " notas de R$50\n") //Expõe a quantidade de cédula de R$50, caso haja } se (quantidadeNotaDeVinte > 0){ //Verifica se é necessária alguma cédula de R$20 escreva (quantidadeNotaDeVinte, " notas de R$20\n") //Expõe a quantidade de cédula de R$20, caso haja } se (quantidadeNotaDeDez > 0){ //Verifica se é necessária alguma cédula de R$10 escreva (quantidadeNotaDeDez, " notas de R$10\n") //Expõe a quantidade de cédula de R$10, caso haja } se (quantidadeNotaDeCinco > 0){ //Verifica se é necessária alguma cédula de R$5 escreva (quantidadeNotaDeCinco, " notas de R$5\n") //Expõe a quantidade de cédula de R$5, caso haja } se (quantidadeNotaDeDois > 0){ //Verifica se é necessária alguma cédula de R$2 escreva (quantidadeNotaDeDois, " notas de R$2\n") //Expõe a quantidade de cédula de R$2, caso haja } } senao { //Caso, mesmo usando todos os valores de cédulas disponíveis, ainda reste um valor de saque que cuja //realização não seja possível pelo caixa eletrônico, emite uma mensagem de aviso. escreva ("\n> O saque não poderá ser realizado.") } } } o problema é no caso de um valor de saque como 13 que pode ser possível mas o programa diz que não é
  10. Robson Oliveira1

    Algoritimo

    1. Imprima uma PG, onde são fornecidos o primeiro termo, a razão e a quantidade de termos desejada. 2. Calcule a soma dos 20 primeiros termos da série: 1!/1 – 2!/3 + 3!/7 – 4!/15 + 5!/31 – ... Alguem da uma ajuda nessas duas questões. Algoritimo em Portugol
  11. Meu código esta assim: programa { //variavel global inteiro matriz[3][3] funcao logico repetiu(inteiro n, inteiro lin, inteiro col){ para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(nao(l == lin e c == col)){ se(matriz[l][c] == n){ retorne verdadeiro } } } } retorne falso } funcao inicio(){ //receber a matriz para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ leia(matriz[l][c]) } } para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(repetiu(matriz[l][c], l, c)) escreva(matriz[l][c], " - ") } } } }
  12. O QUE CONSEGUIR FAZER ATÉ O MOMENTO FOI ISSO programa { //variavel global inteiro matriz[3][3] funcao logico repetiu(inteiro n, inteiro lin, inteiro col){ para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(nao(l == lin e c == col)){ se(matriz[l][c] == n){ retorne verdadeiro } } } } retorne falso } funcao inicio(){ //receber a matriz para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ leia(matriz[l][c]) } } para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(repetiu(matriz[l][c], l, c)) escreva(matriz[l][c], " - ") } } } }
  13. Primeiramente, olá a todos. Estou tentando desenvolver um protótipo de jogo no Portugol Studio usando a biblioteca gráfica, porém encontrei certa dificuldade ao rodar o código. Quando inicio o modo gráfico a imagem que pedi que fosse desenhada não aparece e a janela desaparece rapidamente. Caso alguém se interesse em me ajudar, aqui segue o código: programa { inclua biblioteca Graficos --> g funcao inicio() { inicializar_janela() desenhar_elementos() } funcao inicializar_janela() { g.iniciar_modo_grafico(verdadeiro) g.definir_dimensoes_janela(860, 640) g.definir_titulo_janela("Teste") } funcao desenhar_elementos() { inteiro imagem_fundo imagem_fundo = g.carregar_imagem("fundo.jpg") g.desenhar_imagem(10, 10, imagem_fundo) } }
  14. I_mean_It

    Rotinas Visualg

    Boa noite, comecei a estudar lógica de programação a pouco tempo, e estou com uma dúvida sobre passagem de parâmetros por valor e por referência. Sei a estrutura de cada um e como funciona, porém não sei quando devo usar um ou outro. Será que alguém poderia tentar exemplificar para mim? Estou aprendendo no Visualg.
  15. programa { inclua biblioteca Matematica --> mat funcao inicio() { real a,b,c,x1,x2,delta escreva ("Digite a: ") leia (a) escreva ("Digite b: ") leia (b escreva ("Digite c: ") leia (c) delta = (b * b) - 4 * a * c x1 = (-b + (mat.raiz (delta, 2.0))) / (2 * a) x2 = (-b - (mat.raiz (delta, 2.0))) / (2 * a) se (delta > 0) escreva ("\nA equação possui duas raízes, x1 = ",x1," e x2 = ",x2) senao { x1 = -b / (2*a) escreva ("\nA equação não possui raíz real\n") } se (delta <- 0) { x1 = -b / (2*a) escreva ("\nA equação possui uma raíz real \n",x1) } } }
  16. Alguém pode me ajudar com esse trabalho da Faculdade? to sem ideia de onde começar. – Elabore um algoritmo que solicite ao operador a idade de um grupo de pessoas (várias), processe e apresente: a) a idade média das pessoas; b) a maior idade e quantas pessoas a tiveram; c) a menor idade e quantas pessoas a tiveram. Atenção: 1) quando a idade informada for igual a zero, finalizar as entradas e mostrar os resultados processados. 2) Validar corretivamente para que a idade não seja inferior a zero e nem superior a 120. 3) Verificar se houve entrada de dados, caso não, dê uma mensagem. 4) Lembre-se que a primeira idade informada será a maior e/ou menor em relação as demais idades que serão informadas. Observação1: 1) Criar as seguintes funções: a) Uma função para validar corretivamente a idade para estar no intervalo de 0 a 130. b) uma função para processar o cálculo da média, retornando o resultado para o código principal onde será mostrado. 2) NÃO usar estrutura de vetor e/ou matriz.
  17. nad_nov <- "" Escreva ("Informe a idade do nadador: ") leia(idade) se idade < novo entao novo <- 0 * novo + (idade) nad_nov <- (nome) fimse Pessoal , eu desenvolvi um algoritmo em portugol para uma questão no qual pedia uma série de coisas, entre elas pedia de O nome do nadador mais novo , e é justamente a parte que não deu certo. Como eu armazenaria o nome do nadador mais novo após vários loops?
  18. Olá, Meu professor passou este código em portugol e preciso passar ele para C++, alguém pode me ajudar ? Declare v[100], v2[100],soma[100],multipliacao[100],i,j numerico Para i de 1 ate 100 passo 1 Faca soma <- v1+ v2 Para j de 1 ate 100 passo 1 Faca multiplicacao[j] <- v1[j]+v2[j]
  19. Pessoal bom dia, acabei de iniciar um curso de programação e preciso fazer o algorítimo de uma calculadora, o professor mandou que fizéssemos pelo portugol studio. A calculadora eu consegui fazer e esta funcionando perfeitamente, porém não estou conseguindo coloca-la em loop, ou seja , de que adianta a calculadora se apos cada conta ela tiver de ser fechada e reaberta, teria como alguem me ajudar a coloca-la em loop, nao sei qual o comando certo no portugol para isso. como nao posso por o executável aqui segue o algorítimo que eu tenho pronto : programa { real n1 , n2 , n3 caracter op funcao inicio() { escreva ("Digite o primeiro numero: ") leia (n1) escreva ("Selecione a operação desejada: ") leia (op) escreva ("Digite o segundo número: ") leia (n2) se ( op == '+') { (n3 = n1 + n2) } se ( op == '-') { (n3 = n1 - n2) } se ( op == '*') { (n3 = n1 * n2) } se ( op == '/') { (n3 = n1 / n2) } escreva ("Seu resultado é: " , n3) } } DESDE JÁ AGRADEÇO
  20. Faça um programa que apresente a seguinte saída, perguntando ao usuário o número máximo. Este número deve ter ímpar. Exemplo: Entrada: 9 Saída: 1 2 3 4 5 6 7 8 9 2 3 4 5 6 7 8 3 4 5 6 7 4 5 6 5 Obs.: tem que ser em PORTUGOL
  21. Escrever um algoritmo que lê: - a percentagem do IPI a ser acrescido no valor das peças - o código da peça 1, valor unitário da peça 1, quantidade de peças 1 - o código da peça 2, valor unitário da peça 2, quantidade de peças 2 O algoritmo deve calcular o valor total a ser pago e apresentar o resultado. Fórmula : (valor1*quant1 + valor2*quant2)*(IPI/100 + 1)
  22. Elaborar um algoritmo que lê 3 valores a,b,c e verifica se eles formam ou não um triângulo. Supor que os valores lidos são inteiros e positivos. Caso os valores formem um triângulo, calcular e escrever a área deste triângulo. Se não formam triângulo escrever os valores lidos. ( se a > b + c não formam triângulo algum, se a é o maior).
  23. Olá pessoal, alguem poderia me ajudar a transformar esse codigo simples de portugol para javascript. ALGORITMO TO_FAZENDO_OQUE VAR INTEIRO: A,B,C,M1,M2,M3; INICIO ESCREVA(“DIGITE TRES VALORES INTEIROS”); LEIA(A,B,C); SE(A > B) ENTAO BEGIN M3 A; SE(A > C) ENTAO SE(C > B)ENTAO BEGIN M2C; M1B; END SENAO BEGIN M2  B; M1  C; END FIMSE SENAO BEGIN M3C; M2A; M1B; END FIMSE END SENAO BEGIN M3B; SE(B > C) ENTAO SE(C > A) ENTAO BEGIN M2  C; M1  A; END SENAO BEGIN M2A; M1C; END FIMSE SENAO BEGIN M3C; M2B; M1A; END END FIMSE ESCREVA(M1, “,”,M2, “,”, M3); FIM
  24. Olá pessoal, já tentei inúmeras vezes resolver este problema, mas não consegui. É o seguinte, tenho que escrever um algoritmo que leia o preço de um produto e a quantidade de volumes e no final some tudo e dê o valor final da compra até aí ok, consegui fazer e ficou assim: inteiro preco,quant,cont=0,produtos,soma=0,total1,total2=0 enquanto (cont>=0) { escreva("Digite a quantidade: ") leia(quant) escreva("Digite o preco do prod: ") leia(preco) total1 = quant*preco soma = soma + quant total2 = total2+total1 cont = cont+1 } } escreva("o total da compra foi de: ",total2) Porém o exercicio pede que quando, em "Digite a quantidade" foi digitado 0 (zero) , o programa pule para a parte de escrever o total da compra e encerrar e é justamente esta parte que nao estou conseguindo desenvolver. Por favor, me ajudem. Obrigada desde já.
  25. Boa tarde, sou novo por aqui , comecei a fazer sistema da informação a pouco tempo . Na aula de ontem o professor pediu pra fazermos um exercício em portugol que recebe x números , e depois faz a media dos mesmos ( e quando quiser parar e receber a media a pessoa digita -1) Eu fiz praticamente todo , ta tudo correto , só não consigo fazer com q os valores que a pessoa coloca vão se somando... eu tentei colocar: valores <- valores+valores para ele pegar o valor q a pessoa colocou e somar com o valor novo ... mas não sei porque quando coloco isso ele entra em looping e quando digito -1 ele n para , continua pedindo pra digitar os valores... Não sei se entenderam oque quis dizer , mas preciso q o algoritmo receba um valor , guarde esse valor na variável "valores" depois quando for repetir o laço pela segunda vez ele pegue esse valor armazenado e some com o valor novo e assim sucessivamente , o problema e q eu não sei quantos valores a pessoa vai por é infinito ... por isso não posso por simplesmente n1+n2 , é um variável com outra variável... espero que possam me ajudar. meu código ficou assim : Algoritmo "Valores e Média" // Linguagem e Lógica de Programação // // Descrição : Recebe x valores e calcula a média // Autor(a) : Wellington Capoia // Data atual : 20/4/2016 Var // Seção de Declarações das variáveis media, valores, cont, resultado, valoressomados: real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... cont <- 0 valores <- 0 escreval ("Algoritmo para receber um numero x de valores e calcular média") escreval ("Para para calcular a média digite -1 a qualquer momento") enquanto valores <> -1 faca escreval ("Digite os valores:") leia (valores) valores <- valores+valores cont <- cont+1 fimenquanto escreval ("valores somados", valoressomados) cont <- cont-1 escreval ("Valores digitados:", cont) resultado <- valoressomados/cont escreval ("A média dos valores é:", resultado) Fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.