Jump to content

Search the Community

Showing results for tags 'vetor'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 59 results

  1. Ao sair de um procedimento e entrar em outro, ta apresentando erro quando tento finalizar o programa. Var // Seção de Declarações das variáveis nome: vetor [1..3] de caractere telef: vetor [1..3] de caractere ema: vetor [1..3] de caractere codigo,codigo_contato,codigo_contato_cheio, menu_apagar,opc, opc1: inteiro cont, menu_mostrar,op: inteiro procedimento principal() Inicio // Seção de Comandos, procedimento, funções, operadores, etc... repita escreval ("") escreval ("=== AGENDA TELEFÔNICA ===") escreval ("") escreval ("1. Inserir novo contato") escreval ("2. Apagar contato") escreval ("3. Mostrar todos os contatos") escreval ("4. Sair") escreva ("Digite opcao: ") leia (codigo) limpatela ate (codigo=1) ou (codigo=2) ou (codigo=3) ou (codigo=4) escolha (codigo) caso 1 contato() caso 2 apagar() caso 3 mostrar() caso 4 interrompa fimescolha fimprocedimento //---------------------- NOVO CONTATO ---------------------- procedimento contato() inicio para cont de 1 ate 3 faca limpatela escreval("== INSERIR NOVO CONTATO ==") escreva ("Nome: ") leia (nome[cont]) escreva ("Telefone: ") leia (telef[cont]) escreva ("E-mail: ") leia (ema[cont]) escreval("") escreval("Usuario cadrastrado com sucesso") repita escreval("") escreval("1.Insira novo contato") escreval("2.Voltar ao menu") escreval("") escreva("Digite opção: ") leia(codigo_contato) escolha (codigo_contato) caso 1 escreva("") caso 2 interrompa limpatela principal() outrocaso escreval("") escreval("Opção invalida") escreval("") escreval("Pressione ENTER para voltar") leia(op) limpatela fimescolha ate codigo_contato = 1 fimpara limpatela escreval("") escreval("Lista de contato cheia") repita escreval("") escreval("1.Voltar ao menu") escreval("2.Sair") escreval("") escreval("Digite opção") leia(codigo_contato_cheio) escolha (codigo_contato_cheio) caso 1 limpatela principal() caso 2 interrompa outrocaso escreval("") escreval("Opção invalida") escreval("") escreval("Pressione ENTER para voltar") leia(op) limpatela fimescolha ate codigo_contato_cheio = 1 fimprocedimento //------------------------ Apagar contato------------------------------------ procedimento apagar() inicio limpatela escreval("== APAGAR CONTATO ==") Escreval("") escreva ("Qual contato você quer apagar? ") Escreval("") para cont de 1 ate 3 faca Escreval(cont,". ",nome[cont]) fimpara Escreval("") Escreva("Digite opção:") Leia(opc) se opc >0 entao se opc <4 entao nome[opc]<-"" telef[opc]<-"" ema[opc]<-"" Escreval("") Escreval("Contato Apagado com sucesso") repita escreval("") escreval("1.Apagar outro contato") escreval("2.Voltar ao menu") escreval("3.Sair") escreva("Digite opção:") leia(menu_apagar) Escolha(menu_apagar) caso 1 limpatela apagar() caso 2 limpatela principal() caso3 interrompa outrocaso escreval("") escreval("Opção invalida") escreval("") escreval("Pressione ENTER para voltar") leia(op) senao apagar() fimse fimse fimse fimescolha ate menu_apagar = 3 fimprocedimento //-------------------------- Mostrar todos os contatos --------------------- procedimento mostrar() inicio limpatela escreval("== LISTA DE CONTATOS ==") Escreval("") para cont de 1 ate 3 faca Escreval(cont,". ",nome[cont]) fimpara Escreval("") Escreva("Digite opção:") Leia(opc1) se opc1 >0 entao se opc1 <4 entao limpatela Escreval("Nome: ",nome[opc1]) Escreval("Telefone: ",telef[opc1]) Escreval("E-mail: ",ema[opc1]) repita escreval("") escreval("1.Mostrar outro contato") escreval("2.Voltar ao menu") escreval("") escreva("Digite opção:") Leia(menu_mostrar) Escolha(menu_mostrar) caso 1 limpatela mostrar() caso 2 limpatela principal() outrocaso escreval("") escreval("Opção invalida") escreval("") escreval("Pressione ENTER para voltar") leia(op) senao mostrar() fimse fimse fimescolha limpatela ate menu_mostrar = 1 fimprocedimento inicio // Seção de Comandos principal() Fimalgoritmo
  2. /* Desenvolver um programa para realizar a correção de um prova de múltipla escolha. Os dados iniciais a serem lidos são: - A quantidade de candidatos (N) e - A quantidade de questões aplicadas (M). As respostas possíveis que poderão ser aceitas são: A, B, C, D e E. O primeiro conjunto de dados a ser lido será o gabarito com as respostas corretas das M questões. Após o gabarito, serão lidos os nomes as respostas de cada candidato. Os valores das questões são iguais. A nota máxima é 10 e a de classificação é 5. As estruturas que deverão ser utilizadas são: O programa deverá: a) Gerar o vetor NOTA; b) Apresentar o relatório geral contendo o nome do candidato e sua nota; c) Calcular e apresentar a média geral dos candidatos; d) Apresentar a quantidade e o percentual de classificados e desclassificados; e) Apresentar o relatório de candidatos classificados; f) Apresentar a melhor nota obtida e seu(s) respectivo(s) candidato(s); g) Gerar o vetor ACERTOS com o percentual correspondente e apresentá-lo. */ #include <iostream> using namespace std; // torna desnecessária o uso do comando standard (std) antes das variáveis main() { setlocale(LC_ALL,"Portuguese"); int M[2][2],l, c, nota=0, soma=0, media=0, i=0, j=0; string nome[j]; cout<<"Digite seu nome"<<endl; cin>>nome[j]; for(l=0;l<2;l++) { for (c=0;c<2;c++) { cout<<"["<<l<<"]["<<c<<"] : "; cin>>M[l][c]; } } for (l=0;l<2;l++) { for (c=0;c<2;c++) { cout<<M[l][c]<<" "; } cout<<endl; } cout<<"Matriz A "<<" Vetor B "<<endl; for (l=0;l<2;l++) { soma=0; for (c=0;c<2;c++) { cout<<M[l][c]<<" | "; soma=soma+M[l][c]; media=soma/3; } cout<<" = "<<media<<endl; } cout<<"Somatório da colunas: "<<endl; for (c=0;c<2;c++) { soma=0; for (l=0;l<2;l++) { soma=soma+M[l][c]; } cout<<soma<<endl; } cout<<"Somatório da Diagonal: "<<endl; for (l=0;l<2;l++) { soma=0; for (l=0;l<2;l++) { soma=soma+M[l][l]; } cout<<soma<<endl; } } A pergunta é, como imprimir os nomes na coluna 0 e linhas de 1 a 5 e como fazer para que as respostas possíveis que poderão ser aceitas sejam: A, B, C, D e E?
  3. Thurcos

    Vetor para Imagem (Photoshop)

    Opa, tudo bem ? sou novo aqui e comecei a usar o Illustrator e o Photoshop para um projeto, acontece que ao criar o logo no Illustrator quando eu pego o logo selecionado no illustrator e mando para PS ele simplesmente perde muito a qualidade, o que posso fazer para solucionar o problema ? ps: o problema só acontece quando eu diminuo o tamanho do vetor/imagem no Photoshop, quando eu aumento a resolução ela é excelente, mas no caso eu preciso deixar o logo de canto 1º imagem : com o simbolo de canto o qualidade esta ruim 2º imagem : o pouco de zoom que eu dou ela já fica totalmente ilegível 3º imagem : eu aumentando ela fica legível 4º imagem: ela no Illustrator sei que um vetor não tem pixel e não é uma imagem, mas tem como eu usar a resolução boa do Illustrator no PS ? se eu crio um arquivo no Illustrator o tamanho que eu crio ele interfere quando mando pro Photoshop ? ps: eu não salvei como imagem nem nada eu apenas selecionei o vetor a arrastei para o Photoshop
  4. Numa cidade as crianças costumam brincar com um jogo (de dois jogadores) onde: um jogador A define uma sequência de 10 letras usando: G, R e B (exemplo: G – G – G – R – B – R – B – B – B – R) um jogador B pode ler a sequência quantas vezes quiser o jogador B também pode dizer uma das letras e obter em quais posições a letra dada se encontra na sequência o jogador B também pode dar uma posição e saber qual letra ocupa a posição na sequência para finalizar, o jogador B deve dizer a sequência de letras, obtendo um ponto para cada acerto. Só consegui pensar nisso por enquanto. //identificar que letra ocupa esta posição na sequência: do{ scanf(“%d”,&Posicao); Posicao=Posicao-1;} while ((Posicao<0)||(Posicao>9)); printf(“%c”,Sequencia[Posicao]); //exibir sequencia for (Cont=0; Cont<=9; Cont++) printf(“%c”,Sequencia[Cont]); //exibir posições for (Cont=0; Cont<=9; Cont++) printf(“%d%c”,Cont+1,Sequencia[Cont]);
  5. anderx

    Imprimir somente números

    Prezados, boa tarde. Eu estou fazendo um programa em C que o usuário digite uma sequencia de caracteres e imprima somente valores numéricos e também mostrar os seus respectivos valores correspondentes a tabela ASC. Eu utilizei dois vetores , um para receber os caracteres e um outro para copiar apenas os valores numéricos, mas eu não estou conseguindo transferir somente os valor numéricos para o outro vetor. Alguém tem alguma dica de como posso transferir somete os números ? O código abaixo: #include <stdio.h> #include <string.h> int main () { char str1[30] ={0}; int str2[30]; int i=0; scanf ("%s",str1); for(i=0; i<strlen(str1);i++) { str1*=1; str2=str1; printf("%c : : %d\n",str2,str2); } return 0; }
  6. Boa tarde pessoal, estou tendo muita dificuldade para criar um algoritmo que eu entre com um numero de 0 a 100 e ele me informe quantos números pares tem no intervalo do numero que digitei até 0 e caso o numero digitado for maior que 100 ele solicite que seja digitado o numero de 0 a 100 novamente.
  7. alecram28

    Algoritmo jogo lotérico

    Boa tarde. Tenho o seguinte exercício para fazer em Java: Escreva um algoritmo para jogo lotérico. O usuário deve informar sua aposta através de 5 números inteiros no intervalo de 1 a 100. No servidor, os números da aposta devem ser armazenados em um vetor. O vetor da aposta não pode conter números repetidos. O algoritmo deve realizar o sorteio, gerando 5 números aleatoriamente no intervalo de 1 a 100. Os números sorteados também devem ser armazenados em um vetor. O vetor do sorteio não pode conter números repetidos. Se o usuário acertar menos de 3 números, ele ganha 0% da premiação. Se o usuário acertar 3 números, ele ganha 50% da premiação. Se o usuário acertar 4 números, ele ganha 75% da premiação. Se o usuário acertar os 5 números, ele ganha 100% da premiação. Na interface, o algoritmo deve informar: a. O valor da premiação. b. O vetor da aposta. c. O vetor do sorteio. d. O valor do prêmio recebido pelo usuário. Gostaria de ajuda para como posso verificar os valores iguais entre os vetores (verificar se a pessoa acertou algum numero) Obrigado!
  8. Boa noite pessoal, Sou novo aqui no fórum, então um Oi para todos. Sou novo na programação e estou com um exercício que está difícil de resolver. Uso VisualG para testar. Preciso inserir uma palavra e apresentar como saída a inversão de duas em duas letras. Exemplo: digitar a palavra EXEMPLO e ter como saída: XEMELPO, inclusive quando a palavra tiver um número ímpar de letras a última não modifica. Já tentei alguma coisa, mas não sei se uso vetor mesmo, em todos os exemplos de inversão de palavras o vetor é usado. Alguém pode me dar uma luz? Segue o código: algoritmo "semnome" // Função : // Autor : // Data : 26/10/2018 // Seção de Declarações var palavra: caracter vet: vetor [1..30] de caracter tamanho: inteiro i: inteiro inicio escreva ("Digite uma palavra: ") leia (palavra) tamanho <- compr (palavra) escreva ("A palavra tem ", tamanho, " letras.") para i de 1 ate tamanho faca se ((i mod 2) = 0) entao vet <- vet [i+1] fimse palavra <- vet fimpara escreva ("A palavra agora é ", palavra) fimalgoritmo Obrigado desde já.
  9. Sejam bem vindos em uma serie de Cursos de FreeCAD! Curso em andamento, onde vamos abordar todas as funcões do FreeCAD na linguagem português Brasil. Segue abaixo o link de nossa PlayList no youtube, onde contém todas nossas aulas do curso: Aguardamos a presença de todos vcs, comentem e curtam nossos videos, isso ajuda nosso canal.
  10. Escreva um programa que receba a data de nascimento (dia, mês e ano) e o nome de um número n de pessoas (n deve ser informado pelo usuário). Para cada data de nascimento lida determine a diferença de idade entre você e a pessoa, exiba uma mensagem informando se ela é mais velha ou mais nova que você, e exiba a diferença de idade no formato ano:meses:dias. Por fim, exiba os nomes e as idades em ordem crescente, do mais novo para o mais velho, incluindo você
  11. Programador Legal Olha Só

    Ajuda Algoritmo C++ URGENTE!!!

    Escreva um algoritmo que leia 6 números e os armazene em um vetor. Utilize a função rand para gerar 6 números aleatórios que sejam armazenados em um vetor Compare os dois vetores e informe ao usuário se ele acertou ou nao os numeros Os números digitados podem ser de 1 a 60, assim como os números gerados. Utilize funções para cada algoritmo de seu programa.
  12. Olá, amigos, eu me chamo Daniel e sou aluno de ADS, vamos direto ao ponto, eu gostaria de saber como eu faço para rodar esse programa novamente, resetar as informações anteriores e rodar o programa como se fosse a primeira vez (não sei se estou sendo claro o suficiente) , eu já tentei colocar o comando "system ("cls")" em várias partes do código, mas não está resolvendo, não sei mais o que fazer, agradeço a sua ajuda. Obrigado. #include <iostream> #include <stdlib.h> using namespace std; char matriz[3][3] = {'1','2','3','4','5','6','7','8','9'}; int n; char jog = 'X'; char sair = 's'; bool s = true; void Jogo(){ system("cls"); cout << "\n JOGO DA VELHA\n\n"; for (int a=0;a<3;a++){ cout << "\t"; for (int j=0;j<3;j++){ cout << matriz[a][j]<< " "; } cout << "\n"; } cout << "\n"; } void Entrada(){ int p; cout << "Digite um numero: "; cin >> p; if (p==1){ if(matriz[0][0] == '1'){ matriz[0][0] = jog; } else{ cout << "\nJogada invalida! Tente novamente.\n\n"; Entrada(); } } else if(p==2){ if(matriz[0][1] == '2'){ matriz[0][1] = jog; } else{ cout << "\nJogada invalida! Tente novamente.\n\n"; Entrada(); } } else if(p==3){ if(matriz[0][2] == '3'){ matriz[0][2] = jog; } else{ cout << "\nJogada invalida! Tente novamente.\n\n"; Entrada(); } } else if(p==4){ if(matriz[1][0] == '4'){ matriz[1][0] = jog; } else{ cout << "\nJogada invalida! Tente novamente.\n\n"; Entrada(); } } else if(p==5){ if(matriz[1][1] == '5'){ matriz[1][1] = jog; } else{ cout << "\nJogada invalida! Tente novamente.\n\n"; Entrada(); } } else if(p==6){ if(matriz[1][2] == '6'){ matriz[1][2] = jog; } else{ cout << "\nJogada invalida! Tente novamente.\n\n"; Entrada(); } } else if(p==7){ if(matriz[2][0] == '7'){ matriz[2][0] = jog; } else{ cout << "\nJogada invalida! Tente novamente.\n\n"; Entrada(); } } else if(p==8){ if(matriz[2][1] == '8'){ matriz[2][1] = jog; } else{ cout << "\nJogada invalida! Tente novamente.\n\n"; Entrada(); } } else if(p==9){ if(matriz[2][2] == '9'){ matriz[2][2] = jog; } else{ cout << "\nJogada invalida! Tente novamente.\n\n"; Entrada(); } } } void Alterna(){ if (jog == 'X') jog = 'O'; else{ jog = 'X'; } } char Vencedor(){ // Jogador 1 if (matriz[0][0] == 'X' && matriz[0][1] == 'X' && matriz[0][2] == 'X') return 'X'; if (matriz[1][0] == 'X' && matriz[1][1] == 'X' && matriz[1][2] == 'X') return 'X'; if (matriz[2][0] == 'X' && matriz[2][1] == 'X' && matriz[2][2] == 'X') return 'X'; if (matriz[0][0] == 'X' && matriz[1][0] == 'X' && matriz[2][0] == 'X') return 'X'; if (matriz[0][1] == 'X' && matriz[1][1] == 'X' && matriz[2][1] == 'X') return 'X'; if (matriz[0][2] == 'X' && matriz[1][2] == 'X' && matriz[2][2] == 'X') return 'X'; if (matriz[0][0] == 'X' && matriz[1][1] == 'X' && matriz[2][2] == 'X') return 'X'; if (matriz[0][2] == 'X' && matriz[1][1] == 'X' && matriz[2][0] == 'X') return 'X'; //Jogador2 if (matriz[0][0] == 'O' && matriz[0][1] == 'O' && matriz[0][2] == 'O') return 'O'; if (matriz[1][0] == 'O' && matriz[1][1] == 'O' && matriz[1][2] == 'O') return 'O'; if (matriz[2][0] == 'O' && matriz[2][1] == 'O' && matriz[2][2] == 'O') return 'O'; if (matriz[0][0] == 'O' && matriz[1][0] == 'O' && matriz[2][0] == 'O') return 'O'; if (matriz[0][1] == 'O' && matriz[1][1] == 'O' && matriz[2][1] == 'O') return 'O'; if (matriz[0][2] == 'O' && matriz[1][2] == 'O' && matriz[2][2] == 'O') return 'O'; if (matriz[0][0] == 'O' && matriz[1][1] == 'O' && matriz[2][2] == 'O') return 'O'; if (matriz[0][2] == 'O' && matriz[1][1] == 'O' && matriz[2][0] == 'O') return 'O'; return 'e'; } int main(){ while (s == true){ Jogo();; while (true){ n++; Entrada(); Alterna(); Jogo(); if (Vencedor() == 'X'){ cout << "Jogador X Venceu!\n\n"; break; } else if(Vencedor() == 'O'){ cout << "Jogador O Venceu!\n\n"; break; } else if(Vencedor() == 'e' && n == 9){ cout << "Deu empate!\n\n"; break; } } cout << "Jogar novamente?\n(s/n): "; cin >> sair; if(sair == 's' || sair == 'S'){ s = true; } else if(sair == 'n' || sair == 'N'){ s = false; break; } } system("pause"); }
  13. Manu Oliveira

    Vetor x Struct

    Vetor é um conjunto de variáveis subordinadas a um único nome e struct também é um conjunto de variáveis subordinadas a um único nome. Meu professor pediu para diferencia -las. mais estou com dificuldade.
  14. Eae Galera Tenho o Array $vetor[0]['codigo'] = '1'; $vetor[0]['valor'] = '4'; $vetor[1]['codigo'] = '1'; $vetor[1]['valor'] = '2'; $vetor[2]['codigo'] = '2'; $vetor[2]['valor'] = '2'; Ai eu precisava que jutasse todos os valores com codigos iguais. Fazendo o exemplo acima ficar assim. O codigo 1 ficar com valor 6 E o codigo 2 ficar com valor 2 Alguem tem ideia de como fazer isso????
  15. Bom dia, Estou necessitando de ajuda em um problema que tenho que resolver urgente. Os números de Fibonacci constituem uma sequência de números na qual os dois primeiros elementos são 0 e 1, e os demais, a soma dos dois elementos imediatamente anteriores na sequência. Como exemplo, a sequência formada pelos 10 primeiros números de Fibonacci é: 0, 1, 1, 2, 3, 5, 8, 13, 21, 34. Faça um programa em C para calcular e imprimir os 20 primeiros números da série. eu pensei em por em um vetor e somar a posição anterior com a atual, mas tudo que faço não esta dando certo alguém pode me ajudar? obs: pensei em ponteiro mas não manjo de ponteiro.
  16. Boa Tarde Pessoal Estou fazendo esse programa q pede 10 numeros e troca os 5 primeiros pelos 5 ultimos e vice versa,so que toda vez mudo os 5 numeros das ultimas posições para frente as primeiras posições não entram nas ultimas posições do array,por isso gostaria de saber o que estou fazendo de errado. /* necessita de uma solução que a partir da alimentação de um vetor com 10 valores reais, após, desenvolva uma rotina de programa que troque os 5 primeiros valores pelos 5 últimos e vice-e-versa. Ao final deste processo, imprima o vetor obtido, ou seja todos valores contidos no vetor após a troca. */ package Vetores; import javax.swing.JOptionPane; public class Exercicio3 { public static void main(String[] args) { int valores[]=new int [10]; int valoresA[]=new int [10]; int valoresB[]=new int [10]; int p=0; for (int i=0; i<5; i++) { p++; valoresA=Integer.parseInt(JOptionPane.showInputDialog("Informe um numero para a posição "+p)); } for (int i=0; i<5; i++) { p++; valoresB=Integer.parseInt(JOptionPane.showInputDialog("Informe um numero para a posição "+p)); } for(int i=0; i<5; i++){ valores=valoresB; } for(int i=5; i<10; i++){ valores=valoresA; } for (int i=0; i<10; i++) { System.out.print(valores); } } }
  17. Meu código esta assim: programa { //variavel global inteiro matriz[3][3] funcao logico repetiu(inteiro n, inteiro lin, inteiro col){ para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(nao(l == lin e c == col)){ se(matriz[l][c] == n){ retorne verdadeiro } } } } retorne falso } funcao inicio(){ //receber a matriz para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ leia(matriz[l][c]) } } para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(repetiu(matriz[l][c], l, c)) escreva(matriz[l][c], " - ") } } } }
  18. O QUE CONSEGUIR FAZER ATÉ O MOMENTO FOI ISSO programa { //variavel global inteiro matriz[3][3] funcao logico repetiu(inteiro n, inteiro lin, inteiro col){ para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(nao(l == lin e c == col)){ se(matriz[l][c] == n){ retorne verdadeiro } } } } retorne falso } funcao inicio(){ //receber a matriz para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ leia(matriz[l][c]) } } para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(repetiu(matriz[l][c], l, c)) escreva(matriz[l][c], " - ") } } } }
  19. GabrielSI19

    Mudar posições de um vetor

    Boa tarde, estou fazendo um algorítimo mas ele não roda 100% da maneira que devia. Leia um vetor de 20 posições e o compacte, ou seja, elimine as posições com valor zero avançando uma posição com os valores subsequentes do vetor. Dessa forma, todos os "zeros" devem ficar para o final do vetor. O que acontece é que se eu digitar apenas um índice de valor 0 ele é enviado para o final do vetor, porém se houverem mais de dois índices com o valor 0, o primeiro toma a posição final do vetor mas os outros continuam no mesmo lugar. Alguém pode me ajudar?? #include <iostream> #include <stdlib.h> #include <math.h> #include <locale.h> #include <stdio.h> #include <string.h> int main (void) { setlocale(LC_ALL,"Portuguese"); int vet[20]; int i,aux; for(i=0;i<20;i++) //entrada de dados { printf("Digite o valor da posição %d do vetor: ",i); scanf("%d",&vet[i]); } for(i=0;i<20;i++) //operação realizada { if(vet[i]==0) { aux=vet[i]; vet[i]=vet[i+1]; vet[i+1]=aux; } } for(i=0;i<20;i++){ printf("VetorFinal [%d] = %d\n",i,vet[i]); } }
  20. Doguinho programador

    alguem capaz de responder exercicio de matriz

    Será dado a você uma matriz de tamanho NxM, inicialmente contendo o n ́umero 0 em cada uma das posições, e Q operacoes a serem realizadas sobre essa matriz. Cada operacao é composta de 5 numeros inteiros X1, Y1, X2, Y2 e K, onde (X1, Y1) indicam o canto superior esquerdo e (X2, Y2) o canto inferior direito do retangulo definido por esse par de pontos. O ultimo dos 5 inteiros,representado pelo inteiro K, indica a cor que deverá ser usada para pintar o retangulo dado naquela operacao. Sua tarefa é, dadas Q operacoes (Q retangulos), imprimir a matriz resultante depois de todas elas. Entrada: A primeira linha da entrada possui dois inteiros N, M e Q, indicando as dimensoes da matriz e o numero de opera ̧coes. Depois, haverão Q linhas, contendo os 5 inteiros X1, Y1, X2, Y2 e K que representam as bordas do retangulo e a cor com a qual ele deve ser pintado, como indicado acima. Saıda: A saıda deve conter N linhas com M inteiros cada separados por um espaco em branco, representando a matriz apos a realizacao de todas as operacoes Exemplos Entrada 3 3 2 0 0 1 1 4 2 0 2 1 8 Saıda 4 4 0 4 4 0 8 8 0 Entrada 2 3 3 0 0 1 1 6 0 2 0 2 1 1 0 1 1 5 Sa ́ıda 6 6 1 5 5 0 Segue algoritmo que consegui até agora, mas ainda assim, não consigo entender como sobrescrever e pintar a matriz...
  21. Preciso de ajuda em um programa que receba do usuário a dimensão de um vetor (no máximo 20), receba os elementos desse vetor e efetue a sua ordenação utilizando o bubble-sort.
  22. Boa noite a todos. Estou com uma atividade no qual necessito informar se a matriz é simétrica ou não com base nos valores digitados pelo usuário. O meu código está meio caminho andado. Uma matriz simétrica é a matriz na qual os valores abaixo da diagonal principal são iguais os valores acima da diagonal principal. Logo pensei, se (i < j) valores acima da diagonal e (i > j) valores abaixo da diagonal. Fiz os testes em um FOR, onde se as condições atenderem os requisitos os valores seriam armazenados em vetores distintos, um vetor para valores acima da diagonal e outro vetor para valores abaixo. Depois eu ia comprar os dois vetores para ver se os valores são iguais mas me deparei com um erro de lógica. Vou postar o código e comentar o erro. #define TAM 3 #include <stdio.h> #include <stdlib.h> #include <locale.h> void receberMatriz(int matriz[TAM][TAM]); void acimaDiagonal(int matriz[TAM][TAM], int acimaD[TAM]); void abaixoDiagonal(int matriz[TAM][TAM], int abaixoD[TAM]); void TesteValorVetor(int matriz[TAM][TAM], int acimaD[TAM], int abaixoD[TAM]); int main(void) { setlocale(LC_ALL, ""); int matriz[TAM][TAM] = {0}; int abaixoD[TAM] = {0}; int acimaD[TAM] = {0}; receberMatriz(matriz); acimaDiagonal(matriz, acimaD); abaixoDiagonal(matriz, abaixoD); TesteValorVetor(matriz, acimaD, abaixoD); return 0; } void receberMatriz(int matriz[TAM][TAM]) { int i, j; for(i = 0; i < TAM; i++) { for(j = 0; j < TAM; j++) { printf("Insira valor pos. [%i][%i]: ", i, j); scanf("%i", &matriz[i][j]); } } } void acimaDiagonal(int matriz[TAM][TAM], int acimaD[TAM]) { int i, j; for(i = 0; i < TAM; i++) { for(j = 0; j < TAM; j++) { if(i < j) { acimaD[j] = matriz[i][j]; } } } } void abaixoDiagonal(int matriz[TAM][TAM], int abaixoD[TAM]) { int i, j; for(i = 0; i < TAM; i++) { for(j = 0; j < TAM; j++) { if(i > j) { abaixoD[j] = matriz[i][j]; } } } } void TesteValorVetor(int matriz[TAM][TAM], int acimaD[TAM], int abaixoD[TAM]) { int i, j; system("cls"); for(i = 0; i < TAM; i++) { for(j = 0; j < TAM; j++) { printf("[%i] ", matriz[i][j]); } printf("\n"); } printf("\n"); for(i = 0; i < TAM; i++) { printf("[%i]", acimaD[i]); } printf("\n"); for(i = 0; i < TAM; i++) { printf("[%i]", abaixoD[i]); } } Nas funções: void acimaDiagonal(int matriz[TAM][TAM], int acimaD[TAM]) { int i, j; for(i = 0; i < TAM; i++) { for(j = 0; j < TAM; j++) { if(i < j) { acimaD[j] = matriz[i][j]; } } } } void abaixoDiagonal(int matriz[TAM][TAM], int abaixoD[TAM]) { int i, j; for(i = 0; i < TAM; i++) { for(j = 0; j < TAM; j++) { if(i > j) { abaixoD[j] = matriz[i][j]; } } } } Eu faço a verificação (i < j), acima do diagonal e vise-versa e então armazeno em um vetor. Quando mando mostrar o vetor para ver quais valores tenho lá. Supondo que eu coloque 1, 2, 3, 4, 5, 6, 7, 8, 9... Os valores deveriam ser para o primeiro vetor: [2][3][6] referente aos valores acima da diagonal principal. E [4][7][8] valores abaixo da diagonal principal... Mas ao invés disso o código está me retornando o seguinte: [0][2][6] e [7][8][0]... Ou seja, não está atribuindo alguns valores. A11, A12, A13 A21, A22, A23 A31, A32, A33 Eu identifiquei um erro, na primeira função void acimaDiagonal() quando ele faz a primeira verificação no A11, como a condição se só atribui se for i < j, na primeira casa do primeiro vetor ele ignora qualquer alteração deixando o [0]... Como posso corrigir isso? Fui claro na minha dúvida?
  23. Boa noite a todos. Estou preso em na seguinte questão: Dada uma matriz de 4 x 5 elementos inteiros, calcular a soma de cada linha, de cada coluna e de todos os seus elementos. Obs: Utilize um vetor para armazenar o resultado da soma de cada linha e outro para a soma de cada coluna. Então o programa pede o seguinte: 12345 = [15] 67890 = [30] 98765 = [35] 43212 = [12] Armazenar a soma de cada linha da matriz em um vetor: VetorLinha[4] onde = [15], [30], [35], [12] estariam armazenados, assim como vetorColuna com seus respectivos valores Eis o meu código: #include <stdio.h> #include <stdlib.h> #include <locale.h> void receberMatriz(int matriz[4][5]); void processarMatriz(int matriz[4][5], int vetorA[5], int vetorB[4]); void resultadoMatriz(int matriz[4][5], int vetorA[5], int vetorB[4]); int main(void) { setlocale(LC_ALL, ""); int matriz[4][5]; int vetorA[5]; int vetorB[4]; receberMatriz(matriz); processarMatriz(matriz, vetorA, vetorB); resultadoMatriz(matriz, vetorA, vetorB); return 0; } void receberMatriz(int matriz[4][5]) { int i, j; for(i = 0; i < 4; i++) { for(j = 0; j < 5; j++) { printf("Insira valor posição [%i][%i]: ", i, j); scanf("%i", &matriz[i][j]); } } } void processarMatriz(int matriz[4][5], int vetorA[5], int vetorB[4]) { int i, j; for(i = 0; i < 4; i++) { for(j = 0; j < 5; j++) { vetorA[j] = matriz[i][j]; soma = soma + vetorA[j]; vetorA[j] = soma; } } for(j = 0; j < 5; j++) { for(i = 0; i < 4; i++) { vetorB[i] = matriz[j][i]; soma = soma + vetorB[i]; vetorB[i] = soma; } } } void resultadoMatriz(int matriz[4][5], int vetorA[5], int vetorB[4]) { int i, j; } Claramente eu não alcancei a lógica e queria entender como eu faria esse algoritmo. Não sei o que devo fazer para concluir com êxito nessa parte do código: void processarMatriz(int matriz[4][5], int vetorA[5], int vetorB[4]) { int i, j; for(i = 0; i < 4; i++) { for(j = 0; j < 5; j++) { vetorA[j] = matriz[i][j]; soma = soma + vetorA[j]; vetorA[j] = soma; } } for(j = 0; j < 5; j++) { for(i = 0; i < 4; i++) { vetorB[i] = matriz[j][i]; soma = soma + vetorB[i]; vetorB[i] = soma; } } }
  24. Bom dia/tarde/noite. Preciso de completa ajuda em um exercício de c++. Agradeço. Escreva um programa que leia (aleatoriamente 0-100) um vetor A de 10 elementos e escreva todos que estejam entre 15 a 45 deste vetor.
  25. Boa Noite gente! Preciso criar uma função que dado um vetor v de tamanho n, consigo armazenar cada valor do vetor em uma lista simplesmente encadeada, de forma que cada valor fique em um no da lista, e a função retorne essa lista. Porém não estou conseguindo. Desde já agradeço.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.