Jump to content

Search the Community

Showing results for tags 'Visualg'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 100 results

  1. Olá, sou nova na programação e ainda estou trabalhando só com o visualg. Então relevem qualquer coisa, por favor. Bom... Meu professor pediu para fazermos um programa no visualg que escrevesse de 0 até 100 por extenso. Tem algumas restrições só podemos usar: Se; fimse; Escreva; leia; <- •Não pode usar vetores e isso complicou muito. •Não pode ser (todo) assim: se (numero=45) enato escreva("Quarenta e cinco"), porque isso ia gastar muitas linhas. Ele deu uma dica de como fazer: Var: Unidaden: inteiro Unidadec: caractere Dezena: caractere Numero: inteiro Inicio: escreva ("Digite um número e tecle enter: ) leia (numero) Se (numero>20) e (numero<30) entao escreva ("Vinte e ", ???)
  2. Olá, gostaria que vocês pudessem me ajudar a desenvolver e com resolução esses exercícios aqui, estou quebrando a cabeça e não consigo chegar em nadaaa, obrigado!!! Primeiro exercício 1-Leia um valor inteiro entre 1000 e 9999 e verifique se o número formado apenas pelos algarismos que estão nas casas das unidades de milhar e das centenas é ou não múltiplo de 4. Segundo " " 2- Numa loja de eletrodomésticos, o vendedor encarregado da seção de televisores recebe, mensalmente, um salário fixo mais comissão. Esta comissão é calculada em relação ao tipo e a quantidade de televisores vendidos por mês, obedecendo a seguinte tabela: Sobre o seu salário fixo há um desconto de 10% referente ao INSS. Caso o seu salário bruto exceda a R$ 1500,00 haverá desconto de imposto de renda, conforme a segunda a tabela ao lado, aplicada sobre o valor excedente a R$ 1500,00. Calcule: a comissão do funcionário, o salário bruto, os valores de cada desconto, o total dos descontos e o salário líquido. Terceiro " " Escreva um algoritmo que leia o valor de 3 ângulos de um triângulo e escreva se o triângulo é retângulo, obtusângulo ou acutângulo. A saber, o triângulo retângulo possui um ângulo reto, o triângulo obtusângulo possui um ângulo obtuso, e o triângulo acutângulo possui 3 ângulos agudos. Quarto No Campeonato Mundial de Cross Fit o atleta deve pesar entre 65 Kg (inclusive) e 100 Kg (inclusive) e medir de 1,70 m (inclusive) a 1,95 m (inclusive). Escrever um algoritmo para ler a altura e o peso de um jogador e determinar se o jogador está apto a participar do campeonato, escrevendo a mensagem correta, conforme a situação: • ACEITO (se a altura e o peso do jogador estiverem dentro da faixa especificada) • TOTALMENTE RECUSADO (se a altura e o peso do jogador forem inválidos) • RECUSADO POR ALTURA (se somente a altura do jogador for inválida) • RECUSADO POR PESO (se somente o peso do jogador for inválido)
  3. Gente alguém pode me da uma luz nesse algoritmo? como eu resolvo isso pelo menos? Tentei utilizar o comando arquivo <> no visualg, mas não da certo. Você decidiu comprar um carro e para ajudar na sua decisão, você resolveu desenvolver um código que mostre ao final qual é o menor custo ao final de ano para cada modelo escolhido baseado no custo total de compra do carro, custo com impostos, custo com combustível (considerando o consumo médio de cada veículo e um total estimado de 10.000 Km rodados no ano e o valor de médio R$ 3,98 para o litro de combustível) e custos com seguro. Como dados de entrada você pode criar um arquivo que contenha as seguintes informações que serão carregadas no programa. Modelo do veículo Custo total de compra Custo total de impostos Consumo médio de combustível (Km/l) Custos com seguro Chevrolet Ônix R$36.000,00 R$1.400,00 11,8 R$1.600,00 Ford Fiesta R$32.000,00 R$1.300,00 13,5 R$1.800,00 VW Fox R$31.000,00 R$1.450,00 12,3 R$1.300,00 VW Polo R$41.000,00 R$1.600,00 13,5 R$1.500,00 Hyundai HB20 R$40.000,00 R$1.200,00 11,6 R$1.200,00 Renault Sandero R$30.000,00 R$1.300,00 12,8 R$1.900,00 Ao final o programa deverá mostrar os dados apresentados na tabela para cada veículo e o custo total no final de um ano para cada um deles.
  4. Olá galera tudo beleza? Eu estou tentando resolver um problema no visualg, usando Portugol porém eu não sei aplicar algumas coisas que são pedidas no mesmo. Problema: Dado um número, informar se é par ou ímpar. Se for par somar 5 no número informado e se for ímpar multiplicar por 3 o número informado. Eu fiz a parte em que ele fala se o número e par ou ímpar, mas não sei fazer a parte da soma e a multiplicação alguém pode me ajudar? ALGORITMO: Var n:inteiro inicio escreval("Insira um número inteiro") leia (n) se (n mod2=0) entao escreval ("O número é par") senao escreval("O número é impar") fimse Fimalgoritmo
  5. Fala galera tudo beleza? Então meu professor passou um "problema" e falou para criar um programa no Visualg usando Portugol, só que eu estou com alguns problemas principalmente na fórmula, alguém pode me ajudar? Pergunta: Dado o preço do ingresso e a idade o programa devera informar o preço do ingresso com os seguintes descontos de acordo com a idade: IDADE 0-5-15% 6-20-5% 21-40- 2% acima de 40 - 30% Se puderem me ajudar agradeço.
  6. Var // Seção de Declarações das variáveis romano:caractere subtexto :caractere i:inteiro letra1:caractere Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("Digite um número em romano para ser convertido em arábico") escreval("menor que 4000 e maior que 0") leia(romano) para i de 1 ate Compr(romano) faca subtexto <- Copia(romano,i,1) escreval(subTexto) fimpara Consegui fazer somente isso, o problema está na hora de salvar letra por letra num vetor e saber a posição de cada letra pois se for uma letra menor que a posterior subtrai-se um exemplo é o X antes de C subtrai-se 10 ficando 90 e quando o C vale 100 e quando vem antes de um número maior que ele um exemplo é D ficando 400, acho que somente a letra I, X, C, subtraem-se se estiver antes de um número maior o resto soma-se, o problema está em saber a posição da letra. Alguém tem alguma ideia? Acho que sei como finalmente fazer primeiramente eu pegaria o valor em romano digitado, pegaria o tamanho da letra valor atribuído seria n tamanho da letra e desse tamanho da letra tiraria n-1, depois tentaria dividir a letra, não sei o comando no VisualG para separar as letras e criaria um variável para armazenar o separamento dessas letras nesse caso separador criaria outra variável nesse caso s e receberia zero depois faria um para onde i =0 e i tem que ser menor que o tamanho da letra nessa e iria somando por +1 depois abriria um se verificando se a divisão da letras separador = "M" então s= s+1000 e dentro desse se abriria outro se e se se separador[i-1]= "C" então s= s-200, terminaria esse se depois abriria outro se verificando se separador = "D" então s=s+500 e dentro abriria outro se e se separador[i-1] = "C" então s=s-200 depois fecharia esse se e abriria outro se separador = "C" então s=s+100 e dentro desse se abriria outro se se separador[i-1] = "X" e então s=s-20 depois terminaria esse se e abriria outro se, se separador = "L" então s=s+50 dentro abriria outro se, se separador[i-1] = "X" então s=s-20 depois terminaria esse se e abriria outro se, se separador="X" então s=s+10 abriria outro se, se separador[i-1] = "I" então s=s-2 depois fecharia esse se depois abriria outro se, se separador="V" então s=s+5 e dentro desse se abriria outro se, se separador[i-1] = "I" então s=s-2 fecharia esse se depois abriria outro se se separador = "I" então s=s+1 depois daria um escreval(s) O problema está na hora de separar as letras qual o comando no VisualG para separar letra ou não tem? O comando copia é útil somente se separar letra por letra porém falha na hora, por exemplo de copiar um número romano, eu eu tenho que já passar esse comando com parâmetros já pré-deficinidos copie desta casa até esta casa (romano;1;2), que no não teria como colocar todos os parâmetros para todos os números de 1 a 3999
  7. Var // Seção de Declarações das variáveis romano:caractere subtexto :caractere i:inteiro letra1:caractere Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("Digite um número em romano para ser convertido em arábico") escreval("menor que 4000 e maior que 0") leia(romano) para i de 1 ate Compr(romano) faca subtexto <- Copia(romano,i,1) escreval(subTexto) fimpara Consegui fazer somente isso, o problema está na hora de salvar letra por letra num vetor e saber a posição de cada letra pois se for uma letra menor que a posterior subtrai-se um exemplo é o X antes de C subtrai-se 10 ficando 90 e quando o C vale 100 e quando vem antes de um número maior que ele um exemplo é D ficando 400, acho que somente a letra I, X, C, subtraem-se se estiver antes de um número maior o resto soma-se, o problema está em saber a posição da letra. Alguém tem alguma ideia?
  8. Var // Seção de Declarações das variáveis Fatorial,Numero,x : Inteiro Primo,Resposta : Inteiro vetorr : vetor[0..1000] de inteiro Flag : Logico Inicio // Seção de Comandos, procedimento, funções, operadores, etc... Limpatela Mudacor("Amarelo","Frente") Escreva("Deseja até que número primo: ") leia(Numero) Escreval Escreva(" 1") Para Primo de 2 ate Numero faca Fatorial<- 2 Flag <- Falso enquanto (Primo<>fatorial) faca Resposta <- Primo MOD Fatorial Fatorial <- Fatorial + 1 se Resposta = 0 entao Flag <- Verdadeiro fimse fimenquanto se (Nao Flag) entao escreva(" , ",Primo) vetorr[x] := primo x := x + 1 fimse fimpara escreval escreval escreval("O Número Primo Anterior A ",numero," é ",vetorr[x-1]) O código ficou bom mas contém um erro o número 1 não é primo e preciso otimizá-lo ainda para ficar mais eficiente gostaria de quando você múltiplo de um número já removesse da contagem e passasse para o próximo número, pois quando é múltiplo já não é mais primo pois somente precisa ter 2 divisores exatos que no caso seria o 1 e o número digitado, a e outra falha no algoritmo tem que ser um número primo anterior e caso o número digitado seja primo deve informar o número primo anterior a este digitado
  9. Var // Seção de Declarações das variáveis respostas,gabarito: vetor[1..3]caractere i,acertos, erros: inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... //Escreval("Digite a resposta") //Escreval("Digite o gabarito") para i de 1 ate 3 faca Escreval("Digite a resposta") leia(respostas[i]) se(respostas[i]<>a) e (respostas[i]<>b) e (respostas[i]<>c) e (respostas[i]<>d) Escreval("Por favor digite respostas válidas de a,b,c e d") fimse fimpara para i de 1 ate 3 faca Escreval("Digite o gabarito") leia(gabarito[i]) se(gabarito[i]<>a) e (gabarito[i]<>b) e (gabarito[i]<>c) e (gabarito[i]<>d) Escreval("Por favor digite um gabarito válido de a,b,c e d") fimse fimpara acertos<-0 para i de 1 ate 3 faca se(respostas[i] = gabarito[i]) entao acertos<-acertos+1 fimse erros<-3-acertos fimpara escreval("O número de acertos foi:",acertos) escreval("O número de erros foi:", erros) Fimalgoritmo Criei esse algoritmo porém o mesmo apresenta o erro variável RESPOSTAS[1] não foi encontrada, já tentei achar o erro e nada, o algoritmo que fiz é para pedir as respostas de a até d caso não seja informado isso irá pedir para informar esse valor no gabarito também e também conta os acertos e os erros
  10. Galera, sou novo em programação, alguem poderia me ajudar nessa nessa questão em Visual G? 1-A padaria PãoFresco vende uma certa quantidade de pães franceses e uma quantidade de biscoitos a cada dia. Cada pãozinho custa R$ 0,25 e o biscoito custa R$ 1,70. Ao final do dia, o dono quer saber quanto arrecadou com a venda dos pães e broas (separados) e o total dos 2 juntos. O dono também quer saber quanto deste valor deve guardar numa conta de poupança (sendo este 10% do total arrecadado). Com base nestas informações, desenvolva um algoritmo para ler as quantidades de pães e de biscoitos diários e calcule e imprima as seguintes informações: - Total do valor dos pães - Total do valor dos biscoitos - Total do valor dos pães e biscoitos juntos - Valor que será colocado na poupança - Valor final para o dono ( sem o valor aplicado na poupança)
  11. Rapaziada estou meio adoentado é preciso entregar uma tarefa simples amanha a noite, Preciso fazer um algorítimo em visualg que calcule o tempo gasto de saída de casa é chegada ao trabalho é mostre as horas gastas os minutos gastos é os segundos gastos. Consegui fazer ate a metade mais não estou conseguindo processar o resto. Quem poder da um tombo te agradeço muito. Fiz uma parte Var he,hs,me,ms,hora:inteiro Inicio escreva ("Digite a hora de entrada: ") leia (he) escreva ("Digite os minutos de entrada: ") leia (me) escreva("Digite a hora de saida: ") leia (hs) escreva ("Digite os minutos de saida: ") leia(ms) hora:= hs-he escreva("Passou", hora , ":horas") Fimalgoritmo
  12. guiilhermej

    Ajuda Portugol

    Galera, to com um impasse em umas questões passadas na faculdade, eu realmente gosto de resolver meus exercícios, pois só assim sei que irei aprender, mas acontece que to meio perdido nessas questões, alguem me da um help por favor. 6. Escreva um algoritmo que peça um número n ao usuário, e que gere um novo n de acordo com a seguinte regra: • se n é par, n = n / 2 • se n é impar, n = 3 * n + 1 • imprime n • O programa deve parar quando x tiver o valor igual a 1. Por exemplo, para n = 13, a saída será: 40 -> 20 -> 10 -> 5 -> 16 -> 8 -> 4 -> 2 -> 1 7. Fazer um algoritmo que leia um número que servira para controlar os primeiros números ímpares. Deverá ser impressa a soma desses números. Suponha que o número informado será maior que zero, caso não seja, informar o erro. Informe um número: 5 1 3 5 7 9 A soma dos 5 valores impares é: 25 8. Fazer um algoritmo que leia os limites inferior e superior de um intervalo e o número cujos múltiplos se deseja que sejam impressos no intervalo aberto. Suponha que os dados digitados são para um intervalo crescente. Exemplo: Valor inicial: 5 Valor final: 15 Divisor: 3 6 9 12 15 9. Fazer um algoritmo que leia a quantidade de números que se deseja digitar para que possa ser impresso o maior e o menor número digitado. Não suponha que todos os números lidos serão positivos. Exemplo: Quantos números deseja digitar? 5 Informe um numero:3 Informe um numero:-2 Informe um numero:5 Informe um numero:6 Informe um numero:19 O maior numero informado foi: 19 O menor numero informado foi: -2
  13. Boa noite pessoal, Sou novo aqui no fórum, então um Oi para todos. Sou novo na programação e estou com um exercício que está difícil de resolver. Uso VisualG para testar. Preciso inserir uma palavra e apresentar como saída a inversão de duas em duas letras. Exemplo: digitar a palavra EXEMPLO e ter como saída: XEMELPO, inclusive quando a palavra tiver um número ímpar de letras a última não modifica. Já tentei alguma coisa, mas não sei se uso vetor mesmo, em todos os exemplos de inversão de palavras o vetor é usado. Alguém pode me dar uma luz? Segue o código: algoritmo "semnome" // Função : // Autor : // Data : 26/10/2018 // Seção de Declarações var palavra: caracter vet: vetor [1..30] de caracter tamanho: inteiro i: inteiro inicio escreva ("Digite uma palavra: ") leia (palavra) tamanho <- compr (palavra) escreva ("A palavra tem ", tamanho, " letras.") para i de 1 ate tamanho faca se ((i mod 2) = 0) entao vet <- vet [i+1] fimse palavra <- vet fimpara escreva ("A palavra agora é ", palavra) fimalgoritmo Obrigado desde já.
  14. Algoritmo "semnome" // Disciplina : [Linguagem e Lógica de Programação] // Professor : Antonio Carlos Nicolodi // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : João dos ceus // Data atual : 03/09/2018 Var // Seção de Declarações das variáveis dados: vetor[1..5,1..5] de caracter i,j: inteiro letras: vetor[1..6] de caracter k: inteiro contador:inteiro opcao,opcao2:inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... repita Escreval("------ Menu principal ------") Escreval("Selecione uma das opções") Escreval("1. Inserir sopa de letras") Escreval("2. Sair") leia(opcao) escolha opcao caso 1 escreval("Introduza as letras para a sopa de letras:") para i de 1 ate 5 faca para j de 1 ate 5 faca leia (dados[i,j]) fimpara fimpara escreval ("") escreval("A sopa de letras é:") para i de 1 ate 5 faca para j de 1 ate 5 faca escreva (dados[i,j]) fimpara escreval ("") fimpara escreval ("") escreval(" As letras introduzidas são:") para i de 1 ate 6 faca leia (letras) fimpara para i de 1 ate 5 faca para j de 1 ate 5 faca para k de 1 ate 6 faca se letras[k]=dados[i,j] entao contador<-contador+1 escreval("") escreval ("-> Letra:") escreval (dados[i,j]) escreval ("->> Coordenada:") escreva (i,j) escreval("") escreval ("->>> Numero de vezes que a letra foi repetida:") ESTOU COM DIFICULDADES NESTE CODIGO AQUI, QUERO QUE ME DIGA QUANTAS VEZES A LETRA ESCOLHIDA FOI REPETIDA NA MATRIZ fimse fimpara fimpara fimpara caso 2 fimalgoritmo fimescolha Fimalgoritmo
  15. Olá, pessoas. Criei um programa com fins de estudo no visualg, cuja finalidade é preencher uma matriz com valores aleatórios e, em seguida, conferir e armazenar numa segunda atriz se o valores gerados são pares ou ímpares. Todavia o programa fica dando um erro ("Access violation at address xxxx in module" visualg30.exe). Não sei se eu que estou errando na lógica, se meu pc está quebrado ou se é um bug do visualg. Abaixo deixo meu código para quem puder me ajudar. Obrigado :) Var // Seção de Declarações das variáveis matriz1: vetor [0..2, 0..2] de inteiro matriz2: vetor [0..2, 0..2] de caractere // Procedimento que gera valores inteiros aleatorios para preencher a matriz1. procedimento preencheMatriz var // Variaveis contadoras i1, i2: inteiro inicio para i1 de 0 ate 1 passo 1 faca para i2 de 0 ate 2 passo 1 faca aleatorio on leia (matriz1[i1,i2]) limpatela aleatorio off fimpara fimpara // Imprimindo a matriz na tela para i1 de 0 ate 1 passo 1 faca para i2 de 0 ate 2 passo 1 faca escreva (matriz1[i1,i2]) fimpara escreval ("") fimpara fimprocedimento // Procedimento que verifica se os valores das posições da matriz1 são pares // ou ímpares. procedimento verificaParImpar var i1, i2: inteiro inicio para i1 de 0 ate 1 passo 1 faca para i2 de 0 ate 2 passo 1 faca se (matriz1[i1, i2] MOD 2=0) entao matriz2[i1,i2] <- "par" escreva(matriz2[i1,i2], " ") senao matriz2[i1,i2] <- "ímpar" escreva(matriz2[i1,i2], " ") fimse fimpara escreval(" ") fimpara fimprocedimento Inicio // Seção de Comandos, procedimento, funções, operadores, etc... preencheMatriz verificaParImpar Fimalgoritmo
  16. Prezados, tenho um trabalho pra entregar e resolvi 98% do mesmo, só uma questão que não estou conseguindo, dai pediria ajudar de vcs... O trabalho é este: Faça um algoritmo em VisualG que, dado o salário bruto de uma pessoa, calcule o salário líquido sabendo que há o desconto de dois impostos, de acordo com a tabela abaixo: Tabela IRPF Tabela INSS Salário até R$1500,00 será 0% de imposto; Salário até R$3000,00 será 15% de imposto; Salário acima de R$3000,00 será 27,5% de imposto. Importo fixo de 11% do salário, sendo que o total do imposto não pode ser superior a R$400,00. (aqui onde o bicho pega, não sei como limitar a esse valor) Atenção para calcular o IRPF você poderá utilizar uma estrutura de decisão encadeada, já para o INSS você poderá utilizar uma estrutura de decisão composta. Depois de avaliar as duas estruturas (IRPF e INSS) você então calculará o salário líquido. Para que você possa conferir se seu algoritmo está correto execute com os valores do salário bruto dado abaixo e confira se o salário líquido será o apresentado abaixo: Salário Bruto Salário Líquido R$ 5000,00 R$ 3225,00 R$ 3500,00 R$ 2152,50 Retorno de resultado R$ 1800,00 R$ 1332,00 R$ 1400,00 R$ 1246,00 Meu algoritmo ficou assim (funcionando porém com valores que dão mais de R$ 400,00 de INSS ele não limita, porque não sei como fazer, me ajudem por favor): var salarioB, irpf, inss: real inicio //IRRF: //Até 1.500 | - //De 1.500 até 3.000 | 15,0 //Acima de 3.000 | 27,5 //INSS: //Fixo | 11,0 | Limite de desconto 400 escreva("Digite o salário:") leia (salarioB) se (salarioB<1500.00)ou(salarioB=1500.00) entao inss<- salarioB*11/100 escreval("Seu SalarioB Liquido é", salarioB - inss) senao se (salarioB>1500.01)e(salarioB<=3000.00) entao irpf<- salarioB*15/100 inss<- salarioB*11/100 escreval ("IRPF a ser descontado é", irpf) escreval ("INSS a ser descontado é", inss) escreval("O salário Líquido é", salarioB - irpf - inss) senao se (salarioB>3000.00)ou(salarioB= 3000.00) entao irpf<- salarioB*27.5/100 inss<- salarioB*11/100 escreval ("IRPJ a ser descontado é", irpf) escreval ("INSS a ser descontado é", inss) escreval("O salário Líquido é", salarioB - irpf - inss) fimse fimse fimse fimalgoritmo
  17. lucas25

    Algoritimo

    estou precisando de ajuda nessa questão: A companhia de aviação balanca mas nao cai ltda deseja automatizar o calculo de desconto durante o procedimento de vendas de passagens areas para os seus 2500 voos. Dessa forma, confeccionar um algoritimo que: a. leia cada venda: o dia da semana do voo (2-3-4-5-6-7-0) o turno do voo (diurno ou noturno) a quantidade de passagens o valor da passagem. estou precisando de ajuda não estou conseguindo faze.
  18. Meu código tá dando erro no fim algoritmo algoritmo "Calculador de Maioridade" var an : inteiro var anoa : inteiro var qfuac : caractere var facf : caractere var cpf : caractere inicio escreval ("Qual seu ano de nascimento ") leia (an) anoa <- (2018) an <- (anoa - an) se (an > 18) entao escreval ("Voce tem " , an) escreval ("Voce e maior de idade") escreval (" Voce quer fazer uma faculdade?") leia (qfuac) se (sim ou Sim ) entao escreval ("Qual faculdade voce quer fazer?") leia (facf) escreval ("Quer fazer seu cadastro para ", facf" ?") se (sim ou Sim) entao escreval ("Digite seu CPF") leia (cpf) escreval ("Digite seu RG") leia (rg) escreval ("Pronto Cadastro Feito. Boa sorte") fimse senao escreval ("Voce tem " , an) escreval ("Voce e menor de idade") fimse fimalgoritmo Da esse erro: Dados incorretos : [46:0] = fimalgoritmo Alguém me ajuda
  19. algoritmo "semnome" var nome:caractere c,n:inteiro inicio escreva("Qual é o seu nome ? ") leia(nome) Escreval("Prazer ",nome,".") escreval("Escolha um numero") leia(n) c <- 0 Enquanto (c<=n) faca c <- c + 1 fimEnquanto fimalgoritmo
  20. Olá pessoal podem me ajudar com esses exercicios? anexei a foto das questoes no post, Obrigado a todos pela atenção! 1) Considerando a=5, b=2, e c=8, escreva qual será o valor impresso pelo algoritmo quando valor a ser lido(valor de entrada): a) Valor de entrada, num = -2 b) Valor de entrada, num = 2 2) Escreva um algoritmo que leia dados de entrada 3 números, verificando se eles podem ou não ser lados de um triangulo. Caso sejam lados de um triangulo, calcular a area do mesmo e imprimir o resultado, caso nao sejam imprimir "não sao lados de um triangulo" para que o triangulo exista , um de seus lados deve ser maior que o valor absoluto (modulo) da diferença dos outros dois lados e menor que a soma dos outros dois lados: a > l b-c l, b > l a-c l, c > l a-b l ao calcular a area de um triangulo utilize a formulaçao sendo que a, b e c sao os lados do triangulo A=v(p x(p-a) x (p-b) x (p-c)) P= (a+b+c)/2
  21. Mühlmann

    Algoritmo-VisualG

    Dúvidas ja sanada durante a aula.
  22. Bom dia, estou com uma dificuldade em um algoritmo para um jogo da forca em VisuALG, o algoritmo foi solicitado para um trabalho e um dos requisitos é que ele tenha uma função, como vocês podem ver foi colocado uma função, porém a professora disse que aquela função não retorna nenhum valor, e por isso ela se encaixa como procedimento, pesquisei, tentei e não conseguir encaixar uma função nesse algorítimo, queria acrescentar também a cada final de rodada a opção de jogar ou não novamente. desde já agradeço a ajuda. abaixo segue o Algorítimo - obs o visuALG utilizado foi o 2.0 algoritmo "Jogo da forca" var op,frutas,ne,na:inteiro //op: opçao, ne: numero erro, na:numero de acertos l1,l2,l3,l4,l5,l6,l7,ld1,ld2,ld3,ld4,ld5,ld6,ld7,dig,verifica:caracter //linhas(l1,l2,l3...) serão usadas para o aleatorio, já as ld (ld1, ld2, ld3) serão usadas para verificar o acerto V,D:Caracter funcao Derrota () :caracter inicio Escreval("============================================================") escreval("============================================================") escreval escreval(" --------- FIM DE JOGO! ------- ") ESCREVAL ESCREVAL(" --------- GAME OVER =( ------- ") ESCREVAL Escreval("============================================================") escreval("============================================================") fimfuncao funcao vitoria () : caracter inicio limpatela Escreval("============================================================") escreval("============================================================") escreval escreval(" PARABÊNS VOCE VENCEU! ") ESCREVAL Escreval("============================================================") escreval("============================================================") fimfuncao inicio aleatorio on // ativa o modo aleatorio fonte, palavra on é opcional aleatorio 1,7 // seleciona o ranger do aleatorio, é preciso definir para o comando ter as opção para escolha leia (frutas) // todo leia vai ser lançado um numero aleatorio nesse caso de 1 a 3 aleatorio off // desativa o modo aleatorio, assim ele escolher uma das opções das palavras. limpatela // limpa tela repita // (repita 1) repitir o comando ate achar o comando interrompa escreval("---SEJA BEM VINDO---") escreval escreval(" ---JOGO DA FORCA--- ") escreval("Autores: Charles Ramos, Pedro Duca, Richard Vepo") escreval escreval escreval("Digite 1 para jogar e 0 para sair") leia(op) escolha op // verificar qual opção foi selecionada caso 0 //sair escreva("você escolheu a opção 0 para sair") escreval escreval fimalgoritmo // encerrar o algoritmo caso 1 interrompa // para o loop de escolher opção outrocaso // caso digite algo diferente de 0 ou 1 ele vai limpar a tela limpatela // limpa a tela, e vai voltar para o loop de opção. fimescolha fimrepita// fim repita 1 escolha frutas // palava que vai ser escolhida automaticamente pelo aleatorio no inicio do código em aleatorio on caso 1 l1 <- "d" l2 <- "a" l3 <- "m" l4 <- "a" l5 <- "s" l6 <- "c" l7 <- "o" caso 2 l1 <- "a" l2 <- "b" l3 <- "a" l4 <- "c" l5 <- "a" l6 <- "x" l7 <- "i" caso 3 l1 <- "a" l2 <- "b" l3 <- "a" l4 <- "c" l5 <- "a" l6 <- "t" l7 <- "e" caso 4 l1 <- "a" l2 <- "c" l3 <- "e" l4 <- "r" l5 <- "o" l6 <- "l" l7 <- "a" caso 5 l1 <- "l" l2 <- "a" l3 <- "r" l4 <- "a" l5 <- "n" l6 <- "j" l7 <- "a" caso 6 l1 <- "p" l2 <- "e" l3 <- "s" l4 <- "s" l5 <- "e" l6 <- "g" l7 <- "o" caso 7 l1 <- "g" l2 <- "u" l3 <- "a" l4 <- "r" l5 <- "a" l6 <- "n" l7 <- "a" fimescolha ld1 <- "_" // LINHAS USADAS PARA ESCREVER ld2 <- "_" ld3 <- "_" ld4 <- "_" ld5 <- "_" ld6 <- "_" ld7 <- "_" // inicio do jogo repita //repita2 se (ne > 7) entao // Se número de erros for maior que 6 que é o tamanho das palavras logo, jogador perde, ou seja, jogador possui 6 chances apenas. D<- Derrota FIMALGORITMO fimse se (ld1 <> "_") e (ld2 <> "_") e (ld3 <> "_") e (ld4 <> "_") e (ld5 <> "_") e (ld6 <> "_") e (ld7 <> "_") entao // Se as linhas forem diferentes de _ significa que existe letra no local, V<- Vitoria FIMALGORITMO fimse limpatela Escreval("============================================================") escreval("============================================================") escreval("") escreval(" /-----|") escreval(" / |") se (ne > 0 ) entao escreval(" / (x.x)") senao escreval(" /") fimse se (ne > 1 ) entao escreval(" | __||__ ") senao escreval(" | ") fimse se (ne > 2 ) entao escreval(" | /| |\\") senao escreval(" | ") fimse se (ne > 3) entao escreval(" | / |_____| \\") senao escreval(" | ") fimse se (ne > 4) entao escreval(" | || ||") senao escreval(" | ") fimse se (ne > 5) entao escreval(" | _|| _||") senao escreval(" | ") fimse se (ne > 6) entao escreval(" | |__||__|") escreval("===== ULTIMA CHANCE! ") senao escreval(" | ") escreval("===== ") fimse escreval("") escreval("Acertos: ",na) escreval("Erros: ",ne) escreval("") escreva("Palavra com 7 letras: ",ld1," ",ld2," ",ld3," ",ld4," ",ld5," ",ld6," ",ld7) Escreval("") escreval("Dica da palavra: FRUTA ") escreval escreva("digite uma letra: ") leia(dig) verifica <- "0" se (l1 = dig) e (ld1 = "_") entao ld1 <- dig na <- na + 1 verifica <- "1" fimse se (l2 = dig) e (ld2 = "_") entao ld2 <- dig na <- na + 1 verifica <- "1" fimse se (l3 = dig) e (ld3 = "_") entao ld3 <- dig na <- na + 1 verifica <- "1" fimse se (l4 = dig) e (ld4 = "_") entao ld4 <- dig na <- na + 1 verifica <- "1" fimse se (l5 = dig) e (ld5 = "_") entao ld5 <- dig na <- na + 1 verifica <- "1" fimse se (l6 = dig) e (ld6 = "_") entao ld6 <- dig na <- na + 1 verifica <- "1" fimse se (l7 = dig) e (ld7 = "_") entao ld7 <- dig na <- na + 1 verifica <- "1" fimse se (verifica = "0") entao ne <- ne + 1 fimse escreval("==============================================================") escreval("==============================================================") fimrepita fimalgoritmo
  23. Pessoal queria uma ajuda para fazer esse código funcionar corretamente, o problema é o seguinte, É pra desenvolver um algoritmo que fique recebendo números e quando for digitado o número 0 "zero" o programa pare e mostre o maior e o menor número digitado, usando a função repita - até. Vou deixar anexado a imagem do código que eu fiz.
  24. Faça um algoritmo que leia 20 notas de alunos e armazene em um vetor. Feito isso, o algoritmo deve calcular e mostrar a maior e a menor nota informada. [VisuAlg]
  25. Fernanda De Camargo Fernandes

    me ajuda por favor

    Uma tabela expressa os valores de imóveis de diferentes metragens em diferentes bairros da cidade de Vitória. As colunas dessa Matriz 5x5 contém os valores para cada metragem (100, 150, 200, 250 ou 300m2) e as linhas os valores para cada Bairro. Faça um algoritmo que a)Leia a matriz por completo; b)O usuário deverá informar a metragem (ou número da coluna da matriz) e o algoritmo deverá retornar o preço do apartamento mais barato para a metragem informada; O valor do apartamento deverá ser apresentado na tela; c)O usuário deverá informar um bairro (ou o número da linha da matriz) e a metragem (coluna) e a subrotina retorna o preço do apartamento; O Valor do apartamento deverá ser apresentado na tela; d)O algoritmo deverá informar a média dos preços dos apartamentos por metragem;
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.