Ir para conteúdo

Pesquisar na Comunidade

Mostrando resultados para as tags ''collate''.

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Todas as áreas do Fórum

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Encontrar resultados em...

Encontrar resultados que...


Data de Criação

  • Início

    FIM


Data de Atualização

  • Início

    FIM


Filtrar pelo número de...

Data de Registro

  • Início

    FIM


Grupo


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Encontrado 1 registro

  1. trrac388

    Problemas com Collate e Character SET (PHP e MySQL)

    Pessoal, já rodei o fórum e não achei nada igual parecido ao problema que estou tendo, só por isso estou abrindo este tópico. Já tentei inúmeras saídas como setar tudo através de mysql_query após a conexão com o banco entre diversas outras possíveis soluções e nada resolveu, então vou explicar. Meus arquivos estão todos codificados com UTF-8, meus cabeçalhos HTML todos com UTF-8, meu banco de dados MySQL e Tabelas todos UTF-8 e character set utf8_general_ci. Pela aplicação funciona direitinho, entre aspas, todo o processo de visualização de dados dentro da aplicação é aparentemente normal, leio e gravo caracteres acentuados sem nenhum problema aparente, até o momento em que tento fazer um SELECT com palavras acentuadas ou usando o LIKE '% xx %'. Fui verificar o que poderia estar ocorrendo pois essas consultas não retornavam absolutamente nada então, lá estava o problema: Os registros no banco, estavam sendo gravados totalmente desconfigurados. A palavra "Conceição" que aparece normalmente na aplicação, no banco de dados está gravada como : Conceição A palavra "Pátria" que também aparece normalmente na aplicação, no banco de dados está gravada como: Pátria A palavra "Rosângela" que também aparece normalmente na aplicação, no banco de dados está gravada como: Rosângela Exemplo de testes das palavras exibidas na página HTML/PHP Exemplo dos dados gravados no banco MySQL Criei um novo banco de teste com Latin1 e character set Latin1_swedish_ci e também não resolveu, o caracteres estranhos foram susbtituidos por losangos pretos. :( O mesmo ocorreu com Latin1 e character set latin1_general_ci. Alguém sabe me dizer onde pode estar o problema? Já tentei de tudo que encontrei na internet sobre esse tema e nada resolveu. Obrigado a todos!!
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.