Jump to content

Search the Community

Showing results for tags 'comparar'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 13 results

  1. icaroperetti45

    Dúvida programa em JAVA - repetição

    Faça um programa em JAVA que deve ficar lendo uma letra por vez do teclado até que o operador digite a letra x. Após o operador digitar x o programa deve apresentar na tela o número de vezes que o operador digitou dois caracteres iguais em sequencia. Rapazeada, sou iniciante no java e gostaria de uma ajuda com o Exercício a seguir! Gostaria de saber como utilizo o != para string no while! package br.edu.ifcvideira.Lista3; import java.util.Scanner; public class Exercicio7 { public static void main(String[] args) { Scanner in = new Scanner(System.in); String letra = null; String letraCorreta = "x"; while (letra.equals(letraCorreta)) { } } }
  2. Everton Lins de Paulo

    Comparar campo com a linha anterior no oracle

    Tenho essa query: ----------------------------------------------------------------------- SELECT codigo, entrada, alta, sequencia from atendimentos where codigo = 108 ----------------------------------------------------------------------- que me retorna o seguinte: ------------------------------------------------------------------------------------------------------------ codigo entrada alta sequencia 108, '21/10/2018 00:00:00', '31/10/2018 00:00:00', 1 108, '07/11/2018 00:00:00', '08/11/2018 00:00:00', 2 108, '11/11/2018 00:00:00', '13/11/2018 00:00:00', 3 108, '12/12/2018 00:00:00', '13/12/2018 00:00:00', 4 ------------------------------------------------------------------------------------------------------------ Preciso comparar se a alta da sequencia inferior está num prazo de 15 dias e assim com todas. Ex: Minha sequencia 1 não vai ter nenhuma alta acima dela, então ela vai ter a resposta NÃO A alta da sequencia 1 é menor de 15 dias da entrada da sequencia 2? A resposta vai ser SIM A alta da sequencia 2 é menor de 15 dias da entrada da sequencia 3? A resposta vai ser SIM A alta da sequencia 3 é menor de 15 dias da entrada da sequencia 4? A resposta vai ser NÃO Ficaria assim: ----------------------------------------------------------------------------------------------------------------------------------------------------- codigo entrada alta sequencia Reinternação 108, '21/10/2018 00:00:00', '31/10/2018 00:00:00', 1 NÃO 108, '07/11/2018 00:00:00', '08/11/2018 00:00:00', 2 SIM 108, '11/11/2018 00:00:00', '13/11/2018 00:00:00', 3 SIM 108, '12/12/2018 00:00:00', '13/12/2018 00:00:00', 4 NÃO ----------------------------------------------------------------------------------------------------------------------------------------------------- Algum amigo conhece algum comando para fazer isso?
  3. Boa tarde à todos... Sou totalmente leigo em SQL e estou precisando de uma ajuda de vocês, aliás, um excelente ajuda. Tenho duas tabelas abaixo: Tabela linaus07 d01 d02 d03 d04 d05 d06 d07 10 11 12 13 14 15 16 10 11 12 13 14 16 17 10 11 12 13 14 16 22 Tabela linrep07 d01 d02 d03 d04 d05 d06 d07 d08 d09 d10 d11 d12 d13 d14 d15 1 2 3 4 5 6 7 10 11 12 13 14 16 17 22 1 2 3 4 5 6 7 8 10 11 12 13 14 16 17 1 2 3 4 5 6 7 9 10 11 12 13 14 16 22 Então, o que preciso...??? Pego o 1 registro da tabela linaus07 contendo 7 campos e confronto com todos os registros da tabela linrep07 contendo 15 campos, reparem que o primeiro registro da tabela linaus07, confrontando com a tabela linrep07, em nenhum momento continha 7 iguais nos registros, então, não preciso fazer nada, porém, repare agora, que o segundo registro da tabela linaus07, confrontando com a tabela linrep07, encontramos 7 campos exatamente nos 15 campos da outra tabela, então, pego o registro da tabela linrep07 e gravo em outro banco de dados (um novo), o registro que contem esses 15 campos que tinham os 7 campos da tabela linaus07. o que tem que ser respeitado... Cada registro da tabela linaus07 contendo 7 campos, irá passar em todos os registros da tabela linrep07 contendo 15 campos e irá colocar num novo banco de dados, todos os registros que da tabela linrep07 tiverem exatamente os 7 campos da tabela linaus07 e ao final, esse novo banco, terá com certeza muito registros, mas preciso salvá-los em um arquivo .txt com o separador "-" entre os campos... Espero ter sido claro... Obrigado MARCELO SAMPAIO
  4. Boa tarde pessoal ! Como faço para comparar os valores entre duas tabelas e retornar um valor final ? Por exemplo: Leia valor col1 = vazão(float) e col2 = turbidez (float) e col3 = pH (float) agora compare e busque o resultado na col4 solução = valor pre estabelecido na col4 Quando vazão digitada pelo usuário estiver entre dois valores da tabela de referência ( X e Y ) turbidez digitada pelo usuário estiver entre dois valores ( X e Y) pH digitado pelo usuário estiver entre dois valores ( X e Y) então o Mysql retorna um valor pre estabelecido na col4. Alguém poderia me ajudar a resolver este problema? Agradeço desde já.
  5. Pitag346

    Inserção e Comparação

    Oi pessoal, Beleza? Preciso de ajuda.... Resumidamente: Eu armazeno varios dados no banco de dados inclusive alguns id's que estão em array... eles são armazenados com virgulas (pelo implode)... ou seja, os id's são armazenados desas forma: (1,2,3,4) Esses ids, eu preciso utilizar um SELECT neles para executar um WHILE ... Completo: Tenho um sistema em php + mysqli... onde 1 grupo de usuários faz upload de arquivos... esse grupo pode escolher quais grupos podem visualizar esse arquivo... podem escolher varios grupos ou apenas 1, ou até nenhum... para isso estou utilizando checkbox com array ... (<input type="checkbox" name="turma[]"/>). Faço o envio via POST e com o explode eu separo com virgulas... Ficando da forma que mencionei lá em cima... (1,2,3,4) mas preciso fazer um select e verificar esse campo que tem esses valores com virgulas... o detalhe que no select preciso verificar se o ID DO GRUPO é um dos que estão dentro da virgula se for faço a exibição ... se não, não é exibido... Obs: como serão varios arquivos enviados será necessário um WHILE ... Não faço ideia como fazer... Se não entenderem oq eu realmente estou precisando... podem estar solicitando que faço o anexo de imagens... Att. desde já, Obrigado!
  6. JhoniWillian

    Comparação entre Datas

    Boa noite galera, estou com uma dúvida.. Estou fazendo um select em uma variavel e depois pego o valor da coluna ''data_inicio'' desse select e armazeno em uma variavel, e pego o valor da coluna ''data_fim'' e armazeno em outra variável. Essas informações estão vindo em datetime do MySQL para mim. então no select eu faço SELECT DATE_FORMAT(data_inicio, '%d/%m %H:%i') as data_inicio, DATE_FORMAT(data_fim , '%d/%m %H:%i') as data_fim FROM pixie_andon_nc. $data_inicio = ['data_inicio']; $data_fim = ['data_fim']; para as data vir: DIA/MES Hora/Min ''08/10 18:25'' As duas data me trazem a informação correta, porém, agora eu preciso comparar essas duas datas e saber qual é a maior e a menor. Estou fazendo a comparação porém, ele está levando em consideração somente o dia. Por exemplo Se a datas forem inicio = 08/10 10:00 fim = 09/10 10>00 ele fala que o Inicio é menor que o FIm. até ai está ok. agora se vira o mês, ele me trás divergência, por exemplo. inicio = 08/10 10:00 fim = 01/11 10:00 ele fala que o inicio é maior, porque está considerando somente o dia, ou seja, o dia 8 é maior que o dia 01... porém está errado pq o dia 1 é do outro mês
  7. Olá boa noite, estou precisando fazer uma consulta em uma tabela onde o campo data está no formato datetime e preciso verificar se somente a data é igual ao currente_date. Segue a minha tabela. CREATE TABLE `tb_newsletter` ( `NEW_COD` INT(11) NOT NULL AUTO_INCREMENT, `LEI_COD` INT(11) NULL DEFAULT '0', `LEI_EMAIL` VARCHAR(150) NOT NULL DEFAULT '0', `NEW_DT_CADASTRO` DATETIME NOT NULL DEFAULT '0000-00-00 00:00:00', `NEW_STATUS` VARCHAR(50) NULL DEFAULT '0', PRIMARY KEY (`NEW_COD`), INDEX `LEI_COD` (`LEI_COD`) ) COLLATE='utf8_general_ci' ENGINE=InnoDB AUTO_INCREMENT=2 Segue o código que eu estava tentando, preciso fazer a consulta nessa tabela para me apresentar somente os novos cadastros do dia atual ignorando os cadastros antigos. SELECT COUNT(NEW_COD) AS TOTAL FROM `tb_newsletter` WHERE 'NEW_DT_CADASTRO' = CURRENT_DATE; Obrigado a todos.
  8. Daniela Bondezan dos Reis

    Comparando ano de um exercicio com o ano de uma data

    Boa tarde.Preciso de uma ajuda que não estou conseguindo resolver.Tenho os seguintes inputs:Onde eu tenho o exercicio (Ano) a que se refere o lançamento:<input name="exercicio" type="text" value="<?php echo $row_Recordset2['exercicio']; ?>" size="3" maxlength="4" disabled/>Onde eu tenho a data de vencimento do lançamento:<input name="data_venc" type="date" id="data_venc" value="<?php echo $row_Recordset2['data_venc']; ?>" size="10" maxlength="12" onchange="verifica_data()"/>O que eu preciso fazer é ler essa data de vencimento, extrair o ano dela e comparara com o exercício, pois caso o ano da data de vencimento não seja igual o exercício, o sistema deve avisar.Fiz uma função em javascript, mas me parece que não se lê nada, nem de exercício, nem de data de vencimento. No que eu estou errando ?Alguém consegue me ajudar ?function verifica_data(){var elemento = new Date(document.getElementById('data_venc').value);var ano=elemento.getFullYear();var exercicio = document.getElementsByName('exercicio').value;alert("Exibe Exercício: "+exercicio);if(ano > exercicio){alert("O Ano do Lançamento é Maior !");}else{alert("O Ano do Lançamento é Menor !");}}Att. Dbondezan
  9. gelopes

    Comparar arquivos

    Olá pessoal, tudo bem? Sou novo por aqui e novo no VB hehe Tenho um trabalho para entregar no curso e não faço ideia de como fazer. É uma aplicação bem simples, podem me ajudar? Tenho dois arquivos TXT com uma lista de nomes. Um nome por linha. Preciso de uma aplicação que "abra o arquivo 01", "abra o arquivo 02" e que ao clicar em um botão, ele gere um terceiro aquivo TXT somente com os nomes que não estão repetidos, ou seja, somente com os nomes que não se repetem nos dois arquivos. E eu possa selecionar onde salvar esse terceiro arquivo. Exemplo do layout: http://prntscr.com/d9hbqg Obrigado desde já pela atenção pessoal. Um abraço!
  10. Pessoal, eu tenho uma data dia, mês e ano dentro de um .TXT só tem isso dentro dele somente uma linha gostaria de comparar com a data atual mais ou menos assim: if(data que está dentro do txt == date(d/m/Y)){ faça isso } Exemplo de como a linha que está dentro do .TXT: 01/08/2016
  11. Estou estudando algoritmos e lógica de programação, logo, sempre tento comparar meu código com o do professor, para aprimorar minha aprendizagem. Analisando quantidade de linhas, lógica usada, rotinas, entre outros... Para definir onde posso melhorar ou não. Vocês experientes (ou não) podem me falar quais critérios devo levar em conta, ao comparar dois pseudocódigos e se isso é uma ação válida, isto é, vai acrescentar na minha vida? Abaixo segue o código do professor e o meu. Meu código: algoritmo "Dissecando Matrizes" var opcao, L, C:inteiro M: vetor [1..4, 1..4] de inteiro Procedimento Menu() inicio EscrevaL ("") EscrevaL ("======================") EscrevaL ("MENU DE OPÇÕES") EscrevaL ("======================") EscrevaL ("[1] Mostrar a Matriz") EscrevaL ("[2] Diagonal Principal") EscrevaL ("[3] Triângulo Superior") EscrevaL ("[4] Triângulo Inferior") EscrevaL ("[5] Sair") Escreva ("===== OPÇAO: ") Leia (opcao) FimProcedimento inicio Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Escreva ("Digite o valor para posição [ ",L,", ",C,"]: ") Leia (M[L,C]) FimPara FimPara LimpaTela Repita Menu() Repita Escolha opcao Caso 1 LimpaTela Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Escreva (M[L,C]:2) Fimpara EscrevaL () FimPara Menu() Caso 2 LimpaTela Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Se (L = C) entao Escreva (M[L,C]:2) Senao Escreva (" ":2) FimSe Fimpara EscrevaL() FimPara Menu() Caso 3 LimpaTela Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Se(L = C - 1) ou (L = c - 2) ou (L = C - 3) entao Escreva (M[L,C]:2) Senao Escreva (" ":2) FimSe FimPara EscrevaL () FimPara Menu() Caso 4 LimpaTela Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Se (L = C + 1) ou (L = c + 2) ou (L = C + 3) entao Escreva (M[L,C]:2) Senao Escreva (" ":4) FimSe FimPara EscrevaL () FimPara Menu() Caso 5 LimpaTela Escreva ("SAINDO...") FimEscolha Ate (opcao = 5) Ate (opcao = 5) LimpaTela Escreva ("SAINDO...") fimalgoritmo Código do professor: var m: vetor[1..4, 1..4] de Inteiro l, c, op: Inteiro Procedimento MostraMatriz() inicio Para l <- 1 ate 4 faca Para c <- 1 ate 4 faca Escreva(m[l,c]:4) FimPara EscrevaL() FimPara FimProcedimento Procedimento DiagonalPrincipal() var t: inteiro inicio Para l <- 1 ate 4 faca EscrevaL(m[l,l]:4) Para t <- 1 ate l faca Escreva(" ") FimPara FimPara FimProcedimento Procedimento TrianguloSuperior() var t: Inteiro inicio Para l <- 1 ate 3 faca Escreva(" ") Para c <- l+1 ate 4 faca Escreva(m[l,c]:4) FimPara EscrevaL() Para t <- 1 ate l faca Escreva(" ") FimPara FimPara EscrevaL() FimProcedimento Procedimento TrianguloInferior() inicio Para l <- 2 ate 4 faca EscrevaL() Para c <- 1 ate l-1 faca Escreva(m[l,c]:4) FimPara FimPara EscrevaL() FimProcedimento inicio Para l <- 1 ate 4 faca Para c <- 1 ate 4 faca Escreva("Digite valor para a posicao [", l, ",", c, "]: ") Leia(m[l,c]) FimPara FimPara LimpaTela Repita EscrevaL() EscrevaL("MENU DE OPCOES") EscrevaL("====================") EscrevaL("[1] Mostrar a Matriz") EscrevaL("[2] Diagonal Principal") EscrevaL("[3] Triangulo Superior") EscrevaL("[4] Triangulo Inferior") EscrevaL("[5] Sair") Repita EscrevaL("===== OPCAO: ") Leia(op) Ate (op >=1) e (op <=5) LimpaTela Escolha op Caso 1 MostraMatriz() Caso 2 DiagonalPrincipal() Caso 3 TrianguloSuperior() Caso 4 TrianguloInferior() Caso 5 EscrevaL("ENCERRANDO...") FimEscolha Ate (op = 5) fimalgoritmo Em minha análise amadora, entendo que o meu foi melhor construído que o do professor, o que acham?
  12. brunowdesigner

    Comparar ID e Listar Resultados.

    Boa tarde. Estou com um pequeno problema. Fiz um sistema onde o administrador envia arquivos, gerando pasta com o ID do usuário selecionado e enviando o ID como identificador, a URL do documento e o Nome do Arquivo. Até ai tudo Ok. Assim que o cliente acessa lá estarão os documentos dele. O problema é que não consigo gerar a URL para o cliente fazer download do arquivo. Documento onde aparecem os arquivos listados. (OBS: Sou iniciante em PHP e BD). <?php require_once 'conexao.php'; include("includes/header.php"); ?> <?php $query = mysql_query("SELECT * FROM usuarios WHERE usuario = '$_SESSION[usuario]' AND senha = '$_SESSION[senha]'") or die(mysql_error()); $cliente = mysql_fetch_assoc($query); ?> </head> <body> <div class="navbar navbar-fixed-top"> <div class="navbar-inner"> <div class="container"> <a class="btn btn-navbar" data-toggle="collapse" data-target=".nav-collapse"><span class="icon-bar"></span><span class="icon-bar"></span><span class="icon-bar"></span> </a><a class="brand" href="index.html">Área de Clientes - LCL Contabilidade</a> <div class="nav-collapse"> <ul class="nav pull-right"> <li><a href="?sair" onclick="return confirm('Realmente deseja sair?')">Sair do Sistema</a></li> </li> </ul> </div> <!--/.nav-collapse --> </div> <!-- /container --> </div> <!-- /navbar-inner --> </div> <!-- /navbar --> <div class="subnavbar"> <div class="subnavbar-inner"> <div class="container"> <ul class="mainnav"> <li><a href="home.php"><i class="icon-dashboard"></i><span>Página Inicial</span> </a> </li> <li class="active"><a href="documentos.php"> <i class="icon-file"></i><span>Meus Documentos</span> <b class="caret"></b></a></li> <li><a href="email.php"> <i class="icon-file"></i><span>Enviar Email</span> <b class="caret"></b></a> <li></li> </ul> </div> <!-- /container --> </div> <!-- /subnavbar-inner --> </div> <div class="main"> <div class="main-inner"> <div class="container"> <div class="row"> <div class="span12"></div> <div class="span12"> <div id="target-1" class="widget"> <div class="widget-content"> <h1>Meus Documentos</h1> <hr><p> <?php $query = mysql_query("SELECT nome,url FROM arquivos") or die(mysql_error()); $arquivos = mysql_fetch_assoc($query); $urlbd = $arquivos['url']; $id = $cliente['id']; $nome = $arquivos['nome']; $dir = "../../restrito/adm/uploads/$id"; $url = "../../restrito/adm/uploads/$id/$nome"; $pasta = opendir($dir); /* Loop para ler os arquivos do diretorio */ while ($arquivo = readdir($pasta)){ /* Verificacao para exibir apenas os arquivos e nao os caminhos para diretorios superiores */ if ($arquivo != '.' && $arquivo != '..'){ /* Escreve o nome do arquivo na tela */ echo "<a href='$urlbd' target='_blank'>$arquivo</a><br>"; } } ?> </p> </p> </div> <!-- /widget-content --> </div> <!-- /widget --> </div><!-- span 12 --> </div><!-- row --><!-- /widget --> </div> <!-- /span6 --> </div> <!-- /row --> </div> <!-- /container --> </div> <!-- /main-inner --> </div> <!-- /main --> <?php include("includes/footer.php"); ?> </body> </html>
  13. DinhoPHP

    Comparar colunas via VBA

    Olá! Preciso de um script que ao listar nomes de computadores na rede e este constar, libere o acesso à uma planilha. Já tenho o script que descobre o PC na rede juntamente com nome de usuário e domínio, só falta permitir esse acesso. Quero destacar que não programo em VBA e sim para web, mas achei que sabendo o conceito, conseguiria. Preciso disso urgente! Pois é um trabalho que jáa encontra-se com seu tempo estourado. Desde já agradeço à todos que ajudarem.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.