Ir para conteúdo

Pesquisar na Comunidade

Mostrando resultados para as tags ''logar''.

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Todas as áreas do Fórum

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Encontrar resultados em...

Encontrar resultados que...


Data de Criação

  • Início

    FIM


Data de Atualização

  • Início

    FIM


Filtrar pelo número de...

Data de Registro

  • Início

    FIM


Grupo


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Encontrado 3 registros

  1. richard nicson

    Criar sistema de bloqueio Conta pelo SQL

    Boa tarde,estou com uma dúvida preciso criar algo que exiba mensagem para o usuário que tentar acessar a conta dele mas estiver com o campo Ativado na opção 2 de "Sua conta foi bloqueada." Eu já possuo um campo em todas as contas chamado ativado onde automáticamente é inserido o valor 1 de ativado. Porém usuários que efetuarem algo errado irei bloquear a conta atualizando o valor no sql para 2. Mas de acordo com meu código fiz alguns testes e não está sendo satisfatório,peço auxilio de vocês. abaixo o script de verificar a conta. <?php session_start(); // Inicia a session include "config.php"; $usuario = $_POST['usuario']; $senha = $_POST['senha']; if ((!$usuario) || (!$senha)){ echo "Por favor, todos campos devem ser preenchidos! <br /><br />"; include "logar.php"; }else{ $sql = mysql_query( "SELECT * FROM usuarios WHERE (usuario='$usuario' OR email='$usuario') AND senha='{$senha}'" ); $login_check = mysql_num_rows($sql); if ($login_check > 0){ while ($row = mysql_fetch_array($sql)){ foreach ($row AS $key => $val){ $$key = stripslashes( $val ); } $_SESSION['usuario_id'] = $usuario_id; $_SESSION['nome'] = $nome; $_SESSION['sobrenome'] = $sobrenome; $_SESSION['email'] = $email; $_SESSION['nivel_usuario'] = $nivel_usuario; mysql_query( "UPDATE usuarios SET data_ultimo_login = now() WHERE usuario_id ='{$usuario_id}'" ); ?> <meta http-equiv="refresh" content="0; index.php?page=painel"> <?php } }else{ echo "Voce nao pode logar-se! Este usuario e/ou senha nao sao validos!<br /> Por favor tente novamente!<br />"; include "logar.php"; } } ?>
  2. VMG

    Problemas pra logar intranet no Windows

    Boa tarde, pessoal. Estou desenvolvendo uma intranet para a empresa. Lá na empresa temos um pc com linux 15.04 e nele foi instalado o php. No linux, coloquei uma pasta contendo todos os scripts da intranet. Se eu abro a página de login no próprio linux, e coloco o usuário e a senha, ele verifica no active directory se o usuário existe e loga normalmente. Aí por um computador com o windows eu acesso pelo IP 192.168.0.12 pra entrar na pasta do linux que tem os scripts, aí quando clico no index.php e tento fazer o login ele só da esse erro: "; session_start(); $_SESSION['usu'] = $usu; header("Location: painel.php"); }else { echo "Usuario ou Senha Invalidos"; echo " "; } ?> Então o problema não é o script, pq pelo teste que fiz abrindo pelo linux ele está conectando no AD, verificando o usuário corretamente e logando. O Problema está no windows. Não sei se tem que ser feito alguma configuração no windows pra ele autenticar o usuário ou se tem que modificar algo no script pro windows conseguir fazer esse login. Eu realmente não sei se tem que fazer alguma configuração pra funcionar direito. Alguém poderia me ajudar? Segue abaixo os scripts index.php <HTML xmlns="http://www.w3.org/1999/xhtml" lang="pt-br" xml:lang="pt-br"> <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> <?php session_start('sessao'); ?> <head> <script language="JavaScript" type="text/javascript" src="funcs.js"></script> <style type="text/css"> .login { font-size: 26px; font-family: "Times New Roman", Times, serif; } </style> </head> <CENTER> <img src="Imagens/senha.png" width="130" height="137"><br> </p> <p> </p> <CENTER> <form method="post" action="testeconectar.php" name="form" AUTOCOMPLETE='ON' onSubmit="return valida()"> <span class="login">Usuario:</span> <input type="text" name="usu" size="50" maxlength="50" > <br> <br> <span class="login">Senha:</span> <input type="password" name="senha" size="50" maxlength="50" > <br> </p> <p><br> <input type="submit" class="login" value="Entrar"> <br> <br> </p> </form> </body> </html> testeconectar.php <html> <?php set_time_limit(0); function valida_ldap($srv, $usr, $pwd) { $ldap_server = $srv; $auth_user = $usr; $auth_pass = $pwd; // Tenta se conectar com o servidor if (!($connect = @ldap_connect($ldap_server))){ return FALSE; } // Tenta autenticar no servidor if (!($bind = @ldap_bind($connect, $auth_user, $auth_pass))) { // se nao validar retorna false return FALSE; } else { // se validar retorna true return TRUE; } } // fim funcao conectar ldap $dominio = "@meudominio.local"; $usu = $_REQUEST['usu'].$dominio; $senha = $_REQUEST['senha']; $ip_server = "192.168.1.3"; if (valida_ldap($ip_server, $usu, $senha)) { echo "usuario autenticado<br>"; session_start(); $_SESSION['usu'] = $usu; header("Location: painel.php"); }else { echo "Usuario ou Senha Invalidos"; echo "<br><input type='button' value='voltar' onclick='location.href=\"index.php\";'>"; } ?> Muito obrigado!
  3. Jony Peterson

    Erro ao logar

    Prezados bom dia Estou fazendo uma aplicação para logar utilizando matricula, ao digitar a matricula está retornando dizendo que não existe no banco de dados, já adicionei no banco de dados, mudei de numero para texto, mas mesmo assim retorna que não existe tão registro no banco, se puderem me ajudar ficarei imensamente grato. Segue o código <HTML> <HEAD> <TITLE>MATRICULA</TITLE> </HEAD> <? $login_matricula=$_POST["login_digitado"]; $link=mysql_connect("localhost", "root", "") or die ("<h1>Não foi possivel conectar '''</h1> ".mysql_error()); $banco=mysql_select_db("despacho001", $link) or die ("<h1>Erro ao abrir o banco de dados '''</h1> ".mysql_error()); $busca=mysql_query("SELECT matricula FROM operador WHERE matricula ='$login_digitado'") or die ("<h1>Não foi possivel realizar buscas: '''</h1> ".mysql_error()); while ($reg=mysql_fetch_assoc($busca)) { $matricula_db = $reg["matricula"]; } if ($login_digitado=="") { echo "<BR><BR><center><h2>Matricula não pode ter valor nulo</h2></center>"; echo "<BR><center><a href=\"matricula.php\">Clique aqui para se matricular</a></center>"; } else { if ($matricula_db==$login_digitado) { echo "<BR><BR><center><h2>Matricula não existe ou incorreta</h2></center>"; echo "<BR><center><a href=\"matricula.php\">Clique aqui para se matricular</a></center>"; } } mysql_free_result($busca); mysql_close ($link); ?> </BODY> </HTML> O bando de dados chama-se despacho001 e dentro tem uma tabela com o nome operador CAMPO | TIPO || EXTRA codigo | int(11) auto_increment matricula| varchar(10) nome | varchar(25) Do mais tenham um bom dia. P.s: A MENSAGEM QUE RETORNA AO DIGITAR A MATRICULA é "Matricula não pode ter valor nulo"
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.