Jump to content

Search the Community

Showing results for tags 'matrizes'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 10 results

  1. segue a baixo a questão, a minha duvida é o seguinte, como fazer a soma dos valores recebidos... onde coloca-los para receber o valor certinho, como diz na questão que cada fileira tem um valor, isso eu não entendi ainda A faculdade X pensou em montar um projeto para ajudar os acadêmicos de Engenharia da Computação a levantar dinheiro para sua formatura, a faculdade agora montou uma armário 2 linhas e 13 colunas, ou seja dois andares de armários até 13 totalizando 26 armários disponíveis. Sua tarefa agora é desenvolver um controle para uso de moedas para utilizar os armários. O valor determinado para cada armário é: Armários da fileira debaixo custam R$ 0,50 Armários da fileira superior R$ 1,00. A cada armário mais distante do canto inicial é adicionado R$ 0,10 no valor. Seu programa deverá ter as funcionalidades abaixo: 1 – Exibir todos os armários identificando disponíveis e ocupados. 2 – Exibir todos os armários e o valor recebido até então. 3 – Utilizar armário. Para utilizar o armário deverá informar seu número da linha e da coluna. Se estiver sendo utilizado deve informar: ARMARIO OCUPADO. 4 – Liberar armário. Para liberar o armário deverá informar seu número da linha e da coluna. Se estiver vago deve informar: ARMARIO JÁ ESTA VAGO. 5 – Realizar recebimento. (Nesta funcionalidade você terá que zerar os valores recebidos e contabilizar quanto foi lucrado). 6 – Sair. (Só poderá sair se todos os armários estiverem desocupados, ou seja, deverá realizar o recebimento antes de sair).
  2. Segue abaixo um problema podendo usar vetores ou matrizes, eu não estou conseguindo fazer ele direito, se puderem me ajudar agradeceria A faculdade X pensou em adotar armários para os alunos deixarem seus materiais, da mesma forma que as universidade Americanas. Com isso, ela pensou nos alunos de Engenharia da Computação para montar a automação deste sistema. Para testar o sistema terá que controlar 10 armários. Monte um menu de opções que será exibido num display de controle conforme o exemplo abaixo e implemente as rotinas para que cada opção do menu funcione corretamente: MENU 1 – Mostrar a situação de todos os armários, exemplo: Armario 0: Ocupado, Armario 1: Ocupado, Armario 2: Livre... 2 – Mostrar os armários livres, exemplo: Armario 2, Armario 4, Armario 8... 3 – Utilizar Armário: Informar o número de um armário livre e marcá-lo como ocupado, caso o armário estiver ocupada avisar o usuário ARMARIO SENDO UTILIZADO. 4 – Remover Armário: Informar o número de um armário ocupado e fazer a liberação do armário, caso o armário estiver livre avisar o usuário ARMARIO NAO ESTA SENDO UTILIZADO. 5 – Resumo do Armário, exemplo: 3 Armários livres, 7 Armários ocupados 0 - Sair Observações: O programa deve iniciar com todos os Armários livres e o menu deve ficar em loop infinito, ou seja, depois de escolher qualquer opção deve sempre voltar ao menu. O menu deve tratar opções inválidas.
  3. halfar

    matriz em div é possível?

    É possível criar uma div com elemento ID como matriz? Assim: <div id[1] =nome1></div> <div id[2] =nome2></div> <div id[3] =nome3></div>
  4. Alguem poderia me ajudar? estou tentando multiplicar duas matrizes, A e B e salvar o resultado em C o resultado nao ta certo, to usando thread so queria uma opinião para saber se ta certo o que to fazendo, pq o que ta me intrigando eh que os valores da linha da matriz C nao altera #include<stdio.h> #include<stdlib.h> #include<pthread.h> pthread_t thread_1; pthread_t thread_2; pthread_t thread_3; int a[3][2] = {{1, 4}, {2, 5}, {3, 6}}; int b[2][3] = {{7, 8, 9}, {10, 11, 12}}; int c[3][3] = {{1, 2, 3}, {0, 0, 0}, {0, 0, 0}}; void* tarefa_1(void *p) { printf("\nThread1\n"); for (int col = 0; col < 3; col++) { // Multiplica a linha de A pela coluna de B. for (int i = 0; i < 2; i++) { c[1][col] += a[1][i] * b[i][col]; } printf("%i\t",c[1][col]); printf("\n"); } } void* tarefa_2(void *p) { printf("\nThread2\n"); for (int col = 0; col < 3; col++) { // Multiplica a linha de A pela coluna de B. for (int i = 0; i < 2; i++) { c[2][col] += a[2][i] * b[i][col]; } printf("%i\t",c[2][col]); printf("\n"); } } void* tarefa_3(void *p) { printf("\nThread3\n"); for (int col = 0; col < 3; col++) { // Multiplica a linha de A pela coluna de B. for (int i = 0; i < 2; i++) { c[3][col] += a[3][i] * b[i][col]; } printf("%i\t",c[3][col]); printf("\n"); } } int main() { printf("Inicio das Threads...\n"); // inicia as duas threads, passando como parametroa thread e a função que cada uma deve executar pthread_create(&thread_1, NULL, tarefa_1, NULL); pthread_create(&thread_2, NULL, tarefa_2, NULL); pthread_create(&thread_3, NULL, tarefa_3, NULL); // faz com que a thread principal espere a thread 1,2,3 acabarem; pthread_join(thread_1, NULL); pthread_join(thread_2, NULL); pthread_join(thread_3, NULL); printf("resultado da tabela 3\n"); for(int i = 0;i<3; i++){ for(int j= 0; j<3;j++){ printf("%i\t ",c[i][j]); } printf("\n"); } exit(0); }
  5. AkireDuda

    MATRIZES E VETORES EM C

    Hello, preciso fazer uma questão da faculdade sobre matrizes e vetores. Tentei fazer e o programa não executa, não consigo identificar os erros mais grosseiros. Será que alguma boa alma conhecedora de programação em C poderia ajudar esta nobre pessoa? 20. Leia uma matriz 100 x 10 que se refere respostas de 10 questões de múltipla escolha, referentes a 100 alunos. Leia também um vetor de 10 posições contendo o gabarito de respostas que podem ser a, b, c ou d. Seu programa deverá comparar as respostas de cada candidato com o gabarito e emitir um vetor Resultado, contendo a pontuação correspondente. #include<stdio.h> #include<conio.h> #include<stdlib.h> int main () { int i,j; char matriz[100][10]; char acertos[10]; int gab[10]; int nota; for (i=0;i<10;i++) { printf ("\nResposta de cada aluno:\n\n"); printf ("\nQuestao",i,"Marque a-b-c-d = "); scanf ("%c",&nota); gab = nota; } for (i=0;i<100;i++){ acertos=0; for (j=0;j<10;j++) printf ("\nInforme resposta da",j,"[", i, " , ", j, " ]"); scanf ("%c",&nota); matriz[j]=nota; if (matriz[j] = gab){ acertos= acertos + 1; } } for (i=0;i<10;i++){ printf("O aluno ", i, " teve ", acertos," acertos!"); } getch(); return(0); }
  6. Spaceman._

    Ajuda (Matrizes)

    Olá amigos, sou novo aqui no fórum, estou fazendo um trabalho da faculdade, onde tenho que desenvolver um algoritmo que contenha matrizes bidimencionais e vetores, eu tive a ideia de montar um algoritmo que simule a entrada em um site adulto, este funcionaria da segunda forma, adicionaria o nome dos usuários no vetor de caracteres e suas idades no vetor de numeros, após isso exibiria seus nomes e idade e diria se ele pode entrar ou não, só que ta todo bugado e eu não sei como resolver rsrs, podem me ajudar? valeeu :) segue o algoritmo: #include <iostream> using namespace std; int main (){ int id [5], x=0; char nome [5][30]; int n=0, i=0; for (x=0 ; x<6; x++){ cout<<"Insira o "<< n+1<< " nome: \n"; // n+1 ordena as idades gets(nome[x]);// insere os caracteres cout<<"Insira a " <<i+1<< " idade: \n"; // i+1 ordena as idade cin>> id[x]; // insere as idades } for (x=0 ; x<6; x++){ //bloco de exibição if(id[x]>=18){ cout<< nome [x] << " tem " <<id[x]<< "anos, pode entrar"; //teste condicional } else{ cout<< nome [x] << "tem" <<id[x]<< "anos, não pode entrar"; } } system ("pause"); return 0; }
  7. Estou estudando algoritmos e lógica de programação, logo, sempre tento comparar meu código com o do professor, para aprimorar minha aprendizagem. Analisando quantidade de linhas, lógica usada, rotinas, entre outros... Para definir onde posso melhorar ou não. Vocês experientes (ou não) podem me falar quais critérios devo levar em conta, ao comparar dois pseudocódigos e se isso é uma ação válida, isto é, vai acrescentar na minha vida? Abaixo segue o código do professor e o meu. Meu código: algoritmo "Dissecando Matrizes" var opcao, L, C:inteiro M: vetor [1..4, 1..4] de inteiro Procedimento Menu() inicio EscrevaL ("") EscrevaL ("======================") EscrevaL ("MENU DE OPÇÕES") EscrevaL ("======================") EscrevaL ("[1] Mostrar a Matriz") EscrevaL ("[2] Diagonal Principal") EscrevaL ("[3] Triângulo Superior") EscrevaL ("[4] Triângulo Inferior") EscrevaL ("[5] Sair") Escreva ("===== OPÇAO: ") Leia (opcao) FimProcedimento inicio Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Escreva ("Digite o valor para posição [ ",L,", ",C,"]: ") Leia (M[L,C]) FimPara FimPara LimpaTela Repita Menu() Repita Escolha opcao Caso 1 LimpaTela Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Escreva (M[L,C]:2) Fimpara EscrevaL () FimPara Menu() Caso 2 LimpaTela Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Se (L = C) entao Escreva (M[L,C]:2) Senao Escreva (" ":2) FimSe Fimpara EscrevaL() FimPara Menu() Caso 3 LimpaTela Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Se(L = C - 1) ou (L = c - 2) ou (L = C - 3) entao Escreva (M[L,C]:2) Senao Escreva (" ":2) FimSe FimPara EscrevaL () FimPara Menu() Caso 4 LimpaTela Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Se (L = C + 1) ou (L = c + 2) ou (L = C + 3) entao Escreva (M[L,C]:2) Senao Escreva (" ":4) FimSe FimPara EscrevaL () FimPara Menu() Caso 5 LimpaTela Escreva ("SAINDO...") FimEscolha Ate (opcao = 5) Ate (opcao = 5) LimpaTela Escreva ("SAINDO...") fimalgoritmo Código do professor: var m: vetor[1..4, 1..4] de Inteiro l, c, op: Inteiro Procedimento MostraMatriz() inicio Para l <- 1 ate 4 faca Para c <- 1 ate 4 faca Escreva(m[l,c]:4) FimPara EscrevaL() FimPara FimProcedimento Procedimento DiagonalPrincipal() var t: inteiro inicio Para l <- 1 ate 4 faca EscrevaL(m[l,l]:4) Para t <- 1 ate l faca Escreva(" ") FimPara FimPara FimProcedimento Procedimento TrianguloSuperior() var t: Inteiro inicio Para l <- 1 ate 3 faca Escreva(" ") Para c <- l+1 ate 4 faca Escreva(m[l,c]:4) FimPara EscrevaL() Para t <- 1 ate l faca Escreva(" ") FimPara FimPara EscrevaL() FimProcedimento Procedimento TrianguloInferior() inicio Para l <- 2 ate 4 faca EscrevaL() Para c <- 1 ate l-1 faca Escreva(m[l,c]:4) FimPara FimPara EscrevaL() FimProcedimento inicio Para l <- 1 ate 4 faca Para c <- 1 ate 4 faca Escreva("Digite valor para a posicao [", l, ",", c, "]: ") Leia(m[l,c]) FimPara FimPara LimpaTela Repita EscrevaL() EscrevaL("MENU DE OPCOES") EscrevaL("====================") EscrevaL("[1] Mostrar a Matriz") EscrevaL("[2] Diagonal Principal") EscrevaL("[3] Triangulo Superior") EscrevaL("[4] Triangulo Inferior") EscrevaL("[5] Sair") Repita EscrevaL("===== OPCAO: ") Leia(op) Ate (op >=1) e (op <=5) LimpaTela Escolha op Caso 1 MostraMatriz() Caso 2 DiagonalPrincipal() Caso 3 TrianguloSuperior() Caso 4 TrianguloInferior() Caso 5 EscrevaL("ENCERRANDO...") FimEscolha Ate (op = 5) fimalgoritmo Em minha análise amadora, entendo que o meu foi melhor construído que o do professor, o que acham?
  8. alexandremcf

    Formatação de Matriz C++

    cd
  9. Poligno

    Matrizes com caracteres(INICIANTE).

    Olá pessoal,mais uma vez rsrs Tenho que fazer um código que leia duas strings com 5 nomes cada uma,e escrever os nomes que aparecem em AMBAS as listas. Eu fiz o teste a mão no meu código e me parece tudo ok,porem quando vou executa-lo ele le apenas o primeiro nome da primeira stringa e imprime um monte de coisa aleatória na tela ,não sei onde estou errando, a baixo o meu código: #include<stdlib.h> #include<stdio.h> #include<math.h> #include<string.h> int main() { int i,j,k,l,cont,aux2,pos,cont2=0,cont3=0,sal[5],iaux; char nom[5][50],nom2[5][50],aux[5][50]; printf("Digite os nomes da lista 1:\n"); for(i=0;i<5;i++){ scanf("%[^\n]s",nom); } printf("Digite os nomee da lista 2:\n"); for(i=0;i<5;i++){ scanf("%[^\n]s",nom2); } iaux=0; for(i=0;i<5;i++){ for(j=0;j<5;j++) if(strcmp(nom,nom2[j])==0){ strcpy(aux[iaux++],nom); } } for(i=0;i<50;i++){ printf("Nome:%s\n",aux); } return 0; }
  10. GMVieira

    Matriz Visualg

    EXERCÍCIO: Faça uma subrotina que receba uma matriz 10x10, o número de uma linha, o número de uma coluna e retorne uma matriz 9x9, resultante da remoção da coluna e da linha informados. Comecei a fazer no visualg até onde eu consegui, mas meu algoritmo esta errado porque ele não consegue pular a linha e coluna eliminadas, tirando só o valor e fazendo como se ainda existisse 10 linhas e 10 colunas. Alguém poderia me ajudar? algoritmo "Matriz" var matriz10: vetor [1..10,1..10] de inteiro matriz9: vetor [1..9,1..9] de inteiro linha,coluna,l,c: inteiro inicio para linha de 1 ate 10 faca para coluna de 1 ate 10 faca matriz10[linha,coluna] <- 10 fimpara fimpara escreval ("Informe a linha (1 a 10) ") leia (l) escreval ("Informe a coluna (1 a 10) ") leia © para linha de 1 ate 10 faca para coluna de 1 ate 10 faca se ( (linha <> l) e (coluna <> c) ) entao matriz9[linha,coluna]<- matriz10[linha,coluna] fimse fimpara fimpara fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.