Jump to content

Search the Community

Showing results for tags 'parse'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Calendars

  • Comunidade iMasters

Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 5 results

  1. 7Canim

    Enviar dados via SOAP

    Bom dia Estou desenvolvendo um sistema que faça conexão com o SISBOV e algumas funções estão dando erros. Estou testando vários códigos diferentes e dão diferentes erros, mas no suapUi está funcionando normal Esse é o XML que eu preciso cadastrar <?php try { $wsdl_url = 'http://homolog.agricultura.gov.br/sisbov_ws_nova_hom/'; $client = new SOAPClient($wsdl_url); $params = array( 'usuario' => "XXXXXXXXXX", 'senha' => "XXXXXXXXXX", 'nirf' => "XXXXXXX", 'incra' => "XXXXXXXXXX", 'tipoPropriedade' => "X", 'nomePropriedade' => "XXXXXXXXXX", 'acessoFazenda' => "XXXXXXXXXX", 'distanciaSedeMunicipio' => "XXXXXXXXXX", 'orientacaoLatitude' => "X", 'grauLatitude' => "XX", 'minutoLatitude' => "XX", 'segundoLatitude' => "X", 'orientacaoLongitude' => "X", 'grauLongitude' => "XX", 'minutoLongitude' => "XX", 'segundoLongitude' => "XX", 'area' => "XXXXXXXXXX", 'logradouro' => "XXXXXXXXXX", 'bairro' => "XXXXXXXXXX", 'cep' => "XXXXXXXXXX", 'codMunicipio' => "XXXXXXXXXX", 'enderecoCorrespondenciaLogradouro' => "XXXXXXXXXX", 'enderecoCorrespondenciaBairro' => "XXXXXXXXXX", 'enderecoCorrespondenciaCep' => "XXXXXXXXXX", 'enderecoCorrespondenciaCodMunicipio' => "XXXXXXXXXX", 'telefoneResidencial' => "", 'faxResidencial' => "", 'nrTelefoneContato' => "XXXXXXXXXX", 'nrFaxContato' => "XXXXXXXXXX", ); $return = $client->incluirPropriedade($params); print_r($return); } catch (Exception $e) { echo "Exception occured: " . $e; } Tanto o incluirPropriedade como o alterarPropriedade dá errado nos 4 códigos diferentes que eu tentei. Nesse código dá o erro ERR_CONNECTION_RESET (estou usando Google Chrome) <?php ini_set("soap.wsdl_cache_enabled", "0"); // Desabilita Cache do WSDL $config['soap']['usuario']="XXXXXXXXXXXX"; //Nome do Usuario == CNPJ da Certificadora $config['soap']['senha']="XXXXXXXXXXXX"; //Senha == Senha do FTP $config['soap']['uri']="http://servicosWeb.sisbov.mapa.gov.br"; //NameSpace do WSDL $config['soap']['location']='http://homolog.agricultura.gov.br/sisbov_ws_nova_hom/';//ENDERECO DO WSDL DO WEBSERVICES $client = new SoapClient(null, array('uri' => $config['soap']['uri'], 'location' => $config['soap']['location'])); //Cria o Cliente de WebServices try { //Tente Executar a Chamada //Object incluirPropriedade(string usuario, string senha, string nirf, string incra, long TipoPropriedade, string nome, string roteiroDeAcesso, int distanciaSedeMunicipio, string orientacaoLatitude, int grauLatitude, int minutoLatitude, int segungaLatitude, string orientacaoLongitude, int grauLongitude, int minutoLongitude, int segundoLongitude, long area, string endereco, string bairro, string cep, string codMunicipio, string EnderecoCorres, string bairroCorres, string cepCorres, string codMunicipio, string telefoneResidencial, string faxResidencial, string telefoneContado, string faxContato); $retorno = $client->incluirPropriedade($config['soap']['usuario'], $config['soap']['senha'], 'XXXXXXXXX', '', 1, 'Fazendinha do Bita', 'XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX', 4500, 'S', 20, 29, 0, 'W', 51, 54, 11, 1321800, 'No meio do mato', '...', '79600000', '5008305', 'Rua qualquer', 'Centro', '79600000', '5008305', '', '', '12345678', '12345678'); //Chama a funcao no WebServices print_r($retorno); //Exibe Resultado na Tela } catch (SoapFault $exception) { //Em caso de erros echo $exception; //Exibe erros na tela } Nesse código, o XML pede long, mas o PHP não tem long então dá erro de conversão O erro: SoapFault exception: [soapenv:Server.userException] org.xml.sax.SAXException: Bad types (int -> long) in C:\xampp\htdocs\TestePHP\alterar\alterarPropriedade.php:13 Stack trace: #0 C:\xampp\htdocs\TestePHP\alterar\alterarPropriedade.php(13): SoapClient->__call('alterarPropried...', Array) #1 {main} <?php $url = 'http://homolog.agricultura.gov.br/sisbov_ws_nova_hom/'; $client = new SoapClient($url); $xmlr = new SimpleXMLElement('<incluirPropriedade></incluirPropriedade>'); $xmlr->addChild('usuario', 'XXXXXXXXXXXXXXX'); $xmlr->addChild('senha', 'XXXXXXXXXXX'); $xmlr->addChild('nirf', 'XXXXXXXXX'); $xmlr->addChild('incra', 'XXXXXXXXXXXX'); $xmlr->addChild('tipoPropriedade', '1'); $xmlr->addChild('nomePropriedade', 'Fazendinha do Bita'); $xmlr->addChild('acessoFazenda', 'XXXXXXXXXXXXXXXX'); $xmlr->addChild('distanciaSedeMunicipio', '4500'); $xmlr->addChild('orientacaoLatitude', 'S'); $xmlr->addChild('grauLatitude', '20'); $xmlr->addChild('minutoLatitude', '29'); $xmlr->addChild('segundoLatitude', '0'); $xmlr->addChild('orientacaoLongitude', 'W'); $xmlr->addChild('grauLongitude', '51'); $xmlr->addChild('minutoLongitude', '54'); $xmlr->addChild('segundoLongitude', '11'); $xmlr->addChild('area', '1321800'); $xmlr->addChild('logradouro', 'No meio do mato'); $xmlr->addChild('bairro', '...'); $xmlr->addChild('cep', '79600000'); $xmlr->addChild('codMunicipio', '5008305'); $xmlr->addChild('enderecoCorrespondenciaLogradouro', 'Rua qualquer'); $xmlr->addChild('enderecoCorrespondenciaBairro', 'Centro'); $xmlr->addChild('enderecoCorrespondenciaCep', '79600000'); $xmlr->addChild('enderecoCorrespondenciaCodMunicipio', '5008305'); $xmlr->addChild('telefoneResidencial', ''); $xmlr->addChild('faxResidencial', ''); $xmlr->addChild('nrTelefoneContato', '12345678'); $xmlr->addChild('nrFaxContato', '12345678'); $params = new stdClass(); $params->xml = $xmlr->asXML(); $result = $client->incluirPropriedade($params); Nesse código dá o mesmo erro ERR_CONNECTION_RESET (estou usando Google Chrome) <FONTES!!!> O primeiro código é do netbeans mesmo, o segundo tirei de um outro desenvolvedor SISBOV, e o terceiro adaptei da internet (não achei o tópico) Já tentei desabilitar esse erro do Chorme, mas não consegui Se alguém souber como me ajudar, por favor Desde já, obrigada
  2. Olá Estou tentando capturar a imagem de um banco de dados mysql, já tentei fazer a leitura de um campo tipo blob não deu certo, então pensei em simplesmente criar um campo no bd e referenciar onde está a imagem mas me deparo com o seguinte erro: Parse error: syntax error, unexpected '$produto' (T_VARIABLE), expecting ',' or ';' in C:\Program Files\NetMake\v9\wwwroot\boletosite\cursos.php on line 148 <table data-minrequestedwidth="934" data-computedwidth="934" style="width: 934px;"> <tbody> <?php $Servidor = '127.0.0.1:3306'; $Usuario = 'root'; $Senha = 'senha'; $Banco = 'bd_boleto'; $Conexao = mysqli_connect($Servidor, $Usuario, $Senha); if (mysqli_connect_errno()) { printf("Connect failed: %s\n", mysqli_connect_error()); exit(); } mysqli_SELECT_DB($Conexao, $Banco); $cmd = "SELECT * FROM curso"; $produtos = mysqli_query($Conexao, $cmd); While($produto = mysqli_fetch_array($produtos)) { $seq1 = $produto['seq']; ?> <tr> <td colspan="3" rowspan="1" <style="text-align: center; width: 926px; height: 21px; margin-top: 0px; margin-left: 0px;" class="imVc"> <?php echo $produto['titulo'];?> </td> </tr> <tr> <td style="text-align: center; height: 21px; width: 304px;" class="imVc"> <?php echo $produto['descricao'];?> </td> <td colspan="2" rowspan="1" style="text-align: justify; width: 615px; height: 21px; margin-top: 0px; margin-left: 0px;" class="imVt"> <?php echo "<img src="$produto['endfoto']">";?> </td> </tr> <?php } ?> </tbody> </table> A linha 148 seria essa: <?php echo "<img src="$produto['endfoto']">";?> Procurei por aqui e tentei de várias maneiras mas não obtive sucesso. Onde estou errando? Abraços
  3. Fala pessoal. Tudo bem!? Estou com um erro que está me deixando maluco. Estou tentando fazer um parse de string para datetime e não estou conseguindo. var dt = DateTime.ParseExact(data, "dd/MM/yyyy", CultureInfo.InvariantCulture, DateTimeStyles.None); A variável data vem de uma requisição AJAX (Angular) via POST. public JsonResult ListaParcelas(string codigo, string tipo, string data = null, int? leiAgregacao = null, IList<ParcelaAgregacao> parcelas = null) Ao tentar passar essa linha acima, ele gera o erro: "Cadeia de caracteres não foi reconhecida como DateTime válido" Vamos aos detalhes.... A variável {data} está com a data formata de hoje, ou seja, 20/06/2017. Abrindo o Immediate Window e tentar executar: DateTime.ParseExact(data, "dd/MM/yyyy", CultureInfo.InvariantCulture, DateTimeStyles.None); Gera erro. Porém, se executar: DateTime.ParseExact("20/06/2017", "dd/MM/yyyy", CultureInfo.InvariantCulture, DateTimeStyles.None); Funciona. OK... Como uma forma de tentar resolver o problema, resolvi fazer um SPLIT dessa informação pela barra e dar um new Date informando cada campo separadamente. Para minha surpresa, apresenta um erro de parse no momento de converter para int o dia. if (!string.IsNullOrEmpty(data)) { var parteData = data.Split(@"/".ToCharArray()); var dia = int.Parse(parteData[0]); var mes = int.Parse(parteData[1]); var ano = int.Parse(parteData[2]); dataVencimento = new DateTime(ano, mes, dia); } E este problema só ocorre com o Internet Explorer e o Microsoft Edge. Se eu utilizar o Google Chrome, Firefox, Opera, Safari, etc etc etc, funciona. Alguma dica?
  4. o objetivo seria :Crie um programa que solicite ao usuário que digite 10 números e armazene-os em um array. O programa deve mostrar, no final, os números em ordem inversa à qual foram digitados e a soma de todos os números digitados. porem só consigo fazer ate a soma de numeros,não consigo deixar ele em ordem inversa. <script type="text/javascript"> var m1,m2,m3,m4,m5,m6,m7,m8,m9,m10; m1=parseFloat(prompt("forneca o 1 numero","")); m2=parseFloat(prompt("forneca o 2 numero","")); m3=parseFloat(prompt("forneca o 3 numero","")); m4=parseFloat(prompt("forneca o 4 numero","")); m5=parseFloat(prompt("forneca o 5 numero","")); m6=parseFloat(prompt("forneca o 6 numero","")); m7=parseFloat(prompt("forneca o 7 numero","")); m8=parseFloat(prompt("forneca o 8 numero","")); m9=parseFloat(prompt("forneca o 9 numero","")); m10=parseFloat(prompt("forneca o 10 numero","")); var result= m1 + m2 + m3 + m4 + m5 + m6 + m7 + m8 + m9 + m10; alert (result); </script>
  5. <script type="text/javascript"> var i=10; var num=new array(10); while(i>=1){ num=prompt("forneca o numero","")); i--; } document.write(num); alert(num[x]); </script> porem não abre
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.