Ir para conteúdo

Pesquisar na Comunidade

Mostrando resultados para as tags ''preg_match_all''.

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Todas as áreas do Fórum

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Encontrar resultados em...

Encontrar resultados que...


Data de Criação

  • Início

    FIM


Data de Atualização

  • Início

    FIM


Filtrar pelo número de...

Data de Registro

  • Início

    FIM


Grupo


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Encontrado 3 registros

  1. BrunoBit

    [Resolvido] preg_match_all

    Fala rapaziada. Estou com um problema aqui, acredito que seja algo bem simples, porém não estou identificando. Eu tenho o seguinte regex, bem simples: preg_match_all("/<div class='job-description show-for-medium-up'>(.*)<\/div>/", $get , $match); o meu $get onde quero pegar o conteúdo é esse: <div class='job-description show-for-medium-up'> Addus HomeCare offers a very competitive salary! 20%-30% bonus of the annual salary along with quarterly bonuses! Excellent benefits that start from day one of employment! Growth Opportunities! It’s an exciting time in the healthcare industry and Addus is... </div> E meu resultado é esse: Array ( [0] => Array ( ) [1] => Array ( ) ) Eu quero pegar todo o conteúdo que está dentro dessas div: <div class='job-description show-for-medium-up'> [...conteúdo] </div> Qual erro estou cometendo no regex? Desde já agradeço rapaziada, abração e fiquem com Deus.
  2. Bruno Gama

    Como utilizar preg_match_all neste trecho?

    Site de onde quero pegar os dados Eu preciso utilizar preg_match_all para pegar o que está dentro de <table class="grid-table survey-info" cellspacing="0"> Por enquanto fiz o seguinte <?php $url = 'http://metadados.capes.gov.br/index.php/catalog/100'; $dadosSite = file_get_contents($url); preg_match_all('/(O que falta)/', $dadosSite, $conteudo); $echo conteudo[0][0]; ?>
  3. matheusmarson

    problema com preg_match_all para upload imagem

    Olá a todos Estou com um problema muito estranho aqui. Tenho um script para upload de imagens via ajax e jquery. Utilizo está função a bastante tempo e sempre funcionou bem. Ocorre que em um projeto que implementei o script ele começou a dar problema Algumas imagens ele faz o upload e e outras (a maioria) não As imagens tem tamanhos diferentes e independente se é muito pesada, grade ou pequena ele hora faz o upload e hora não. Portanto não é problema com tamanho das imagens o aquivo que deveria faze o upload é o seguinte: <?php session_start(); if (isset($_POST['img'])){ if (!preg_match_all('/^data:image\/(.*);base64,(.*)$/m', $_POST['img'], $match)) die ('ERRO AO OBTER IMAGEM'); $img_name = md5(uniqid(rand(), true)) . '.' .$match[1][0]; $img_source = base64_decode($match[2][0]); $destino = '../fotos/perfil/' . $img_name; if (file_put_contents($destino, $img_source) === FALSE) die ('ERRO AO SALVAR IMAGEM'); print "NOVA IMAGEM CARREGADA COM SUCESSO!!! | $img_name"; $_SESSION["foto_perfil_user"] = $img_name; } ?> Alguem teve problema parecido e sabe me dizer como resolver? Localmente aqui em minha máquina está perfeito, faz o upload de qualquer imagem A pasta de destino da imagem já está com a permissão de escrita também, tudo certo. Oque pode estar havendo? Seria algo com a função no host? obrigado desde já
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.