Jump to content

Search the Community

Showing results for tags 'require_once'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Web Development
    • HTML e CSS
    • Javascript
    • PHP
    • Ruby
    • Python
    • Java
    • .NET
    • Docker, Kubernets and other environments
    • WordPress
    • Mobile
    • Agile
    • Desenvolvimento de Games
    • Banco de Dados
    • Design and UX
    • Algoritmos & Outras Tecnologias
  • Entretenimento e uso pessoal
    • Segurança & Malwares
    • Geral
    • iMasters's pub

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 4 results

  1. marcelosbraga01

    Problemas com as Imagens Utilizando requeri_once

    Boa noite Senhores, estou aprendendo PHP, fazendo um site com as seguintes configurações: Tenho uma pagina chamada index.php que contém o seguinte conteúdo: <?php require_once ("pag/topo.php"); require_once ("pag/menu.php"); require_once ("pag/conteudo.php"); require_once ("pag/rodape.php"); ?> Na minha pagina menu.php possui um menu ao acessar esses outros links, percebi que minha página perde a referência dos diretórios, pois as páginas de links estão em outras pastas. Por exemplo: a página topo.php possui o seguintes conteúdo: <div class="container"> <img class="img-responsive" src="img/logo_ipsemcp.gif"> <img class="img-responsive" src="img/esc_ipsem.png"> </div> Quando estou na pagina principal, index.php funciona tudo normalmente, quando navego pelo site, com a estrutura que criei, ele perde a referencia dos endereços de imagens, css e etc... Não estou conseguindo enxergar...
  2. Olá! Pessoal, misteriosamente após algumas alterações a página ficou branca, ou seja, simplesmente não é exibida. Por favor me ajudem! Pois é de um cliente. Só funciona se eu inserir o código da header_home2.php no lugar do require, e não desejo isso. Código que chama a header_home2.php <?php require_once("include/head.php"); ?> <body> <div style="display:none;" class="tips"><?=__FILE__?></div> <div class="tail-top"> <?php require_once (DIR_BLOCO . "/header_home2.php"); //require_once(DIR_BLOCO . "/bloco_busca_topo.php"); ?> <div class="ImageTop"> <?php require_once(DIR_BLOCO . "/bannerhome.php"); ?> <?php require_once(DIR_BLOCO . "/bloco_busca_home.php"); ?> </div> <div class="mainhome"> <?php require_once(DIR_BLOCO . "/autenticacao.php"); /*require_once(DIR_BLOCO . "/box_mapa.php");*/ require_once(DIR_BLOCO . "/bloco_anuncios_destaques.php"); require_once(DIR_BLOCO . "/bloco_banners_meio.php"); require_once(DIR_BLOCO . "/bloco_cidades_destaque.php"); require_once(DIR_BLOCO . "/bloco_noticias_destaques.php"); require_once(DIR_BLOCO . "/bloco_botao_anuncie_rodape.php"); ?> </div> </div> <?php require_once(DIR_BLOCO . "/rodape.php"); ?> </body> </html> header_home2.php (alterada por mim) <?php $sql = "select idpai,id,name,tipo,link,linkexterno,target from category where ( idpai=0 or idpai is null) and zone='group' and display = 'Y' order by sort_order desc"; $rs = mysql_query($sql); $sqlP = "select status from page where id = 'about_us'"; $rsP = mysql_query($sqlP); $rowP = mysql_fetch_assoc($rsP); $sqlA = "select status from page where id = 'about_terms'"; $rsA = mysql_query($sqlA); $rowA = mysql_fetch_assoc($rsA); ?> <div style="display:none;" class="tips"><?=__FILE__?></div> <style> a{ color:#fff; } </style> <div class="headertop"> <div id="header_content" style="height: auto;"> <div id="header_links" style="background-color: #00307d;"> <div style="margin-top: 0px; font-size: 13px;color:#ffffff;"> <?php if($login_user){ ?> <? if($INI['option']['anunciousuario'] == "Y" ){?> <a href="<?=$ROOTPATH;?>/adminanunciante/team/edit.php"><img style="width:21px;margin-left:8px;" src="<?=$PATHSKIN;?>/images/ico_conta.png"> Anunciar Imóvel</a> <a href="<?=$ROOTPATH;?>/adminanunciante/"><img style="width:21px;margin-left:8px;" src="<?=$PATHSKIN;?>/images/ico_conta.png"> Meus Anúncios</a> <? } ?> <a href="<?=$ROOTPATH;?>/autenticacao/logout.php"><img style="width:21px;margin-left:8px;" src="<?=$PATHSKIN;?>/images/ico_off.png"> Sair</a> <?} else {?> <a class='tk_logar' href="#"><img style="width:21px;" src="<?=$PATHSKIN;?>/images/ico_entrar.png">Anunciar Imóvel </a> <a class='tk_logar' href="#"><img style="width:21px;" src="<?=$PATHSKIN;?>/images/ico_entrar.png">Entrar </a> <a class='tk_cadastrar' href="#"><img style="width:21px;margin-left:8px;" src="<?=$PATHSKIN;?>/images/ico_cadastrar.png">Cadastrar</a> <? } ?> </div> <a href="#"><img src="<?php echo $PATHSKIN."/images/bs_sistemas_ico.png"; ?>" style="width: 5%;"/></a> <div id="anunciar_gratis" style="display: flex; justify-content: space-around; align-items: center; background-color: #f26122; height: 35px; margin-top: -10px; padding-left: 20px; padding-right: 20px; font-size: 0.85em;" class="tips"> <a class='tk_logar' href="#" style="color: #ffffff;">Anunciar imóvel Grátis </a> </div> </div> <div class="div_logo"> <a href="<?=$ROOTPATH;?>"> <img class="logotipohome" border="0" src="<?=$ROOTPATH;?>/include/logo/logo.png"/></a> <ul> <?php /*while($l = mysql_fetch_assoc($rs)){ $tipocategoria = "categorias"; $linkid =""; if($l['linkexterno']!=""){*/?> <li class="formata_li parent"><img src="<?php echo $PATHSKIN."/images/ico_entrar.png"; ?>"/><a href="#">HOME</a></li> <li class="formata_li parent"><img src="<?php echo $PATHSKIN."/images/ico_entrar.png"; ?>"/><a href="#">FAVORITOS</a></li> <li class="formata_li parent"><img src="<?php echo $PATHSKIN."/images/ico_entrar.png"; ?>"/><a href="#">AVALIE SEU IMÓVEL</a></li> <li class="formata_li parent"><img src="<?php echo $PATHSKIN."/images/ico_entrar.png"; ?>"/><a href="#">BUSCA NO MAPA</a></li> <li class="formata_li parent"><img src="<?php echo $PATHSKIN."/images/ico_entrar.png"; ?>"/><a href="#">TEMPORADA</a></li> </ul> </div> </div> </div> <?php header_home2.php (original) <div style=" display:none;" class="tips"><?=__FILE__?></div> <style> a{ color:#fff; } </style> <div class="headertop"> <header style="height:103px;"> <div style="float:left;color:#000;margin-top:4px;width:442px;margin-left:122px;"> <a href="<?=$ROOTPATH?>"><img class="logotipohome" border="0" src="<?=$ROOTPATH?>/include/logo/logo.png"></a> </div> <!-- <div class="viplogo"></div> --> <div style="float: right; margin-top: 8px;margin-right:33px;"> <div style="margin-top: 0px; font-size: 13px;color:#000"> <?php if($login_user){ ?> <? if($INI['option']['anunciousuario'] == "Y" ){?> <a href="<?=$ROOTPATH?>/adminanunciante/team/edit.php"><img style="width:21px;margin-left:8px;" src="<?=$PATHSKIN?>/images/ico_conta.png"> Anunciar Imóvel</a> <a href="<?=$ROOTPATH?>/adminanunciante/"><img style="width:21px;margin-left:8px;" src="<?=$PATHSKIN?>/images/ico_conta.png"> Meus Anúncios</a> <? } ?> <a href="<?=$ROOTPATH?>/autenticacao/logout.php"><img style="width:21px;margin-left:8px;" src="<?=$PATHSKIN?>/images/ico_off.png"> Sair</a> <?} else {?> <a class='tk_logar' href="#"><img style="width:21px;" src="<?=$PATHSKIN?>/images/ico_entrar.png">Anunciar Imóvel </a> <a class='tk_logar' href="#"><img style="width:21px;" src="<?=$PATHSKIN?>/images/ico_entrar.png">Entrar </a> <a class='tk_cadastrar' href="#"><img style="width:21px;margin-left:8px;" src="<?=$PATHSKIN?>/images/ico_cadastrar.png">Cadastrar</a> <? } ?> </div> </div> </header> </div> <?php
  3. Saudações! Estou tendo problemas para chamar arquivos, quando carrego a página ele diz que diretório não foi encontrado, então corrijo o erro apontado, corrigido então, o outro arquivo dá o mesmo erro, corrigido então, o erro passa para o outro arquivo e assim segue nesse ciclo. Já tentei usar require_once, require, include, include_once, __autoload, spl_autoload_register, massssssss, nada funcionou! Give a light ! Oooh Big Oracle! Fatal error: Class 'DB' not found in C:\xampp\htdocs\RegistroPonto\controller\Controller.php on line 9 //essa é a classe Controller.php que fica na pasta controller <?php function loaderClass($bancFile){ if(file_exists("model/" . $bancFile . ".php")){ require_once ("model/" . $bancFile . ".php"); } } spl_autoload_register("loaderClass"); class Controller extends DB { //....e continua //======================================================== <?php function __autoload($file){ if(file_exists('controller/' . $file . '.php')){ require_once ('controller/' . $file . '.php'); } else { exit('O aquivo' . $file . 'não foi encotrado!'); } } <!DOCTYPE html> <html lang="en"> <head> <meta charset="UTF-8"> //........ e continua //========================================================= Desde já agradeço qualquer manifestação !
  4. Olá amigos! Estou com um problema para "chamar" um arquivo com a extensão inc de uma aplicação que faz um login. Tenho um arquivo principal chamado index.php onde contém na página somente dois campos de texto (usuário e senha) e um botão de login. Nisso, essa página redireciona para uma outra chamada login.php onde contém o código abaixo: <?php require_once ("classBancoDados.inc"); $conexao_bd = new classBancoDados("localhost"); if (!$conexao_bd->AbrirConexao()) { echo "<p>Erro na conexão com o banco de dados!<br>" . $conexao_bd->MensagemErro() . "</p>"; } else { $conexao_bd->SetSELECT("*","hoteis","UF,Cidade"); if($conexao_bd->ExecSELECT()) { $NumeroRegistros = $conexao_bd->TotalRegistros(); $DataSet = $conexao_bd->GetDataSet(); if($NumeroRegistros > 0) { while($Registros = $DataSet->fecth_assoc()) { $EnderecoHotel = "<p><b>" . trim($Registros["Endereco"]) . "," . trim($Registros["Numero"]) . "<br>"; $EnderecoHotel .= trim($Registros["Bairro"]) . " - " . $Registros["Cidade"] . "<br>"; $EnderecoHotel .= $Registros["UF"] . " - Fone: " . $Registros["Telefone"] . "<br></b></p>"; echo $EnderecoHotel; } } } else { echo "<p>Erro na execução do comando SELECT</p>"; } } $conexao_bd->FecharConexao(); ?> A Classe "classBancoDados.inc" contém informações do acesso ao banco de dados, login, senha tabela e etc. Porém, quando clico no botão login, o erro que aparece é o seguinte. Pelo que percebi ele está dizendo que meu arquivo "classBancoDados" não foi encontrado junto dos outros arquivos que compõem a aplicação. É isso mesmo? Mas eles estão na mesma pasta. Estou usando wamp server com mysql e servidor apache. Podem me ajudar? Obrigado
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.