Jump to content

Search the Community

Showing results for tags 'se'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 5 results

  1. Boa tarde, Necessito concluir minha função Se, de forma a qual me retorne em valor-se-falso o valor encontrado por ela no valor-se-verdadeiro, Assim consigo tornar automatizado minha planilha, carregando a quantidade de clientes que cada pessoa tem até o final do mês de forma a ser acumulativo, E também a quantidade estimada e fornecida acumulativa a cada mês. O problema é que quando vira a data programada ex.31/05/18 (43251) a formula me retorna um erro, "" ou Nda... preciso que ela retorne o valor que estava antes ou até a data mas que não mude dali em diante pois sera a função de uma próxima célula. Pensando no conceito de que esta planilha sera alimentada diariamente,. preciso que no fechamento de cada mês ela grave tais informações. Se houver outras funções ou modificações na planilha, Agradeço Ideias. Segue planilha... https://drive.google.com/open?id=110HwTjlQdyuROEB4hQGRvZU2PBTu3IaU
  2. Estou começando agora a programar, faço alguns exercícios para exercitar, e queria saber porque toda vez que executo o programa Visualg informa que esta faltando o "fimse" na linha 34, se eu colocar mais um "fimse" funciona, mas assim ficaria 3 sendo que existem apenas 2 condicionais, uma "se" e outra "se" ninhada. Segue o algorítimo, quem poder me explicar o porque, agradeço: Algoritmo "Equação" Var a,b,c,x1,x2,D: real Inicio Escreval("----EQUAÇAO DE SEGUNDO GRAU-----") Escreval("") Escreval("Digite o valor de a: ") Leia (a) Escreval("Digite o valor de b: ") Leia (b) Escreval("Digite o valor de c: ") Leia (c) D <- (b^2)-4*a*c x1 <- (-b+ RaizQ(D))/(2*a) x2 <- (-b- RaizQ(D))/(2*a) se (D > 0) entao Escreval("Delta : ",D," , maior que zero, ou seja, 2 raizes") Escreval(" X1: ", x1) Escreval(" X2: ", x2) senao entao se (D=0) entao Escreval("Delta : ", D," , sendo assim, uma raiz") Escreval(" X1: ", x) se não entao Escreval("Delta: ", D," , Raiz negativa!") fimse fimse Fimalgoritmo
  3. Ola A estrutura se deste algoritimo esta dando erro,agradeço se alguem puder me ajudar. // Função :6) Faça um algoritmo que o usuário informe dois números inteiros, que o segundo //número divida o primeiro e que se o resto for par, o quociente for ímpar e o resultado //for maior que 3, informe que ele venceu o desafio do algoritmo, e independente de //vencer ou não mostre os resultados das operações. // Autor :Emerson Reinecke // Data : 03/08/2017 // Seção de Declarações var n1,n2:inteiro resultado,quoc,resto:real inicio escreval("Digite um numero:") leia(n1) escreval("Digite um numero:") leia(n2) resultado<-(n1/n2) resto<-(n1 mod n2) quoc<-(n1 div n2) se (resto=0) e (resultado>3) e (quoc mod 2 = 0 ) entao escreval("Voce Venceu o Desafio do Algoritmo!") escreval("O Resultado da operação foi ",resultado,"") escreval("O Quociente da operação foi ",quoc,"") escreval("O Resto da operação foi ",resto,"") senao escreval("O Resultado da operação foi ",resultado,"") escreval("O Quociente da operação foi ",quoc,"") escreval("O Resto da operação foi ",resto,"") fimse fimalgoritmo
  4. Boa tarde amigos. O professor passou uma atividade que não estou conseguindo fazer, de jeito maneira. Já li e reli todo o material já apresentado, pesquisei na internet, assisti vídeos, e não consigo desenvolver a atividade. Não sei mais o que fazer. Acho que esse é um daqueles problemas para espantar os alunos já no início da faculdade. Já tentei no Portugol Studio e no Visualg. Por favor, vocês podem me ajudar a entender o que se pede, e como fazer? Desenvolver um algoritmo que tenha como dado de entrada a data de nascimento de uma pessoa qualquer no formato dia, mês e ano. A partir dessa data, calcular a idade da pessoa em: a) anos, meses e dias. Ex: a resposta seria a pessoa tem 38 anos 3 meses e 5 dias de vida b) meses e dias. EX: a pessoa tem 459 meses e 5 dias C) somente em dias. Ex: a pessoa tem 30.995 dias de vida OBS: considerar o ano com 365 dias e o mês com 30dias. Segue meu código: algoritmo "idades" var diaAtual, mesAtual, anoAtual, diaNas, mesNas, anoNas, anos, meses, dias : INTEIRO inicio escreval ("Digite dia, mês, e ano atuais") escreval ("Formato DD/MM/AAAA, separados com a tecla Enter: ") leia (diaAtual, mesAtual, anoAtual) escreval ("Digite dia, mês, e ano do nascimento") escreval ("Formato DD/MM/AAAA, separados com a tecla Enter: ") leia (diaNas, mesNas, anoNas) // ANO SE ((mesAtual = mesNas) E (diaAtual >= diaNas)) então //JÁ FEZ ANIVERSARIO anos <- anoAtual - anoNas FIMSE SE ((mesAtual = mesNas) E (diaAtual < diaNas)) então //AINDA NÃO FEZ ANIVERSARIO anos <- anoAtual - anoNas - 1 FIMSE SE (mesAtual < mesNas) então //AINDA NÃO FEZ ANIVERSARIO anos <- anoAtual - anoNas - 1 FIMSE //MÊS SE ((mesAtual < mesNas) E (diaAtual >= diaNas)) então //Se não fez aniversário mas completou mês corrente meses <- 12 - (mesNas - mesAtual) FIMSE SE ((mesAtual < mesNas) E (diaAtual < diaNas)) então //Se não fez aniversário e nem completou mês corrente meses <- 12 (mesNas - mesAtual) - 1 FIMSE SE ((mesAtual > mesNas) E (diaAtual < diaNas)) então meses <- (mesAtual - mesNas) - 1 FIMSE //DIA SE (diaAtual < diaNas) então dias <- 30 - diaNas + diaAtual FIMSE SE (diaAtual >= diaNas) então dias <- diaAtual - diaNas FIMSE fimalgoritmo Desde já agradeço.
  5. sorioalex

    Algoritmos

    Escreva um algoritmo para ler o número total de eleitores de um município, o número de votos brancos, nulos e válidos. Calcular e escrever o percentual que cada um representa em relação ao total de eleitores. Gente, eu cheguei a fazer este algoritmo abaixo, mas a professora quer que eu faça condições de exceções e erros, eu queria saber como se faz isso e onde colocar... Algoritmo Eleicoes Var TotEleitor, VB, VV, VN, PorcBrancos, ---ulos, PorcValidos: real Inicio Escreva Digite o número total de eleitores do município: Leia TotEleitor Escreva Digite o número de votos brancos: Leia VB Escreva Digite o número de votos nulos Leia VN Escreva Digite o número de votos válidos: Leia VV PorcBranco=100*VB/TotEleitor PorcNulo=100*VN/TotEleitor PorcValido = 100*VV/TotEleitor Escreva Votos Brancos:, PorcBrancos: % Escreva Votos Nulos:, PorcNulos: % Escreva Votos Válidos, PorcValidos: % Fim
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.