Jump to content

Search the Community

Showing results for tags 'senao'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 3 results

  1. Bom dia galera! Então, eu fiz esse algoritimo para resolver um exercicio (Faça um Programa que leia três números e mostre-os em ordem decrescente). Ele esta funcional, tudo certinho(eu acho). O que eu realmente queria saber é se existe uma forma de eu simplificar ele utilizando apenas as estruturas condicionais ou se dessa forma que eu fiz já é o mais simples possivel ? Valeu pela atenção pessoal!!! Segue o codigo criado no visualg //Faça um Programa que leia três números e mostre-os em ordem decrescente algoritmo "ex009" var n1, n2, n3: inteiro inicio escreva("Primeiro numero: ") leia(n1) escreva("Segundo numero: ") leia(n2) escreva("Terceiro numero: ") leia(n3) se (n1<n2) e (n2<n3) entao escreva(n3,n2,n1) senao se (n1<n3) e (n3<n2) entao escreva(n2,n3,n1) senao se (n2<n1) e (n1<n3) entao escreva(n3,n1,n2) senao se (n2<n3) e (n3<n1) entao escreva(n1,n3,n2) senao se (n3<n1) e (n1<n2) entao escreva(n2,n1,n3) senao se (n3<n2) e (n2<n1) entao escreva(n1,n2,n3) fimse fimse fimse fimse fimse fimse fimalgoritmo
  2. Boa tarde amigos. O professor passou uma atividade que não estou conseguindo fazer, de jeito maneira. Já li e reli todo o material já apresentado, pesquisei na internet, assisti vídeos, e não consigo desenvolver a atividade. Não sei mais o que fazer. Acho que esse é um daqueles problemas para espantar os alunos já no início da faculdade. Já tentei no Portugol Studio e no Visualg. Por favor, vocês podem me ajudar a entender o que se pede, e como fazer? Desenvolver um algoritmo que tenha como dado de entrada a data de nascimento de uma pessoa qualquer no formato dia, mês e ano. A partir dessa data, calcular a idade da pessoa em: a) anos, meses e dias. Ex: a resposta seria a pessoa tem 38 anos 3 meses e 5 dias de vida b) meses e dias. EX: a pessoa tem 459 meses e 5 dias C) somente em dias. Ex: a pessoa tem 30.995 dias de vida OBS: considerar o ano com 365 dias e o mês com 30dias. Segue meu código: algoritmo "idades" var diaAtual, mesAtual, anoAtual, diaNas, mesNas, anoNas, anos, meses, dias : INTEIRO inicio escreval ("Digite dia, mês, e ano atuais") escreval ("Formato DD/MM/AAAA, separados com a tecla Enter: ") leia (diaAtual, mesAtual, anoAtual) escreval ("Digite dia, mês, e ano do nascimento") escreval ("Formato DD/MM/AAAA, separados com a tecla Enter: ") leia (diaNas, mesNas, anoNas) // ANO SE ((mesAtual = mesNas) E (diaAtual >= diaNas)) então //JÁ FEZ ANIVERSARIO anos <- anoAtual - anoNas FIMSE SE ((mesAtual = mesNas) E (diaAtual < diaNas)) então //AINDA NÃO FEZ ANIVERSARIO anos <- anoAtual - anoNas - 1 FIMSE SE (mesAtual < mesNas) então //AINDA NÃO FEZ ANIVERSARIO anos <- anoAtual - anoNas - 1 FIMSE //MÊS SE ((mesAtual < mesNas) E (diaAtual >= diaNas)) então //Se não fez aniversário mas completou mês corrente meses <- 12 - (mesNas - mesAtual) FIMSE SE ((mesAtual < mesNas) E (diaAtual < diaNas)) então //Se não fez aniversário e nem completou mês corrente meses <- 12 (mesNas - mesAtual) - 1 FIMSE SE ((mesAtual > mesNas) E (diaAtual < diaNas)) então meses <- (mesAtual - mesNas) - 1 FIMSE //DIA SE (diaAtual < diaNas) então dias <- 30 - diaNas + diaAtual FIMSE SE (diaAtual >= diaNas) então dias <- diaAtual - diaNas FIMSE fimalgoritmo Desde já agradeço.
  3. sorioalex

    Algoritmos

    Escreva um algoritmo para ler o número total de eleitores de um município, o número de votos brancos, nulos e válidos. Calcular e escrever o percentual que cada um representa em relação ao total de eleitores. Gente, eu cheguei a fazer este algoritmo abaixo, mas a professora quer que eu faça condições de exceções e erros, eu queria saber como se faz isso e onde colocar... Algoritmo Eleicoes Var TotEleitor, VB, VV, VN, PorcBrancos, ---ulos, PorcValidos: real Inicio Escreva Digite o número total de eleitores do município: Leia TotEleitor Escreva Digite o número de votos brancos: Leia VB Escreva Digite o número de votos nulos Leia VN Escreva Digite o número de votos válidos: Leia VV PorcBranco=100*VB/TotEleitor PorcNulo=100*VN/TotEleitor PorcValido = 100*VV/TotEleitor Escreva Votos Brancos:, PorcBrancos: % Escreva Votos Nulos:, PorcNulos: % Escreva Votos Válidos, PorcValidos: % Fim
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.