Ir para conteúdo

Pesquisar na Comunidade

Mostrando resultados para as tags ''sintaxe''.

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Todas as áreas do Fórum

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Encontrar resultados em...

Encontrar resultados que...


Data de Criação

  • Início

    FIM


Data de Atualização

  • Início

    FIM


Filtrar pelo número de...

Data de Registro

  • Início

    FIM


Grupo


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Encontrado 8 registros

  1. mauspinola

    Ajuda na sintaxe

    Sou novato em php/mysql e estou com uma emergência p resolver na loja. O problema é a sintaxe, pois não sei ainda. A lógica da rotina eu já tenho. Preciso que alguém possa por favor me ajudar nisso pois é uma emergência das grandes! Eu tenho uma tabela, chamada "caixa" nela dois campos "faltapagar" e "status". Quando um produto não está pago, o campo "faltapagar" fica com valor acima de '0' ou seja, fica com valor do saldo a pagar, e o campo "status" fica com valor 'pendente'. E sempre que um produto é totalmente pago, o campo "faltapagar" fica '0' e o código ao ler isso, muda o campo "status" para 'sucesso' e o cliente recebe um email com a liberação do produto para retirada. Até ai está certo. Mas começou a acontecer um problema justo na saída do programador e estou com uma emergência enorme aqui na loja que eu mesmo terei que resolver. O problema é o seguinte: Devido a um erro de execução que eu ainda n descobri a origem, o campo "status" tem mudado o valor para 'sucesso' com "faltapagar" sem estar '0', e isso está fazendo produtos não pagos ficarem com status de pago. Está dando um problema muito sério com os clientes, e é uma emergência muito grande resolver isso hoje!!! Por isso preciso muito de uma ajuda aqui bem objetiva, de quem puder me ajudar. Uma solução rápida e paleativa que encontrei aqui é complementar um código que no momento da execução olhe na tabela "caixa" e faça assim: Se "status" está com valor 'sucesso' com "faltapagar" tendo um valor acima de '0' então alterar "status" para valor 'pendente'. Ou até mesmo se fosse o caso, fazer também um script roando no crontab em que de minuto em minuto examinasse a tabela "caixa" e comparar os campos "faltapagar" e "status", quando "status" estiver com valor 'sucesso' sem que "faltapagar" esteja com valor '0', esse script iria corrigir o valor 'sucesso' para 'pendente'. A lógica do que é para ser feito eu já sei, mas o problema é a sintaxe, que não sei. Alguém , me ajuda a montar esse script? É uma emergência!! Desde já agradeço muito!
  2. Pessoal, estou tentando fazer um jogo da velha um pouco diferente do padrão. É uma versão bem simples. Só que um dos comandos está dando problema e eu não faço ideia o porquê disso. Vejam: algoritmo "Jogo da Velha" var jogo: vetor[1..3, 1..3] de inteiro i, j: inteiro cont: inteiro pos1: inteiro pos2: inteiro num: vetor[1..9] de inteiro Procedimento Topo() inicio EscrevaL ("---------------") EscrevaL (" JOGO DA VELHA ") EscrevaL ("---------------") cont <- 1 Para i <- 1 ate 3 faca Para j <- 1 ate 3 faca jogo [i,j] <- cont Se jogo[i,j] = num[pos1] entao Escreva ("| X|") senao Se jogo[i,j] = num[pos2] entao Escreva ("| O|") senao Escreva ("| ", cont, "| ") FimSe FimSe cont <- cont + 1 FimPara EscrevaL () FimPara EscrevaL ("---------------") FimProcedimento Procedimento JogadaJ1 () inicio Repita EscrevaL ("Digite a posição para o jogador (X)") Leia (pos1) Se num[pos1] = jogo[i,j] entao Escreva ("JOGADA INVÁLIDA. Digite outra posição") FimSe Ate num[pos1] <> jogo[i,j] num[pos1] <- pos1 Topo () JogadaJ2 () FimProcedimento Procedimento JogadaJ2 () inicio Repita EscrevaL ("Digite a posição para o jogador (O)") Leia (pos2) Se num[pos2] = jogo[i,j] entao Escreva ("JOGADA INVÁLIDA. Digite outra posição") FimSe Ate num[pos2] <> jogo[i,j] num[pos2] <- pos2 Topo () JogadaJ1 () FimProcedimento inicio LimpaTela EscrevaL ("---------------") EscrevaL (" JOGO DA VELHA ") EscrevaL ("---------------") cont <- 1 Para i <- 1 ate 3 faca Para j <- 1 ate 3 faca jogo [i,j] <- cont Escreva ("| ", cont, "| ") cont <- cont + 1 FimPara EscrevaL () FimPara JogadaJ1 () fimalgoritmo Ainda não terminou, mas há um erro de sintaxe na linha do "Se jogo[i,j] = num[pos1] entao" e "Se jogo[i,j] = num[pos2] entao". Alguém pode me dizer por quê ?
  3. Olá. Estou há muitos anos sem mexer com PHP. O que significa esta sintaxe de colocar um ponto após um número? Exemplo: $aux01 = (1.-$equad/4.-3.*$equad*$equad/64.-5.*$equad*$equad*$equad/256.)*$latO;
  4. Static analysis: 3 errors were found during analysis. Unexpected beginning of statement. (near "T" at position 0) Unexpected beginning of statement. (near "FOREIGN_KEY_CHECKS" at position 2) Unexpected beginning of statement. (near "0" at position 21) Comando SQL: T FOREIGN_KEY_CHECKS=0 Mensagens do MySQL : Documentação #1064 - Você tem um erro de sintaxe no seu SQL próximo a 'T FOREIGN_KEY_CHECKS=0' na linha 1 Esse erro ocorre quando tento importar um banco de dados de pouco mais de 2 megas. A questão é que cerca de 2 anos atrás eu importei o mesmo BD, no phpmyadmin em um Linux e funcionou perfeitamente. Aqui Segue o link para o BD para análise caso alguma alma caridosa queira me ajudar, realmente suplico por ajuda pois estou cansado de procurar, testar, falhar.
  5. felipecsamuel

    [RESOLVIDO]Visualg - Erro de sintaxe no algoritmo

    PODE EXCLUIR O TÓPICO.
  6. M4thews

    Código em php

    Olá, sou iniciante nessa linguagem e estou estudando pela internet, fazendo cursos e etc. Meu primeiro "código" em php foi este: <?php //inteiros-números sem casas decimais //ponto flutuante-número com casas decimais //boolean- true or false //array- variáveis multidimensiônais, vetor $idade= 30; print($idade); ?> Todas as vezes que executo o código ao invez de mostrar somente a "mensagem", ele mostra na tela os comentarios também, o que pode ser isso?
  7. Ta dando erro de sintaxe nesse algoritmo, mas nao consigo achar :/ Alguem sabe onde tá? Obg desde ja
  8. Gustavo Benedito Costa

    Erro de síntaxe, usando NoAB como uma classe e usando nome como variáv

    Olá pessoal, Boa noite, senhores e senhoras, Eu estou com um erro de síntaxe nos códigos de nó de árvore binária o qual fiquei pesquisando no Google e não consegui resolver. Veja a parte do código onde o aplicativo de edição de códigos Eclipse acusou NoAB(NoAB p, NoAB a, NoAB pr, String n): public class NoAB extends ArvoreBinaria { NoAB altura; ... String nome; ... boolean isRoot; // CONSTRUTORES NoAB(NoAB p, NoAB a, NoAB pr, String n) { ... altura = a; ... nome = n; } public String getNome() { return nome; } public void setNome(String nome) { this.nome = nome; } ​} Eu importei java.lang.String, mas continuou o mesmo erro. Mudei de String para NoAB, continuou novamente e não entendi o que aconteceu.
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.