Ir para conteúdo

Pesquisar na Comunidade

Mostrando resultados para as tags ''statement''.

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Todas as áreas do Fórum

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Encontrar resultados em...

Encontrar resultados que...


Data de Criação

  • Início

    FIM


Data de Atualização

  • Início

    FIM


Filtrar pelo número de...

Data de Registro

  • Início

    FIM


Grupo


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Encontrado 2 registros

  1. Rasp

    mysqli statement + select view

    Prezados, Fiz em ambiente local (xampp) uma tela de login simples e está funcionando perfeitamente, sem apresentar qualquer erro, porém, ao subir para meu servidor web (ambos rodam PHP 7.1), o sistema de login não funciona, só gera a mensagem de erro de login e senha. Após verificar os possíveis erros, identifiquei que a consulta SQL não está funcionando, porém, no PHPmyAdmin funciona normalmente (no servidor web), estou usando uma view, mas não encontrei nada que tivesse o mesmo problema que estou passando. Segue código: if($sql = $mysqli->prepare("SELECT * FROM `vw_login` WHERE `login` = ? LIMIT 1")) { $sql->bind_param("s", $frmlogin); $sql->execute(); $sql->bind_result($id, $nome, $hash); if($sql->fetch() AND Bcrypt::check($frmsenha, $hash)) { ... header('Location: /'); } else { session_destroy(); $retorno = "Login ou senha incorretos."; } $sql->close(); } Obrigado!
  2. Olá pessoal, estou com problemas para criar um simples sistema de login usando PDO statement. É um sistema de login bem simples, não utilizei nem criptografia nas senhas. Quando executo o código, trago as informações do banco em forma de array utilizando fetchAll(PDO::FETCH_ASSOC); Mas o array retorna vazio, e os dados inseridos no formulário existem no banco de dados. Arquivo login.php: <?php require_once 'Banco.php'; $email = isset($_POST['email']) ? $_POST['email']: ''; $senha = isset($_POST['senha']) ? $_POST['senha']: ''; $pdo = conecta(); $sql = "SELECT * FROM usuarios WHERE email = :email AND senha = :senha"; $stmt = $pdo->prepare($sql); $stmt->bindValue(':email', $email); $stmt->bindValue(':senha', $senha); $stmt->execute(); $array = $stmt->fetchAll(PDO::FETCH_ASSOC); if(count($array) <= 0){ echo 'Acesso liberado'; var_dump($array); }else{ echo 'Usuario ou senha incorretos'; } Desde já agradeço!
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.