Publicidade

J.2009

Exercicio de algoritmos

Galera to com um problemao. Eu estudo o 1° semestre de sistemas de informação e tem uma lista de exercícios que tenho q entregar segunda-feira.

O professor exige de mais da gente e ele passou uma coisa dificil que ele nao encinou ainda. Então se vcs poderem ajudar.

Agradeço desde ja.

 

Esta os exercícios abaixo

 

1)Escreva um algoritmo que leia um número real e apresente a sua terça parte.

 

2)Escreva um algoritmo que leia o saldo de uma aplicação e apresente o novo saldo reajustado em 2%.

 

3)escreva um algoritmo q dado um número no formato: Centena, Dezena e Unidade (CDU) apresente-o invertido da seguinte forma: Unidade, Dezena, Centena (UDC).

 

4)Antes do racionamento de energia ser decretado, quase ninguém falava em quilowatts (KW), mas, agora, todos incorporaram essa palavra em seu vocabulário. Sabendo-se que 100 quilowatts de energia custam um sétimo do salário mínimo, escreva um algoritmo que receba o valor do salário mínimo, a quantidade de quilowatts gastos por uma residência e apresente as seguintes informações:

1. O valor em reais de cada quilowatts;

2. O valor em reais a ser pago.

3. O valor a ser pago por essa residência com desconto de 10%

 

5) Escreva um algoritmo que leia o raio de um círculo e apresente o valor do seu perímetro e a área. Dica: Perímetro =2πR Área =2π².

 

6) Em época de pouco dinheiro, os comerciantes estão procurando aumentar suas vendas oferecendo descontos. Faça um algoritmo que receba o valor do produto e o percentual de desconto e apresente o novo valor tendo em vista o desconto concedido.

 

7) Escreva um algoritmo que efetue o cálculo do salário liquido de um professor. Os dados fornecidos são: o valor da hora aula, numero de aulas dadas no mês e o percentual de desconto do INSS.

 

8) Escreva um algoritmo que leia a temperatura em graus Centígrados e apresente o seu valor correspondente em fahrenheit e C é a temperatura em Centígrados.

 

9) Escreva um algoritmo que calcule e apresente a quantidade de litro de combustível gastos em uma viagem e a velocidade média. O algoritmo deverá apresentar os valores da velocidade média, o tempo gasto na viagem, a distância percorrida e a quantidade de litros de combustível utilizados na viagem.

 

10) Escreva um algoritmo que leia dois números X E Y efetuar a troca dos valores de forma que a variável X passe a ter o valor da variável Y e que a variável Y passe a ter o valor da variável X. Apresente os valores trocados.

 

 

Sei q são muitos mais se puderem ajudar eu agradeceria.

Editado por Mário Monteiro
Retirada a palavra "AJUDA" do Titulo ou Descrição
0

Compartilhar este post


Link para o post
Compartilhar em outros sites

o que ja fez?

 

ou ajudar é fazer tudo para voce?

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu so fiz a 1 que foi a que consigui fazer

Tentei usar a mesma logica para as outras mais nao consegui

ta ae a 1

Algoritmo

VAR

a: real;

INICIO

Leia (a)

Escreva (“sua terça parte e”)a/3

Fim algoritmo

 

 

Ja tentei olhar em livros apostilas na internet so q nao consegui intender mt bem como se faz

Meu professor ele nao explica mt bem, e nao estou entendendo mt a materia da uma força ae

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

oloco, fala pra mim na internet e ql o nome das apostilas q você naum conseguiw entender?

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

O segundo é tão simples quanto o primeiro.

 

Algoritmo
VAR
a: real;
INICIO
   Leia (a)
   Escreva ("Saldo atualizado eh: ")a*1.02 // saldo eh atualizado em 2%
Fim algoritmo

Quero mostrar que voce precisa interpretar o que o exercício pede e transformar o modelo matemático em código.

 

Tente os outros e quando aparecer dúvidas volte a postar.

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

galera se vcs puderem postar uma apostila de facil entendimento pra mim seria uma boa

De preferencia uma que tenha mts exercicios resolvidos.hehehe

VLW galera

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

galerinha eu consegui fazer algumas Confiram ae pra ver se fiz certo

Vlw

1)

Algoritmo

VAR

a: real;

INICIO

Leia (a)

Escreva (“sua terça parte e”)a/3

Fim algoritmo

 

2)

Algoritmo “exercício 2”

VAR

S, reajuste: real

 

INICIO

Leia (s,reajuste)

Reajuste <-(12/100)*5)+5

Escreva (s)

FIMALGORITMO

 

 

Algoritmo

VAR

a: real;

INICIO

Leia (a)

Escreva ("Saldo atualizado eh: ")a*1.02 // saldo eh atualizado em 2%

Fim algoritmo

 

3)

Algoritmo “exercício 3”

VAR

N,c,d,u:inteiro

INICIO

Escreva (“ digite um numero de 3 algarismo”)

Leia (N)

C<-n.d

N<- n-c*100

 

 

 

 

4

Algoritmo “Exercício 4”

VAR

sm,k: real

INICIO

Escreva”R$350,100 kw”

Leia (sm, k)

Escreva”cada kilowat custa”1/700*sm” reais a conta final eh”k/700*sm”com desconto fica”k/100*sm – k/100*sm*0.1

FIMALGORITMO

 

 

 

 

5-

Algoritmo “exercício 5”

VAR

Raio,p,a: real

INICIO

Leia (raio)

P<- (2*3,14)*raio

A<-(2*3,14)(raio*raio)

Escreva (a)

Escreva (p)

Fimalgoritmo

 

6)

algoritmo ”exercício 6”

VAR

Vp,desc,resp: real

INICIO

Leia (vp,desc)

Resp<-(vp-(vp*desc/100)

Escreva (“o valor pago com desconto será”)

Fim algoritmo

 

7)

Algoritmo ”exercício 7”)

VAR

 

 

 

 

8)

Algoritmo “exercício 8”

VAR

F, C: real

INICIO

Leia ©

F<- (c+160)/5

Escreva (F)

Fim algoritmo

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

galerinha eu consegui fazer algumas Confiram ae pra ver se fiz certo

Vlw

1)

Algoritmo

VAR

a: real;

INICIO

Leia (a)

Escreva (“sua terça parte e”)a/3

Fim algoritmo

 

2)

Algoritmo “exercício 2”

VAR

S, reajuste: real

 

INICIO

Leia (s,reajuste)

Reajuste <-(12/100)*5)+5

Escreva (s)

FIMALGORITMO

 

 

Algoritmo

VAR

a: real;

INICIO

Leia (a)

Escreva ("Saldo atualizado eh: ")a*1.02 // saldo eh atualizado em 2%

Fim algoritmo

 

3)

Algoritmo “exercício 3”

VAR

N,c,d,u:inteiro

INICIO

Escreva (“ digite um numero de 3 algarismo”)

Leia (N)

C<-n.d

N<- n-c*100

 

 

 

 

4

Algoritmo “Exercício 4”

VAR

sm,k: real

INICIO

Escreva”R$350,100 kw”

Leia (sm, k)

Escreva”cada kilowat custa”1/700*sm” reais a conta final eh”k/700*sm”com desconto fica”k/100*sm – k/100*sm*0.1

FIMALGORITMO

 

 

 

 

5-

Algoritmo “exercício 5”

VAR

Raio,p,a: real

INICIO

Leia (raio)

P<- (2*3,14)*raio

A<-(2*3,14)(raio*raio)

Escreva (a)

Escreva (p)

Fimalgoritmo

 

6)

algoritmo ”exercício 6”

VAR

Vp,desc,resp: real

INICIO

Leia (vp,desc)

Resp<-(vp-(vp*desc/100)

Escreva (“o valor pago com desconto será”)

Fim algoritmo

 

7)

Algoritmo ”exercício 7”)

VAR

 

 

 

 

8)

Algoritmo “exercício 8”

VAR

F, C: real

INICIO

Leia ©

F<- (c+160)/5

Escreva (F)

Fim algoritmo

 

Eu tb não manjo de lógica mais creio que você se preciptou no algoritmo do exercicio 4, afinal, você só atentou-se para as variáveis "C" e "N" respectivamente, sendo que, "n * d (0) = 0 e n - c (0) * 100 = 0" O RESULTADO DESSE ALGOTIMO É ZERO CARA!

 

Não sei em qual linguagem está executando esses algoritmo mas acho que você se deu bem no exerc. 6

Eu fiz da seguinte forma no visualg

 

var
VAL, DESC, NOVO : REAL
inicio

LEIA (VAL)
LEIA (DESC)
NOVO <- VAL * (DESC / 100)
NOVO <- NOVO - VAL
ESCREVAL (NOVO)
fimalgoritmo

Só fiz esses dois aki.... pq eu to tentando resolver outro lance que está tirando meu sono rs

Peguei o seguinte exercicio na net:

 

. Crie um programa que lê três inteiros e informa VERDADEIRO se apenas o maior deles é par

ou se o menor deles é ímpar ou informa FALSO em caso contrário.

 

Tentei da seguinte maneira:

 

var
A, B, C : INTEIRO

inicio

LEIA (A, B, C)
SE (A > B) E (B > C) ENTAO
A <- A MOD 2
SE (A = 0) ENTAO
ESCREVAL ("O MAIOR NÚMERO É PAR (VERDADEIRO)")
SENAO // Se eu tirar o "SENAO" ele retornará "VERDADEIRO" se o 1º=par e 3ºimpar nesse caso ele só retorna um dos dois
SE (B > C) ENTAO
C <- C MOD 2
SE NAO (C = 0) ENTAO
ESCREVAL ("O MENOR NÚMERO É IMPAR (VERDADEIRO)")
		 FIMSE
	   FIMSE
	 FIMSE

SENAO
ESCREVAL ("FALSO")
FIMSE
fimalgoritmo

Como faço para ele retornar...exatamente como pede no exercicio?

Ta show de bola esse forúm.... PARABÉNS!!

Agora vou dormir rs

 

Abraço!

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

A maioria dos que postou está correto.

Os que ainda estão com erro e os não resolvidos são:

3, 4, 7, 9 e 10

 

Vamos corrigir os exercícios 3 e 4 enquanto voce tente resolver os restantes e poste as dúvidas.

 

 

O exercício 3 pede para inverter um número CDU em UDC.

 

Primeiro pegue a centena.

c<-inteiro(numero/100)
Agora a dezena

d<-inteiro((numero-c)/10)
Agora a unidade

u<-numero - (c*100 + d*10)
Agora é só mostrar o novo número.
0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia eu, precisava do exercicio 4 escrito em linguagem de programação C, se alguem puder me ajudar. fico mto grato.

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!


Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.


Entrar Agora

  • Próximos Eventos