Ir para conteúdo
CHAVES C++

[Resolvido] Exercício: Calcular media da idade de 7 pessoas

Recommended Posts

1 – Faça um algoritmo que receba a idade e o peso de 7 pessoas, calcule e mostre:

• A quantidade de pessoas com mais de 90 quilos;

• A média das idades das 7 pessoas

Compartilhar este post


Link para o post
Compartilhar em outros sites

Titulo editado, conforme as Regras do Fórum iMasters (ver 9ª regra)

ALQUEM ME AJUDA NESSE EXERCICIO http://forum.imasters.com.br/public/style_emoticons/default/seta.gif Exercício: Calcular media da idade de 7 pessoas

 

---------------

 

Ok, e o que você ja tem pronto?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Titulo editado, conforme as Regras do Fórum iMasters (ver 9ª regra)

ALQUEM ME AJUDA NESSE EXERCICIO http://forum.imasters.com.br/public/style_emoticons/default/seta.gif Exercício: Calcular media da idade de 7 pessoas

 

---------------

 

Ok, e o que você ja tem pronto?

inicio

inteiro:id,p,qp,mid;

p=0;

qp=0;

para i de 1 ate 7 passo 1 faça

escreva ("digite idade");

leia (id);

se (p>90)

entao

qp=qp+1;

fimse;

fimpara;

se

mas agora com faço

para calcular a media da idade

das pessoas...

me ajude aiiii ...

obrigado.....

Compartilhar este post


Link para o post
Compartilhar em outros sites

"Ok, e o que você ja tem pronto? " EM C/C++ ?

Compartilhar este post


Link para o post
Compartilhar em outros sites

em c++

mais e nao

estou consequindo

escrever o algoritmo...

me descupe

por nao tem lido as regras do forum.....

Editado por Mário Monteiro
Retirada de CAIXA ALTA

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não digite em caixa-alta. Parece que você está gritando, e é considerado mal comportamento na internet.

O que você sabe de C/C++.

alguma vez você ja estudou essas linguagens de programação?

 

Para calcular a média é muito simples, olhe:

para cada i em [0..7]
	escreve("Qual a idade do homem %d", i);
	idades = idades + input();

media = idades / 7;
escreve("A media é %d", media);

Compartilhar este post


Link para o post
Compartilhar em outros sites

cara você qr fazer um programa em C/C++ e ainda naum sabe nd da linguagem..

sugiro q de uma boas olhadas no google sobre a linguagem..

um codigo bem simples q td mundo aprende.

 

#include <sdtio.h>

int main(){
	printf("ola mundo");
	return 0;
}

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não digite em caixa-alta. Parece que você está gritando, e é considerado mal comportamento na internet.

O que você sabe de C/C++.

alguma vez você ja estudou essas linguagens de programação?

 

Para calcular a média é muito simples, olhe:

para cada i em [0..7]
	escreve("Qual a idade do homem %d", i);
	idades = idades + input();

media = idades / 7;
escreve("A media é %d", media);
Victor eu estou estudando

isso mas esse exercicio

eu nao estou consequindo fazer.

eu estou fazendo em c++.

 

pessoal olha a mudança sera q esta certo.

inicio

inteiro:id,p,qp,mid;

p=0;

qp=0;

para i de 1 ate 7 passo 1 faça

escreva ("digite idade");

leia (id);

se (p>90)

entao

qp=qp+1;

mid=id/7;

fimse;

fimpara;

escreva("a media de pessoas =",mid);

fimse;

fim;

se

Compartilhar este post


Link para o post
Compartilhar em outros sites

idadetotal = qtd90 = 0;

para i de 0 até 6 faça

leia (idade);

idadetotal += idade;

leia (peso);

se (peso > 90) então

qtd90++;

fim_se

fim_para

media = idadetotal/7;

escreva("bla bla bla");

Compartilhar este post


Link para o post
Compartilhar em outros sites

idadetotal = qtd90 = 0;
para i de 0 até 6 faça
	leia (idade);
	idadetotal += idade;
	leia (peso);
	se (peso > 90) então 
		qtd90++;
	fim_se
fim_para
media = idadetotal/7;
escreva("bla bla bla");
certo cara

obrigado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu fiz em C, mas quando vou rodar dá erro, o que tem de errado?

 

#include <stdio.h>

int main ()

{
    int idade,i,somaid=0,pfm=0;
    float peso,media;

    for(i=1;i<=7;i++)
    {

    printf("DADOS DA PESSOA %i:\n\n",i);
    printf("Digite a idade: ");
    scanf("%i",&idade);
    somaid+=idade;
    printf("Digite o peso: ");
    scanf("%f",peso);
    printf("\n\n=======================\n\n");
    if(peso>=90)
    {
    pfm++;
    }
    }

    if(pfm!=0)
    {
    printf("%i PESSOAS PESAM MAIS DE 90kg.\n\n",pfm);
    }
    media=somaid/7.0;
    printf("A media de idade e: %.2f\n",media);
}

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 03/11/2013 at 17:17, João Ribossomo disse:

Eu fiz em C, mas quando vou rodar dá erro, o que tem de errado?

 


#include <stdio.h>

int main ()

{
    int idade,i,somaid=0,pfm=0;
    float peso,media;

    for(i=1;i<=7;i++)
    {

    printf("DADOS DA PESSOA %i:\n\n",i);
    printf("Digite a idade: ");
    scanf("%i",&idade);
    somaid+=idade;
    printf("Digite o peso: ");
    scanf("%f",peso);
    printf("\n\n=======================\n\n");
    if(peso>=90)
    {
    pfm++;
    }
    }

    if(pfm!=0)
    {
    printf("%i PESSOAS PESAM MAIS DE 90kg.\n\n",pfm);
    }
    media=somaid/7.0;
    printf("A media de idade e: %.2f\n",media);
}

Alguns anos depois né kkkkkk, só faltou o & em scanf("%f",peso);

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.