Jump to content

Archived

This topic is now archived and is closed to further replies.

studdiox

[Resolvido] Problemas com acentuação no thickbox

Recommended Posts

Opa galera esses dias tive um problema com o thickbox e consegui resolver graças a ajuda do pessoal aqui .... muito obrigado ao moderador

 

mas agora estou com um outro problema revisando os detalhes notei que o thickbox esta me deixando na mão com a acentuação ja revisei o mysql e la esta com a acentuação

 

o cabeçalho html esta correto tambem com

<!DOCTYPE html PUBLIC "-//WAPFORUM//DTD XHTML Mobile 1.0//EN" "http://www.wapforum.org/DTD/xhtml-mobile10.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

e mesmo assim sem a acentuação correta alguem pode me ajudar creio que o erro esta no thickbox

 

aqui o link da listagem o detalhe eu vi no Astra GLS Shimitão cliquem nele para ver a acentuação

 

http://www.socarro.net/site/tab2.php <<- aqui link da listagem e como eu vi que pode ser no thickbox vendo

aqui nesse link http://www.socarro.net/site/detalhes.php?id=862&height=520&width=650 <<-- o mesmo carro com a acentuação correta

 

se alguem puder ajudar fico grato

Share this post


Link to post
Share on other sites

nunca usei o thickbox dessa forma.

 

aqui é feito um ajax, é isso ?

javascript:show('detalhes.php?id=809&height=520&width=650')

 

 

verifique quais cabeçalhos ele envia, se ta usando o mesmo charset que você, e veja se a resposta do php, também vem no mesmo formato.

 

a aba Rede|Net do Firebug (complemento do Firefox), pode te ajudar.

Share this post


Link to post
Share on other sites

nunca usei o thickbox dessa forma.

 

aqui é feito um ajax, é isso ?

javascript:show('detalhes.php?id=809&height=520&width=650')

 

 

verifique quais cabeçalhos ele envia, se ta usando o mesmo charset que você, e veja se a resposta do php, também vem no mesmo formato.

 

a aba Rede|Net do Firebug (complemento do Firefox), pode te ajudar.

 

ok ele esta me retonando assim

Date Wed, 16 Mar 2011 19:48:09 GMT

Server Apache/2.2.11

Expires Thu, 19 Nov 1981 08:52:00 GMT

Cache-Control no-store, no-cache, must-revalidate, post-check=0, pre-check=0

Pragma no-cache

Vary Accept-Encoding

Content-Encoding gzip

Content-Length 439

Keep-Alive timeout=5, max=498

Connection Keep-Alive

Content-Type text/html

Cabeçalhos de Solicitaçãover fonte

Host www.socarro.net

User-Agent Mozilla/5.0 (Windows; U; Windows NT 6.1; pt-BR; rv:1.9.2.15) Gecko/20110303 AskTbFXTV5/3.9.1.14019 Firefox/3.6.15

Accept text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

Accept-Language pt-br,pt;q=0.8,en-us;q=0.5,en;q=0.3

Accept-Encoding gzip,deflate

Accept-Charset ISO-8859-1,utf-8;q=0.7,*;q=0.7

Keep-Alive 115

Connection keep-alive

Referer http://www.socarro.net/site/tab2.php

Cookie PHPSESSID=921e871dfcdf7a4e9bc904e80ea7f816

 

 

ali me parece que esta retornando correto

e aqui

javascript:show('detalhes.php?id=809&height=520&width=650')

é feito com javascript

Share this post


Link to post
Share on other sites

é feito com javascript

sim, eu sei disso.

 

continuando..

acessando diretamente:

http://www.socarro.net/site/detalhes.php?id=628

 

os acentos estão corretos, então o problema é no ajax mesmo.

o arquivo esta codificado em ISO ?

tenta enviar um header de charset na primeira linha com php, para forçar a codificação

Share this post


Link to post
Share on other sites

é feito com javascript

sim, eu sei disso.

 

continuando..

acessando diretamente:

http://www.socarro.net/site/detalhes.php?id=628

 

os acentos estão corretos, então o problema é no ajax mesmo.

o arquivo esta codificado em ISO ?

tenta enviar um header de charset na primeira linha com php, para forçar a codificação

 

 

Hummm tem algum exemplo andei lendo aqui pelo forum e vi alguma coisa parecida so que era em asp e ele conseguiu resolvendo enviando o mesmo

iso pelo asp so que eu não consegui fazer tem algum exemplo para que eu tente la ?

 

aqui o link do mesmo erro so que era usado asp no lugar do php

 

http://forum.imasters.com.br/topic/328734-resolvido%26nbsp%3Bacentuacao-com-thickbox/page__p__1212890__hl__thickbox__fromsearch__1#entry1212890

Share this post


Link to post
Share on other sites

era só pesquisar um pouco

 

http://php.net/manual/en/function.header.php

header('Content-Type: text/html; charset=utf-8'); 

ou:

header("Content-Type: text/html; charset=ISO-8859-1"); 

Share this post


Link to post
Share on other sites

era só pesquisar um pouco

 

http://php.net/manual/en/function.header.php

header('Content-Type: text/html; charset=utf-8'); 

ou:

header("Content-Type: text/html; charset=ISO-8859-1"); 

 

 

ARE BABA .... heheheh TU É O CARA isso mesmo agora deu certo ... QUEM SABE FAZ AO VIVO ..... VALEW MESMO

MAIS UMA VEZ O FORUM IMASTERS ME TIRANDO DO SUFOCO

Share this post


Link to post
Share on other sites

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.