Publicidade

Arquivado

Este tópico foi arquivado e está fechado para novas respostas.

Tales S.C

Mega Sena Visualg

Patrocínio:

estou fazer um algoritmo da mega sena, gerei seis numeros e mostrei na tela os 6 numeros sem repetição, agora eu gostaria de colocar na ordem crescente. Alguem me ajuda a aplicar o Método Bolha?? Não estou Conseguindo, Obrigado.

 

var
Concorda: Caractere
i,j,x,n,r,o: inteiro
valor: vetor[1..6] de inteiro
funcao NumAle(inter: inteiro; Cn: logico; Cm: logico): inteiro
inicio
r <- int(rand*inter)
se (Cm) então
r <- r + 1
fimse
se (Cn) então
r <- (r - int(inter/2))
fimse
retorne r
fimfuncao
inicio
i <- 1
repita

escreval (" 1 - Sortear números ")
escreval (" 2 - Mostrar números sorteados ")
escreval (" 3 - Verificar aposta ")
escreval (" 9 - Encerrar programa ")
escreva ("Digite a opção desejada: ")
leia (n)
escreval ()
Se (n = 1) então
Escreval(" Sorteiro Realizado ")
Escreval("--------------------")
Escreva("Quer limpar a tela?, Sim ou Não: ")
Leia(Concorda)
Se Concorda = "Sim" então
Limpatela
Senao
Fimse

Para i de 1 ate 6 faca
valor[i] <- NumAle(60, falso, verdadeiro), ",")
x <- i-1
Fimpara
i <- 1
Para i de 1 ate 6 faca
Se valor[i] > valor[i+1] então
valor[i] <- NumAle(60, falso, verdadeiro), ",")
valor[i] <- o
o <- valor[i]
Fimse
Fimpara
senao
Se (n=2)então
para j de 1 ate 1 faca
escreval (j, "º Sorteio ")
para i de 1 ate 6 faca
escreva (valor[i], ",")
fimpara
fimpara
fimse
fimse

ate n=9
Escreval("Obrigado por visitar nosso sistema!")
fimalgoritmo

0

Compartilhar este post


Link para o post
Compartilhar em outros sites