Publicidade

Entre para seguir isso  
Seguidores 0
Wagner sz

[Resolvido] Numero Par ou Impar

Oi, sou iniciante em algoritmos e estou tendo dificuldade para entender algoritmos de decisão. Enfim queria saber onde eu errei? Eu uso o visualg. xD

 

-->Escreva um programa que leia um número inteiro. Mostrar se o número é “par” ou “ímpar”.

 

algoritmo "Par_impar"

// Função :

// Autor :

// Data : 15/3/2012

// Seção de Declarações

var

n: inteiro

inicio

// Seção de Comandos

leia (n)

se n /2 = 0 entao

escreva ("O valor é par:")

fimse

se n /2 = 1 entao

escreva ("O valor é impar:")

fimse

 

 

fimalgoritmo

Editado por Mário Monteiro
Retirada a palavra "HELP" do Titulo ou Descrição
0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde Wagner

Neste exercício você deve dividir a variável por 2 e se o resto da divisão for igual a zero o numero é par senao o numero é impar.

Você pode utilizar o operador mod para verificar o resto da divisão.

 

A diferença entre mod e / é:

n<-7 // n possui o valor 7

n/2 = 3 // valor da divisão

n mod 2 = 1 // resto da divisão

 

Outra coisa você só tem duas possibilidades ou é par ou é impar, você não precisa checar o resultado duas vezes ou seja duas condições, uma basta

se (n mod 2 = 0) par

senao impar

 

algoritmo "Par_impar"
var
n: inteiro
inicio
// Seção de Comandos
leia (n)
se n mod 2 = 0 entao
 escreva ("O valor é par:")
senao
 escreva ("O valor é impar:")
fimse
fimalgoritmo

 

Aproveitando leia este tópico para te ajudar a postar suas dúvidas no forum:

http://forum.imasters.com.br/topic/294104-aviso-leia-antes-de-postar/

Editado por ulfreitas
0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Oi, sou iniciante em algoritmos e estou tendo dificuldade para entender algoritmos de decisão. Enfim queria saber onde eu errei? Eu uso o visualg. xD

 

-->Escreva um programa que leia um número inteiro. Mostrar se o número é “par” ou “ímpar”.

 

algoritmo "Par_impar"

// Função :

// Autor :

// Data : 15/3/2012

// Seção de Declarações

var

n: inteiro

inicio

// Seção de Comandos

leia (n)

se n /2 = 0 entao

escreva ("O valor é par:")

fimse

se n /2 = 1 entao

escreva ("O valor é impar:")

fimse

 

 

fimalgoritmo

 

no

se n /2 = 0 entao

entao você coloca no / você usa mod que e igual %

so substituir o / por %

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!


Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.


Entrar Agora
Entre para seguir isso  
Seguidores 0

  • Próximos Eventos

    • 0
      22 fevereiro 2017 19:00
      Até
      22 fevereiro 2017 22:30