Ir para conteúdo
    • João Batista Neto

      iMasters InterCon 2017   10-10-2017

      Ainda dá tempo de se inscrever no iMasters InterCon 2017, o maior evento dev do Brasil!  

Arquivado

Este tópico foi arquivado e está fechado para novas respostas.

Wagner sz

[Resolvido] Numero Par ou Impar

Recommended Posts

Oi, sou iniciante em algoritmos e estou tendo dificuldade para entender algoritmos de decisão. Enfim queria saber onde eu errei? Eu uso o visualg. xD

 

-->Escreva um programa que leia um número inteiro. Mostrar se o número é “par” ou “ímpar”.

 

algoritmo "Par_impar"

// Função :

// Autor :

// Data : 15/3/2012

// Seção de Declarações

var

n: inteiro

inicio

// Seção de Comandos

leia (n)

se n /2 = 0 entao

escreva ("O valor é par:")

fimse

se n /2 = 1 entao

escreva ("O valor é impar:")

fimse

 

 

fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde Wagner

Neste exercício você deve dividir a variável por 2 e se o resto da divisão for igual a zero o numero é par senao o numero é impar.

Você pode utilizar o operador mod para verificar o resto da divisão.

 

A diferença entre mod e / é:

n<-7 // n possui o valor 7

n/2 = 3 // valor da divisão

n mod 2 = 1 // resto da divisão

 

Outra coisa você só tem duas possibilidades ou é par ou é impar, você não precisa checar o resultado duas vezes ou seja duas condições, uma basta

se (n mod 2 = 0) par

senao impar

 

algoritmo "Par_impar"
var
n: inteiro
inicio
// Seção de Comandos
leia (n)
se n mod 2 = 0 entao
 escreva ("O valor é par:")
senao
 escreva ("O valor é impar:")
fimse
fimalgoritmo

 

Aproveitando leia este tópico para te ajudar a postar suas dúvidas no forum:

http://forum.imasters.com.br/topic/294104-aviso-leia-antes-de-postar/

Compartilhar este post


Link para o post
Compartilhar em outros sites

Oi, sou iniciante em algoritmos e estou tendo dificuldade para entender algoritmos de decisão. Enfim queria saber onde eu errei? Eu uso o visualg. xD

 

-->Escreva um programa que leia um número inteiro. Mostrar se o número é “par” ou “ímpar”.

 

algoritmo "Par_impar"

// Função :

// Autor :

// Data : 15/3/2012

// Seção de Declarações

var

n: inteiro

inicio

// Seção de Comandos

leia (n)

se n /2 = 0 entao

escreva ("O valor é par:")

fimse

se n /2 = 1 entao

escreva ("O valor é impar:")

fimse

 

 

fimalgoritmo

 

no

se n /2 = 0 entao

entao você coloca no / você usa mod que e igual %

so substituir o / por %

Compartilhar este post


Link para o post
Compartilhar em outros sites

×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.

Este projeto é mantido e patrocinado pelas empresas:
Hospedado por: