Jump to content

Archived

This topic is now archived and is closed to further replies.

Dárcio Gomes

[Resolvido] Como conectar o PHP do server local a um banco de dad

Recommended Posts

Olá galera !

 

estamos desenvolvendo um projeto em que surgiu a necessidade de fazer uma conexão em PHP com um servidor instalado em minha máquina a um banco de dados de um site online, já fizemos várias pesquisas e não encontramos nada que podesse resolver nosso problema...

 

utilizo em minha máquina o WAMPSERVER

versão do apache: 2.2.21

PHP : 5.3.8

e MySQL : 5.5.16

 

dá os seguintes erros:

( ! ) Warning: mysql_pconnect() [function.mysql-pconnect]: Premature end of data (mysqlnd_wireprotocol.c:554) in C:\wamp\www\conectLocal.php on line 7

Call Stack

# Time Memory Function Location

1 0.0224 366368 {main}( ) ..\conectLocal.php:0

2 0.0224 366864 mysql_pconnect ( ) ..\conectLocal.php:7

 

( ! ) Warning: mysql_pconnect() [function.mysql-pconnect]: OK packet 1 bytes shorter than expected in C:\wamp\www\conectLocal.php on line 7

Call Stack

# Time Memory Function Location

1 0.0224 366368 {main}( ) ..\conectLocal.php:0

2 0.0224 366864 mysql_pconnect ( ) ..\conectLocal.php:7

 

( ! ) Warning: mysql_pconnect() [function.mysql-pconnect]: mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication. Please use an administration tool to reset your password with the command SET PASSWORD = PASSWORD('your_existing_password'). This will store a new, and more secure, hash value in mysql.user. If this user is used in other scripts executed by PHP 5.2 or earlier you might need to remove the old-passwords flag from your my.cnf file in C:\wamp\www\conectLocal.php on line 7

Call Stack

# Time Memory Function Location

1 0.0224 366368 {main}( ) ..\conectLocal.php:0

2 0.0224 366864 mysql_pconnect ( ) ..\conectLocal.php:7

 

( ! ) Warning: mysql_select_db() [function.mysql-select-db]: Access denied for user ''@'localhost' (using password: NO) in C:\wamp\www\conectLocal.php on line 8

Call Stack

# Time Memory Function Location

1 0.0224 366368 {main}( ) ..\conectLocal.php:0

2 0.6087 367944 mysql_select_db ( ) ..\conectLocal.php:8

 

( ! ) Warning: mysql_select_db() [function.mysql-select-db]: A link to the server could not be established in C:\wamp\www\conectLocal.php on line 8

Call Stack

# Time Memory Function Location

1 0.0224 366368 {main}( ) ..\conectLocal.php:0

2 0.6087 367944 mysql_select_db ( ) ..\conectLocal.php:8

Nao foi possivel efetuar a conexao!

 

Alguém tem alguma ideia de como resolver esse problema?

 

agradeço desde já... tt

Share this post


Link to post
Share on other sites

Bom dia,

Posta aí seu arquivo de conexão.

 

Mas a principio basta você colocar o IP do servidor.

 

Onde todo mundo usa LocalHost => 189.999.99.999

 

Só to chutando...

Posta o arquivo de configuração aí que da para ajudar melhor!

Share this post


Link to post
Share on other sites

Bom dia,

Posta aí seu arquivo de conexão.

 

Mas a principio basta você colocar o IP do servidor.

 

Onde todo mundo usa LocalHost => 189.999.99.999

 

Só to chutando...

Posta o arquivo de configuração aí que da para ajudar melhor!

 

Bom dia Uerlen!

 

eu estava utilizando a função mysql_connect mas ai coloquei o mysql_pconnect para percistir na conexão mas nada...

o código que estou utilizando é esse aí:

 

<?php

$server ="mysql.meudominio.com.br"; 
$user="usuario";   
$password="senha";    
$dbname="banco";    
$conn = mysql_pconnect($server,$user,$password);
$db = mysql_select_db($dbname);


if(!$conn){
echo "Nao foi possivel efetuar a conexao!";
}else{
echo "Conexao efetuada com sucesso!";
}

?>

 

já tentamos colocar o IP o IP com a porta e nada...

 

se poder me ajudar serei muito grato... vlw

Share this post


Link to post
Share on other sites

Cara é como imaginei...

 

Esse trecho

$server ="mysql.meudominio.com.br"; 

 

Testa com o ip do seu servidor, se você não sabe basta abrir o prompt de comando e dar um ping no endereço

 

ping mysql.meudominio.com.br

 

Com o IP em mãos

 

$server ="IPDOSERVIDOR"; 

 

Atenciosamente

Uerlen Santos

 

 

 

Bom dia Uerlen!

 

eu estava utilizando a função mysql_connect mas ai coloquei o mysql_pconnect para percistir na conexão mas nada...

o código que estou utilizando é esse aí:

 

<?php

$server ="mysql.meudominio.com.br"; 
$user="usuario";   
$password="senha";    
$dbname="banco";    
$conn = mysql_pconnect($server,$user,$password);
$db = mysql_select_db($dbname);


if(!$conn){
echo "Nao foi possivel efetuar a conexao!";
}else{
echo "Conexao efetuada com sucesso!";
}

?>

 

se poder me ajudar serei muito grato... vlw

Share this post


Link to post
Share on other sites

tentei colocar o IP, mas nada, coloquei o IP com a porta e também nada...

 

persiste no mesmo problema citado no inicio do tópico, se você tiver outra alternativa?

será alguma configuração no meu WAMPSERVER?

 

Grato ... vlw

Share this post


Link to post
Share on other sites

O código está correto amigo. Oque ocorre é que alguns provedores bloqueiam a conexão externa ao banco. Ligue no seu provedor e confirme a possibilidade de conectar de fora do ftp da hospedagem.

Share this post


Link to post
Share on other sites

Exatamente como o Periscuelo citou...

 

Uma ultima tentativa seria você conseguir o endereço do banco, tipo

 

mysql.seuserver.com.br e usa-lo na conexão.

Share this post


Link to post
Share on other sites

Exatamente como o Periscuelo citou...

 

Uma ultima tentativa seria você conseguir o endereço do banco, tipo

 

mysql.seuserver.com.br e usa-lo na conexão.

 

 

valeu Uerlen, já tentei essa alternativa vou seguir a dica do amigo Periscuelo e checar com o pessoal do servidor...

assim que tiver uma resposta concreta eu posto aqui

 

abraços ... tt

 

pois é amigos...

acabei de entrar em contato com o pessoal do servidor onde está hospedado o site e não existe nenhum bloqueio em relação ao nosso assunto.

 

se tiverem mais alguma alternativa eu agradeço a ajuda!

 

estou na busca... tt

Share this post


Link to post
Share on other sites

Putz... que complicado hein...

 

Ah... minhas alternativas acabaram... rsrs

 

Tenta desligar seu firewall (Vai que ele que ta bloqueando)

 

Ps.: Se for eu jogo na mega sena.... rsrs

 

valeu Uerlen, já tentei essa alternativa vou seguir a dica do amigo Periscuelo e checar com o pessoal do servidor...

assim que tiver uma resposta concreta eu posto aqui

 

abraços ... tt

 

pois é amigos...

acabei de entrar em contato com o pessoal do servidor onde está hospedado o site e não existe nenhum bloqueio em relação ao nosso assunto.

 

se tiverem mais alguma alternativa eu agradeço a ajuda!

 

estou na busca... tt

Share this post


Link to post
Share on other sites

kkkkk... o negócio tá tenso eim... rsrs

 

pior q nem tenho firewall.. o do windows deixo sempre desativado e o antivirus num é possível que ele esteja bloqueando minha conexão... mas vo fazer o teste... rsrs

 

vo ficar na busca qualquer coisa eu posto aqui ... vlw pelas dicas

 

e se alguém ainda tiver alguma alternativa por favor peço que ajudem ...

obrigado galera!

 

abrass.. tt

Share this post


Link to post
Share on other sites

Talvez seja problema da versão do MySQL. Tente conectar via console ou veja qual é a versão do MySQL de sua hospedagem. Um dos erros diz que não foi possível efetuar login com sistema de autenticação antigo. Teste também uma conexão não persistente. Se funcionar é alguma configuração que está errada, ou porta ou flag. Da uma olhada na documentação

 

Também existe um tópico de alguém com problema similar ao seu, parece ser algum parâmetro ou restrição de usuário. http://forum.imasters.com.br/topic/478060-conexao-a-banco-on-line-a-partir-de-computador-local-mysql-php/page__p__1899576__fromsearch__1#entry1899576

Share this post


Link to post
Share on other sites

Nunca conectei direto, mais vai aí uma TENTATIVA de solução:

 

Eu tive uma aula de java com conexão a banco de dados

o professor passou dessa forma a conexao:

 

mysql//:host:3306/banco

 

Lembrando que isso eh no JAVA, sei que estamos em PHP, mas é parecido, e além do mais nunca é demais tentar né?

 

se não funcionar, não me leve a mal, só tentei ajudar :thumbsup:

Share this post


Link to post
Share on other sites

Amigos... estou muito grato mesmo pelas dicas, mas...

 

infelizmente nada que nos tentamos aqui não faz a conexão com o banco remoto...

 

já liberei os acessos remotos no server online, já mudei a versão do PHP, do MySQL e do apache coloquei a mesma versão do MySQL do server e nada tentei conexão com java como o amigo rafael-tdc citou, todas as dicas do amigo perisculo e dos outros colegas que ajudaram e nada, todas as tentativas sem sucesso.

 

mas vo ficar tentando preciso fazer essa conexão, agradeço a todos que estão ajudando e se tiverem qualquer outra idéia ou sugestão por favor, não exitem em postar qualquer que seja.

 

vamos desvendar esse mistério juntos ... rsrsrs

 

abrass galera

Share this post


Link to post
Share on other sites

Tentei já amigo Wingdings... e adivinha! :cry: ;) :mellow:

 

sem sucesso... quando uso o www. em vez de mysql. o php fica carregando e não conecta, e como o php corta a tentativa de conexão em 30 segundos, cai a conexão.

 

mas vlw a dica se tiver alguma outra ideia poste ai...

 

abrass.. tt

Share this post


Link to post
Share on other sites

Teste sua conexão remota em outro servidor. Peça para um amigo seu criar um bd e criar uma senha para você testar a conexão. Se funcionar, o problema está na configuração do servidor. Porque realmente não há o que mudar. Teria de funcionar normalmente.

Share this post


Link to post
Share on other sites

Pois é amigo Periscuelo...

 

fiz isso e advinha!...

 

conexão efetuada com sucesso... dois dias de trabalho e pesquisa e o problema está com o servidor da kinghost que não está deixando fazer essa conexão local.

 

obrigado a todos pelas dicas.

 

abrass... tt

Share this post


Link to post
Share on other sites

é cPANEL ?

 

se for cpanel, procura por Gerenciar Acesso Remoto ao MySQL phpMyAdmin

 

ai coloca em

 

Adicionar Acesso de Servidor

Servidor (% wildcard é permitido)

 

INSIRA O SIMBOLO % e confirma

 

depois pra acessar é dominio:porta ou apenas dominio

Share this post


Link to post
Share on other sites

então rohde...

 

fiz um teste em um cPanel e fiz essas configurações que você passou e funcionou belezinha...

 

acontece que o site que preciso fazer a conexão está na kinghost e a kinghost não tem cpanel, tem a opção de liberar os IP's assim como nos cPanel's mas mesmo assim não conecta.

 

vlw pela dica!

 

Talvez seja problema da versão do MySQL. Tente conectar via console ou veja qual é a versão do MySQL de sua hospedagem. Um dos erros diz que não foi possível efetuar login com sistema de autenticação antigo. Teste também uma conexão não persistente. Se funcionar é alguma configuração que está errada, ou porta ou flag. Da uma olhada na documentação

 

Também existe um tópico de alguém com problema similar ao seu, parece ser algum parâmetro ou restrição de usuário. http://forum.imasters.com.br/topic/478060-conexao-a-banco-on-line-a-partir-de-computador-local-mysql-php/page__p__1899576__fromsearch__1#entry1899576

 

só pode mesmo ser problema com a versão do MySQL pois tudo que podia ser feito já fizemos aqui.

 

alguém tem alguma idéia ond achar a versão do SQL 5.5.25?

 

achei um link pra baixar o phpMyAdmin: http://www.positiv-it.fr/thecus/download/MySQL_5.5.25_x86.rar

Share this post


Link to post
Share on other sites

_______________________________________________________________________

 

 

taí rapazeada...

 

depois de muitas tentativas e muita busca nosso parceiro de trabalho aqui descobriu o que estava impossibilitando a conexão.

 

O grande problema era a versão do PHP, a gente tinha alterado as versões do SQL e nada, foi só alterar a versão do PHP e pronto conexão realizada com sucesso.

 

e para facilitar as verificações de versões do PHP e SQL nosso amigo utilizou um sisteminha chamado Easy PHP.

 

é isso galera vlw pela dicas... tt :thumbsup:

 

""

 

""

Share this post


Link to post
Share on other sites

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.