Jump to content

Archived

This topic is now archived and is closed to further replies.

asacap1000

Tirar apenas a virgula no final do resultado.

Recommended Posts

Galera estou quase finalizando um processo de consulta porém travei em uma parte.

O processo é muto simples porém como tive que adicionar algumas alterações no resultado, não consigo eliminar apenas a ultima virgula.

Ja procurei nos post aqui mas nada adiantou.

 

Abaixo o código.

$sql9 ="select adi.tb_doc documentos, adi.tb_prot protocolo
          from agend_coleta.documentos adi where adi.tb_prot = $id";
$result9 = mysql_query($sql9) or die(mysql_error());
		
while($linha9=mysql_fetch_array($result9)) {
							
								
$doc2 =nl2br("'".substr($linha9['documentos'], 0, 2) . "/" . substr($linha9['documentos'], 2, 7). "-" .substr($linha9['documentos'],-1)."',");	

echo $doc2;

Os resultados saem desta forma que é o correto pois será utilizado como base de consulta em outro banco que está formatado desta forma.

 

'15/1626127-7','15/1626154-4','15/1627521-9','21/5081295-1',

 

mas para que a consulta funcione eu preciso retirar a ultima virgula

Share this post


Link to post
Share on other sites

Pesquise sobre substr

Então já andei pesquisando para adicionar a formatação que utilizo acima que vai barra e traço. Já concatenei no select também, já utilizei o group concat, mas nada

Share this post


Link to post
Share on other sites

Você não vai conseguir dessa maneira. A vírgula foi inserida por você para cada resultado encontrado no laço de repetição, dessa forma, qualquer função que você inclua para retirar essa vírgula, ela irá desaparecer de todos os resultados.

Share this post


Link to post
Share on other sites

Porém, você pode fazer com concatenação.

 

Veja o exemplo no seu caso.

$doc2='';
while($linha9=mysql_fetch_array($result9)) {
                            
                                
$doc2.=nl2br("'".substr($linha9['documentos'], 0, 2) . "/" . substr($linha9['documentos'], 2, 7). "-" .substr($linha9['documentos'],-1)."',");    

}
echo substr($doc2,0,-1);

Share this post


Link to post
Share on other sites

  • Similar Content

    • By Sapinn
      Galera estou usando o PHPStorm para alguns projetos e estou com meus arquivos marcados em vermelho não sei oq é alguem pode me ajuda?
       
       

    • By danielambrosio
      Estou trabalhando numa programação PHP é conectado na tabela (cl_configs) para reconhece coluna name que reconhece esses 5 campos.
      e também que adiciona esses 5 valores é adicionado nessa outra tabela (cl_ads_block_ips) nesses 8 coluna (id, ip, clicks, last_click, dads_refresh_qtd, dads_refresh_data, dads_refresh_ldata, clicks_rotativo_dia).
      E a conexão que eu usa era de outro site e não estou tendo problema e configurar em outro site que reconhece essa banco de dados abaixo.
       
      <?php $host = "localhost"; $user = "ads"; $pass = "_CMpFF4Hpa!G_gTh"; $dbname = "ads"; $port = 3306; try {     $conn = new PDO('mysql:host=' . $host . ';port=' . $port . ';dbname=' . $dbname, $user, $pass);     //echo "Conexão com banco de dados realizado com sucesso!"; } catch (PDOException $err) {     echo "Erro: Conexão com banco de dados não foi realizada com sucesso. Erro gerado " . $err->getMessage(); } ?>  
      Conecta com sucesso só não está reconhecendo a tabela (cl_configs) e nem adicionando na tabela (cl_ads_block_ips).
       
       
      Agora não sei porque não esta reconhecendo (cl_configs) e nem adicionando (cl_ads_block_ips).
       
       


    • By ment0r
      Boa tarde a todos.

      Estou iniciando um estudo com o banco MySQL (trabalho co PostgreSQL e Firebird) para futuros trabalhos. Bom, me deparei com um problema chato: caracteres especiais.
      Um exemplo: T�tulo.
      Não consigo exibir no meu site tais caracteres. O banco tem Charset/Collation: utf8/utf8_bin como configuração.
      Já usei o utf_encode e utf_decode - não resolveu.

      Alguém sabe o que mais posso fazer?
      Desde já, muito obrigado.
    • By asacap1000
      Galera salve salve!!
      Estou com um projeto em que são armazenados vídeos, porém seguindo os requisitos exigidos, para visualizar e baixar esses vídeos eles tem que aparecer com numero de cadastro do usuário que está acessando no centro do video como uma marca d'agua.
       
      Para simplesmente aparecer na tela eu consigo fazer uma camada superior com css e apresentar os dados do usuário mas para baixar o vídeo ele já faz sem a marca.
       
      Vocês conhecem algum recurso pra adicionar essa marca? ela não pode ficar no arquivo original pois outros usuário poderão baixar com sua identificação na tela.
       
      Se alguem puder me dar um norte ajudaria muito
    • By marcelo.ourico
      Estou precisando fazer o envio de um XML via webservice. Estou utilizando PHP 7.4 e nuSoap.

      Porém esse XML de envio possui várias tags com hífen. Por exemplo <tag-name></tag-name>.
       
      Esse hífen tem sido um problema, principalmente por que eu não posso enviar o XML como string. Apenas como objeto. Então imaginem isso:
       
      $objeto = simplexml_load_string($string_xml);  
      Se simplesmente eu tentar resgatar o valor da TAG já dá erro...
       
      $campo1= $objeto->tag-name;
      O erro ocorre em função de que o hífen é um caractere reservado do PHP... Então como resolver?

      Independente disso, quando eu tento fazer o envio via nuSoap, também recebo erro abaixo:
      wsdl->getTypeDef('tag-name', 'http://xyz.abr...')
      wsdl->serializeType('tag-name', 'tag-name', Object(SimpleXMLElement), '

      Alguém já passou por isso? Sabe como resolver? Pode dar uma dica?
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.