Jump to content
Davidk

Login e senha php não funciona no browser smatphone android

Recommended Posts

Desenvolvi um sistema que possui login e senha que funciona perfeitamente no desktop, entretanto quando vou logar no smartphone não funciona.

 

segue o código de login:

 

public function viewLogin($objLogin) {
?>

<!DOCTYPE html>

<html>
<head>
<title>Gerência de dados</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta charset="UTF-8">
<link rel="stylesheet" type="text/css" href="/libs/css/menu.css" />
</head>
<body>
<div id="box">
<div id="header">
<div id="logo"></div><!-- logo -->
<div id="cabecalho"></div><!-- cabecalho -->
</div><!-- header -->
<div id="content">
<br />
<h1 align="center">Efetue Login no Sistema </h1>
<br />
<?php
if(isset($_POST["login"]) || isset($_POST["senha"])){
if ((@$_POST["login"] == "") || (@$_POST["senha"] == "")) {
?><h3 class="error" ><?php echo "Preencha todos os campos"; ?></h3><?php
}else{
$objLogin->logar($_POST["login"],$_POST["senha"]);
}
}
?>
<h3 class="error" ><?php echo $objLogin->getErro(); ?></h3>
<br /><br />
<fieldset class="formlogin">
<form name="formlogin" id="formlogin" method="post" action="">

<label for="login">Login  </label><br /><input type="text" name="login" class="largura"><br /><br />
<label for="senha">Senha  </label><br /><input type="password" name="senha" class="largura"><br /><br />
<label for="enviar"></label><input type="submit" name="enviar" id="enviar" value="Enviar">
</form>
</fieldset>
</div><!-- content -->
<div id="footer">
Todos os Direitos Reservados
</div><!-- footer -->
</div><!-- box -->
</body>
</html>
<?php
}

 

quando é enviado o form vai para o método logar

 

public function logar($usuario, $senha) {
$campovalor = "loginuser = '{$usuario}' AND senhauser = '{$this->cript($senha)}'";
if($this->verificaloginSenha($campovalor)){
if(!isset($_SESSION)){
session_start();
}
$_SESSION['Logado']=true;
$this->getById($campovalor);
header("Location:./");
}
}

 

se alguém tiver alguma dica, agradeço!

Share this post


Link to post
Share on other sites

desculpe... mas encontrei o erro: header("Location:./index");

não sei explicar, mas no browser do smartphone não redireciona direto para index. valeu! Resolvido.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.