Jump to content
capoia

[DUVIDA] Exercicio de receber valores e calcular media em portugol

Recommended Posts

Boa tarde, sou novo por aqui , comecei a fazer sistema da informação a pouco tempo .
Na aula de ontem o professor pediu pra fazermos um exercício em portugol que recebe x números , e depois faz a media dos mesmos ( e quando quiser parar e receber a media a pessoa digita -1)
Eu fiz praticamente todo , ta tudo correto , só não consigo fazer com q os valores que a pessoa coloca vão se somando... eu tentei colocar:
valores <- valores+valores para ele pegar o valor q a pessoa colocou e somar com o valor novo ... mas não sei porque quando coloco isso ele entra em looping e quando digito -1 ele n para , continua pedindo pra digitar os valores...
Não sei se entenderam oque quis dizer , mas preciso q o algoritmo receba um valor , guarde esse valor na variável "valores" depois quando for repetir o laço pela segunda vez ele pegue esse valor armazenado e some com o valor novo e assim sucessivamente , o problema e q eu não sei quantos valores a pessoa vai por é infinito ... por isso não posso por simplesmente n1+n2 , é um variável com outra variável...
espero que possam me ajudar.
meu código ficou assim :

Algoritmo "Valores e Média"
// Linguagem e Lógica de Programação 
//  
// Descrição   : Recebe x valores e calcula a média
// Autor(a)    : Wellington Capoia
// Data atual  : 20/4/2016
Var
// Seção de Declarações das variáveis 
media, valores, cont, resultado, valoressomados:  real


Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
cont <- 0
valores <- 0
escreval ("Algoritmo para receber um numero x de valores e calcular média")
escreval ("Para para calcular a média digite -1 a qualquer momento")
enquanto valores <> -1 faca

         escreval ("Digite os valores:")
         leia (valores)
         valores <- valores+valores
         cont <- cont+1
fimenquanto
escreval ("valores somados", valoressomados)
cont <- cont-1
escreval ("Valores digitados:", cont)
resultado <- valoressomados/cont
escreval ("A média dos valores é:", resultado)

Fimalgoritmo

 

Share this post


Link to post
Share on other sites

Você não pode atribuir a entrada (número digitado pelo usuário) na mesma variável que está guardando os valores;

Aliás..

Sua variável valoressomados não está recebendo a soma :lol:

 

O motivo pelo qual ele não para quando digita -1, é porque a variável valores tem um número, e depois você soma com -1.. Ai quando o 'enquanto' verifica, não vai ser -1

  • +1 1

Share this post


Link to post
Share on other sites

Inicie valoressomados com 0, junto com as outras

valoressomados <- 0
cont <- 0
valores <- 0
  • +1 1

Share this post


Link to post
Share on other sites

aqui esta a versão corrigida do programa

 

Algoritmo "Valores e Média"

Var

media, valores, valorant, cont, resultado, valoressomados:  real
valor: INTEIRO
 

Inicio
valoressomados <- 0
cont <- 1
valores <- 0
valor <- 0
valorAnt <-0
escreval ("Algoritmo para receber um numero x de valores e calcular média")
escreval ("Para para calcular a média digite -1 a qualquer momento")
escreval ("Digite os valores:")
leia (valores)
valorant <- valores

enquanto valor <> -1 faca

         escreval ("Digite os valores:")
         leia (valores)
         cont <- cont+1
         escreval ("Digite qualquer valor para continuar, ou digite -1 para finalizar a inserção de dados")
         leia(valor)
         valorant <- valores + valorant
fimenquanto

escreval ("Valores digitados:", cont)
resultado <- valorant/cont
escreval ("A média dos valores é:", resultado)

Fimalgoritmo

 

gambiarra a gente aceita, o que a gente não aceita é a derrota.

 

e outra coisa que a gente nao aceita é "programar" nesse pascal mascarado. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By louisefgomes
      oii gente, é que surgiu várias dúvidas agora que eu quis iniciar desenho digital...  Então gostaria de saber qual programa vocês indicam, que tipo de notebook é melhor pra aguentar os programas e que mesa digital vocês indicam...
      para da uma ajudinha:
      01. eu queria programas que fossem recomendados para quem quer fazer quadrinhos, porém se existir um que se adeque tanto para quadrinhos quanto para desenhos realista ficaria feliz ( caso não exita pode indicar um programa bom para cada área ?)
      02. sobre as mesas eu ja vi que as melhores são da wacom queria saber qual dessas é melhor : 
            - Mesa Digitalizadora One by Wacom Pequena - CTL472L
            - Mesa Digitalizadora Wacom Intuos Pequena - CTL4100
      Agradeço desde já atenção de vocês !!!
          
    • By thiagoguedes
      Olá pessoal,  estou dando meus primeiros passos no php e gostaria da ajuda de vocês. 
       
      Estou exibindo os dados da  tabela frete e nela há a chave estrangeira cod_empresa, que informa qual empresa está oferecendo o frete. 
      Quero exibir o nome da empresa quando apresentar o nome da empresa e não o código, então estou fazendo um INNER JOIN pra tabela empresa e tentando exibir o campo nomefantasia_empresa.
       
      Meu código, porém, está dando erro e não consigo corrigir. Vocês podem me ajudar?
       
      <?php include "conexao.php"; $result_fretes = "SELECT * FROM frete AS f INNER JOIN empresa AS e ON f.cod_empresa = e.cod_empresa"; $resultado_cursos = mysqli_query($conn, $result_cursos); while ($rows_cursos = mysqli_fetch_array($resultado_cursos)){ echo $rows_cursos['cod_frete']; echo $rows_cursos['cod_empresa']; echo $rows_cursos['rasaosocial_empresa']; } ?>  
    • By 4ly
      O exercício propunha fazer duas funções uma para multiplicação e outra para criar uma fatorial, porém devem ser feitas usando apenas operações de soma e subtração
      bom fiz uma função para multiplicar e esta funcionando porém estou tentando utiliza-la para fazer a fatorial e o resultado sempre da zero ;-; podem me ajudar 
       
       
      algoritmo "semnome" var a,b:inteiro funcao multi(a:inteiro;b:inteiro):real var aux:real inicio se a=0 entao retorne 0 senao aux <- 0 enquanto b>0 faca aux <- aux+a b <- b-1 fimenquanto retorne aux fimse fimfuncao funcao fatorial(a:inteiro):real var fat,res:real inicio enquanto fat > 0 faca fat<-a fat <- fat - 1 res <- multi(fat,a) fimenquanto retorne res fimfuncao inicio leia(a) escreval(fatorial(a)) fimalgoritmo  
    • By rakas
      ola pessoal, preciso mesmo de umas opiniões sobre - Que equipamento vale a pena para desenho - para posteriormente os desenhos serem usados para animação e ou modelação 3D.
       então a minha duvida é qual vale a pena um ipad ou uma mesa digitalizadora!?!? 
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.